Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Need help to resolve a slot conflict
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
deltamalloc
Tux's lil' helper
Tux's lil' helper


Joined: 18 Jan 2013
Posts: 128

PostPosted: Sun Dec 29, 2013 5:31 am    Post subject: Need help to resolve a slot conflict Reply with quote

When trying to do a world update, I got the following slot conflict, how do I resolve it?

Code:

Calculating dependencies... done!
[ebuild     U  ] dev-libs/boost-1.53.0-r1 [1.53.0]
[ebuild     UD ] dev-libs/libgcrypt-1.5.3 [1.6.0]
[ebuild     U  ] sys-block/thin-provisioning-tools-0.2.8-r2 [0.2.8-r1]
[ebuild     U  ] x11-proto/xextproto-7.3.0 [7.2.99.901]
[ebuild  N     ] x11-libs/libxshmfence-1.1  USE="-static-libs" ABI_X86="32 (64) (-x32)"
[ebuild  N     ] x11-proto/dri3proto-1.0  ABI_X86="32 (64) (-x32)"
[ebuild  N     ] x11-proto/presentproto-1.0  ABI_X86="32 (64) (-x32)"
[ebuild     U  ] net-misc/curl-7.34.0-r1 [7.34.0]
[ebuild     U  ] dev-qt/qtcore-4.8.5-r1 [4.8.5]
[ebuild     U  ] sys-libs/readline-6.2_p5-r1 [6.2_p5] ABI_X86="32%* (64%*) (-x32)"
[ebuild     U  ] app-office/libreoffice-l10n-4.1.4.2 [4.1.3.2]
[ebuild     U  ] app-text/libetonyek-0.0.3 [0.0.0] USE="{-test%}"
[ebuild     U  ] sys-apps/kmod-16 [15-r1]
[ebuild     U  ] app-text/liblangtag-0.5.2 [0.5.1]
[ebuild     U  ] sys-devel/llvm-3.3-r2 [3.3-r1] USE="xml%*"
[ebuild     U  ] sys-apps/hwids-20131226 [20130915.1]
[ebuild     U  ] sys-fs/cryptsetup-1.6.3 [1.6.2]
[ebuild     U  ] media-sound/mpg123-1.17.0 [1.16.0]
[ebuild     U  ] x11-base/xorg-server-1.14.99.904 [1.14.5]
[ebuild     U  ] dev-vcs/git-1.8.5.2 [1.8.5.1]
[ebuild     U  ] app-office/libreoffice-4.1.4.2 [4.1.3.2-r2]
[ebuild     U  ] x11-drivers/ati-drivers-13.12 [13.11_beta6]
[ebuild     U  ] app-emulation/wine-1.7.9 [1.7.4] USE="-netapi%"
[blocks B      ] <=app-emulation/emul-linux-x86-baselibs-20131008-r6 ("<=app-emulation/emul-linux-x86-baselibs-20131008-r6" is blocking sys-libs/readline-6.2_p5-r1)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-base/xorg-server:0

  (x11-base/xorg-server-1.14.99.904::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-base/xorg-server-1.14.5::gentoo, installed) pulled in by
    <=x11-base/xorg-server-1.14.49[-minimal] required by (x11-drivers/ati-drivers-13.12::gentoo, ebuild scheduled for merge)
    x11-base/xorg-server:0/1.14.5= required by (x11-drivers/xf86-input-keyboard-1.7.0::gentoo, installed)
    x11-base/xorg-server:0/1.14.5= required by (x11-drivers/xf86-input-mouse-1.9.0::gentoo, installed)
    x11-base/xorg-server:0/1.14.5= required by (x11-drivers/xf86-input-evdev-2.8.2::gentoo, installed)

dev-libs/libgcrypt:0

  (dev-libs/libgcrypt-1.5.3::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/libgcrypt-1.2.2:0/11= required by (app-crypt/gcr-3.8.2::gentoo, installed)
    (and 1 more with the same problem)

  (dev-libs/libgcrypt-1.6.0::gentoo, installed) pulled in by
    dev-libs/libgcrypt:0/20= required by (net-analyzer/wireshark-1.10.5::gentoo, installed)
    >=dev-libs/libgcrypt-1.1.42:0/20= required by (dev-libs/libxslt-1.1.28-r1::gentoo, installed)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-libs/readline-6.2_p5-r1::gentoo, ebuild scheduled for merge) pulled in by
    sys-libs/readline required by (sci-visualization/gnuplot-4.6.4::gentoo, installed)
    sys-libs/readline required by (sys-devel/gdb-7.6.2::gentoo, installed)
    sys-libs/readline required by (app-text/hunspell-1.3.2-r3::gentoo, installed)
    sys-libs/readline required by (media-sound/jack-audio-connection-kit-0.121.3-r1::gentoo, installed)
    sys-libs/readline required by (sys-apps/gawk-4.1.0::gentoo, installed)
    sys-libs/readline required by (app-crypt/gnupg-2.0.22::gentoo, installed)
    sys-libs/readline required by (dev-lang/lua-5.1.5::gentoo, installed)
    sys-libs/readline required by (dev-embedded/avrdude-5.11.1::gentoo, installed)
    >=sys-libs/readline-4.1 required by (dev-lang/python-2.7.6::gentoo, installed)
    sys-libs/readline required by (sys-fs/lvm2-2.02.104::gentoo, installed)
    >=sys-libs/readline-4.1 required by (dev-lang/python-3.3.3::gentoo, installed)
    >=sys-libs/readline-6.2 required by (app-shells/bash-4.2_p45::gentoo, installed)
    sys-libs/readline:= required by (dev-libs/libxml2-2.9.1-r1::gentoo, installed)
    >=sys-libs/readline-4.1 required by (sys-devel/bc-1.06.95-r1::gentoo, installed)
    sys-libs/readline:= required by (net-wireless/bluez-4.101-r8::gentoo, installed)
    sys-libs/readline required by (net-wireless/wpa_supplicant-2.0-r3::gentoo, installed)
    sys-libs/readline required by (net-print/gutenprint-5.2.9::gentoo, installed)
    sys-libs/readline required by (dev-libs/libpcre-8.34::gentoo, installed)
    sys-libs/readline required by (net-dns/bind-tools-9.9.4::gentoo, installed)
    sys-libs/readline required by (dev-db/sqlite-3.8.2::gentoo, installed)
    >=sys-libs/readline-6.1 required by (dev-db/unixODBC-2.3.1-r1::gentoo, installed)
    >=sys-libs/readline-5.2 required by (sys-block/parted-3.1-r1::gentoo, installed)
    >=sys-libs/readline-5.2 required by (net-fs/samba-3.6.22::gentoo, installed)
    sys-libs/readline:0/0= required by (dev-libs/libxml2-2.9.1-r1::gentoo, installed)
    sys-libs/readline:0/0= required by (net-wireless/bluez-4.101-r8::gentoo, installed)

  (app-emulation/emul-linux-x86-baselibs-20131008-r6::gentoo, installed) pulled in by
    ~app-emulation/emul-linux-x86-baselibs-20131008 required by (app-emulation/emul-linux-x86-xlibs-20131008::gentoo, installed)
    app-emulation/emul-linux-x86-baselibs[development] required by (x11-libs/libSM-1.2.2::gentoo, installed)
    app-emulation/emul-linux-x86-baselibs required by (app-emulation/wine-1.7.9::gentoo, ebuild scheduled for merge)
    ~app-emulation/emul-linux-x86-baselibs-20131008 required by (app-emulation/emul-linux-x86-medialibs-20131008-r1::gentoo, installed)
    ~app-emulation/emul-linux-x86-baselibs-20131008 required by (app-emulation/emul-linux-x86-gtklibs-20131008-r1::gentoo, installed)
    ~app-emulation/emul-linux-x86-baselibs-20131008[abi_x86_32=] (~app-emulation/emul-linux-x86-baselibs-20131008[abi_x86_32]) required by (app-emulation/emul-linux-x86-soundlibs-20131008-r2::gentoo, installed)
    ~app-emulation/emul-linux-x86-baselibs-20131008 required by (app-emulation/emul-linux-x86-sdl-20131008::gentoo, installed)
    >=app-emulation/emul-linux-x86-baselibs-20121028 required by (games-util/steam-launcher-1.0.0.43::steam-overlay, installed)
    >=app-emulation/emul-linux-x86-baselibs-20131008[development] required by (app-emulation/wine-1.7.9::gentoo, ebuild scheduled for merge)
    >=app-emulation/emul-linux-x86-baselibs-20121028 required by @steam
    app-emulation/emul-linux-x86-baselibs[development] required by (app-emulation/wine-1.7.9::gentoo, ebuild scheduled for merge)
    >=app-emulation/emul-linux-x86-baselibs-20130224[development] required by (app-emulation/wine-1.7.9::gentoo, ebuild scheduled for merge)
    ~app-emulation/emul-linux-x86-baselibs-20131008 required by (app-emulation/emul-linux-x86-db-20131008::gentoo, installed)
    app-emulation/emul-linux-x86-baselibs required by (www-plugins/adobe-flash-11.2.202.332::gentoo, installed)
Back to top
View user's profile Send private message
jpc22
Apprentice
Apprentice


Joined: 29 Jan 2012
Posts: 187

PostPosted: Sun Dec 29, 2013 5:56 am    Post subject: Reply with quote

looks like a circular dependancy.

first you need to upgrade to higher version the following packages
x11-drivers/ati-drivers-13.12
x11-drivers/xf86-input-keyboard-1.7.0
x11-drivers/xf86-input-mouse-1.9.0
x11-drivers/xf86-input-evdev-2.8.2
so that x11-base/xorg-server-1.14.5 no longer gets pulled by them.

app-crypt/gcr-3.8.2:
net-analyzer/wireshark-1.10.5
dev-libs/libxslt-1.1.28-r1

and all the apps ''required by'' so that they all require the same version the conflicting program


that will require some trial and error to get the versions right and almost certainly unmasking with --autounmask-write and dispatch-conf.

look up versions with eix or zugaina and recheck the output of world update after each change you make and the list should get shorter every time if you get the versions right.


Temporary uninstalling some apps that are not essential to the system can also help lifting some conflicts but it should be your last ressort only if it is needed.


Good luck, arm yourself with patience and ask more questions if nothings works.
Back to top
View user's profile Send private message
Lustmored
Apprentice
Apprentice


Joined: 28 May 2010
Posts: 203
Location: Poland

PostPosted: Sun Dec 29, 2013 8:46 am    Post subject: Reply with quote

It's ebuilds bug due to file collision between new readline and not updated emul-linux-x86-baselibs. There is already bug report:

https://bugs.gentoo.org/show_bug.cgi?id=496314
Back to top
View user's profile Send private message
Dominique_71
Veteran
Veteran


Joined: 17 Aug 2005
Posts: 1485
Location: Switzerland (Romandie)

PostPosted: Fri Jan 24, 2014 3:57 am    Post subject: Reply with quote

I get the same issue with the xorg stuffs. The solution for me was to mask the higher xorg-server version.
_________________
[[[ To any NSA and FBI agents reading that text: please consider ]]]
[[[ whether defending the US Constitution against all enemies, ]]]
[[[ foreign or domestic, requires you to follow Snowden's example. ]]]
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum