Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] perl update and mrtg errors
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
novazur
Guru
Guru


Joined: 19 Mar 2005
Posts: 421
Location: Martinique

PostPosted: Fri Dec 20, 2013 6:32 pm    Post subject: [solved] perl update and mrtg errors Reply with quote

Hi,

Today, after updating my server

Code:
     Fri Dec 20 09:34:54 2013 >>> media-libs/jpeg-6b-r9
     Fri Dec 20 09:39:06 2013 >>> sys-devel/gettext-0.18.2
     Fri Dec 20 09:42:46 2013 >>> dev-lang/perl-5.16.3
     Fri Dec 20 09:42:57 2013 >>> perl-core/net-ping-2.36
     Fri Dec 20 09:45:47 2013 >>> dev-lang/ruby-1.9.3_p484
     Fri Dec 20 09:47:13 2013 >>> dev-libs/nss-3.15.3.1
     Fri Dec 20 09:51:36 2013 >>> net-fs/samba-3.6.22
     Fri Dec 20 09:55:40 2013 >>> net-analyzer/net-snmp-5.7.2-r1
     Fri Dec 20 09:56:10 2013 >>> dev-java/icedtea-bin-6.1.12.7


I have errors in my mrtg cron like :
Code:
Subroutine main::pack_sockaddr_in6 redefined at /usr/lib64/perl5/5.16.3/Exporter.pm line 66.
 at /usr/bin/mrtg line 101.

I have already used "perl-cleaner --all", emerged mrtg & net-snmp, restarted snmpd...
I don't know what to try next.


Last edited by novazur on Fri Dec 20, 2013 7:12 pm; edited 1 time in total
Back to top
View user's profile Send private message
novazur
Guru
Guru


Joined: 19 Mar 2005
Posts: 421
Location: Martinique

PostPosted: Fri Dec 20, 2013 6:50 pm    Post subject: Reply with quote

using masked net-analyzer/mrtg-2.17.4 solved this error, but I still have other errors :

Code:
SNMP Error:
Received SNMP response with error code
  error status: noSuchName
  index 2 (OID: 1.3.6.1.2.1.25.2.3.1.5.38)
SNMPv1_Session (remote host: "localhost" [127.0.0.1].161)
                  community: "public"
                 request ID: 2063930835
                PDU bufsize: 8000 bytes
                    timeout: 2s
                    retries: 5
                    backoff: 1)
 at /usr/lib64/perl5/vendor_perl/5.16.3/SNMP_util.pm line 492.
SNMPGET Problem for hrStorageUsed.38 hrStorageSize.38 sysUptime sysName on public@localhost::::::v4only
 at /usr/bin/mrtg line 2330.
2013-12-20 14:48:17: ERROR: Target[localhost.57-part-6][_IN_] ' $target->[1]{$mode}  * 4' (warn): Use of uninitialized value in multiplication (*) at (eval 653) line 1.
2013-12-20 14:48:17: ERROR: Target[localhost.57-part-6][_OUT_] ' $target->[1]{$mode}  * 4' (warn): Use of uninitialized value in multiplication (*) at (eval 654) line 1.
run-parts: /etc/cron.mrtg/disk-space.sh exited with return code 91
2013-12-20 14:48:28: WARNING: Could not match host:'public@localhost:' ref:'Descr' key:'Intel Corporation 82566DM-2 Gigabit Network Connection'
2013-12-20 14:48:28: WARNING: Could not match host:'public@localhost:' ref:'Descr' key:'Intel Corporation 82573L Gigabit Ethernet Controller'
2013-12-20 14:48:28: WARNING: Could not match host:'public@localhost:' ref:'Descr' key:'VIA Technologies, Inc. VT6105/VT6106S [Rhine-III]'
2013-12-20 14:48:28: ERROR: Target[localhost.35-eth0][_IN_] ' $target->[0]{$mode} ' did not eval into defined data
2013-12-20 14:48:28: ERROR: Target[localhost.35-eth0][_OUT_] ' $target->[0]{$mode} ' did not eval into defined data
2013-12-20 14:48:28: ERROR: Target[localhost.40-eth1][_IN_] ' $target->[1]{$mode} ' did not eval into defined data
2013-12-20 14:48:28: ERROR: Target[localhost.40-eth1][_OUT_] ' $target->[1]{$mode} ' did not eval into defined data
2013-12-20 14:48:28: ERROR: Target[localhost.15-ppp0][_IN_] ' $target->[2]{$mode} ' did not eval into defined data
2013-12-20 14:48:28: ERROR: Target[localhost.15-ppp0][_OUT_] ' $target->[2]{$mode} ' did not eval into defined data
run-parts: /etc/cron.mrtg/traffic.sh exited with return code 92
Back to top
View user's profile Send private message
novazur
Guru
Guru


Joined: 19 Mar 2005
Posts: 421
Location: Martinique

PostPosted: Fri Dec 20, 2013 7:12 pm    Post subject: Reply with quote

solved after modifying my mrtg configs.
Back to top
View user's profile Send private message
jhardin
n00b
n00b


Joined: 12 Oct 2005
Posts: 30

PostPosted: Sun Dec 29, 2013 2:35 am    Post subject: Reply with quote

novazur wrote:
solved after modifying my mrtg configs.

I'm having the same problem with Exporter.pm. You fixed it by modifying them how?

ETA: I guess my configs were cleaner than yours. I emerged the masked version of MRTG and had no further problems, no config changes were needed.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum