Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Cannot build =sys-devel/gcc-4.1.2 (makeinfo missing?)
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
Tux's lil' helper
Tux's lil' helper

Joined: 14 Oct 2008
Posts: 79
Location: Seattle, WA

PostPosted: Fri Dec 27, 2013 8:02 pm    Post subject: Cannot build =sys-devel/gcc-4.1.2 (makeinfo missing?) Reply with quote

We use a proprietary binary program on our systems that links to, which is provided in sys-devel/gcc:4.1. As a result, I need to have both the current gcc (4.7.3-r1 as of this post), and 4.1 installed (4.1.2 currently) installed since I have not found a way to just keep the just the libraries around from 4.1.

In doing my regular Friday updates, both gcc:4.7 and gcc:4.1 required rebuilding. This requires me to rebuild gcc:4.1 manually as the -march=native in the make.conf is not compatible with 4.1. Thus, I compile like this:

env CFLAGS="-march=nocona -O2 -pipe -fomit-frame-pointer" CXXFLAGS="-march=nocona -O2 -pipe -fomit-frame-pointer" emerge -q sys-devel/gcc:4.1

Up until today, this worked. Now it's failing every time I try and build it. The error is always:

if [ x = xinfo ]; then \
  rm -f doc/*; \
  /var/tmp/portage/sys-devel/gcc-4.1.2/work/gcc-4.1.2/missing makeinfo --split-size=5000000 --split-size=5000000 -I /var/tmp/portage/sys-devel/gcc-4.1.2/work/gcc-4.1.2/gcc/doc/include -I /var/tmp/portage/sys-devel/gcc-4.1.2/work/gcc-4.1.2/gcc/fortran \
    -o doc/ /var/tmp/portage/sys-devel/gcc-4.1.2/work/gcc-4.1.2/gcc/fortran/gfortran.texi; \
else true; fi
rm -f /var/tmp/portage/sys-devel/gcc-4.1.2/image//usr/share/gcc-data/x86_64-pc-linux-gnu/4.1.2/info/
if [ -f doc/ ]; then \
  for f in doc/*; do \
    realfile=`echo $f | sed -e 's|.*/\([^/]*\)$|\1|'`; \
    /usr/bin/install -c -m 644 $f /var/tmp/portage/sys-devel/gcc-4.1.2/image//usr/share/gcc-data/x86_64-pc-linux-gnu/4.1.2/info/$realfile; \
    chmod a-x /var/tmp/portage/sys-devel/gcc-4.1.2/image//usr/share/gcc-data/x86_64-pc-linux-gnu/4.1.2/info/$realfile; \
  done; \
else true; fi
if /bin/sh -c 'install-info --version' >/dev/null 2>&1; then \
  if [ -f /var/tmp/portage/sys-devel/gcc-4.1.2/image//usr/share/gcc-data/x86_64-pc-linux-gnu/4.1.2/info/ ]; then \
    install-info --dir-file=/var/tmp/portage/sys-devel/gcc-4.1.2/image//usr/share/gcc-data/x86_64-pc-linux-gnu/4.1.2/info/dir /var/tmp/portage/sys-devel/gcc-4.1.2/image//usr/share/gcc-data/x86_64-pc-linux-gnu/4.1.2/info/; \
  else true; fi; \
else true; fi;
/var/tmp/portage/sys-devel/gcc-4.1.2/work/gcc-4.1.2/missing makeinfo --split-size=5000000 --split-size=5000000 --no-split -I /var/tmp/portage/sys-devel/gcc-4.1.2/work/gcc-4.1.2/gcc/doc/include -o doc/ /var/tmp/portage/sys-devel/gcc-4.1.2/work/gcc-4.1.2/gcc/treelang/treelang.texi
WARNING: `makeinfo' is missing on your system.  You should only need it if
         you modified a `.texi' or `.texinfo' file, or any other file
         indirectly affecting the aspect of the manual.  The spurious
         call might also be the consequence of using a buggy `make' (AIX,
         DU, IRIX).  You might want to install the `Texinfo' package or
         the `GNU make' package.  Grab either from any GNU archive site.
make[2]: *** [doc/] Error 1
make[2]: Leaving directory `/var/tmp/portage/sys-devel/gcc-4.1.2/work/build/gcc'
make[1]: *** [install-gcc] Error 2
make[1]: Leaving directory `/var/tmp/portage/sys-devel/gcc-4.1.2/work/build'
make: *** [install] Error 2
emake failed
 * ERROR: sys-devel/gcc-4.1.2::gentoo failed (install phase):
 *   (no error message)
 * Call stack:
 *, line   93:  Called src_install
 *   environment, line 4271:  Called toolchain_src_install
 *   environment, line 4984:  Called die
 * The specific snippet of code:
 *       S="${WORKDIR}"/build emake -j1 DESTDIR="${D}" install || die;
 * If you need support, post the output of `emerge --info '=sys-devel/gcc-4.1.2::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=sys-devel/gcc-4.1.2::gentoo'`.
 * Please include /var/tmp/portage/sys-devel/gcc-4.1.2/work/gcc-build-logs.tar.bz2 in your bug report.
 * The complete build log is located at '/var/tmp/portage/sys-devel/gcc-4.1.2/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-devel/gcc-4.1.2/temp/environment'.
 * Working directory: '/var/tmp/portage/sys-devel/gcc-4.1.2/work/build'
 * S: '/var/tmp/portage/sys-devel/gcc-4.1.2/work/gcc-4.1.2'

The only thing that I can see as unusual in the build is that the missing script thinks that makeinfo is not installed, or broken. texinfo is installed, and hasn't been updated in like 1.5 years. For fun, I re-emerged make and texinfo to see if it changed anything, but it did not. I also tried switching gcc to 4.1 and trying to emerge again, but ended up with the same errors.

I've linked my emerge --info, make.conf and the build.log here:
Note: pastebin was not an option with a 7 MiB build.log.

If anyone has any ideas on how I can fix this, I'd love to hear it. Alternately, if you have any ideas on how to only have the libraries I need installed instead of maintaining all of gcc 4.1 (which I don't build with), I'm all ears.
Back to top
View user's profile Send private message

Joined: 29 May 2005
Posts: 6765
Location: Saint Amant, Acadiana

PostPosted: Sat Dec 28, 2013 1:01 am    Post subject: Reply with quote

Not exactly what you asked, but it might be easiest to run a virtual machine for your proprietary application.
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum