Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Trying to emerge World has strange unmet requirements
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
muadib25
Tux's lil' helper
Tux's lil' helper


Joined: 08 Aug 2010
Posts: 92
Location: Sweden

PostPosted: Wed Dec 04, 2013 5:38 pm    Post subject: Trying to emerge World has strange unmet requirements Reply with quote

Hello!

I tried to update my system with 'emerge --sync' followed by 'emerge -pu world'. The latter returns this:

Code:
# emerge -pu world

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! The ebuild selected to satisfy ">=app-misc/tracker-0.16" has unmet requirements.
- app-misc/tracker-0.16.4::gentoo USE="exif flac gif gtk iso jpeg miner-fs mp3 pdf tiff vorbis xml -cue (-eds) -firefox-bookmarks -gsf -gstreamer -iptc -laptop -libsecret -nautilus -networkmanager -playlist -rss -test -thunderbird -upnp-av -xine -xmp -xps"

  The following REQUIRED_USE flag constraints are unsatisfied:
    exactly-one-of ( gstreamer xine )

  The above constraints are a subset of the following complete expression:
    exactly-one-of ( gstreamer xine ) cue? ( gstreamer ) upnp-av? ( gstreamer ) !miner-fs? ( !cue !exif !flac !gif !gsf !iptc !iso !jpeg !mp3 !pdf !playlist !tiff !vorbis !xml !xmp !xps )

(dependency required by "gnome-base/gnome-extra-apps-3.8.0-r1[tracker]" [ebuild])
(dependency required by "gnome-base/gnome-3.8.0-r1[extras]" [ebuild])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])

 * IMPORTANT: 6 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

#


Thank you!
_________________
“What we do for ourselves dies with us. What we do for others and the world remains and is immortal.” -Albert Pine
Back to top
View user's profile Send private message
Christian99
l33t
l33t


Joined: 28 May 2009
Posts: 900

PostPosted: Wed Dec 04, 2013 5:43 pm    Post subject: Reply with quote

Code:
The following REQUIRED_USE flag constraints are unsatisfied:
    exactly-one-of ( gstreamer xine )


U need to activate one of the gstreamer or xine useflags for the package app-misc/tracker
Back to top
View user's profile Send private message
muadib25
Tux's lil' helper
Tux's lil' helper


Joined: 08 Aug 2010
Posts: 92
Location: Sweden

PostPosted: Wed Dec 04, 2013 5:48 pm    Post subject: Reply with quote

Christian99 wrote:
U need to activate one of the gstreamer or xine useflags for the package app-misc/tracker


Hey, thanks for replying! :)
Ok, I added '>=app-misc/tracker-0.16 xine' to package.use, but it now returns:
Code:
# emerge -pu world

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! The ebuild selected to satisfy ">=net-misc/networkmanager-0.9.8[modemmanager?]" has unmet requirements.
- net-misc/networkmanager-0.9.8.8::gentoo USE="bluetooth consolekit dhcpcd gnutls introspection nss ppp wext wifi -avahi -connection-sharing -dhclient -modemmanager -resolvconf -systemd -test -vala"

  The following REQUIRED_USE flag constraints are unsatisfied:
    exactly-one-of ( nss gnutls )

  The above constraints are a subset of the following complete expression:
    modemmanager? ( ppp ) exactly-one-of ( nss gnutls ) exactly-one-of ( dhclient dhcpcd )

(dependency required by "gnome-base/gnome-control-center-3.8.6" [ebuild])
(dependency required by "net-libs/gnome-online-accounts-3.8.5[gnome]" [ebuild])
(dependency required by "gnome-extra/gnome-documents-3.8.5" [ebuild])
(dependency required by "gnome-base/gnome-extra-apps-3.8.0-r1[tracker]" [ebuild])
(dependency required by "gnome-base/gnome-3.8.0-r1[extras]" [ebuild])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])

 * IMPORTANT: 6 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


_________________
“What we do for ourselves dies with us. What we do for others and the world remains and is immortal.” -Albert Pine
Back to top
View user's profile Send private message
depontius
Advocate
Advocate


Joined: 05 May 2004
Posts: 2384

PostPosted: Wed Dec 04, 2013 5:48 pm    Post subject: Reply with quote

It looks like you've got both or neither gstreamer and xine installed, with attendent USE flags, and tracker wants to see exactly one of them.

If you've got neither installed, add either gstreamer or xine to your USE flags in /etc/portage/make.conf. If you've got both installed, pick one of them and add something like this to /etc/portage/package.use:
Code:
>=app-misc/tracker-0.16 gstreamer -xine

or
Code:
>=app-misc/tracker-0.16 -gstreamer xine

Depending on which one you like.
_________________
.sigs waste space and bandwidth
Back to top
View user's profile Send private message
muadib25
Tux's lil' helper
Tux's lil' helper


Joined: 08 Aug 2010
Posts: 92
Location: Sweden

PostPosted: Wed Dec 04, 2013 5:55 pm    Post subject: Reply with quote

Hmm... true. I add 'xine' to make.conf (I had xinerama also there, I guess it's something different), however emerge returns the same about 'networkmanager':
Code:
# emerge -pu world

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! The ebuild selected to satisfy ">=net-misc/networkmanager-0.9.8[modemmanager?]" has unmet requirements.
- net-misc/networkmanager-0.9.8.8::gentoo USE="bluetooth consolekit dhcpcd gnutls introspection nss ppp wext wifi -avahi -connection-sharing -dhclient -modemmanager -resolvconf -systemd -test -vala"

  The following REQUIRED_USE flag constraints are unsatisfied:
    exactly-one-of ( nss gnutls )

  The above constraints are a subset of the following complete expression:
    modemmanager? ( ppp ) exactly-one-of ( nss gnutls ) exactly-one-of ( dhclient dhcpcd )

(dependency required by "gnome-base/gnome-control-center-3.8.6" [ebuild])
(dependency required by "net-libs/gnome-online-accounts-3.8.5[gnome]" [ebuild])
(dependency required by "gnome-extra/gnome-documents-3.8.5" [ebuild])
(dependency required by "gnome-base/gnome-extra-apps-3.8.0-r1[tracker]" [ebuild])
(dependency required by "gnome-base/gnome-3.8.0-r1[extras]" [ebuild])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])

 * IMPORTANT: 6 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

#


UPDATE: Using the same logic you proposed above, I added '>=net-misc/networkmanager-0.9.8[modemmanager?] -dhcpcd -nss dhclient' to package.use. I now get:
Code:
# emerge -pu world

These are the packages that would be merged, in order:

Calculating dependencies... done!

The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by dev-libs/folks-0.9.3[eds]
# required by gnome-extra/gnome-contacts-3.8.3
# required by gnome-base/gnome-core-apps-3.8.0
# required by gnome-base/gnome-3.8.0-r1
# required by @selected
# required by @world (argument)
>=gnome-extra/evolution-data-server-3.8.5 vala
# required by gnome-base/gdm-3.8.4-r3
# required by gnome-base/gnome-3.8.0-r1
# required by @selected
# required by @world (argument)
>=sys-auth/pambase-20120417-r3 systemd
# required by gnome-base/gnome-shell-3.8.4-r1[i18n]
# required by gnome-extra/gnome-tweak-tool-3.8.1-r1
# required by gnome-base/gnome-extra-apps-3.8.0-r1
# required by gnome-base/gnome-3.8.0-r1[extras]
# required by @selected
# required by @world (argument)
=app-i18n/ibus-1.5.2 dconf
# required by media-sound/pulseaudio-4.0[alsa]
# required by gnome-base/gnome-settings-daemon-3.8.6.1
# required by gnome-extra/gnome-tweak-tool-3.8.1-r1
# required by gnome-base/gnome-extra-apps-3.8.0-r1
# required by gnome-base/gnome-3.8.0-r1[extras]
# required by @selected
# required by @world (argument)
=media-plugins/alsa-plugins-1.0.27 pulseaudio
# required by gnome-extra/gnome-contacts-3.8.3
# required by gnome-base/gnome-core-apps-3.8.0
# required by gnome-base/gnome-3.8.0-r1
# required by @selected
# required by @world (argument)
>=dev-libs/folks-0.9.3 eds

emerge: there are no ebuilds built with USE flags to satisfy "net-misc/curl[ssl,curl_ssl_nss]".
!!! One of the following packages is required to complete your request:
- net-misc/curl-7.31.0::gentoo (Change USE: +curl_ssl_nss, this change violates use flag constraints defined by net-misc/curl-7.31.0: 'threads? ( !adns ) ssl? ( exactly-one-of ( curl_ssl_axtls curl_ssl_cyassl curl_ssl_gnutls curl_ssl_openssl curl_ssl_nss curl_ssl_polarssl ) )')
(dependency required by "net-libs/liboauth-1.0.1[curl,nss]" [ebuild])
(dependency required by "dev-libs/libgdata-0.14.0" [ebuild])
(dependency required by "gnome-extra/gnome-documents-3.8.5" [ebuild])
(dependency required by "gnome-base/gnome-extra-apps-3.8.0-r1[tracker]" [ebuild])
(dependency required by "gnome-base/gnome-3.8.0-r1[extras]" [ebuild])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])

 * IMPORTANT: 6 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

#


...
_________________
“What we do for ourselves dies with us. What we do for others and the world remains and is immortal.” -Albert Pine
Back to top
View user's profile Send private message
depontius
Advocate
Advocate


Joined: 05 May 2004
Posts: 2384

PostPosted: Wed Dec 04, 2013 6:02 pm    Post subject: Reply with quote

Oh crud! You're really caught in the gnome-3.8 stabilization mess. This is a much bigger problem than I thought. A lot of people are having problems with this upgrade, I'd start looking at more of the recent threads for more info.

For my part, I'm planning to block gnome-3.8 and systemd, I just haven't gotten around to it, yet. There are multiple threads on that process, as well.
_________________
.sigs waste space and bandwidth
Back to top
View user's profile Send private message
muadib25
Tux's lil' helper
Tux's lil' helper


Joined: 08 Aug 2010
Posts: 92
Location: Sweden

PostPosted: Wed Dec 04, 2013 7:31 pm    Post subject: Reply with quote

Ouch!

Well, that's an approach that sounds attractive for me as well atm. What other options do I have?
_________________
“What we do for ourselves dies with us. What we do for others and the world remains and is immortal.” -Albert Pine
Back to top
View user's profile Send private message
Christian99
l33t
l33t


Joined: 28 May 2009
Posts: 900

PostPosted: Wed Dec 04, 2013 8:14 pm    Post subject: Reply with quote

yeah, for some reason, there is much gnome stuff pulled in. To track this down, can yoou try to install xine?
Code:
emerge -1at xine

and post the output if there are dep conflicts.
Back to top
View user's profile Send private message
muadib25
Tux's lil' helper
Tux's lil' helper


Joined: 08 Aug 2010
Posts: 92
Location: Sweden

PostPosted: Wed Dec 04, 2013 8:21 pm    Post subject: Reply with quote

Absolutely! :)

You mean 'xine-ui', right? Or perhaps 'xine-lib'? Because there is no plain 'xine' package from what I see here... :(
Code:
# emerge -1at xine

 * IMPORTANT: 6 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


These are the packages that would be merged, in reverse order:

Calculating dependencies... done!

emerge: there are no ebuilds to satisfy "xine".

emerge: searching for similar names...
emerge: Maybe you meant any of these: media-video/oxine, media-video/gxine, sys-apps/xinetd?

_________________
“What we do for ourselves dies with us. What we do for others and the world remains and is immortal.” -Albert Pine
Back to top
View user's profile Send private message
depontius
Advocate
Advocate


Joined: 05 May 2004
Posts: 2384

PostPosted: Wed Dec 04, 2013 8:38 pm    Post subject: Reply with quote

Actually I believe it's either libxine or xine-lib. You could do "emerge -ptv xine-ui" and see what it pulls in. Other applications will use xine-lib, (or whatever) xine-ui is just what you use when running it standalone.
_________________
.sigs waste space and bandwidth
Back to top
View user's profile Send private message
muadib25
Tux's lil' helper
Tux's lil' helper


Joined: 08 Aug 2010
Posts: 92
Location: Sweden

PostPosted: Thu Dec 05, 2013 6:19 pm    Post subject: Reply with quote

The above command pulls in only xine-ui, which I installed and it runs properly... No conflicts.
_________________
“What we do for ourselves dies with us. What we do for others and the world remains and is immortal.” -Albert Pine
Back to top
View user's profile Send private message
Christian99
l33t
l33t


Joined: 28 May 2009
Posts: 900

PostPosted: Thu Dec 05, 2013 6:34 pm    Post subject: Reply with quote

just a stupid question: do you have gnome stuff already installed, or is this new stuff on your system?
Back to top
View user's profile Send private message
muadib25
Tux's lil' helper
Tux's lil' helper


Joined: 08 Aug 2010
Posts: 92
Location: Sweden

PostPosted: Thu Dec 05, 2013 6:53 pm    Post subject: Reply with quote

Yep, I do! :)
Gnome-about says: 2.32.1
_________________
“What we do for ourselves dies with us. What we do for others and the world remains and is immortal.” -Albert Pine
Back to top
View user's profile Send private message
Christian99
l33t
l33t


Joined: 28 May 2009
Posts: 900

PostPosted: Thu Dec 05, 2013 7:24 pm    Post subject: Reply with quote

then you should better stick to the gnome-3.8 upgrading or masking threads. there are some already :)
Back to top
View user's profile Send private message
muadib25
Tux's lil' helper
Tux's lil' helper


Joined: 08 Aug 2010
Posts: 92
Location: Sweden

PostPosted: Thu Dec 05, 2013 7:38 pm    Post subject: Reply with quote

Do you mean to wait until the whole issue is resolved?
_________________
“What we do for ourselves dies with us. What we do for others and the world remains and is immortal.” -Albert Pine
Back to top
View user's profile Send private message
Christian99
l33t
l33t


Joined: 28 May 2009
Posts: 900

PostPosted: Thu Dec 05, 2013 9:41 pm    Post subject: Reply with quote

yeah, would be best. I'm no expert on either gnome nor systemd, becuase I haven't one or the other. What I have read in some other threads is, that gnome-3.8 definitely needs systemd, so enabling the useflag globally should be easiest. and according to your posts, maybe pulseaudio is also needed and should be enabled, but i'm not sure about that.
also switching to systemd seems to make sometimes trouble, but I just saw the thread captions, didn't read them.
so, good luck...
Back to top
View user's profile Send private message
gherardo
n00b
n00b


Joined: 19 Dec 2004
Posts: 19

PostPosted: Fri Dec 27, 2013 10:31 pm    Post subject: Reply with quote

Do not know whether this is useful to somebody.

During a fresh install of ubuntu, I ran in the same problem when compiling gnome.

I tried adding the flags "-xine +gstreamer", it failed.

Then I tried the opposite: "xine -gstreamer", it worked!
_________________
Gherardo Piacitelli
Back to top
View user's profile Send private message
gherardo
n00b
n00b


Joined: 19 Dec 2004
Posts: 19

PostPosted: Tue Dec 31, 2013 10:15 am    Post subject: Reply with quote

Not really. It did not work one step later:

gherardo wrote:
Do not know whether this is useful to somebody.

During a fresh install of ubuntu, I ran in the same problem when compiling gnome.

I tried adding the flags "-xine +gstreamer", it failed.

Then I tried the opposite: "xine -gstreamer", it worked!


Take this problem as indication that you have a profile problem.

Eventually every problem disappeared for me upon selecting the right profile: I had chosen desktop,
the right choice was instead the subprofile desktop/gnome/systemd (you need systemd otherwise you get stuck later).

So I eseleted the right profile, I reemerged world with options "-avuND", next I depcleaned, and afterwards emerging gnome went fine.
_________________
Gherardo Piacitelli
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum