Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge tracker fails with dependency issue
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
anthonyatech
n00b
n00b


Joined: 24 Dec 2013
Posts: 3

PostPosted: Tue Dec 24, 2013 9:47 pm    Post subject: emerge tracker fails with dependency issue Reply with quote

Hello, thanks ahead of time for the support. I am pretty much out of ideas/options on how to fix this issue. I try to do an emerge -uDav world and this is the output:

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! The ebuild selected to satisfy ">=app-misc/tracker-0.16" has unmet requirements.
- app-misc/tracker-0.16.4::gentoo USE="gtk iso jpeg miner-fs tiff vorbis xml -cue (-eds) -exif -firefox-bookmarks -flac -gif -gsf -gstreamer -iptc -laptop -libsecret -mp3 -nautilus -networkmanager -pdf -playlist -rss -test -thunderbird -upnp-av -xine -xmp -xps"

The following REQUIRED_USE flag constraints are unsatisfied:
exactly-one-of ( gstreamer xine )

The above constraints are a subset of the following complete expression:
exactly-one-of ( gstreamer xine ) cue? ( gstreamer ) upnp-av? ( gstreamer ) !miner-fs? ( !cue !exif !flac !gif !gsf !iptc !iso !jpeg !mp3 !pdf !playlist !tiff !vorbis !xml !xmp !xps )

(dependency required by "gnome-base/gnome-extra-apps-3.8.0-r1[tracker]" [ebuild])
(dependency required by "gnome-base/gnome-3.8.0-r1[extras]" [ebuild])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])

I have had this issue for a while and even removed tracker, but the above message still occurs.
Here is the output of my emerge --info
emerge --info
Portage 2.2.7 (default/linux/x86/13.0, gcc-4.5.4, glibc-2.15-r3, 3.1.10-gentoo-r1 i686)
=================================================================
System uname: Linux-3.1.10-gentoo-r1-i686-Pentium-R-_Dual-Core_CPU_E5200_@_2.50GHz-with-gentoo-2.2
KiB Mem: 2034848 total, 92808 free
KiB Swap: 2008120 total, 1983252 free
Timestamp of tree: Tue, 24 Dec 2013 21:00:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
app-shells/bash: 4.2_p45
dev-java/java-config: 2.1.12-r1
dev-lang/python: 2.6.6-r2, 2.7.5-r3, 3.1.4-r3, 3.2.5-r3, 3.3.2-r2
dev-util/cmake: 2.8.10.2-r2
dev-util/pkgconfig: 0.28
sys-apps/baselayout: 2.2
sys-apps/openrc: 0.11.8
sys-apps/sandbox: 2.6-r1
sys-devel/autoconf: 2.13, 2.69
sys-devel/automake: 1.10.3, 1.11.6, 1.12.6, 1.13.4
sys-devel/binutils: 2.23.1
sys-devel/gcc: 4.4.7, 4.5.4, 4.6.3, 4.7.3-r1
sys-devel/gcc-config: 1.7.3
sys-devel/libtool: 2.4.2
sys-devel/make: 3.82-r4
sys-kernel/linux-headers: 3.9 (virtual/os-headers)
sys-libs/glibc: 2.15-r3
Repositories: gentoo
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="* -@EULA dlj-1.1 PUEL"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt /var/bind /var/lib/neatx/home"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/apache2-php5.5/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cgi-php5.5/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/php/cli-php5.5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=i686 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--autounmask=n"
FCFLAGS="-O2 -march=i686 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -march=i686 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
USE="X acl apache2 apm berkdb bzip2 cairo cdda cli consolekit cracklib crypt cups cxx dbus device-mapper dlz dri dvd extensions extras fbcon fortran ftp gdbm gdu gnome gnutls gtk gudev hal hwdb iconv imap ipv6 java javascript jpeg modules mudflap mysql ncurses nls nptl openmp pam pcre php policykit pop python readline samba sasl session sqlite ssl tcpd unicode vhosts x86 xml zlib" ABI_X86="32" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby18" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
USE_PYTHON="2.7 3.3"
Unset: CPPFLAGS, CTARGET, INSTALL_MASK, LANG, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, SYNC

Any help would be greatly appreciated! Thanks!!
Back to top
View user's profile Send private message
eccerr0r
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3598
Location: USA

PostPosted: Tue Dec 24, 2013 11:07 pm    Post subject: Reply with quote

This means that the package needs one of the use flags set, so need USE=gstreamer or USE=xine for app-misc/tracker .

Since it's exactly-one-of, you can't, however, have both.
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed to be advocating?
Back to top
View user's profile Send private message
anthonyatech
n00b
n00b


Joined: 24 Dec 2013
Posts: 3

PostPosted: Wed Dec 25, 2013 10:46 am    Post subject: Reply with quote

I added gstreamer to the use variables and then did "emerge -uDav --newuse world" and got this message:

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! The ebuild selected to satisfy ">=net-misc/networkmanager-0.9.8[modemmanager?]" has unmet requirements.
- net-misc/networkmanager-0.9.8.8::gentoo USE="consolekit dhcpcd gnutls introspection nss ppp wext wifi -avahi -bluetooth -connection-sharing -dhclient -modemmanager -resolvconf -systemd -test -vala"

The following REQUIRED_USE flag constraints are unsatisfied:
exactly-one-of ( nss gnutls )

The above constraints are a subset of the following complete expression:
modemmanager? ( ppp ) exactly-one-of ( nss gnutls ) exactly-one-of ( dhclient dhcpcd )

(dependency required by "gnome-base/gnome-control-center-3.8.6" [ebuild])
(dependency required by "net-libs/gnome-online-accounts-3.8.5[gnome]" [ebuild])
(dependency required by "gnome-extra/gnome-documents-3.8.5" [ebuild])
(dependency required by "gnome-base/gnome-extra-apps-3.8.0-r1[tracker]" [ebuild])
(dependency required by "gnome-base/gnome-3.8.0-r1[extras]" [ebuild])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])

I already have gnutls in my use variables, so I added dhcpcd and tried "emerge -uDav --newuse world" again and got this message:
These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! The ebuild selected to satisfy ">=net-misc/networkmanager-0.9.8[modemmanager?]" has unmet requirements.
- net-misc/networkmanager-0.9.8.8::gentoo USE="consolekit dhcpcd gnutls introspection nss ppp wext wifi -avahi -bluetooth -connection-sharing -dhclient -modemmanager -resolvconf -systemd -test -vala"

The following REQUIRED_USE flag constraints are unsatisfied:
exactly-one-of ( nss gnutls )

The above constraints are a subset of the following complete expression:
modemmanager? ( ppp ) exactly-one-of ( nss gnutls ) exactly-one-of ( dhclient dhcpcd )

(dependency required by "gnome-base/gnome-control-center-3.8.6" [ebuild])
(dependency required by "net-libs/gnome-online-accounts-3.8.5[gnome]" [ebuild])
(dependency required by "gnome-extra/gnome-documents-3.8.5" [ebuild])
(dependency required by "gnome-base/gnome-extra-apps-3.8.0-r1[tracker]" [ebuild])
(dependency required by "gnome-base/gnome-3.8.0-r1[extras]" [ebuild])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])

so then I now added ppp to my use variables tried again and got this message:

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! The ebuild selected to satisfy ">=net-misc/networkmanager-0.9.8[modemmanager?]" has unmet requirements.
- net-misc/networkmanager-0.9.8.8::gentoo USE="consolekit dhcpcd gnutls introspection nss ppp wext wifi -avahi -bluetooth -connection-sharing -dhclient -modemmanager -resolvconf -systemd -test -vala"

The following REQUIRED_USE flag constraints are unsatisfied:
exactly-one-of ( nss gnutls )

The above constraints are a subset of the following complete expression:
modemmanager? ( ppp ) exactly-one-of ( nss gnutls ) exactly-one-of ( dhclient dhcpcd )

(dependency required by "gnome-base/gnome-control-center-3.8.6" [ebuild])
(dependency required by "net-libs/gnome-online-accounts-3.8.5[gnome]" [ebuild])
(dependency required by "gnome-extra/gnome-documents-3.8.5" [ebuild])
(dependency required by "gnome-base/gnome-extra-apps-3.8.0-r1[tracker]" [ebuild])
(dependency required by "gnome-base/gnome-3.8.0-r1[extras]" [ebuild])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])

This is what my make.conf looks like:

# These settings were set by the catalyst build script that automatically
# built this stage.
# Please consult /usr/share/portage/config/make.conf.example for a more
# detailed example.
CFLAGS="-O2 -march=i686 -pipe"
CXXFLAGS="-O2 -march=i686 -pipe"
# WARNING: Changing your CHOST is not something that should be done lightly.
# Please consult http://www.gentoo.org/doc/en/change-chost.xml before changing.
CHOST="i686-pc-linux-gnu"
MAKEOPTS="-j3"
USE="ppp dhcpcd gstreamer hwdb gudev dlz python cdda -qt4 -qt3 -kde jpeg gnutls extensions X dbus gtk extras gdu consolekit cairo sqlite policykit device-mapper gnome hal xml ssl sasl java javascript mysql cups ftp apm samba php imap pop dvd apache2 fbcon vhosts"
ACCEPT_LICENSE="dlj-1.1 PUEL"
USE_PYTHON="2.7 3.3"
INPUT_DEVICES="evdev"
VIDEO_CARDS="intel"
EMERGE_DEFAULT_OPTS="--autounmask=n"

# Set PORTDIR for backward compatibility with various tools:
# gentoo-bashcomp - bug #478444
# euse - bug #474574
# euses and ufed - bug #478318
PORTDIR="/usr/portage"

I have added every one of the requested use variables and still cannot update ... thanks for the response, its greatly appreciated as is any other help! :)
Back to top
View user's profile Send private message
eccerr0r
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3598
Location: USA

PostPosted: Thu Dec 26, 2013 3:00 am    Post subject: Reply with quote

You probably have USE=nss set as a default somewhere, can try USE=-nss ... or if you can do without gnutls, apparently that's some sort of default...
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed to be advocating?
Back to top
View user's profile Send private message
anthonyatech
n00b
n00b


Joined: 24 Dec 2013
Posts: 3

PostPosted: Thu Dec 26, 2013 3:41 am    Post subject: Reply with quote

I ended up having to add png vala eds dconf udisks systemd ogg theora icu pulseaudio gstreamer to the use variables and remove gnutls and finally its working.. Thanks for all of the help!!!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum