Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Emerge failing grub2
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
spacelike
n00b
n00b


Joined: 15 Sep 2011
Posts: 53

PostPosted: Tue Dec 24, 2013 4:56 am    Post subject: [SOLVED] Emerge failing grub2 Reply with quote

I've been having several things fail to emerge. But the first one to occur was Grub2 during an emerge world.

Code:
 * Messages for package sys-boot/grub-2.02_beta1-r1:

 * ERROR: sys-boot/grub-2.02_beta1-r1::gentoo failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=sys-boot/grub-2.02_beta1-r1::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=sys-boot/grub-2.02_beta1-r1::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/sys-boot/grub-2.02_beta1-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-boot/grub-2.02_beta1-r1/temp/environment'.
 * Working directory: '/var/tmp/portage/sys-boot/grub-2.02_beta1-r1/work/grub-2.02~beta1-guessed'
 * S: '/var/tmp/portage/sys-boot/grub-2.02_beta1-r1/work/grub-2.02~beta1'


emerge --info '=sys-boot/grub-2.02_beta1-r1::gentoo'
http://bpaste.net/show/161398/

emerge -pqv '=sys-boot/grub-2.02_beta1-r1::gentoo'
Code:
[ebuild     U ] sys-boot/grub-2.02_beta1-r1 [2.00_p5107-r2] USE="multislot nls sdl truetype -debug -device-mapper -doc -efiemu -libzfs -mount -static {-test} (-custom-cflags%)" GRUB_PLATFORMS="-coreboot -efi-32 -efi-64 -emu -ieee1275 -multiboot -pc -qemu -qemu-mips -yeeloong"


build log /var/tmp/portage/sys-boot/grub-2.02_beta1-r1/temp/build.log
http://bpaste.net/show/161399/

ebuild environment file /var/tmp/portage/sys-boot/grub-2.02_beta1-r1/temp/environment
http://bpaste.net/show/161401/

Not sure what other information to provide, so if anything else is needed please let me know.


Last edited by spacelike on Tue Dec 24, 2013 10:02 pm; edited 1 time in total
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5267

PostPosted: Tue Dec 24, 2013 6:21 am    Post subject: Reply with quote

Given the errors, most likely solution is "run perl-cleaner".
Back to top
View user's profile Send private message
spacelike
n00b
n00b


Joined: 15 Sep 2011
Posts: 53

PostPosted: Tue Dec 24, 2013 6:29 pm    Post subject: Reply with quote

That did the trick

Thank you very much
Back to top
View user's profile Send private message
giocitta
n00b
n00b


Joined: 11 Dec 2013
Posts: 4
Location: Località Cheirasca, 21 -15066 Gavi (AL)

PostPosted: Wed Dec 25, 2013 7:55 am    Post subject: Grub:2 ERROR Reply with quote

Exactly the same thing happened to me yesterday after a world update. grub2-mkconfig not working; grub:2 not removable; grub:2 not installable. Emerge ERROR: sys-boot/grub-2.02_beta1-r1::gentoo failed (compile phase): emake failed.

Everything went back to its place after: perl-cleaner --reallyall
and grub:2 reinstall.

Thanks for the indirect help.
_________________
Giorgio Cittadini
Back to top
View user's profile Send private message
thenextdon13
n00b
n00b


Joined: 26 Sep 2012
Posts: 9

PostPosted: Fri Jan 03, 2014 4:57 pm    Post subject: Reply with quote

Same thing here, running perl-cleaner --all did the trick.
Thank you!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum