Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Teamspeak3 Client Fehlermeldung
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Stype1337
n00b
n00b


Joined: 24 Dec 2013
Posts: 9

PostPosted: Tue Dec 24, 2013 4:22 pm    Post subject: Teamspeak3 Client Fehlermeldung Reply with quote

Hallo,

bevor ich anfange erstmal frohe Weihnachten :)

...

ich bin neu in Gentoo und (verspottet mich nicht) war vorher langezeit Debianer, daher tauchen hier und da noch einige Hürden für mich auf :)

Ja, mit Google, FAQs und Handbüchern bin ich vertraut (auch in Englisch). Ich würde diesen Thread also nicht erstellen, wenn ich nicht schon mindestens 4 Stunden Suchen investietr hätte.
Ja, vielleicht habe ich was übersehen.

Genug der Rechtfertigungen:

Code:

[ Results for search key : teamspeak ]
[ Applications found : 2 ]

*  media-sound/teamspeak-client-bin
      Latest version available: 3.0.13.1
      Latest version installed: 3.0.13.1
      Size of files: 32,429 kB
      Homepage:      http://www.teamspeak.com/
      Description:   TeamSpeak Client - Voice Communication Software
      License:       teamspeak3


Um das zu installieren musste ich die *.run von der offiziellen Teamspeak-Seite downloaden.

Installiert wurde alles.

Quote:

# l /opt/teamspeak3-client/
total 14788
drwxr-xr-x 13 root root 4096 Dec 24 13:09 .
drwxr-xr-x 6 root root 4096 Dec 24 12:56 ..
-rw-r--r-- 1 root root 145514 Dec 24 12:56 CHANGELOG
-rw-r--r-- 1 root root 23854 Dec 24 12:56 LICENSE
drwxr-xr-x 2 root root 4096 Dec 24 12:56 accessible
-rw-r--r-- 1 root root 117119 Dec 24 12:56 error_report
drwxr-xr-x 4 root root 4096 Dec 24 12:56 gfx
drwxr-xr-x 2 root root 4096 Dec 24 12:56 imageformats
-rw-r--r-- 1 root root 88424 Dec 24 12:56 libgcc_s.so.1
-rw-r--r-- 1 root root 998000 Dec 24 12:56 libstdc++.so.6
-rw-r--r-- 1 root root 142 Dec 24 12:56 mirrors.ini
drwxr-xr-x 5 root root 4096 Dec 24 12:56 news
-rw-r--r-- 1 root root 149298 Dec 24 12:56 package_inst
drwxr-xr-x 6 root root 4096 Dec 24 12:56 plugins
drwxr-xr-x 6 root root 4096 Dec 24 12:56 pluginsdk
-rw-r--r-- 1 root root 26 Dec 24 12:56 qt.conf
drwxr-xr-x 6 root root 4096 Dec 24 12:56 sound
drwxr-xr-x 2 root root 4096 Dec 24 12:56 soundbackends
drwxr-xr-x 2 root root 4096 Dec 24 12:56 sqldrivers
drwxr-xr-x 5 root root 4096 Dec 24 12:56 styles
drwxr-xr-x 2 root root 4096 Dec 24 12:56 translations
-rwxr-xr-x 1 root root 12509096 Dec 24 12:56 ts3client
-rwxr-xr-x 1 root root 283 Dec 24 13:09 ts3client_runscript.sh
-rwxr-xr-x 1 root root 1034882 Dec 24 12:56 update


Ich habe ts3client und update noch +x gegeben, das war nicht der Fall.


Beim Starten erhalte ich folgendes:

Quote:

# teamspeak3
"TS3Tables" changed
"General" changed
2013-12-24 16:17:30.874237|INFO | | | TeamSpeak 3 Client 3.0.13.1 (2013-10-23 12:10:11)
2013-12-24 16:17:30.874322|INFO | | | SystemInformation: Linux 3.10.17-gentoo #1 SMP Sun Dec 22 13:42:11 UTC 2013 x86_64 Binary: 64bit
2013-12-24 16:17:30.874346|INFO | | | Using hardware aes
terminate called after throwing an instance of 'std::runtime_error'
what(): locale::facet::_S_create_c_locale name not valid
Aborted



Nach einiger googlelei könnte es wohl an den locales liegen:

Quote:

# locale
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=de_DE.UTF-8
LC_CTYPE="de_DE.UTF-8"
LC_NUMERIC="de_DE.UTF-8"
LC_TIME="de_DE.UTF-8"
LC_COLLATE=C
LC_MONETARY="de_DE.UTF-8"
LC_MESSAGES="de_DE.UTF-8"
LC_PAPER="de_DE.UTF-8"
LC_NAME="de_DE.UTF-8"
LC_ADDRESS="de_DE.UTF-8"
LC_TELEPHONE="de_DE.UTF-8"
LC_MEASUREMENT="de_DE.UTF-8"
LC_IDENTIFICATION="de_DE.UTF-8"
LC_ALL=


Ich habe diese schon abgeändert, und auch mal LC_ALL gesetzt (wovon dringend abgeraten wurde) und dann wieder unset durchgeführt usw.
Das brachte allerdings keine Besserung.

Ist es ein Compiler-Problem ? Er meckert ja offensichtlich über c-locales ... also muss es ja doch was mit locales zu tun haben, aber was ??
Kann evtl. etwas nicht gesetzt werden ?


Danke für eure Hilfe und einen heiligen Abend :)
Back to top
View user's profile Send private message
mv
Advocate
Advocate


Joined: 20 Apr 2005
Posts: 3784

PostPosted: Tue Dec 24, 2013 6:12 pm    Post subject: Reply with quote

Hast Du eine passende /etc/locale.gen erstellt? Darin sollte mindestens die Zeile
/etc/locale.gen wrote:
de_DE.UTF-8 UTF-8
stehen. Oder hast Du die Datei erst nach dem emergen von glibc erstellt/geändert? In dem Fall solltest Du mal locale-gen aufrufen.
Back to top
View user's profile Send private message
Stype1337
n00b
n00b


Joined: 24 Dec 2013
Posts: 9

PostPosted: Tue Dec 24, 2013 10:14 pm    Post subject: Reply with quote

Hallo,

ja das habe ich gemacht, aber ich habe es vorsichtshalber noch einmal durchgeführt, es brachte allerdings keine Besserung;

Code:

# locale-gen
 * Generating 4 locales (this might take a while) with 1 jobs
 *  (1/4) Generating en_US.ISO-8859-1 ... [ ok ]
 *  (2/4) Generating en_US.UTF-8 ... [ ok ]
 *  (3/4) Generating de_DE.ISO-8859-1 ... [ ok ]
 *  (4/4) Generating de_DE.ISO-8859-15@euro ... [ ok ]
 * Generation complete

# env-update
>>> Regenerating /etc/ld.so.cache...


# l /etc/locale.gen
-rw-r--r-- 1 root root 871 Dec 22 16:25 /etc/locale.gen

[0:503] 10:13:04 Tue Dec 24 [root@PC:/dev/pts/0 +2] ~
# teamspeak3
2013-12-24 22:13:13.960891|INFO    |              |   | TeamSpeak 3 Client 3.0.13.1 (2013-10-23 12:10:11)
2013-12-24 22:13:13.961308|INFO    |              |   | SystemInformation: Linux 3.10.17-gentoo #1 SMP Sun Dec 22 13:42:11 UTC 2013 x86_64 Binary: 64bit
2013-12-24 22:13:13.961363|INFO    |              |   | Using hardware aes                                                                                             
terminate called after throwing an instance of 'std::runtime_error'                                                                                                   
  what():  locale::facet::_S_create_c_locale name not valid                                                                                                           
Aborted                                                                                                                                                               
Back to top
View user's profile Send private message
Stype1337
n00b
n00b


Joined: 24 Dec 2013
Posts: 9

PostPosted: Tue Dec 24, 2013 10:18 pm    Post subject: Reply with quote

Ach ich bin so Doof -.-


Ich habe eine essentielle Zeile in meiner /etc/locale.gen vergessen !!!!!


Quote:
# cat /etc/locale.gen
# /etc/locale.gen: list all of the locales you want to have on your system
#
# The format of each line:
# <locale> <charmap>
#
# Where <locale> is a locale located in /usr/share/i18n/locales/ and
# where <charmap> is a charmap located in /usr/share/i18n/charmaps/.
#
# All blank lines and lines starting with # are ignored.
#
# For the default list of supported combinations, see the file:
# /usr/share/i18n/SUPPORTED
#
# Whenever glibc is emerged, the locales listed here will be automatically
# rebuilt for you. After updating this file, you can simply run `locale-gen`
# yourself instead of re-emerging glibc.

en_US ISO-8859-1
en_US.UTF-8 UTF-8
#ja_JP.EUC-JP EUC-JP
#ja_JP.UTF-8 UTF-8
#ja_JP EUC-JP
#en_HK ISO-8859-1
#en_PH ISO-8859-1
de_DE ISO-8859-1
de_DE@euro ISO-8859-15
+de_DE.UTF-8 UTF-8
#es_MX ISO-8859-1
#fa_IR UTF-8
#fr_FR ISO-8859-1
#fr_FR@euro ISO-8859-15
#it_IT ISO-8859-1


Händisch ergänzt und env-update durchgeführt.

Sorry eure Zeit geklaut zu haben :)

Vielen Dank für die Hilfe.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum