Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message

Joined: 19 Aug 2004
Posts: 582
Location: Oslo, Norway

PostPosted: Fri Nov 02, 2012 7:33 pm    Post subject: Reply with quote

For the record
rootnoverify (hd0,2)
chainloader (hd0,2)/bootmgr
gave the error "Invalid or unsupported executable format"

I'm just gonna try and install it on a different disk while I wait and see if anyone has any ideas.
Noone wrote:
Back to top
View user's profile Send private message

Joined: 27 Nov 2012
Posts: 5
Location: Burgdorf (CH)

PostPosted: Sat Dec 01, 2012 7:29 am    Post subject: Error 15: File not found Reply with quote

Hey Guys

I work my way through a gentoo install.
But something went wrong whit my grub entry.
Now I get this boot-error.
root (hd0,1)
Filesystem type is ext2fs, partition type 0x*3
kernel /boot/kernel-3.5.7-gentoo root=/dev/sda5

Error 15: File not found

That's how my disk look like.
sda1 Windows
sda2 Boot
sda3 Swap
sda5 Root
sda6 Home

Thanks for teaching me.
Back to top
View user's profile Send private message

Joined: 25 Jul 2002
Posts: 26

PostPosted: Sun Apr 07, 2013 12:31 am    Post subject: grub geom error Reply with quote

I have been trying to get the Windows 7 bootloader to start Grub with no success. I have installed Gentoo on a new mSATA drive, and have a working Ubuntu installation in my Windows partition (installed with wubi). I would like to keep the Windows bootloader in the MBR.
Here's a description of my system:
Sager NP9170 Notebook
my partitions:
/dev/sda1 750 GB user data (D:) HDD
/dev/sdb1 210 MB System (no windows drive letter) SSD
/dev/sdb2 180 GB Windows (C:)
/dev/sdc1 256 GB Linux (/) mSATA SSD
/dev/sdd1 32 GB flash drive

after installing GRUB to (hd2,0), which should correspond to /dev/sdc1 I used dd to copy the bootloader to a file in my Windows partition, and used bcdedit to add it to the Windows boot menu.
When I try to boot Gentoo I get the following error:
Grub Geom Error

I have also tried installing GRUB into (hd2) the MBR of /dev/sdc and still haven't gotten it to work.
I have also tried using EasyBCD. With other configurations I have tried I got this error too:

It just prints Grub and nothing else.

The only thing that has worked has been to press F7 at boot to select the mSATA drive and load GRUB from its MBR. But then I have to edit the command and change
root (hd2,0)
root (hd0,0)

I hope someone can help me figure out what is going on.

Some additional Information:
Grub version grub-0.97-r12

default 0
timeout 30

title Gentoo Linux 3.7.10
root (hd2,0)
kernel /boot/kernel-3.7.10-gentoo root=/dev/sdc1


# grub-install --no-floppy /dev/sdc1
Installation finished. No error reported.
This is the contents of the device map /boot/
Check if this is correct or not. If any of the lines is incorrect,
fix it and re-run the script `grub-install'.

(fd0)   /dev/fd0
(hd0)   /dev/sda
(hd1)   /dev/sdb
(hd2)   /dev/sdc
(hd3)   /dev/sdd

I also tried installing grub manually as per the handbook:

root (hd2,0)
setup (hd2,0)

Grub installation has not given any errors.
Back to top
View user's profile Send private message

Joined: 03 Sep 2002
Posts: 413
Location: Shake & Bake

PostPosted: Sun Apr 21, 2013 5:15 am    Post subject: Reply with quote

My Grub Config
based on

title FlashGen2


kernel /boot/kernel-genkernel-x86_6403.4.34-gentoo root=PARTUID=b969b2c9-becb-48cc-ad6d-81517bb12ca8

Grub is throwing a fit with error 11 on one of the PARTUUID= entries (I'm thinking it's the second or is it the first? The root= should allow the system to boot no matter what drive letter is assigned
Back to top
View user's profile Send private message
Tux's lil' helper
Tux's lil' helper

Joined: 12 Nov 2013
Posts: 94

PostPosted: Wed Nov 27, 2013 11:41 pm    Post subject: Reply with quote

OK, here's a weird on for you. When I boot my comp GRUB gos into it's install mode thing, as if I was setting it up manually. I any ideas?

Also this may help:

Edit: Looking around I can see that this thread gets about 1 post a month... I'll just reinstall with ext2 on boot.
Back to top
View user's profile Send private message

Joined: 24 Dec 2013
Posts: 2

PostPosted: Tue Dec 24, 2013 7:01 pm    Post subject: Reply with quote


Ive got some troubles with grub.
screenshots attached, imgs will tell you enough i think .




PS i c, that there is strange error with grub2-probe that tells about "unknown filesystem", but idk how to handle it.

probe is rly buggy, or idk, but it also tells that sda1 & sda3 got an ext2, when it ext4...

Didnt found anything about flag setting in handbook, when "GPT" label selected in "parted".
Somebody should add "set 1 bios_grub on" command, coz now parted with "GPT" case in handbook is incomplete\not working; if somebody choses GPT & knows nothing about it (like me =), when installing gentoo for 1st time he can got an error.

PPS yep, im using genkernel, so ext4 supported by kernel.

sry 4 bad english.
chaos is theory in action
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Goto page Previous  1, 2
Page 2 of 2

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum