Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Tkint] impossible d'installer [resolu]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
pepit
n00b
n00b


Joined: 11 Jan 2013
Posts: 60

PostPosted: Thu Nov 21, 2013 3:47 pm    Post subject: [Tkint] impossible d'installer [resolu] Reply with quote

Bonjour,

Pour utiliser sereinement replicatorg, j'ai essayé tout ce que j'ai trouvé, rien n'y fait!

1 Mis dans /etc/portage/package.use : dev-lang/python tk

2 Exécuté : emerge --newuse python

~ Fait tout un tas d'autre truc glané ça et là

Version python : 3.2.3-r2

Des idées?


Last edited by pepit on Thu Nov 28, 2013 10:34 am; edited 1 time in total
Back to top
View user's profile Send private message
XavierMiller
Moderator
Moderator


Joined: 23 Jul 2004
Posts: 5265
Location: ~Brussels - Belgique

PostPosted: Thu Nov 21, 2013 8:30 pm    Post subject: Reply with quote

Quel est le problème, en fait ? Pourrais-tu donner le message d'erreur et la commande associée ?

et
Code:
emerge --info

_________________
Xavier Miller
(FR) Merci de respecter les règles du forum.
http://www.xaviermiller.be
Back to top
View user's profile Send private message
pepit
n00b
n00b


Joined: 11 Jan 2013
Posts: 60

PostPosted: Fri Nov 22, 2013 3:49 pm    Post subject: Reply with quote

Message de l'application:
"Editing profiles requires Tkinter to be installed. No valid Tkinter install was found.etc.."
Idem pour émetre le Gcode, de plus mon modèle n'est pas affiché.

Message de emerge --newuse python : Aucun, tout semble se compiler dans le meilleur des mondes, dev-lang semble bien pris en charge.

Extrait emerge --info:

"Portage 2.1.12.2 (default/linux/x86/13.0/desktop/kde, gcc-4.6.3, glibc-2.15-r3, 3.8.13-gentoo i686)
=================================================================
System uname: Linux-3.8.13-gentoo-i686-Mobile_Pentium_II-with-gentoo-2.2
KiB Mem: 253700 total, 42856 free
KiB Swap: 610464 total, 605228 free
Timestamp of tree: Sat, 15 Jun 2013 10:45:01 +0000
ld GNU ld (GNU Binutils) 2.22
app-shells/bash: 4.2_p45
dev-java/java-config: 2.1.12-r1
dev-lang/python: 2.7.3-r3, 3.2.3-r2
dev-util/cmake: 2.8.10.2-r2
dev-util/pkgconfig: 0.28
sys-apps/baselayout: 2.2
sys-apps/openrc: 0.11.8
sys-apps/sandbox: 2.5
sys-devel/autoconf: 2.13, 2.69
sys-devel/automake: 1.10.3, 1.11.6, 1.12.6
sys-devel/binutils: 2.22-r1
sys-devel/gcc: 4.6.3
sys-devel/gcc-config: 1.7.3
sys-devel/libtool: 2.4-r1
sys-devel/make: 3.82-r4
sys-kernel/linux-headers: 3.7 (virtual/os-headers)
sys-libs/glibc: 2.15-r3
Repositories: gentoo
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="* -@EULA"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -pipe"
CHOST="i686-pc-linux-gnu""

Est-ce suffisant?
Back to top
View user's profile Send private message
XavierMiller
Moderator
Moderator


Joined: 23 Jul 2004
Posts: 5265
Location: ~Brussels - Belgique

PostPosted: Fri Nov 22, 2013 4:29 pm    Post subject: Reply with quote

Donc il te manque tkinter. Tu devras donc l'installer avec la bonne instruction emerge.

Quelle applcation est-ce ?
_________________
Xavier Miller
(FR) Merci de respecter les règles du forum.
http://www.xaviermiller.be
Back to top
View user's profile Send private message
pepit
n00b
n00b


Joined: 11 Jan 2013
Posts: 60

PostPosted: Fri Nov 22, 2013 5:16 pm    Post subject: Reply with quote

Ca oui, il manque pour replicatorg : pilote d'impression 3d.

Pourtant j'ai suivit à la lettre les howto gentoo comme décrit dans le premier post et bien d'autre chose glané dans des forums diverses.....

J'arrive malgré tout à imprimer en générant le gcode sur une autre machine Mandriva et en copiant les fichiers dans le"pc pilote" sous gentoo mais c'est pas très pratique!
Back to top
View user's profile Send private message
XavierMiller
Moderator
Moderator


Joined: 23 Jul 2004
Posts: 5265
Location: ~Brussels - Belgique

PostPosted: Fri Nov 22, 2013 5:40 pm    Post subject: Reply with quote

Hello,

Tes réponses ne sont pas claires du tout : quel logiciel veux-tu installer ? Quelle documentation as-tu suivie ? Qu'as-tu déjà fait qui fonctionne ?
_________________
Xavier Miller
(FR) Merci de respecter les règles du forum.
http://www.xaviermiller.be
Back to top
View user's profile Send private message
pepit
n00b
n00b


Joined: 11 Jan 2013
Posts: 60

PostPosted: Fri Nov 22, 2013 7:47 pm    Post subject: Reply with quote

Ben, aurai-je du mal à me faire comprendre?
Excuse moi, je pensait que l'usage n'avais pas d'importance, mon problème étant surtout le fait que en suivant la procédure d'installation lue entre autre ici:
http://how-to.wikia.com/wiki/How_to_install_Python_Tkinter_in_Gentoo_Linux
ça ne fonctionne pas.
Sur Mandriva par exemple j'ai pas eu à installer Tkint, j'ai juste décompressé l'archive du logiciel, lancé l'exécutable et aucun souci Tkint faisait partie du système par défaut.

Bon, si tu as besoin de tout les éléments, les voiçi:

Mon pilote d'impression replicatorg est installé et fonctionne très bien en tant que pilote pour mon imprimante 3d.

http://replicat.org/

Ce logiciel intègre en outre des modules pour afficher des fichiers au format xxx.stl construit à partir d'un autre logiciel de dessin 3d comme solidworks. Pour pouvoir imprimer, replicatorg transforme ensuite le fichier stl en gcode pour le rendre utilisable par l'imprimante.

Ces deux dernières fonctions qui nécessite java, python et tkint, ne fonctionne pas sur mon pc à cause du manque de tkint.

Voilà :P
Back to top
View user's profile Send private message
nutsi
n00b
n00b


Joined: 13 Jul 2012
Posts: 30

PostPosted: Sat Nov 23, 2013 9:54 am    Post subject: Reply with quote

Dis nous pour quelle version de python tu veux installer 'tkinter' ? Et quelle version de python est utilisé par defaut ainsi que la version de python 'replicatorg' utilise.
Back to top
View user's profile Send private message
Poussin
l33t
l33t


Joined: 08 Jun 2007
Posts: 659
Location: Liège

PostPosted: Sat Nov 23, 2013 12:03 pm    Post subject: Reply with quote

Je vois ici http://docs.python.org/2/library/tkinter.html que Tkinter est la lib de la version 2, et tkinter de la version 3.

Le message d'erreur parle de Tkinter.
Peux-tu donner la sortie de
Code:
emerge -pv python:2.7


Si c'est bien compilé avec tk, la commande que tu utilises pour démarrer ce truc, elle utilise /usr/bin/python /usr/bin/python2 /usr/bin/python3 ? Peut-être jouer avec eselect pour sélectionner python 2.7


(ce qui semble louche, c'est que la seule dépendance de replicamachin, c'est oracle-jre-bin, tu peux ouvrir un ticket sur le buzilla, parce que ça n'est visiblement pas complet)
Back to top
View user's profile Send private message
pepit
n00b
n00b


Joined: 11 Jan 2013
Posts: 60

PostPosted: Sat Nov 23, 2013 5:48 pm    Post subject: Reply with quote

Merci pour vos aides....

Comme dit dans mon premier message la version de python par défaut est : 3.2.3.
Sur le pc sont installé python 2.7 et 3.2

Le logiciel replicatorg permet de choisir la version de python à utiliser pour lui. J'ai esséyé les deux.
Si commande il y a , c'est réplicatorg qui l'envoie pas moi, je lance juste l'exécutalble.

Que donne emerge -pv python:2.7 :

"* Last emerge --sync was Sat Jun 15 12:35:01 2013.

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild R ] dev-lang/python-2.7.3-r3:2.7 USE="berkdb* gdbm ipv6 ncurses readline ssl tk* (wide-unicode) xml -build -doc -examples -hardened -sqlite -threads* -wininst" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB

* IMPORTANT: 6 news items need reading for repository 'gentoo'.
* Use eselect news to read news items."
Back to top
View user's profile Send private message
XavierMiller
Moderator
Moderator


Joined: 23 Jul 2004
Posts: 5265
Location: ~Brussels - Belgique

PostPosted: Sat Nov 23, 2013 6:22 pm    Post subject: Reply with quote

Donc python n'a pas été recompilé avec les bons USE

Essaie de mettre à jour @world:
Code:
emerge -DuNav @world

_________________
Xavier Miller
(FR) Merci de respecter les règles du forum.
http://www.xaviermiller.be
Back to top
View user's profile Send private message
Poussin
l33t
l33t


Joined: 08 Jun 2007
Posts: 659
Location: Liège

PostPosted: Sun Nov 24, 2013 9:12 pm    Post subject: Reply with quote

Accessoirement, tu as des news à lire jeune padawan :)
Back to top
View user's profile Send private message
pepit
n00b
n00b


Joined: 11 Jan 2013
Posts: 60

PostPosted: Thu Nov 28, 2013 10:32 am    Post subject: Reply with quote

Houlala, ça va mal chez moi, une simple mise à jour...
Tant que j'y suis j'ai au préalable lancé emerge --sync -q....

....Hé ben j'aurai pas du!!

Mon vieu tecra 8000 n'a pas aimé, + de 190 maj, 3 jours de compilations, pour avoir mon dd de 10 gio full, pourtant presque rien d'installé et pratiquement pas de donnée utilisateur.

Bon, je me fait une raison et le remet sous Toutou, Gentoo ce sera pour les deux autres PC bien plus puissant. Pas envie de repasser 3 semaines à tout réinstaller plus léger.

Je considère le problème résolut, mes impressions 3d attendrons un peu.

Merci pour vos aides constructives! :D
Back to top
View user's profile Send private message
pepit
n00b
n00b


Joined: 11 Jan 2013
Posts: 60

PostPosted: Mon Dec 02, 2013 7:57 pm    Post subject: Reply with quote

Juste pour infos :
Toutou : plante au démarrage du livecd, idem pour slitaz, Crunchbang plante après le bootloader en USB. Je me suis finalement rabattu sur debian, et comme ça ramais avec gnome, je l'ai remplacé par openbox et tint2.
le système et mes quelques soft installés n'occupe que 40% du DD et ça tourne aussi bien qu'avec gentoo. Sauf le navigateur par défaut un peu lourd.

Il a fallu que je fasse un apt-get install python-tk pour que tkint soit honoré.

Ben vous savez quoi?... j'ai toujours pas l'image dans réplicatorg! Mais j'arrive à générer le gcode.
Peut être que le défaut d'affichage ce cet image est lié avec un bug des dernières version X11 connu avec l'affichage des icônes sous openbox dans entre-autre thunar car j'ai le problème.....

Bonne continuation! ;)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum