Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
kernel 3.10.7ff.: mouse problems after resume
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
freifunk_connewitz
Tux's lil' helper
Tux's lil' helper


Joined: 08 Feb 2006
Posts: 103

PostPosted: Fri Aug 30, 2013 9:58 am    Post subject: kernel 3.10.7ff.: mouse problems after resume Reply with quote

hi,

posting this under Kernel/Hardware, since it occured after I upgraded to kernel gentoo-sources-3.10.7 (from 3.8.8).

problem: after resume from suspend2ram, the mouse shows a weird behaviour. I can move the pointer around, I can right click everywhere with the correct reaction, but every left click triggers no appropriate reaction. if I click on a button, nothing happens, the same if I try to move a scroll slider. in the last case, if in file manager, it sometimes marks the list of files.

it affects the USB mouse as well as the synaptics touchpad, there the button as well as the tapping.

no other problems, e.g. with keyboard or graphics system.

after switching to logging console (Alt-F12) and back to X (Alt-F7), everything is running perfectly again.
also if I boot into the former kernel again, everythings works as it should.
I also rebuilt xorg-drivers, xorg-server, the intel-video and evdev drivers, no change.

I searched the forum and bugzilla (freedesktop and KDE), no hits.

my system: intel i7-2620M w/ GPU, kernel 3.10.7, KDE, xorg-server 1.13, xorg-drivers ~1.14, xf86-video-intel 2.20, xf86-input-evdev 2.7.3 und -synaptics 1.6.2-r1

do you have an idea, except going back to kernel 3.8.8?

thank you


Last edited by freifunk_connewitz on Tue Nov 26, 2013 4:12 pm; edited 1 time in total
Back to top
View user's profile Send private message
freifunk_connewitz
Tux's lil' helper
Tux's lil' helper


Joined: 08 Feb 2006
Posts: 103

PostPosted: Tue Nov 26, 2013 4:10 pm    Post subject: Reply with quote

the bug is still there w/ kernel 3.10.17

and as an addition:
statistics: happens ALL THE TIME. but in many cases occurs only some seconds after the resume process finished.
sometimes also the right button is affected, it's just the whole mouse/touchpad button scheme thats screwed up.

does any mod think it's a good idea to move this thread to DE?
Back to top
View user's profile Send private message
aCOSwt
Moderator
Moderator


Joined: 19 Oct 2007
Posts: 2375
Location: Hilbert space

PostPosted: Tue Nov 26, 2013 5:02 pm    Post subject: Reply with quote

Going back to 3.8, (apart if it's a networkless embedded system) should not be considered an option.
The only viable option for going back being 3.4
This being said and out of curiosity, what kind of settings do you get on your 3.10 regarding :
CONFIG_NO_HZ / CONFIG_NO_HZ_IDDLE ?
_________________
Back to top
View user's profile Send private message
freifunk_connewitz
Tux's lil' helper
Tux's lil' helper


Joined: 08 Feb 2006
Posts: 103

PostPosted: Tue Nov 26, 2013 7:30 pm    Post subject: Reply with quote

Quote:

CONFIG_NO_HZ_COMMON=y
CONFIG_NO_HZ_IDLE=y
# CONFIG_NO_HZ_FULL is not set
CONFIG_NO_HZ=y
# CONFIG_RCU_FAST_NO_HZ is not set


oh, and yes: since the problem can be walked around quickly by a CTRL-ALT-F12 + ...-F7 I didn't really regard going back to an older kernel an option.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum