Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] problem with lightdm
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
yufw
n00b
n00b


Joined: 11 Nov 2013
Posts: 31

PostPosted: Fri Nov 22, 2013 4:54 am    Post subject: [SOLVED] problem with lightdm Reply with quote

I followed the Gentoo wiki to install lightdm and set DISPLAYMANAGER to lightdm, but when I ran xdm start, lightdm just crashed. Did I miss some important configuration?

Last edited by yufw on Sat Nov 23, 2013 10:42 am; edited 1 time in total
Back to top
View user's profile Send private message
Logicien
l33t
l33t


Joined: 16 Sep 2005
Posts: 738
Location: Montréal

PostPosted: Fri Nov 22, 2013 5:21 am    Post subject: Reply with quote

A display manager depend on the Xorg server to work. If Xorg itself have some problem so start, no display manager will start too. So the first thing I would do is to check the Xorg log in /var/log/Xorg.0.log to have some possible hints.
_________________
Paul
Back to top
View user's profile Send private message
yufw
n00b
n00b


Joined: 11 Nov 2013
Posts: 31

PostPosted: Fri Nov 22, 2013 5:36 am    Post subject: Reply with quote

Logicien wrote:
A display manager depend on the Xorg server to work. If Xorg itself have some problem so start, no display manager will start too. So the first thing I would do is to check the Xorg log in /var/log/Xorg.0.log to have some possible hints.
Yes, startx works correctly, it's just that I can't log in with a display manager.
Back to top
View user's profile Send private message
yufw
n00b
n00b


Joined: 11 Nov 2013
Posts: 31

PostPosted: Fri Nov 22, 2013 6:24 am    Post subject: Reply with quote

I observed that If I have just 'exec awesome' in .xinitrc, startx works fine, but if I have this in .xinitrc,
Code:
exec ck-launch-session dbus-launch --sh-syntax --exit-with-session awesome
startx just crashes, and the log file is here,
Code:
[   466.904]
X.Org X Server 1.14.3
Release Date: 2013-09-12
[   466.906] X Protocol Version 11, Revision 0
[   466.906] Build Operating System: Linux 3.10.17-gentoo i686 Gentoo
[   466.907] Current Operating System: Linux gentoo 3.10.17-gentoo #9 SMP Thu Nov 21 16:32:16 CST 2013 i686
[   466.907] Kernel command line: BOOT_IMAGE=/kernel-3.10.17-gentoo root=/dev/sda9 ro
[   466.909] Build Date: 21 November 2013  10:34:10PM
[   466.910] 
[   466.910] Current version of pixman: 0.30.2
[   466.912]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[   466.912] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   466.916] (==) Log file: "/var/log/Xorg.1.log", Time: Fri Nov 22 13:50:46 2013
[   466.917] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[   466.917] (==) No Layout section.  Using the first Screen section.
[   466.917] (==) No screen section available. Using defaults.
[   466.917] (**) |-->Screen "Default Screen Section" (0)
[   466.917] (**) |   |-->Monitor "<default monitor>"
[   466.917] (==) No monitor specified for screen "Default Screen Section".
   Using a default monitor configuration.
[   466.917] (==) Automatically adding devices
[   466.917] (==) Automatically enabling devices
[   466.917] (==) Automatically adding GPU devices
[   466.917] (WW) The directory "/usr/share/fonts/TTF/" does not exist.
[   466.917]    Entry deleted from font path.
[   466.917] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[   466.917]    Entry deleted from font path.
[   466.917] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[   466.917]    Entry deleted from font path.
[   466.917] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[   466.917]    Entry deleted from font path.
[   466.917]    (Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
[   466.917] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[   466.917]    Entry deleted from font path.
[   466.917]    (Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[   466.917] (==) FontPath set to:
   /usr/share/fonts/misc/
[   466.917] (==) ModulePath set to "/usr/lib/xorg/modules"
[   466.917] (II) The server relies on udev to provide the list of input devices.
   If no devices become available, reconfigure udev or disable AutoAddDevices.
[   466.917] (II) Loader magic: 0x825f620
[   466.917] (II) Module ABI versions:
[   466.917]    X.Org ANSI C Emulation: 0.4
[   466.917]    X.Org Video Driver: 14.1
[   466.917]    X.Org XInput driver : 19.1
[   466.917]    X.Org Server Extension : 7.0
[   466.917] (II) xfree86: Adding drm device (/dev/dri/card0)
[   466.918] setversion 1.4 failed
[   466.918] (II) xfree86: Adding drm device (/dev/dri/card1)
[   466.919] setversion 1.4 failed
[   466.920] (--) PCI:*(0:0:2:0) 8086:0116:103c:166e rev 9, Mem @ 0xa0000000/4194304, 0x90000000/268435456, I/O @ 0x00005000/64
[   466.920] (--) PCI: (0:1:0:0) 1002:6760:103c:166e rev 0, Mem @ 0x80000000/268435456, 0xa2600000/131072, I/O @ 0x00004000/256, BIOS @ 0x????????/131072
[   466.921] Initializing built-in extension Generic Event Extension
[   466.922] Initializing built-in extension SHAPE
[   466.923] Initializing built-in extension MIT-SHM
[   466.924] Initializing built-in extension XInputExtension
[   466.925] Initializing built-in extension XTEST
[   466.926] Initializing built-in extension BIG-REQUESTS
[   466.927] Initializing built-in extension SYNC
[   466.928] Initializing built-in extension XKEYBOARD
[   466.929] Initializing built-in extension XC-MISC
[   466.930] Initializing built-in extension XINERAMA
[   466.931] Initializing built-in extension XFIXES
[   466.932] Initializing built-in extension RENDER
[   466.933] Initializing built-in extension RANDR
[   466.934] Initializing built-in extension COMPOSITE
[   466.935] Initializing built-in extension DAMAGE
[   466.936] Initializing built-in extension MIT-SCREEN-SAVER
[   466.937] Initializing built-in extension DOUBLE-BUFFER
[   466.938] Initializing built-in extension RECORD
[   466.938] Initializing built-in extension DPMS
[   466.939] Initializing built-in extension X-Resource
[   466.940] Initializing built-in extension XVideo
[   466.941] Initializing built-in extension XVideo-MotionCompensation
[   466.942] Initializing built-in extension XFree86-VidModeExtension
[   466.942] Initializing built-in extension XFree86-DGA
[   466.943] Initializing built-in extension XFree86-DRI
[   466.944] Initializing built-in extension DRI2
[   466.944] (II) LoadModule: "glx"
[   466.944] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[   466.944] (II) Module glx: vendor="X.Org Foundation"
[   466.944]    compiled for 1.14.3, module version = 1.0.0
[   466.944]    ABI class: X.Org Server Extension, version 7.0
[   466.944] (==) AIGLX enabled
[   466.945] Loading extension GLX
[   466.945] (==) Matched intel as autoconfigured driver 0
[   466.945] (==) Matched vesa as autoconfigured driver 1
[   466.945] (==) Matched modesetting as autoconfigured driver 2
[   466.945] (==) Matched fbdev as autoconfigured driver 3
[   466.945] (==) Assigned the driver to the xf86ConfigLayout
[   466.945] (II) LoadModule: "intel"
[   466.945] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[   466.945] (II) Module intel: vendor="X.Org Foundation"
[   466.945]    compiled for 1.14.3, module version = 2.21.15
[   466.945]    Module class: X.Org Video Driver
[   466.945]    ABI class: X.Org Video Driver, version 14.1
[   466.945] (II) LoadModule: "vesa"
[   466.945] (WW) Warning, couldn't open module vesa
[   466.946] (II) UnloadModule: "vesa"
[   466.946] (II) Unloading vesa
[   466.946] (EE) Failed to load module "vesa" (module does not exist, 0)
[   466.946] (II) LoadModule: "modesetting"
[   466.946] (WW) Warning, couldn't open module modesetting
[   466.946] (II) UnloadModule: "modesetting"
[   466.946] (II) Unloading modesetting
[   466.946] (EE) Failed to load module "modesetting" (module does not exist, 0)
[   466.946] (II) LoadModule: "fbdev"
[   466.946] (WW) Warning, couldn't open module fbdev
[   466.946] (II) UnloadModule: "fbdev"
[   466.946] (II) Unloading fbdev
[   466.946] (EE) Failed to load module "fbdev" (module does not exist, 0)
[   466.946] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
   i810, i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G,
   915G, E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM,
   Pineview G, 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,
   GM45, 4 Series, G45/G43, Q45/Q43, G41, B43, HD Graphics,
   HD Graphics 2000, HD Graphics 3000, HD Graphics 2500,
   HD Graphics 4000, HD Graphics P4000, HD Graphics 4600,
   HD Graphics 5000, HD Graphics P4600/P4700, Iris(TM) Graphics 5100,
   HD Graphics 4400, HD Graphics 4200, Iris(TM) Pro Graphics 5200
[   466.946] (--) using VT number 8

[   469.165] (EE) intel(0): [drm] failed to set drm interface version: Permission denied [13].
[   469.165] (EE) intel(0): Failed to claim DRM device.
[   469.165] (II) UnloadModule: "intel"
[   469.165] (EE) Screen(s) found, but none have a usable configuration.
[   469.165] (EE)
Fatal server error:
[   469.165] (EE) no screens found(EE)
[   469.165] (EE)
Please consult the The X.Org Foundation support
    at http://wiki.x.org
 for help.
[   469.165] (EE) Please also check the log file at "/var/log/Xorg.1.log" for additional information.
[   469.165] (EE)
[   469.172] (EE) Server terminated with error (1). Closing log file.

Since lightdm also uses ConsoleKit (is this right?), I think it may be the problem with ConsoleKit, but I can start ConsoleKit and D-Bus with no problem, quite confused.
Back to top
View user's profile Send private message
yufw
n00b
n00b


Joined: 11 Nov 2013
Posts: 31

PostPosted: Fri Nov 22, 2013 9:24 am    Post subject: Reply with quote

I updated my system and now it worked, I didn't know why.
Back to top
View user's profile Send private message
Logicien
l33t
l33t


Joined: 16 Sep 2005
Posts: 738
Location: Montréal

PostPosted: Fri Nov 22, 2013 10:32 am    Post subject: Reply with quote

Normal users must be in the video group to use DRI. Otherwise, permissions must be set an Xorg configuration file.
_________________
Paul
Back to top
View user's profile Send private message
666threesixes666
Veteran
Veteran


Joined: 31 May 2011
Posts: 1223
Location: 42.68n 85.41w

PostPosted: Fri Nov 22, 2013 6:51 pm    Post subject: Reply with quote

please append [solved] to the title of the thread. i switched from lightdm to slim. slim doesn't show what users are on the box, so they have to guess user & password, not just password.
_________________
cat /etc/*-release
Funtoo Linux - baselayout 2.2.0
consider this warning no. 1
http://ecx.images-amazon.com/images/I/81Ku-vxIb3L._SL1500_.jpg
http://wiki.gentoo.org/wiki/Special:Contributions/666threesixes666
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum