Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] Fail connecting lo: unsupported interface type 00
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
Facu
n00b
n00b


Joined: 18 Nov 2013
Posts: 47
Location: Localhost

PostPosted: Mon Nov 18, 2013 1:39 am    Post subject: [Solved] Fail connecting lo: unsupported interface type 00 Reply with quote

Hi all. First at all I apologize if my english is not enough. Im from argentina :P

Second, i will tell you that is my first time in gentoo. Im trying to install it following the handbook. The install was successful, but now im having problems to connect to internet. I hope somebody can helpme, I hope somebody can help me, I didn't find a solution in google, maybe i'm not using the correct words :?

dhcpcd starts successful on start. But when trying to connect:

Code:

dhcpcd[1871]: version 5.6.4 starting
dhcpcd[1871]: lo: unsupported interface type 00, falling back to ethernet
dhcpcd[1871]: lo: sending IPv6 Router Solicitation
dhcpcd[1871]: lo: sendmsg Network is unrecheable
dhcpcd[1871]: lo: sending IPv6 Router Solicitation
dhcpcd[1871]: lo: sendmsg Network is unrecheable
dhcpcd[1871]: lo: sending IPv6 Router Solicitation
dhcpcd[1871]: lo: sendmsg Network is unrecheable
dhcpcd[1871]: lo: sending IPv6 Router Solicitation
dhcpcd[1871]: lo: sendmsg Network is unrecheable
dhcpcd[1871]: lo: no IPv6 Routers available
dhcpcd[1871]: lo: timed out
dhcpcd[1871]: lo: allowing 8 seconds fpr IPv4LL timeout
dhcpcd[1871]: lo: timed out


following the handbook i do:
Code:

# cd /etc/init.d
# ln -s net.lo net.eth0


/etc/conf.d/net have:
Code:

modules_lo="dhcp"
routers_lo="default via 192.168.0.1"


(192.168.0.1 -> My router)

I tried to leave blank this file, but is the same...

my ifconfig:
Code:

lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
        inet 127.0.0.1    netmask 255.0.0.0
        inet6 ::1 prefixlen 128 scopeid 0x10<host>
        loop txqueuelen 0 (local loopback)
        RX packets 36 bytes 2440 (2.3KiB)
        RX errors 0 dropped 0 overruns 0 frame 0
        TX packets 36 bytes (2.3KiB)
        TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0


I haven't yet iwconfig or lspci. But i have a atheros and i am almost sure that i installed the module compiling the kernel :/ But i dont know how to check over.

I hope somebody can help me.. Again, i apologize about my bad english :?

Bytes! ;)


Last edited by Facu on Fri Nov 22, 2013 7:02 am; edited 1 time in total
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 7093
Location: Saint Amant, Acadiana

PostPosted: Mon Nov 18, 2013 2:25 am    Post subject: Reply with quote

lo is loopback, you cannot use it to make connections to the outside world. Run
Code:
ifconfig -a
to see what network interfaces you have in your system. This command will show you all interfaces present and supported by your kernel.
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
Facu
n00b
n00b


Joined: 18 Nov 2013
Posts: 47
Location: Localhost

PostPosted: Mon Nov 18, 2013 5:52 am    Post subject: Reply with quote

Jaglover wrote:
lo is loopback, you cannot use it to make connections to the outside world. Run
Code:
ifconfig -a
to see what network interfaces you have in your system. This command will show you all interfaces present and supported by your kernel.


lol. Sorry. Stupid my mistake ._.. I can not to get used the new names ._.

when I do ifconfig -a this give me two more interfaces:

sit0: flags=128 <NOARP> mtu 1480
and
wlp2s0: flags=4098 <BROADCAST,MULTICAST> mtu 1500

If is necessary, I can post the entire output. I didn't post everything because i am copying that manually :cry: (I cant connect from my other pc).

Evend doing #dhcpcd sit0 or #dhcpcd wlp2s0. I cant connect :?

Thank you for the help!
Back to top
View user's profile Send private message
Facu
n00b
n00b


Joined: 18 Nov 2013
Posts: 47
Location: Localhost

PostPosted: Tue Nov 19, 2013 12:12 am    Post subject: Reply with quote

Somebody pliz? :? I still can not

------------------------------------------- Edit:

I tried re-compiling the kernel as showed here:

http://unix.stackexchange.com/questions/4031/configure-atheros-ar9285-wireless-in-gentoo

But nothing happens :?
Back to top
View user's profile Send private message
Facu
n00b
n00b


Joined: 18 Nov 2013
Posts: 47
Location: Localhost

PostPosted: Tue Nov 19, 2013 11:35 pm    Post subject: News.. Reply with quote

News...

I tryed this: http://abi71.wordpress.com/2011/12/21/enable-atheros-ethernet-card-ar8151-on-linux-slackware/

I compiled this option in the kernel selecting * (no module - M). And i tried "modprobe atl1e" and nothing happens...

I installed lspci and I have a Atheros AR8151 (The same describen in the top link..)

Somebody? :?
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 7093
Location: Saint Amant, Acadiana

PostPosted: Wed Nov 20, 2013 1:34 am    Post subject: Reply with quote

wlp2s0 - this is your device, if driver wasn't loaded it wouldn't be there. You need to troubleshoot why your network is not functional. Is the cable plugged in, etc.
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
Facu
n00b
n00b


Joined: 18 Nov 2013
Posts: 47
Location: Localhost

PostPosted: Wed Nov 20, 2013 1:38 am    Post subject: Reply with quote

Thanx for answer Jaglover :)

Emm. Yhea, I tried running dhcpcd over wlp2s0 and i cant get it work. :/

using the liveDVD from gentoo, everything works fine. But in the installation this not works.. :/ Maybe is something about config? :S


Code:

#dhcpcd wlp2s0
dhcpcd[1931]: version 5.6.4 starting
dhcpcd[1931]: wlp2s0: carrier acquired
dhcpcd[1931]: wlp2s0: carrier lost
dhcpcd[1931]: wlp2s0: waiting for carrier
dhcpcd[1931]: timed out
dhcpcd[1931]: allowing 8 seconds for IPv4LL timeout
dhcpcd[1931]: timed out
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 7093
Location: Saint Amant, Acadiana

PostPosted: Wed Nov 20, 2013 1:55 am    Post subject: Reply with quote

Alright, make friends with wgetpaste and post link to your kernel config.
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
Facu
n00b
n00b


Joined: 18 Nov 2013
Posts: 47
Location: Localhost

PostPosted: Wed Nov 20, 2013 2:06 am    Post subject: Jaglover Reply with quote

Ok. One sec. I will try downloading and compiling one last time my kernel and I post here the configs.. Thank you for the help
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 7093
Location: Saint Amant, Acadiana

PostPosted: Wed Nov 20, 2013 4:03 am    Post subject: Reply with quote

Why you think you need to download the kernel sources again? Unless you altered them by hand there is no need for it.
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
Facu
n00b
n00b


Joined: 18 Nov 2013
Posts: 47
Location: Localhost

PostPosted: Wed Nov 20, 2013 4:13 am    Post subject: Reply with quote

Because I compiled 3 times from the same source and this does no works :/ I will try again from beginning. Downloading and compiling. I'm already compiling. If this does not work I will post the .config file here.

Thanx again for the help! I hope this works :S
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 7093
Location: Saint Amant, Acadiana

PostPosted: Wed Nov 20, 2013 4:21 am    Post subject: Reply with quote

Facu,

please see /usr/src/linux/README for available make targets. For instance, make mrproper will remove everything that wasn't part of bare sources. If your kernel does not work then it is most likely a configuration issue.
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
Facu
n00b
n00b


Joined: 18 Nov 2013
Posts: 47
Location: Localhost

PostPosted: Wed Nov 20, 2013 4:55 am    Post subject: Reply with quote

I built the kernel from beginning. Without the old config.

Something i saw, is that when I compile the kernel using 64bits (And selecting this on the kernel config). The kernel image saves in arch/x86 (instead of arch/x68_64)

I built the kernel using this .config: http://pastebin.com/py06ZQG4

and now when I try to run, the system does not start .__.

Lilo output:
Code:
 loading gentooEBDA is big; kernel setup stack overlaps LILO second stage


How is that possible? I reinstalled LILO and the same happens...

My lilo.conf: http://pastebin.com/WCyLgrkp

-----Edit----
I saw this post: https://forums.gentoo.org/viewtopic-t-337443.html

Im going to install grub :P
Back to top
View user's profile Send private message
Facu
n00b
n00b


Joined: 18 Nov 2013
Posts: 47
Location: Localhost

PostPosted: Thu Nov 21, 2013 9:04 am    Post subject: Reply with quote

OK. I finished to install gentoo from beginning... I used the kernel configs mentioned above. And still does not work.. :S

Now. When I do a ifconfig -a:

Code:

lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
     ....
     ....
     ....

wlp2s0: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500
    ....
    ....
    ....

(Again, i didnt post everything because im writing this manually. If it is necessary just ask for.)

When I do "dhcpcd wlp2s0". This is the entire output:
Code:

dhcpcd[1758]: sending commands to master dhcpcd process


I dont know what can I do... I compiled 4 times the kernel, and installed gentoo twice...

I wanna try gentoo for first time but i'm about to giving up.

Somebody have idea how can I fix this? :/

Thank you once more
Back to top
View user's profile Send private message
moonfrog
n00b
n00b


Joined: 21 Nov 2013
Posts: 5
Location: San Diego, CA

PostPosted: Thu Nov 21, 2013 1:23 pm    Post subject: Reply with quote

I had similar problems with my network this time with my new install.
If I'm wrong I hope someone will correct me but reading through your posts I think it's same culprit.

Udev has recently changed it's hardware naming scheme so now your "eth0" is called "wlp2s0" or something else, the install guide we followed has us setting up "eth0". I just found Gentoo's wiki page on it:
http://wiki.gentoo.org/wiki/Udev/upgrade#Fixing_network_interfaces

I didn't like the new naming and found udev's (4) solution(s) to getting the old names back.
http://www.freedesktop.org/wiki/Software/systemd/PredictableNetworkInterfaceNames/

At the bottom of the page under "I don't like this, how do I disable this?"
I chose the first one=
"mask udev's rule file for the default policy:"
Code:
ln -s /dev/null /etc/udev/rules.d/80-net-name-slot.rules
Back to top
View user's profile Send private message
Facu
n00b
n00b


Joined: 18 Nov 2013
Posts: 47
Location: Localhost

PostPosted: Thu Nov 21, 2013 9:13 pm    Post subject: Reply with quote

Definitely... Gentooo hates me :'(

I compiled the kernel using genkernel !! And this does not work. It jams in middle from the booting...

If somebody can give me a solution, please do it. If I cant solve it, tonight I will unistall gentoo and maybe I will install arch. But i really wanna try gentoo... :S

6 days +/- without pc... I need install something.

Bytes! ;)
Back to top
View user's profile Send private message
Facu
n00b
n00b


Joined: 18 Nov 2013
Posts: 47
Location: Localhost

PostPosted: Thu Nov 21, 2013 11:39 pm    Post subject: Reply with quote

moonfrog wrote:
I had similar problems with my network this time with my new install.
If I'm wrong I hope someone will correct me but reading through your posts I think it's same culprit.

Udev has recently changed it's hardware naming scheme so now your "eth0" is called "wlp2s0" or something else, the install guide we followed has us setting up "eth0". I just found Gentoo's wiki page on it:
http://wiki.gentoo.org/wiki/Udev/upgrade#Fixing_network_interfaces

I didn't like the new naming and found udev's (4) solution(s) to getting the old names back.
http://www.freedesktop.org/wiki/Software/systemd/PredictableNetworkInterfaceNames/

At the bottom of the page under "I don't like this, how do I disable this?"
I chose the first one=
"mask udev's rule file for the default policy:"
Code:
ln -s /dev/null /etc/udev/rules.d/80-net-name-slot.rules



Sorry. I didnt saw your answer lol :P

I made what you say, and yes, now the names are fixed.
When I do ifconfig -a the output is "lo" and "wlan0". Thanx for that :)
But eth0 dont exist :S

How is that possible? :S

Thanks for the help!
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 7093
Location: Saint Amant, Acadiana

PostPosted: Fri Nov 22, 2013 12:19 am    Post subject: Reply with quote

For eth0 to appear the kernel driver must be loaded. Look at output of
Code:
lspci -nnk
it will tell you if driver is loaded or not, also it will print the PCI ID which is useful to determine what driver is needed. Output from my desktop is below.
Code:
02:00.0 Ethernet controller [0200]: Qualcomm Atheros Attansic L1 Gigabit Ethernet [1969:1048] (rev b0)
        Subsystem: ASUSTeK Computer Inc. P5KPL-VM Motherboard [1043:8226]
        Kernel driver in use: atl1

_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
Facu
n00b
n00b


Joined: 18 Nov 2013
Posts: 47
Location: Localhost

PostPosted: Fri Nov 22, 2013 12:55 am    Post subject: Reply with quote

This is the output:
Quote:

00:00.0 Host bridge [0600]: Intel Corporation 2nd Generation Core Processor Family DRAM Controller [8086:0104] (rev 09)
Subsystem: Device [1b0a:2099]
00:02.0 VGA compatible controller [0300]: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0126] (rev 09)
Subsystem: Device [1b0a:2080]
Kernel driver in use: i915
00:16.0 Communication controller [0780]: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 [8086:1c3a] (rev 04)
Subsystem: Device [1b0a:2099]
00:1a.0 USB controller [0c03]: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 [8086:1c2d] (rev 05)
Subsystem: Device [1b0a:2099]
Kernel driver in use: ehci-pci
00:1b.0 Audio device [0403]: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller [8086:1c20] (rev 05)
Subsystem: Device [1b0a:2098]
Kernel driver in use: snd_hda_intel
00:1c.0 PCI bridge [0604]: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 [8086:1c10] (rev b5)
Kernel driver in use: pcieport
00:1c.1 PCI bridge [0604]: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 2 [8086:1c12] (rev b5)
Kernel driver in use: pcieport
00:1c.5 PCI bridge [0604]: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 6 [8086:1c1a] (rev b5)
Kernel driver in use: pcieport
00:1d.0 USB controller [0c03]: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 [8086:1c26] (rev 05)
Subsystem: Device [1b0a:2099]
Kernel driver in use: ehci-pci
00:1f.0 ISA bridge [0601]: Intel Corporation HM65 Express Chipset Family LPC Controller [8086:1c49] (rev 05)
Subsystem: Device [1b0a:2099]
00:1f.2 IDE interface [0101]: Intel Corporation 6 Series/C200 Series Chipset Family 4 port SATA IDE Controller [8086:1c01] (rev 05)
Subsystem: Device [1b0a:2099]
Kernel driver in use: ata_piix
00:1f.3 SMBus [0c05]: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller [8086:1c22] (rev 05)
Subsystem: Device [1b0a:2099]
Kernel driver in use: i801_smbus
00:1f.5 IDE interface [0101]: Intel Corporation 6 Series/C200 Series Chipset Family 2 port SATA IDE Controller [8086:1c09] (rev 05)
Subsystem: Device [1b0a:2099]
Kernel driver in use: ata_piix
02:00.0 Network controller [0280]: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) [168c:002b] (rev 01)
Subsystem: XAVi Technologies Corp. XW204E 802.11bgn Wireless Half-size Mini PCIe Card [1b9a:0401]
Kernel driver in use: ath9k
03:00.0 Ethernet controller [0200]: Qualcomm Atheros AR8151 v2.0 Gigabit Ethernet [1969:1083] (rev c0)
Subsystem: Device [1b0a:208d]


I could connect using wifi so I can install packages and continue configuring.
But I still want to fix ethernet :/ Thanx

Bytes!
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 7093
Location: Saint Amant, Acadiana

PostPosted: Fri Nov 22, 2013 3:52 am    Post subject: Reply with quote

You need to enable atl1c driver for your eth0.
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
Facu
n00b
n00b


Joined: 18 Nov 2013
Posts: 47
Location: Localhost

PostPosted: Fri Nov 22, 2013 6:19 am    Post subject: Re: News.. Reply with quote

aaa. OK jag. Thx. I will try :)

----Edit----

Thank you once more! :) This really works. THANK YOU! :) The fail was i used atl1e intead atl1c
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum