Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
X starts up black
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
JohnLM
n00b
n00b


Joined: 20 Apr 2009
Posts: 59
Location: LATVIA

PostPosted: Tue Nov 19, 2013 9:33 am    Post subject: X starts up black Reply with quote

I have a rather odd bug with X. Sometimes it starts up normally, but most of the time it just starts up black.
I reckon it might be some race condition in new X server, because it worked fine before package update.

I have an Acer Aspire 1640 laptop with integrated intel graphics.
I'm using open-source 'intel' video driver and

  • x11-base/xorg-server-1.14.3-r2:0/1.14.3
  • x11-base/xorg-drivers-1.14:0
  • x11-drivers/xf86-video-intel-2.21.15:0
  • x11-apps/xrandr-1.4.1:0
  • sys-kernel/gentoo-sources-3.10.7-r1:3.10.7-r1


Code:
[ 10587.016]
X.Org X Server 1.14.3
Release Date: 2013-09-12
[ 10587.030] X Protocol Version 11, Revision 0
[ 10587.035] Build Operating System: Linux 3.10.7-gentoo-r1 i686 Gentoo
[ 10587.040] Current Operating System: Linux lapsa 3.10.7-gentoo-r1 #2 Fri Oct 11 12:51:35 EEST 2013 i686
[ 10587.040] Kernel command line: root=/dev/sda1 rootfstype=ext3
[ 10587.050] Build Date: 15 November 2013  10:36:37AM
[ 10587.054] 
[ 10587.058] Current version of pixman: 0.30.2
[ 10587.065]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[ 10587.065] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 10587.081] (==) Log file: "/var/log/Xorg.0.log", Time: Tue Nov 19 10:00:41 2013
[ 10587.114] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[ 10587.151] (==) No Layout section.  Using the first Screen section.
[ 10587.151] (==) No screen section available. Using defaults.
[ 10587.151] (**) |-->Screen "Default Screen Section" (0)
[ 10587.151] (**) |   |-->Monitor "<default monitor>"
[ 10587.164] (==) No monitor specified for screen "Default Screen Section".
   Using a default monitor configuration.
[ 10587.164] (==) Automatically adding devices
[ 10587.164] (==) Automatically enabling devices
[ 10587.164] (==) Automatically adding GPU devices
[ 10587.204] (WW) The directory "/usr/share/fonts/TTF/" does not exist.
[ 10587.204]    Entry deleted from font path.
[ 10587.204] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[ 10587.204]    Entry deleted from font path.
[ 10587.204] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[ 10587.204]    Entry deleted from font path.
[ 10587.204] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[ 10587.204]    Entry deleted from font path.
[ 10587.204]    (Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
[ 10587.214] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[ 10587.214]    Entry deleted from font path.
[ 10587.214]    (Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[ 10587.214] (==) FontPath set to:
   /usr/share/fonts/misc/
[ 10587.214] (==) ModulePath set to "/usr/lib/xorg/modules"
[ 10587.214] (II) The server relies on udev to provide the list of input devices.
   If no devices become available, reconfigure udev or disable AutoAddDevices.
[ 10587.214] (II) Loader magic: 0x827c600
[ 10587.214] (II) Module ABI versions:
[ 10587.214]    X.Org ANSI C Emulation: 0.4
[ 10587.214]    X.Org Video Driver: 14.1
[ 10587.214]    X.Org XInput driver : 19.1
[ 10587.214]    X.Org Server Extension : 7.0
[ 10587.215] (II) xfree86: Adding drm device (/dev/dri/card0)
[ 10587.217] (--) PCI:*(0:0:2:0) 8086:2592:1025:008f rev 3, Mem @ 0xb0080000/524288, 0xc0000000/268435456, 0xb0000000/262144, I/O @ 0x00001800/8
[ 10587.217] (--) PCI: (0:0:2:1) 8086:2792:1025:008f rev 3, Mem @ 0x54c00000/524288
[ 10587.221] Initializing built-in extension Generic Event Extension
[ 10587.225] Initializing built-in extension SHAPE
[ 10587.228] Initializing built-in extension MIT-SHM
[ 10587.232] Initializing built-in extension XInputExtension
[ 10587.235] Initializing built-in extension XTEST
[ 10587.238] Initializing built-in extension BIG-REQUESTS
[ 10587.241] Initializing built-in extension SYNC
[ 10587.244] Initializing built-in extension XKEYBOARD
[ 10587.248] Initializing built-in extension XC-MISC
[ 10587.251] Initializing built-in extension XINERAMA
[ 10587.255] Initializing built-in extension XFIXES
[ 10587.258] Initializing built-in extension RENDER
[ 10587.261] Initializing built-in extension RANDR
[ 10587.264] Initializing built-in extension COMPOSITE
[ 10587.266] Initializing built-in extension DAMAGE
[ 10587.268] Initializing built-in extension MIT-SCREEN-SAVER
[ 10587.270] Initializing built-in extension DOUBLE-BUFFER
[ 10587.272] Initializing built-in extension RECORD
[ 10587.274] Initializing built-in extension DPMS
[ 10587.276] Initializing built-in extension X-Resource
[ 10587.278] Initializing built-in extension XVideo
[ 10587.280] Initializing built-in extension XVideo-MotionCompensation
[ 10587.282] Initializing built-in extension XFree86-VidModeExtension
[ 10587.284] Initializing built-in extension XFree86-DGA
[ 10587.286] Initializing built-in extension XFree86-DRI
[ 10587.288] Initializing built-in extension DRI2
[ 10587.288] (II) LoadModule: "glx"
[ 10587.310] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[ 10587.457] (II) Module glx: vendor="X.Org Foundation"
[ 10587.457]    compiled for 1.14.3, module version = 1.0.0
[ 10587.457]    ABI class: X.Org Server Extension, version 7.0
[ 10587.457] (==) AIGLX enabled
[ 10587.459] Loading extension GLX
[ 10587.459] (==) Matched intel as autoconfigured driver 0
[ 10587.459] (==) Matched intel as autoconfigured driver 1
[ 10587.459] (==) Matched vesa as autoconfigured driver 2
[ 10587.459] (==) Matched modesetting as autoconfigured driver 3
[ 10587.459] (==) Matched fbdev as autoconfigured driver 4
[ 10587.459] (==) Assigned the driver to the xf86ConfigLayout
[ 10587.459] (II) LoadModule: "intel"
[ 10587.460] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[ 10587.580] (II) Module intel: vendor="X.Org Foundation"
[ 10587.580]    compiled for 1.14.3, module version = 2.21.15
[ 10587.580]    Module class: X.Org Video Driver
[ 10587.580]    ABI class: X.Org Video Driver, version 14.1
[ 10587.580] (II) LoadModule: "vesa"
[ 10587.581] (WW) Warning, couldn't open module vesa
[ 10587.581] (II) UnloadModule: "vesa"
[ 10587.581] (II) Unloading vesa
[ 10587.581] (EE) Failed to load module "vesa" (module does not exist, 0)
[ 10587.581] (II) LoadModule: "modesetting"
[ 10587.581] (WW) Warning, couldn't open module modesetting
[ 10587.581] (II) UnloadModule: "modesetting"
[ 10587.581] (II) Unloading modesetting
[ 10587.581] (EE) Failed to load module "modesetting" (module does not exist, 0)
[ 10587.581] (II) LoadModule: "fbdev"
[ 10587.582] (WW) Warning, couldn't open module fbdev
[ 10587.582] (II) UnloadModule: "fbdev"
[ 10587.582] (II) Unloading fbdev
[ 10587.582] (EE) Failed to load module "fbdev" (module does not exist, 0)
[ 10587.582] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
   i810, i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G,
   915G, E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM,
   Pineview G, 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,
   GM45, 4 Series, G45/G43, Q45/Q43, G41, B43, HD Graphics,
   HD Graphics 2000, HD Graphics 3000, HD Graphics 2500,
   HD Graphics 4000, HD Graphics P4000, HD Graphics 4600,
   HD Graphics 5000, HD Graphics P4600/P4700, Iris(TM) Graphics 5100,
   HD Graphics 4400, HD Graphics 4200, Iris(TM) Pro Graphics 5200
[ 10587.583] (--) using VT number 7

[ 10587.623] (II) intel(0): Creating default Display subsection in Screen section
   "Default Screen Section" for depth/fbbpp 24/32
[ 10587.623] (==) intel(0): Depth 24, (--) framebuffer bpp 32
[ 10587.623] (==) intel(0): RGB weight 888
[ 10587.623] (==) intel(0): Default visual is TrueColor
[ 10587.623] (--) intel(0): Integrated Graphics Chipset: Intel(R) 915GM
[ 10587.624] (--) intel(0): CPU: x86, sse2
[ 10587.624] (**) intel(0): Framebuffer tiled
[ 10587.624] (**) intel(0): Pixmaps tiled
[ 10587.624] (**) intel(0): "Tear free" disabled
[ 10587.624] (**) intel(0): Forcing per-crtc-pixmaps? no
[ 10587.624] (II) intel(0): Output LVDS1 has no monitor section
[ 10587.624] (--) intel(0): found backlight control interface intel_backlight (type 'raw')
[ 10587.624] (II) intel(0): Output VGA1 has no monitor section
[ 10587.624] (II) intel(0): Output TV1 has no monitor section
[ 10587.624] (==) intel(0): DPI set to (96, 96)
[ 10587.624] (II) Loading sub module "dri2"
[ 10587.625] (II) LoadModule: "dri2"
[ 10587.625] (II) Module "dri2" already built-in
[ 10587.625] (==) Depth 24 pixmap format is 32 bpp
[ 10587.797] (II) intel(0): SNA initialized with Alviso (gen3) backend
[ 10587.797] (==) intel(0): Backing store disabled
[ 10587.797] (==) intel(0): Silken mouse enabled
[ 10587.809] (II) intel(0): HW Cursor enabled
[ 10587.809] (II) intel(0): RandR 1.2 enabled, ignore the following RandR disabled message.
[ 10587.840] (==) intel(0): DPMS enabled
[ 10587.842] (II) intel(0): [DRI2] Setup complete
[ 10587.842] (II) intel(0): [DRI2]   DRI driver: i915
[ 10587.842] (II) intel(0): direct rendering: DRI2 Enabled
[ 10587.842] (==) intel(0): hotplug detection: "enabled"
[ 10587.842] (--) RandR disabled
[ 10588.409] (II) AIGLX: enabled GLX_MESA_copy_sub_buffer
[ 10588.409] (II) AIGLX: enabled GLX_INTEL_swap_event
[ 10588.409] (II) AIGLX: enabled GLX_ARB_create_context
[ 10588.409] (II) AIGLX: enabled GLX_ARB_create_context_profile
[ 10588.409] (II) AIGLX: enabled GLX_EXT_create_context_es2_profile
[ 10588.409] (II) AIGLX: enabled GLX_SGI_swap_control and GLX_MESA_swap_control
[ 10588.409] (II) AIGLX: GLX_EXT_texture_from_pixmap backed by buffer objects
[ 10588.409] (II) AIGLX: Loaded and initialized i915
[ 10588.409] (II) GLX: Initialized DRI2 GL provider for screen 0
[ 10589.331] (II) config/udev: Adding input device Power Button (/dev/input/event3)
[ 10589.331] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[ 10589.331] (II) LoadModule: "evdev"
[ 10589.332] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[ 10589.385] (II) Module evdev: vendor="X.Org Foundation"
[ 10589.385]    compiled for 1.14.3, module version = 2.8.1
[ 10589.385]    Module class: X.Org XInput Driver
[ 10589.385]    ABI class: X.Org XInput driver, version 19.1
[ 10589.385] (II) Using input driver 'evdev' for 'Power Button'
[ 10589.385] (**) Power Button: always reports core events
[ 10589.385] (**) evdev: Power Button: Device: "/dev/input/event3"
[ 10589.385] (--) evdev: Power Button: Vendor 0 Product 0x1
[ 10589.385] (--) evdev: Power Button: Found keys
[ 10589.385] (II) evdev: Power Button: Configuring as keyboard
[ 10589.386] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXPWRBN:00/input/input3/event3"
[ 10589.386] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 6)
[ 10589.386] (**) Option "xkb_rules" "evdev"
[ 10589.386] (**) Option "xkb_model" "pc104"
[ 10589.386] (**) Option "xkb_layout" "us"
[ 10589.446] (II) config/udev: Adding input device Video Bus (/dev/input/event4)
[ 10589.446] (**) Video Bus: Applying InputClass "evdev keyboard catchall"
[ 10589.446] (II) Using input driver 'evdev' for 'Video Bus'
[ 10589.446] (**) Video Bus: always reports core events
[ 10589.446] (**) evdev: Video Bus: Device: "/dev/input/event4"
[ 10589.446] (--) evdev: Video Bus: Vendor 0 Product 0x6
[ 10589.446] (--) evdev: Video Bus: Found keys
[ 10589.447] (II) evdev: Video Bus: Configuring as keyboard
[ 10589.447] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/device:00/PNP0A08:00/LNXVIDEO:00/input/input4/event4"
[ 10589.447] (II) XINPUT: Adding extended input device "Video Bus" (type: KEYBOARD, id 7)
[ 10589.447] (**) Option "xkb_rules" "evdev"
[ 10589.447] (**) Option "xkb_model" "pc104"
[ 10589.447] (**) Option "xkb_layout" "us"
[ 10589.447] (II) config/udev: Adding input device Power Button (/dev/input/event1)
[ 10589.448] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[ 10589.448] (II) Using input driver 'evdev' for 'Power Button'
[ 10589.448] (**) Power Button: always reports core events
[ 10589.448] (**) evdev: Power Button: Device: "/dev/input/event1"
[ 10589.448] (--) evdev: Power Button: Vendor 0 Product 0x1
[ 10589.448] (--) evdev: Power Button: Found keys
[ 10589.448] (II) evdev: Power Button: Configuring as keyboard
[ 10589.448] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/device:00/PNP0C0C:00/input/input1/event1"
[ 10589.448] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 8)
[ 10589.448] (**) Option "xkb_rules" "evdev"
[ 10589.448] (**) Option "xkb_model" "pc104"
[ 10589.448] (**) Option "xkb_layout" "us"
[ 10589.449] (II) config/udev: Adding input device Lid Switch (/dev/input/event0)
[ 10589.449] (II) No input driver specified, ignoring this device.
[ 10589.449] (II) This device may have been added with another device file.
[ 10589.449] (II) config/udev: Adding input device Sleep Button (/dev/input/event2)
[ 10589.449] (**) Sleep Button: Applying InputClass "evdev keyboard catchall"
[ 10589.449] (II) Using input driver 'evdev' for 'Sleep Button'
[ 10589.449] (**) Sleep Button: always reports core events
[ 10589.449] (**) evdev: Sleep Button: Device: "/dev/input/event2"
[ 10589.449] (--) evdev: Sleep Button: Vendor 0 Product 0x3
[ 10589.449] (--) evdev: Sleep Button: Found keys
[ 10589.449] (II) evdev: Sleep Button: Configuring as keyboard
[ 10589.449] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/device:00/PNP0C0E:00/input/input2/event2"
[ 10589.449] (II) XINPUT: Adding extended input device "Sleep Button" (type: KEYBOARD, id 9)
[ 10589.449] (**) Option "xkb_rules" "evdev"
[ 10589.449] (**) Option "xkb_model" "pc104"
[ 10589.449] (**) Option "xkb_layout" "us"
[ 10589.450] (II) config/udev: Adding drm device (/dev/dri/card0)
[ 10589.451] (II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event5)
[ 10589.451] (**) AT Translated Set 2 keyboard: Applying InputClass "evdev keyboard catchall"
[ 10589.451] (II) Using input driver 'evdev' for 'AT Translated Set 2 keyboard'
[ 10589.451] (**) AT Translated Set 2 keyboard: always reports core events
[ 10589.451] (**) evdev: AT Translated Set 2 keyboard: Device: "/dev/input/event5"
[ 10589.451] (--) evdev: AT Translated Set 2 keyboard: Vendor 0x1 Product 0x1
[ 10589.451] (--) evdev: AT Translated Set 2 keyboard: Found keys
[ 10589.451] (II) evdev: AT Translated Set 2 keyboard: Configuring as keyboard
[ 10589.451] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio0/input/input5/event5"
[ 10589.451] (II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD, id 10)
[ 10589.451] (**) Option "xkb_rules" "evdev"
[ 10589.451] (**) Option "xkb_model" "pc104"
[ 10589.451] (**) Option "xkb_layout" "us"
[ 10589.452] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/event6)
[ 10589.452] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "evdev touchpad catchall"
[ 10589.452] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "touchpad catchall"
[ 10589.452] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "Default clickpad buttons"
[ 10589.452] (II) LoadModule: "synaptics"
[ 10589.452] (II) Loading /usr/lib/xorg/modules/input/synaptics_drv.so
[ 10589.509] (II) Module synaptics: vendor="X.Org Foundation"
[ 10589.509]    compiled for 1.14.3, module version = 1.7.1
[ 10589.509]    Module class: X.Org XInput Driver
[ 10589.509]    ABI class: X.Org XInput driver, version 19.1
[ 10589.509] (II) Using input driver 'synaptics' for 'SynPS/2 Synaptics TouchPad'
[ 10589.509] (**) SynPS/2 Synaptics TouchPad: always reports core events
[ 10589.509] (**) Option "Device" "/dev/input/event6"
[ 10589.509] (--) synaptics: SynPS/2 Synaptics TouchPad: x-axis range 1472 - 5472 (res 61)
[ 10589.509] (--) synaptics: SynPS/2 Synaptics TouchPad: y-axis range 1408 - 4448 (res 100)
[ 10589.509] (--) synaptics: SynPS/2 Synaptics TouchPad: pressure range 0 - 255
[ 10589.509] (--) synaptics: SynPS/2 Synaptics TouchPad: finger width range 0 - 15
[ 10589.509] (--) synaptics: SynPS/2 Synaptics TouchPad: buttons: left right double triple scroll-buttons
[ 10589.509] (--) synaptics: SynPS/2 Synaptics TouchPad: Vendor 0x2 Product 0x7
[ 10589.509] (--) synaptics: SynPS/2 Synaptics TouchPad: touchpad found
[ 10589.509] (**) SynPS/2 Synaptics TouchPad: always reports core events
[ 10589.509] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio1/input/input6/event6"
[ 10589.509] (II) XINPUT: Adding extended input device "SynPS/2 Synaptics TouchPad" (type: TOUCHPAD, id 11)
[ 10589.509] (**) synaptics: SynPS/2 Synaptics TouchPad: (accel) MinSpeed is now constant deceleration 2.5
[ 10589.509] (**) synaptics: SynPS/2 Synaptics TouchPad: (accel) MaxSpeed is now 1.75
[ 10589.509] (**) synaptics: SynPS/2 Synaptics TouchPad: (accel) AccelFactor is now 0.040
[ 10589.509] (**) SynPS/2 Synaptics TouchPad: (accel) keeping acceleration scheme 1
[ 10589.509] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration profile 1
[ 10589.509] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration factor: 2.000
[ 10589.509] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration threshold: 4
[ 10589.509] (--) synaptics: SynPS/2 Synaptics TouchPad: touchpad found
[ 10589.510] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/mouse0)
[ 10589.510] (**) SynPS/2 Synaptics TouchPad: Ignoring device from InputClass "touchpad ignore duplicates"
[ 10595.894] (II) AIGLX: Suspending AIGLX clients for VT switch


I can switch to a VT and if I query xrandr, I get this:
Code:
johnlm@lapsa ~ $ DISPLAY=":0.0" xrandr
xrandr: Output LVDS1 is not disconnected but has no modes
xrandr: Output VGA1 is not disconnected but has no modes
xrandr: Output TV1 is not disconnected but has no modes
Screen 0: minimum 320 x 200, current 1024 x 768, maximum 32767 x 32767
LVDS1 connected (normal left inverted right x axis y axis)
VGA1 connected (normal left inverted right x axis y axis)
TV1 connected (normal left inverted right x axis y axis)

which of course is wrong, cause LVDS1 (laptop display) is always connected (I can still use VTs)
and VGA1 and TV1 should be disconnected.

Any ideas?
_________________
"I reject your reality and substitute my own" - A. Savage
Back to top
View user's profile Send private message
tw04l124
Veteran
Veteran


Joined: 03 Oct 2006
Posts: 1308
Location: A t z e l, lower austria

PostPosted: Tue Nov 19, 2013 10:25 am    Post subject: Reply with quote

Code:
* x11-apps/intel-gpu-tools
     Available versions:  1.2^t 1.3^t {VIDEO_CARDS="nouveau"}
     Homepage:            http://xorg.freedesktop.org/
     Description:         intel gpu userland tools


You could install these gpu-tools and play around, but they did not helped me much a year ago.

Since you upgraded I recommend you downgrade and wait for the next useable version, if possible.

Another guess is to upgrade your kernel as it is rather "old" compared to your other software versions. They always change things so it fits together more nicely under the hood.

My personal opinion is not to touch gpu driver / xorg server when not necessary and to update only both together at the same time. It may be wise to update the kernel too at that point. Too much hassle with no gain (I use 1x nvidia, 1x build in intel gpu and in both worlds you can say 20 percent average problems if you update too often)
Back to top
View user's profile Send private message
FizzyWidget
Veteran
Veteran


Joined: 21 Nov 2008
Posts: 1109
Location: 127.0.0.1

PostPosted: Tue Nov 19, 2013 7:41 pm    Post subject: Reply with quote

I believe there was a fix put into kernel 3.12 to address LVDS issues
_________________
I know 43 ways to kill with a SKITTLE, so taste my rainbow bitch.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum