Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] ~/.Xmodmap not sourced when I login
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Javran
n00b
n00b


Joined: 18 Nov 2013
Posts: 8

PostPosted: Mon Nov 18, 2013 3:20 am    Post subject: [SOLVED] ~/.Xmodmap not sourced when I login Reply with quote

Hello there,

I'm trying to troubleshoot the problem that my ~/.Xmodmap is not applied automatically when I login.

I haven't done any modification to /etc/X11/xinit/xinitrc, which I believe is responsible of loading my xmodmap settings, I can see that this script will attempt to load "$HOME/.Xresources" and "$HOME/.Xmodmap".

The most weird thing is my .Xresource does work properly however. I use xfce and I even add "xmodmap /home/user/.Xmodmap" to my "Application autostart" list but it doesn't work either and I have to run it manually (running this command in my terminal yields no error)

I'm happy to provide any conf/log necessary but I just don't know where can I find them.

Thanks


Last edited by Javran on Mon Nov 18, 2013 8:01 pm; edited 1 time in total
Back to top
View user's profile Send private message
Logicien
l33t
l33t


Joined: 16 Sep 2005
Posts: 786
Location: Montréal

PostPosted: Mon Nov 18, 2013 3:57 am    Post subject: Reply with quote

Hi,
it can depend on the order by which Xfce execute his boot applications sequence. If the keyboard layout is loaded after your .Xmodmap application autostart
Code:
/usr/bin/xmodmap /full/path/to/.Xmodmap


than the keyboard layout can erase the Xorg keyboard setup done by .Xmodmap.

To help, you should check 'Use the default parameters' in the Disposition tab of the Keyboard dialog window of the Parameters section of the Xfce menu. That way, Xfce should not load any keymap at boot time and your .Xmodmap setup should stay in place.

.Xmodmap and .Xresources are loaded from .xinitrc in my home directory after I execute startx in a framebuffer terminal. Their setup stay in place. It should work from .xsessionrc if you use a display manager to open a graphic session.

Xfce do not set a lot of Xorg clients applications parameters at boot time. That can explain why the .Xresources setup is not modified.
_________________
Paul
Back to top
View user's profile Send private message
Javran
n00b
n00b


Joined: 18 Nov 2013
Posts: 8

PostPosted: Mon Nov 18, 2013 7:30 am    Post subject: Reply with quote

Logicien wrote:
Hi,
it can depend on the order by which Xfce execute his boot applications sequence. If the keyboard layout is loaded after your .Xmodmap application autostart
Code:
/usr/bin/xmodmap /full/path/to/.Xmodmap


than the keyboard layout can erase the Xorg keyboard setup done by .Xmodmap.

To help, you should check 'Use the default parameters' in the Disposition tab of the Keyboard dialog window of the Parameters section of the Xfce menu. That way, Xfce should not load any keymap at boot time and your .Xmodmap setup should stay in place.

.Xmodmap and .Xresources are loaded from .xinitrc in my home directory after I execute startx in a framebuffer terminal. Their setup stay in place. It should work from .xsessionrc if you use a display manager to open a graphic session.

Xfce do not set a lot of Xorg clients applications parameters at boot time. That can explain why the .Xresources setup is not modified.


Thanks for your response! It took me a while to find that setting, I guessed what you meant is Xfce Menu -> Settings -> Keyboard -> "Layout" tab -> Check "Use system defaults". But it didn't work.

I use slim for login manager.
Back to top
View user's profile Send private message
Javran
n00b
n00b


Joined: 18 Nov 2013
Posts: 8

PostPosted: Mon Nov 18, 2013 8:00 pm    Post subject: Reply with quote

Javran wrote:
Logicien wrote:
Hi,
it can depend on the order by which Xfce execute his boot applications sequence. If the keyboard layout is loaded after your .Xmodmap application autostart
Code:
/usr/bin/xmodmap /full/path/to/.Xmodmap


than the keyboard layout can erase the Xorg keyboard setup done by .Xmodmap.

To help, you should check 'Use the default parameters' in the Disposition tab of the Keyboard dialog window of the Parameters section of the Xfce menu. That way, Xfce should not load any keymap at boot time and your .Xmodmap setup should stay in place.

.Xmodmap and .Xresources are loaded from .xinitrc in my home directory after I execute startx in a framebuffer terminal. Their setup stay in place. It should work from .xsessionrc if you use a display manager to open a graphic session.

Xfce do not set a lot of Xorg clients applications parameters at boot time. That can explain why the .Xresources setup is not modified.


Thanks for your response! It took me a while to find that setting, I guessed what you meant is Xfce Menu -> Settings -> Keyboard -> "Layout" tab -> Check "Use system defaults". But it didn't work.

I use slim for login manager.


well... finally I figure it out, I happened to uncheck "use system keyboard" in my ibus settings. thank you for help anyway.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum