Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Cannot get 1440x900 running - Intel 82946GZ/GL
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
x.para
Apprentice
Apprentice


Joined: 22 May 2005
Posts: 166
Location: CZ

PostPosted: Sat Nov 16, 2013 8:09 pm    Post subject: [SOLVED] Cannot get 1440x900 running - Intel 82946GZ/GL Reply with quote

Hi all,

this is my xrandr output:

Code:


xrandr --verbose
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 640 x 480, current 1024 x 768, maximum 1280 x 1024
default connected primary 1024x768+0+0 (0x141) normal (normal) 0mm x 0mm
        Identifier: 0x13f
        Timestamp:  21063
        Subpixel:   no subpixels
        Clones:   
        CRTC:       0
        CRTCs:      0
        Transform:  1.000000 0.000000 0.000000
                    0.000000 1.000000 0.000000
                    0.000000 0.000000 1.000000
                   filter:
  1280x1024 (0x140)    0.0MHz
        h: width  1280 start    0 end    0 total 1280 skew    0 clock    0.0KHz
        v: height 1024 start    0 end    0 total 1024           clock    0.0Hz
  1024x768 (0x141)    0.0MHz *current
        h: width  1024 start    0 end    0 total 1024 skew    0 clock    0.0KHz
        v: height  768 start    0 end    0 total  768           clock    0.0Hz
  800x600 (0x142)    0.0MHz
        h: width   800 start    0 end    0 total  800 skew    0 clock    0.0KHz
        v: height  600 start    0 end    0 total  600           clock    0.0Hz
  640x480 (0x143)    0.0MHz
        h: width   640 start    0 end    0 total  640 skew    0 clock    0.0KHz
        v: height  480 start    0 end    0 total  480           clock    0.0Hz





Chipset:

Code:

00:02.0 VGA compatible controller: Intel Corporation 82946GZ/GL Integrated Graphics Controller (rev 02)


1440x900 mode is missing, so i decided to add this manualy because in WIN7 this mode is working just fine.

Code:


cvt 1440 900
# 1440x900 59.89 Hz (CVT 1.30MA) hsync: 55.93 kHz; pclk: 106.50 MHz
Modeline "1440x900_60.00"  106.50  1440 1528 1672 1904  900 903 909 934 -hsync +vsync

xrandr --newmode "1440x900_60.00"  106.50  1440 1528 1672 1904  900 903 909 934 -hsync +vsync

xrandr --addmode  default "1440x900_60.00"

xrandr --output default --mode 1440x900_60.00
xrandr: Failed to get size of gamma for output default
xrandr: Configure crtc 0 failed



KMS is enabled in my kernel 3.10.17-gentoo

Code:

uname  -a
Linux stable 3.10.17-gentoo #2 SMP PREEMPT Sat Nov 16 13:27:37 CET 2013 i686 Intel(R) Pentium(R) 4 CPU 3.20GHz GenuineIntel GNU/Linux


modules:

Code:


lsmod |grep intel
snd_hda_intel          26960  2
snd_hda_codec         110088  2 snd_hda_codec_idt,snd_hda_intel
snd_pcm                66908  2 snd_hda_codec,snd_hda_intel
snd_page_alloc          5742  2 snd_pcm,snd_hda_intel
intel_agp               8488  1 i915
intel_gtt               9778  3 i915,intel_agp


lsmod |grep i915
i915                  439801  0
cfbfillrect             3054  1 i915
cfbimgblt               1795  1 i915
i2c_algo_bit            4319  1 i915
cfbcopyarea             2978  1 i915
drm_kms_helper         23824  1 i915
drm                   176572  2 i915,drm_kms_helper
intel_agp               8488  1 i915
intel_gtt               9778  3 i915,intel_agp



where the problem can be?

thanks..!


EDIT: It looks driver was falling back to VESA even intel was instaled. Unmerged VESA- no screen at all. Solved by adding missing mapkey USE flag to udev, recompiling xorg-server, xorg-drivers, xf86-video-intel. After reboot xrandr shows all Monitor modes including 1440x900 and intel driver is used.
_________________
Miracles are happening!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum