Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
No bluetooth icon in Gnome 3, unable to receive files
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
benny1967
Apprentice
Apprentice


Joined: 25 Apr 2004
Posts: 217

PostPosted: Thu Nov 14, 2013 9:05 pm    Post subject: No bluetooth icon in Gnome 3, unable to receive files Reply with quote

It's already been a while since I 'lost' the bluetooth icon in Gnome. I really cannot remember when. But it now bugs me I cant get it back.

I'm on Gnome 3.8 currently and therefore have systemd, but neither the exact version of Gnome nor systemd are relevant; it must have started well before Gnome 3.6.

I see the Bluetooth settings with paired devices, I can pair new devices, I can send files to remote devices via bluetooth, so in principle my BT setup can't be all that broken.
(Also, BT works perfectly well in KDE.)

The only thing I cannot do is send files from a, say, smartphone to the computer when running Gnome. There will be an error on the smartphone. (I've treid quite a few phones plus a laptop.)
Also, the fancy BT-icon is missing.


I found an article somewhere suggesting that the problem, receiving files will be solved by installing gnome-user-share and apply the appropriate settings. Tried that, didn't change a thing.


Any ideas what else to check? :(
Back to top
View user's profile Send private message
benny1967
Apprentice
Apprentice


Joined: 25 Apr 2004
Posts: 217

PostPosted: Thu Nov 28, 2013 5:05 pm    Post subject: Reply with quote

Update:

A little progress: The nifty bluetooth icon does show up now. I had to enable RFKILL in the kernel configuration for it to work.

Still, this doesn't solve the functional problem: Cannot transfer files to the PC when Gnome is running as the desktop environment.
Back to top
View user's profile Send private message
arfbtwn
n00b
n00b


Joined: 17 Nov 2013
Posts: 2

PostPosted: Thu Dec 19, 2013 6:55 pm    Post subject: Reply with quote

It appears we're in the same boat, although your situation is slightly better than mine. I'm not even able to send files from Gnome, and the Connection slider for the paired device flips instantaneously back to the off position when I try to enable it.

Like yourself, I do remember this working when I first installed the gnome overlay, perhaps that was version 3.2/3.4? Anyway, it was working so well that I had the phone routing its audio through the laptop as if the laptop was a headset...

Are you still running Gnome 3.8 or have you updated like myself and perhaps found a similar regression?

For me, I think the next step is to try and use any console utilities to pair and send/receive files therefore verifying that it is the Gnome component causing the issue.

FWIW, my bluez is 5.12, gnome-bluetooth is 3.10.0.

Sorry I don't have a solution for you, I'm hoping we can come to one together ;)
_________________
--
Registered Linux User #392373
Back to top
View user's profile Send private message
benny1967
Apprentice
Apprentice


Joined: 25 Apr 2004
Posts: 217

PostPosted: Sat Dec 28, 2013 7:32 pm    Post subject: Reply with quote

I'm running Gnome 3.8.

What seems to have solved the issue for me (I'll add 'solved' to the thread title if it works for you too):
I went to the system settings and clicked on what's most likely named "sharing" in the English user interface. Everything was 'off' there, just as I expected it to be. I don't want to share anything on my network. I then enabled sharing overall (whcih I had to do to enter the sub-items), then clicked on 'bluetooth' and enabled the item about receiving files into the download folder. That did it for me. I could even disable the general sharing-setting afterwards, it seems that once the bluetooth-setting was touched in a way, it worked. And it works both ways now.
Back to top
View user's profile Send private message
arfbtwn
n00b
n00b


Joined: 17 Nov 2013
Posts: 2

PostPosted: Tue Jan 07, 2014 1:17 pm    Post subject: Reply with quote

Hi, sorry for the late reply, I had thought I'd selected to subscribe for notifications but apparently not.

Go ahead and mark the thread as solved, I actually downgraded to gnome 3.8 with bluez 4 and everything is working again for me too.

For any gnome 3.10/bluez 5 users casually browsing the thread, I think my problem was actually distinct and perhaps caused by the replacement of obex-data-server. I didn't manage to resolve it though.
_________________
--
Registered Linux User #392373
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum