Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
XFCE: keeping getting randomly logged out of XFCE
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
BrummieJim
l33t
l33t


Joined: 22 Jul 2005
Posts: 605

PostPosted: Thu Nov 14, 2013 9:01 am    Post subject: XFCE: keeping getting randomly logged out of XFCE Reply with quote

Hi,
Just done an upgrade and I keep getting randomly logged out of XFCE and returned to my login screen. The only pattern I can acertain is that it's related to press buttons, for instance clicking on recover documents in libre office booted me out twice, as did trying to stat emacs from the command line. I was if any of you had found something similar? Also suspend has also stopped working,

Thanks for your help, sorry about the less than helpful instructions,
James

Here's a fragment of my message log over the time of the crash.
Quote:

v 14 09:21:42 Columbian dbus[2524]: [system] Activating service name='org.freedesktop.nm_dispatcher' (using servicehelper)
Nov 14 09:21:42 Columbian dbus[2524]: [system] Successfully activated service 'org.freedesktop.nm_dispatcher'
Nov 14 09:21:42 Columbian /etc/init.d/NetworkManager[4076]: status: inactive
Nov 14 09:21:42 Columbian kernel: [ 277.978955] xfce4-session[3438]: segfault at ffffffff00000000 ip 00007f9ecfed5b1a sp 00007fff5a74d0b0 error 5 in libglib-2.0.so.0.3600.4[7f9ecfe70000+128000]
Nov 14 09:21:42 Columbian /etc/init.d/NetworkManager[4089]: status: inactive
Nov 14 09:21:42 Columbian lightdm: pam_unix(lightdm:session): session closed for user ja
Nov 14 09:21:42 Columbian lightdm: pam_unix(lightdm:session): session closed for user ja
Nov 14 09:21:42 Columbian kernel: [ 278.065703] xfconfd (3440) used greatest stack depth: 4248 bytes left

_________________
Intel 2.2 Core 2 Duo, 4Gb Ram, 320GB Sata Drive and Nvidia card.
Back to top
View user's profile Send private message
eyoung100
Veteran
Veteran


Joined: 23 Jan 2004
Posts: 1406

PostPosted: Thu Nov 14, 2013 2:46 pm    Post subject: Reply with quote

This might be the suspect:
Code:
Nov 14 09:21:42 Columbian kernel: [ 277.978955] xfce4-session[3438]: segfault at ffffffff00000000 ip 00007f9ecfed5b1a sp 00007fff5a74d0b0 error 5 in libglib-2.0.so.0.3600.4[7f9ecfe70000+128000]


Looks like we may need to submit a bug, and use this as the URL: periodic crashes of xfce4-session

Your bug will follow the upstream bug...

According to the bug, lets try downgrading glib. What version of dev-libs/glib do you have installed :?:

If you need help writing the bug let me know, as there are 2 patches that need to be included.
_________________
The Birth and Growth of Science is the Death and Atrophy of Art -- Unknown
Registerd Linux User #363735
Adopt a Post | Strip Comments| Emerge Wrapper
Back to top
View user's profile Send private message
666threesixes666
Veteran
Veteran


Joined: 31 May 2011
Posts: 1223
Location: 42.68n 85.41w

PostPosted: Thu Nov 14, 2013 6:28 pm    Post subject: Reply with quote

this has been driving me up the wall with my laptop. xfce4 crashing all the time, its so under powered ill only go down in desktop power.
_________________
cat /etc/*-release
Funtoo Linux - baselayout 2.2.0
consider this warning no. 1
http://ecx.images-amazon.com/images/I/81Ku-vxIb3L._SL1500_.jpg
http://wiki.gentoo.org/wiki/Special:Contributions/666threesixes666
Back to top
View user's profile Send private message
BrummieJim
l33t
l33t


Joined: 22 Jul 2005
Posts: 605

PostPosted: Thu Nov 14, 2013 6:51 pm    Post subject: Reply with quote

This is the version I'm running, had to jump a few versions due to a horrible case of the blocks (emerge -uND).
Quote:

[I] dev-libs/glib
Available versions:
(1) 1.2.10-r5
(2) 2.32.4-r1 (~)2.34.3-r1 (~)2.36.4-r1
{debug fam hardened selinux static-libs systemtap test utils xattr ABI_MIPS="n32 n64 o32" ABI_X86="32 64 x32" KERNEL="linux" PYTHON_TARGETS="python2_6 python2_7"}
Installed versions: 2.36.4-r1(2)(08:46:48 10/28/13)(-debug -fam -selinux -static-libs -systemtap -test -utils -xattr ABI_MIPS="-n32 -n64 -o32" ABI_X86="64 -32 -x32" KERNEL="linux" PYTHON_TARGETS="python2_7 -python2_6")
Homepage: http://www.gtk.org/
Description: The GLib library of C routines



[I] sys-libs/glibc
Available versions: (2.2) ~2.9_p20081201-r3^s 2.10.1-r1^s 2.11.3^s ~2.12.1-r3^s 2.12.2^s ~2.13-r2^s 2.13-r4^s ~2.14^s ~2.14.1-r2^s 2.14.1-r3^s ~2.15-r1^s 2.15-r2^s 2.15-r3^s ~2.16.0^s ~2.17^s **2.18^s **9999^s
{debug gd hardened multilib nscd profile selinux suid systemtap vanilla CROSSCOMPILE_OPTS="headers-only"}
Installed versions: 2.15-r3(2.2)^s(05:38:59 01/30/13)(multilib -debug -gd -hardened -profile -selinux -vanilla CROSSCOMPILE_OPTS="-headers-only")
Homepage: http://www.gnu.org/software/libc/libc.html
Description: GNU libc6 (also called glibc2) C library


_________________
Intel 2.2 Core 2 Duo, 4Gb Ram, 320GB Sata Drive and Nvidia card.
Back to top
View user's profile Send private message
eyoung100
Veteran
Veteran


Joined: 23 Jan 2004
Posts: 1406

PostPosted: Thu Nov 14, 2013 6:58 pm    Post subject: Reply with quote

You need to downgrade from 2.36.4 to 2.34 as per the bug from before.
_________________
The Birth and Growth of Science is the Death and Atrophy of Art -- Unknown
Registerd Linux User #363735
Adopt a Post | Strip Comments| Emerge Wrapper
Back to top
View user's profile Send private message
saibot
n00b
n00b


Joined: 02 May 2006
Posts: 34
Location: nerd town

PostPosted: Sat Dec 07, 2013 3:52 pm    Post subject: Reply with quote

Same problem here...

Quote:

You need to downgrade from 2.36.4 to 2.34 as per the bug from before.

Unfortunately, that's actually not so easy to do:

Code:

Calculating dependencies... done!
[ebuild     UD~] dev-libs/glib-2.34.3-r1:2 [2.36.4-r1:2] USE="-debug (-fam) (-selinux) -static-libs -systemtap {-test} -utils -xattr" ABI_X86="(-32%) (-64%*) (-x32%)" PYTHON_TARGETS="python2_7 -python2_6" 6,187 kB

Total: 1 package (1 downgrade), Size of downloads: 6,187 kB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/glib:2

  (dev-libs/glib-2.34.3-r1::gentoo, ebuild scheduled for merge) pulled in by
    =dev-libs/glib-2.34.3-r1

  (dev-libs/glib-2.36.4-r1::gentoo, installed) pulled in by
    >=dev-libs/glib-2.36.0:2 required by (net-libs/libsoup-2.42.3.1::gentoo, installed)
    (and 10 more with the same problem)

So do I need to downgrade libsoup and the "10 more" packages as well? I'm afraid this will create a long chain of required downgrades... are there any other options for working around that xfce bug? Or should I look into slotting glib?
Back to top
View user's profile Send private message
TomWij
Developer
Developer


Joined: 04 Jul 2012
Posts: 1339

PostPosted: Sat Dec 07, 2013 4:01 pm    Post subject: Reply with quote

eyoung100 wrote:
This might be the suspect:
Code:
Nov 14 09:21:42 Columbian kernel: [ 277.978955] xfce4-session[3438]: segfault at ffffffff00000000 ip 00007f9ecfed5b1a sp 00007fff5a74d0b0 error 5 in libglib-2.0.so.0.3600.4[7f9ecfe70000+128000]


Looks like we may need to submit a bug, and use this as the URL: periodic crashes of xfce4-session


If you do, please keep http://www.gentoo.org/proj/en/qa/backtraces.xml in mind such that you can provide more detailed debugging information.
Back to top
View user's profile Send private message
deltamalloc
Tux's lil' helper
Tux's lil' helper


Joined: 18 Jan 2013
Posts: 128

PostPosted: Sun Dec 08, 2013 7:36 pm    Post subject: XFCE crashes after world update Reply with quote

I'm using stable and after a world update I get segfaults in XFCE when I click on the panel. Things such as starting a program with a shortcut on the panel or clicking the "log out" icon results in X restarting (before actually having selected I wish to shutdown, of course).

dmesg gives me errors like this:

xfce4-session[2295]: segfault at ffffffff02664960 ip 00007f39ecd64535 sp 00007fff7a0ca8a0 error 5 in libglib-2.0.so.0.3600.4[7f39eccff000+125000]

I have tried doing another world update to see if this was just an intermittent issue that would be resolved quickly in a new update.
Back to top
View user's profile Send private message
desultory
Administrator
Administrator


Joined: 04 Nov 2005
Posts: 7817

PostPosted: Thu Dec 12, 2013 4:34 am    Post subject: Reply with quote

Merged the above post, in case additional solutions are desired.
Back to top
View user's profile Send private message
sligo
n00b
n00b


Joined: 17 Oct 2011
Posts: 47

PostPosted: Mon Dec 16, 2013 3:04 pm    Post subject: Reply with quote

looks like this bug is fixed in xfce4-session-4.10.1 which is currently in portage unstable. no more crashes for me so far. someone should make it stable as the current stable version is unstable (breaks system).
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum