Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
chicony camera module
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
funky1096
n00b
n00b


Joined: 10 Oct 2013
Posts: 47

PostPosted: Mon Nov 04, 2013 8:12 pm    Post subject: chicony camera module Reply with quote

Hello i have a chicony camera and i cant seem to find the correct module for it

lsusb output

Code:

Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 001 Device 004: ID 04f2:b1d6 Chicony Electronics Co., Ltd CNF9055 Toshiba Webcam
Bus 002 Device 003: ID 0bda:0138 Realtek Semiconductor Corp. RTS5138 Card Reader Controller


i have tryed modprobing uvcvideo after enabling it and needed features in kernel but to no avial.

i have a /dev/video0 but after trying

Code:

cat /dev/video0 > /dev/null


its result
Code:

cat: /dev/video0: Invalid argument

what do i do now?
Back to top
View user's profile Send private message
<3
l33t
l33t


Joined: 21 Oct 2004
Posts: 734

PostPosted: Mon Nov 04, 2013 8:32 pm    Post subject: Reply with quote

Try this and see if it is of any assistance http://kmuto.jp/debian/hcl/
Back to top
View user's profile Send private message
funky1096
n00b
n00b


Joined: 10 Oct 2013
Posts: 47

PostPosted: Mon Nov 04, 2013 8:37 pm    Post subject: Reply with quote

It's a internal usb camera not a PCI device the site doesent work with usb.
Back to top
View user's profile Send private message
funky1096
n00b
n00b


Joined: 10 Oct 2013
Posts: 47

PostPosted: Mon Nov 04, 2013 8:42 pm    Post subject: Reply with quote

Ok i got the device itself working i forgot something in the kernel config oops :cry:

but now i cant get audio working with it. ugh :?
Back to top
View user's profile Send private message
<3
l33t
l33t


Joined: 21 Oct 2004
Posts: 734

PostPosted: Sat Nov 30, 2013 3:28 am    Post subject: Reply with quote

What kernel module did you use to enable it, as I have a Toshiba Laptop with that same camera and I don't remember what driver to use.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum