Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solucionado] Problema de gráficos: Driver Nouveau no carga
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
edgar_uriel84
Guru
Guru


Joined: 21 Dec 2008
Posts: 438
Location: Tultitlan, México

PostPosted: Mon Oct 07, 2013 2:13 am    Post subject: [Solucionado] Problema de gráficos: Driver Nouveau no carga Reply with quote

Hola, pues tengo una Asus UX32VD con gráficos híbridos, un Intel y un Nvidia Optimus Mi problema es que no puedo activar la Nvidia porque no aparece cuando ejecuto "xrandr --listproviders", revisé el dmesg y si aparece un error (dejo el dmesg aquí y la configuración de mi kernel) que no aparece en los LiveCD con los que he probado la tarjeta. De hecho el LiveCD de Ubuntu detecta la tarjeta incluso con el driver Nouveau, eso si, sin optimización de energía. Espero alguien pueda darme una pista sobre como solucionar el problema con la carga del módulo, dejo más info sobre mi configuración abajo.
lspci:
00:00.0 Host bridge: Intel Corporation 3rd Gen Core processor DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor PCI Express Root Port (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
00:04.0 Signal processing controller: Intel Corporation 3rd Gen Core Processor Thermal Subsystem (rev 09)
00:14.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller (rev 04)
00:16.0 Communication controller: Intel Corporation 7 Series/C210 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 1 (rev c4)
00:1c.1 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 2 (rev c4)
00:1d.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation HM76 Express Chipset LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 7 Series Chipset Family 6-port SATA Controller [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 7 Series/C210 Series Chipset Family SMBus Controller (rev 04)
00:1f.6 Signal processing controller: Intel Corporation 7 Series/C210 Series Chipset Family Thermal Management Controller (rev 04)
01:00.0 3D controller: NVIDIA Corporation GF117M [GeForce 610M/710M / GT 620M/625M/630M] (rev a1)
03:00.0 Network controller: Intel Corporation Centrino Advanced-N 6235 (rev 24)

emerge --info:

Portage 2.2.1 (default/linux/amd64/13.0, gcc-4.7.3, glibc-2.15-r3, 3.10.7-gentoo-r1 x86_64)
=================================================================
System uname: Linux-3.10.7-gentoo-r1-x86_64-Intel-R-_Core-TM-_i7-3517U_CPU_@_1.90GHz-with-gentoo-2.2
KiB Mem:     5545584 total,   4795116 free
KiB Swap:    4194300 total,   4194300 free
Timestamp of tree: Thu, 03 Oct 2013 21:00:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
app-shells/bash:          4.2_p45
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.7.5-r2
dev-util/cmake:           2.8.10.2-r2
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.10.3, 1.11.6, 1.13.4
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.7.3-r1
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.9 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo x-portage
ACCEPT_KEYWORDS="amd64 x86"
ACCEPT_LICENSE="@FREE"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=corei7 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/maven-bin-3.0/conf"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.5/ext-active/ /etc/php/cgi-php5.5/ext-active/ /etc/php/cli-php5.5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=corei7 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="es_MX.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_EXTRA_OPTS="--exclude-from=/etc/portage/rsync_excludes --delete-excluded"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
USE="X a52 aac acl acpi alsa amd64 bash-completion berkdb bluetooth bzip2 cli cracklib crypt cups curl cxx dbus directfb dri emacs fbcon flac fortran gdbm gif gnutls gpm iconv imlib ipv6 java jpeg lm_sensors mad mmx mmxext modules mp3 mudflap multilib mysql ncurses nls nptl ntfs ogg opengl openmp pam pcre pdf png readline savedconfig sdl session smp spell sse sse2 sse3 sse4_1 sse4_2 ssl ssse3 static-libs svg tcpd theora threads tiff truetype unicode usb v4l vaapi vcd vorbis xinerama xml xv xvid zlib" ABI_X86="64" ALSA_CARDS="hda-intel" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" GRUB_PLATFORMS="efi-64 qemu" INPUT_DEVICES="evdev keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="es es_MX en" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7" QEMU_SOFTMMU_TARGETS="arm i386 x86_64" QEMU_USER_TARGETS="arm i386 x86_64" RUBY_TARGETS="ruby19" SANE_BACKENDS="epson2" USERLAND="GNU" VIDEO_CARDS="intel i915 nouveau" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, SYNC, USE_PYTHON

PD.: La verdad espero no tener que usar el driver oficial, se que hay guías en otras partes del foro pero parece que nadie ha tenido buenos resultados configurandolo, es muy engorroso y no es SL.
_________________
Algún día habrá una persona mejor que yo, pero esa persona no eres tú ni ese momento es ahora.


Last edited by edgar_uriel84 on Mon Oct 28, 2013 6:41 pm; edited 1 time in total
Back to top
View user's profile Send private message
edgar_uriel84
Guru
Guru


Joined: 21 Dec 2008
Posts: 438
Location: Tultitlan, México

PostPosted: Mon Oct 28, 2013 1:57 am    Post subject: Reply with quote

Hoy por fin avance un poco en este problema. Actualice el kernel a la version 3.11.6 y ahora puedo ver ambas tarjetas gráficas. Después de actualizar el kernel mi Xorg.1.log sacaba muchos errores no se si relevantes donde decía que faltaban los drivers fbdev, modesetting, nv. Así que agregué esos controladores al make.conf.

También instalé mesa-progs y surgió un nuevo problema al activar PRIME:

Code:
┌─ [3][19:46:26][bofe@genomorro-ux32vd][~]
└$ xrandr --listproviders
Providers: number : 2
Provider 0: id: 0x86 cap: 0xb, Source Output, Sink Output, Sink Offload crtcs: 3 outputs: 4 associated providers: 0 name:Intel
Provider 1: id: 0x5f cap: 0x5, Source Output, Source Offload crtcs: 0 outputs: 0 associated providers: 0 name:nouveau
┌─ [4][19:46:37][bofe@genomorro-ux32vd][~]
└$ xrandr --setprovideroffloadsink Intel nouveau
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  139 (RANDR)
  Minor opcode of failed request:  34 ()
  Value in failed request:  0x86
  Serial number of failed request:  16
  Current serial number in output stream:  17


Claro que glxgears detecta el mismo problema:

Code:
┌─ [5][19:46:49][bofe@genomorro-ux32vd][~]
└$ LIBGL_DEBUG=verbose DRI_PRIME=1 glxgears
libGL: OpenDriver: trying /usr/lib64/dri/tls/i965_dri.so
libGL: OpenDriver: trying /usr/lib64/dri/i965_dri.so
libGL error: dlopen /usr/lib64/dri/i965_dri.so failed (/usr/lib64/dri/i965_dri.so: cannot open shared object file: N
libGL error: unable to load driver: i965_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: i965
libGL: OpenDriver: trying /usr/lib64/dri/tls/swrast_dri.so
libGL: OpenDriver: trying /usr/lib64/dri/swrast_dri.so
libGL: Can't open configuration file /home/bofe/.drirc: No such file or directory.
10 frames in 5.3 seconds =  1.872 FPS
8 frames in 5.0 seconds =  1.596 FPS
8 frames in 5.2 seconds =  1.545 FPS
8 frames in 5.2 seconds =  1.548 FPS
9 frames in 5.5 seconds =  1.640 FPS
8 frames in 5.2 seconds =  1.535 FPS
8 frames in 5.2 seconds =  1.551 FPS
XIO:  fatal IO error 11 (Resource temporarily unavailable) on X server ":1"
      after 1339 requests (1339 known processed) with 0 events remaining.


El log de Xorg también:

Xorg.1.log:
[    29.408] (EE) AIGLX error: dlopen of /eusr/lib64/dri/i965_dri.so failed (/usr/lib64/dri/i965_dri.so: cannot open shared object file: No such file or directory)
[    29.408] (EE) AIGLX: reverting to software rendering


Por cierto comprobé que /usr/lib64/dri/i965_dri.so existe en esa ruta, no se porque no lo abre. Sugerencias?

EDITO: i965_dri.so no existe es un enlace simbólico roto, alguien sabe como lo genero?
_________________
Algún día habrá una persona mejor que yo, pero esa persona no eres tú ni ese momento es ahora.
Back to top
View user's profile Send private message
opotonil
l33t
l33t


Joined: 17 Jun 2005
Posts: 781
Location: 127.0.0.1

PostPosted: Mon Oct 28, 2013 11:15 am    Post subject: Reply with quote

Quote:

i965_dri.so no existe es un enlace simbólico roto, alguien sabe como lo genero?


https://forums.gentoo.org/viewtopic-t-935668-start-0.html
Quote:

/usr/lib64/dri/i965_dri.so is a symlink that is managed by eselect mesa, and should normally point to /usr/lib64/mesa/i965_dri.so


Salu2.
_________________
Localnet
Films Localnet
Back to top
View user's profile Send private message
edgar_uriel84
Guru
Guru


Joined: 21 Dec 2008
Posts: 438
Location: Tultitlan, México

PostPosted: Mon Oct 28, 2013 6:40 pm    Post subject: Reply with quote

Gracias!, leído y resuelto. Mi make.conf quedó con lo siguiente:

make.conf:
VIDEO_CARDS="fbdev intel i915 i965 modesetting nouveau nv"
INPUT_DEVICES="evdev keyboard mouse synaptics"


Creo que puedo quitar algunos drivers que puse para que el log de Xorg no marcara errores pero realmente parecen no ser necesarios. Como ya dije, requerí eso y el kernel 3.11. Luego un script para cuando quiera usar la Nvidia:

Code:
#!/bin/bash
export DRI_PRIME=1
exec "$@"


Ahora todo va bien. Trataré de avanzar en poder apagar la Nvidia cuando no la necesite, primero trataré con bumblebee, sino, trataré de usar directamente bbswitch si consigo algo lo anotaré.
_________________
Algún día habrá una persona mejor que yo, pero esa persona no eres tú ni ese momento es ahora.
Back to top
View user's profile Send private message
gringo
Advocate
Advocate


Joined: 27 Apr 2003
Posts: 3706

PostPosted: Tue Oct 29, 2013 2:38 pm    Post subject: Reply with quote

Quote:
Creo que puedo quitar algunos drivers


desde luego, usa solo los que necesites. Es normal que te aparecen en el log, al no haber xorg.conf va probando todo.
En INPUT_DEVICES si usas evdev te sobran keyboard y mouse.

Quote:
Trataré de avanzar en poder apagar la Nvidia cuando no la necesite


si quieres usar la nvidia de vez en cuando creo que de momento solo puedes hacerlo con bumblebee o similares; si lo que quieres es desconectarla directamente tienes varias posibilidades. Yo uso acpi_call y lo lanzo en cada inicio de sesión.

saluetes
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum