Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
need help trying to update
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
todd93
Guru
Guru


Joined: 30 Oct 2006
Posts: 436
Location: Missouri

PostPosted: Sun Oct 27, 2013 1:42 pm    Post subject: need help trying to update Reply with quote

First of all, I really need to apologize, more to myself really, I have not ran a successful emerge -uDNv world in a little while. now I am running into some trouble when I do it. I will post the output that I can, but I can't get the entire package list (I'm sure there is a way, but I'm not sure how to do it). I will mention that I have been working to have a mostly stable system, but we all know how that goes. I will post what I can, and if someone could tell me how to get the entire output, I'll be happy to post that.
Code:

[blocks B      ] <dev-lang/vala-0.20.0 ("<dev-lang/vala-0.20.0" is blocking dev-libs/gobject-introspection-1.36.0-r1)
[blocks B      ] <=x11-drivers/xf86-video-sis-0.10.7 ("<=x11-drivers/xf86-video-sis-0.10.7" is blocking x11-base/xorg-drivers-1.14)

Total: 556 packages (495 upgrades, 4 downgrades, 25 new, 10 in new slots, 22 reinstalls, 3 uninstalls), Size of downloads: 1,415,209 kB
Conflict: 15 blocks (3 unsatisfied)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

media-libs/freetype:2

  (media-libs/freetype-2.4.11::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (media-libs/freetype-2.4.11::gentoo, ebuild scheduled for merge) pulled in by
    media-libs/freetype[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (x11-libs/libXft-2.3.1-r1::gentoo, ebuild scheduled for merge)
    >=media-libs/freetype-2.2.1[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (media-libs/fontconfig-2.10.92::gentoo, ebuild scheduled for merge)

app-text/poppler:0

  (app-text/poppler-0.22.2-r2::gentoo, installed) pulled in by
    >=app-text/poppler-0.16:0/35=[xpdf-headers(+),cxx] required by (app-office/libreoffice-4.1.2.3::gentoo, installed)
    app-text/poppler:0/35=[cxx,jpeg,lcms,tiff,xpdf-headers(+)] required by (net-print/cups-filters-1.0.34-r1::gentoo, installed)

  (app-text/poppler-0.22.5::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

dev-libs/expat:0

  (dev-libs/expat-2.1.0-r2::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/expat-2.1.0-r2::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/expat-1.95.3[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (media-libs/fontconfig-2.10.92::gentoo, ebuild scheduled for merge)

media-libs/cogl:1.0

  (media-libs/cogl-1.14.1_pre20130901::gentoo, ebuild scheduled for merge) pulled in by
    >=media-libs/cogl-1.14.0:1.0=[introspection?,pango] required by (media-libs/clutter-1.14.4-r1::gentoo, ebuild scheduled for merge)

  (media-libs/cogl-1.12.2-r1::gentoo, installed) pulled in by
    media-libs/cogl:1.0/11=[introspection] required by (media-libs/clutter-gtk-1.4.2::gentoo, installed)

media-libs/lcms:2

  (media-libs/lcms-2.3::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (media-libs/lcms-2.5::gentoo, installed) pulled in by
    >=media-libs/lcms-2.5:2= required by (x11-misc/colord-1.0.3::gentoo, ebuild scheduled for merge)

virtual/libffi:0

  (virtual/libffi-3.0.11::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (virtual/libffi-3.0.11::gentoo, ebuild scheduled for merge) pulled in by
    virtual/libffi[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (dev-libs/glib-2.36.4-r1::gentoo, ebuild scheduled for merge)

virtual/libiconv:0

  (virtual/libiconv-0::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (virtual/libiconv-0::gentoo, ebuild scheduled for merge) pulled in by
    virtual/libiconv[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (dev-libs/glib-2.36.4-r1::gentoo, ebuild scheduled for merge)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (dev-lang/vala-0.14.2-r2::gentoo, installed) pulled in by
    dev-lang/vala:0.14[vapigen] required by (net-libs/gssdp-0.12.2.1::gentoo, installed)

  (x11-libs/gtk+-2.24.22::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-libs/gtk+-2.24:2 required by (gnome-extra/evolution-data-server-2.32.3-r3::gentoo, installed)
    >=x11-libs/gtk+-2.18:2 required by (media-gfx/eog-2.32.1::gentoo, installed)
    >=x11-libs/gtk+-2.11:2 required by (dev-libs/libgweather-2.30.3::gentoo, installed)
    >=x11-libs/gtk+-2.20:2 required by (gnome-extra/deskbar-applet-2.32.0::gentoo, installed)
    x11-libs/gtk+:2 required by (media-gfx/xsane-0.998-r1::gentoo, installed)
    >=x11-libs/gtk+-2.21.2:2 required by (gnome-base/gnome-settings-daemon-2.32.1-r2::gentoo, installed)
    >=x11-libs/gtk+-2.4:2 required by (games-emulation/nestopia-1.40::gentoo, installed)
    x11-libs/gtk+:2 required by (dev-db/libiodbc-3.52.7::gentoo, installed)
    >=x11-libs/gtk+-2.19.7:2 required by (app-admin/gnome-system-tools-2.32.0-r3::gentoo, installed)
    >=x11-libs/gtk+-2.24.10:2 required by (net-libs/webkit-gtk-2.0.4::gentoo, ebuild scheduled for merge)
    >=x11-libs/gtk+-2.22:2[introspection?] (>=x11-libs/gtk+-2.22:2[introspection]) required by (gnome-base/gnome-panel-2.32.1-r3::gentoo, installed)
    >=x11-libs/gtk+-2.6:2 required by (net-analyzer/nmap-6.25::gentoo, installed)
    >=x11-libs/gtk+-2.20:2 required by (gnome-extra/gconf-editor-2.32.0::gentoo, installed)
    >=x11-libs/gtk+-2.21.8:2 required by (media-video/totem-2.32.0-r2::gentoo, installed)
    >=x11-libs/gtk+-2.10:2 required by (games-emulation/snes9x-1.53::gentoo, installed)
    >=x11-libs/gtk+-2.24:2 required by (app-office/libreoffice-4.1.2.3::gentoo, installed)
    x11-libs/gtk+:2 required by (media-video/mjpegtools-2.0.0-r3::gentoo, installed)
    >=x11-libs/gtk+-2.24:2 required by (dev-python/pygtk-2.24.0-r3::gentoo, installed)
    >=x11-libs/gtk+-2.16:2 required by (gnome-base/librsvg-2.36.4-r1::gentoo, ebuild scheduled for merge)
    >=x11-libs/gtk+-2.18:2 required by (gnome-extra/gcalctool-5.32.2::gentoo, installed)
    x11-libs/gtk+:2 required by (app-text/ghostscript-gpl-9.05-r1::gentoo, installed)
    >=x11-libs/gtk+-2.20.0:2 required by (media-libs/libcanberra-0.30-r1::gentoo, installed)
    >=x11-libs/gtk+-2.18:2 required by (x11-terms/gnome-terminal-2.32.1-r1::gentoo, ebuild scheduled for merge)
    >=x11-libs/gtk+-2.22.1-r1:2 required by (gnome-base/gnome-2.32.1-r2::gentoo, installed)
    x11-libs/gtk+:2 required by (www-plugins/adobe-flash-11.2.202.310::gentoo, ebuild scheduled for merge)
    >=x11-libs/gtk+-2.18:2 required by (x11-misc/notification-daemon-0.5.0::gentoo, installed)
    x11-libs/gtk+:2 required by (media-sound/pulseaudio-2.1-r1::gentoo, installed)
    >=x11-libs/gtk+-2.2.1:2 required by (net-p2p/gtk-gnutella-1.0.0::gentoo, ebuild scheduled for merge)
    >=x11-libs/gtk+-2.14:2 required by (gnome-base/libgnomeui-2.24.5::gentoo, installed)
    >=x11-libs/gtk+-2.18:2 required by (gnome-extra/yelp-2.30.2-r200::gentoo, installed)
    >=x11-libs/gtk+-2.21.5:2[introspection?] (>=x11-libs/gtk+-2.21.5:2[introspection]) required by (app-text/evince-2.32.0-r4::gentoo, installed)
    >=x11-libs/gtk+-2.20:2 required by (net-analyzer/gnome-netstatus-2.28.2::gentoo, installed)
    >=x11-libs/gtk+-2.10:2[aqua=] (>=x11-libs/gtk+-2.10:2[-aqua]) required by (net-im/pidgin-2.10.7-r4::gentoo, ebuild scheduled for merge)
    >=x11-libs/gtk+-2.20.1:2 required by (dev-java/icedtea-bin-6.1.12.6::gentoo, ebuild scheduled for merge)
    x11-libs/gtk+:2 required by (media-gfx/gtkimageview-1.6.4::gentoo, installed)
    >=x11-libs/gtk+-2.18:2 required by (gnome-extra/nautilus-sendto-2.32.0::gentoo, installed)
    >=x11-libs/gtk+-2.14 required by (mail-client/thunderbird-17.0.9::gentoo, ebuild scheduled for merge)
    >=x11-libs/gtk+-2.6:2 required by (gnome-base/libgnomeprintui-2.18.6::gentoo, installed)
    >=x11-libs/gtk+-2.24:2 required by (x11-libs/gtk+-3.8.6::gentoo, ebuild scheduled for merge)
    >=x11-libs/gtk+-2.8.10:2 required by (gnome-base/libglade-2.6.4::gentoo, installed)
    x11-libs/gtk+:2 required by (x11-libs/wxGTK-2.8.12.1::gentoo, installed)
    x11-libs/gtk+:2 required by (www-client/opera-12.16_p1860::gentoo, installed)
    x11-libs/gtk+:2 required by (app-mobilephone/obex-data-server-0.4.6::gentoo, installed)
    >=x11-libs/gtk+-2.11:2[introspection?] (>=x11-libs/gtk+-2.11:2[introspection]) required by (dev-libs/libunique-1.1.6-r1::gentoo, installed)
    >=x11-libs/gtk+-2.24:2[introspection?] (>=x11-libs/gtk+-2.24:2[introspection]) required by (gnome-extra/polkit-gnome-0.102::gentoo, installed)
    >=x11-libs/gtk+-2.10.7:2 required by (media-gfx/inkscape-0.48.4::gentoo, installed)
    >=x11-libs/gtk+-2.14.0:2 required by (gnome-extra/gnome-screensaver-2.30.2-r1::gentoo, installed)
    >=x11-libs/gtk+-2.18:2 required by (gnome-extra/evolution-webcal-2.32.0::gentoo, installed)
    >=x11-libs/gtk+-2.22.0:2 required by (gnome-base/gnome-session-2.32.1-r3::gentoo, installed)
    >=x11-libs/gtk+-2.20:2 required by (gnome-base/libgnomekbd-2.32.0-r1::gentoo, installed)
    >=x11-libs/gtk+-2.6:2 required by (gnome-base/gdm-2.20.11-r1::gentoo, installed)
    >=x11-libs/gtk+-2:2 required by (x11-themes/gnome-themes-2.32.1-r1::gentoo, installed)
    >=x11-libs/gtk+-2.20.0:2 required by (mail-client/evolution-2.32.3-r1::gentoo, installed)
    >=x11-libs/gtk+-2.20:2 required by (gnome-extra/gnome-system-monitor-2.28.2-r1::gentoo, installed)
    >=x11-libs/gtk+-2:2 required by (www-plugins/nspluginwrapper-1.4.4-r3::gentoo, installed)
    x11-libs/gtk+:2 required by (kde-misc/kde-gtk-config-2.2.1::gentoo, installed)
    >=x11-libs/gtk+-2.19.7:2[introspection?] (>=x11-libs/gtk+-2.19.7:2[introspection]) required by (x11-libs/libwnck-2.31.0::gentoo, installed)
    x11-libs/gtk+:2 required by (app-misc/geoclue-0.12.99::gentoo, installed)
    >=x11-libs/gtk+-2.21.4:2 required by (app-arch/file-roller-2.32.2::gentoo, installed)
    >=x11-libs/gtk+-2.12:2 required by (gnome-extra/hamster-applet-2.32.1-r1::gentoo, installed)
    x11-libs/gtk+:2 required by (net-dns/avahi-0.6.31-r2::gentoo, ebuild scheduled for merge)
    >=x11-libs/gtk+-2.4.0:2 required by (dev-python/gnome-python-desktop-base-2.32.0::gentoo, installed)
    x11-libs/gtk+:2 required by (x11-misc/xscreensaver-5.22::gentoo, ebuild scheduled for merge)
    >=x11-libs/gtk+-2.22:2[introspection?] (>=x11-libs/gtk+-2.22:2[introspection]) required by (gnome-base/nautilus-2.32.2.1-r2::gentoo, installed)
    >=x11-libs/gtk+-2.4:2 required by (x11-libs/gksu-2.0.2-r1::gentoo, installed)
    >=x11-libs/gtk+-2.8.12:2 required by (gnome-base/libbonoboui-2.24.5::gentoo, installed)
    >=x11-libs/gtk+-2.20:2 required by (media-sound/sound-juicer-2.32.0-r1::gentoo, installed)
    >=x11-libs/gtk+-2.20:2 required by (gnome-base/gnome-applets-2.32.1.1-r2::gentoo, installed)
    >=x11-libs/gtk+-2.20:2 required by (gnome-base/gnome-control-center-2.32.1-r1::gentoo, installed)
    x11-libs/gtk+:2 required by (net-irc/hexchat-2.9.5-r1::gentoo, ebuild scheduled for merge)
    >=x11-libs/gtk+-2.20:2[introspection?] (>=x11-libs/gtk+-2.20:2[introspection]) required by (x11-libs/vte-0.28.2-r204::gentoo, installed)
    >=x11-libs/gtk+-2.12:2 required by (x11-libs/gtksourceview-2.10.5-r2::gentoo, installed)
    x11-libs/gtk+:2 required by (games-emulation/sdlmess-0.148_p1::gentoo, installed)
    >=x11-libs/gtk+-2.17.7:2 required by (gnome-extra/gnome-power-manager-2.32.0-r3::gentoo, installed)
    >=x11-libs/gtk+-2.12:2 required by (x11-themes/gtk-engines-2.20.2::gentoo, installed)
    >=x11-libs/gtk+-2.6:2 required by (x11-themes/gnome-themes-extras-2.22.0-r1::gentoo, installed)
    x11-libs/gtk+:2 required by (media-plugins/audacious-plugins-3.2.2-r1::gentoo, installed)
    >=x11-libs/gtk+-2.0.3:2 required by (x11-libs/gtkglarea-2.0.1-r1::gentoo, installed)
    >=x11-libs/gtk+-2.12:2 required by (net-libs/gssdp-0.12.2.1::gentoo, installed)
    >=x11-libs/gtk+-2.21.9:2[introspection?] (>=x11-libs/gtk+-2.21.9:2[introspection]) required by (app-cdr/brasero-2.32.1-r1::gentoo, installed)
    x11-libs/gtk+:2 required by (app-text/gtkspell-2.0.16::gentoo, installed)
    >=x11-libs/gtk+-2.18:2 required by (gnome-extra/zenity-2.32.1::gentoo, installed)
    >=x11-libs/gtk+-2.8.6:2 required by (www-client/firefox-17.0.9::gentoo, ebuild scheduled for merge)
    >=x11-libs/gtk+-2.6:2 required by (app-admin/sabayon-2.30.1::gentoo, installed)
    >=x11-libs/gtk+-2.14:2 required by (gnome-extra/bug-buddy-2.32.0-r2::gentoo, installed)
    >=x11-libs/gtk+-2.14.0:2[introspection?] (>=x11-libs/gtk+-2.14.0:2[introspection]) required by (gnome-extra/gucharmap-3.0.1-r200::gentoo, installed)
    x11-libs/gtk+:2 required by (media-sound/audacious-3.2.2-r1::gentoo, installed)
    >=x11-libs/gtk+-2.20:2 required by (gnome-extra/gnome-utils-2.32.0-r2::gentoo, installed)
    >=x11-libs/gtk+-2.16:2 required by (net-misc/vinagre-2.30.3::gentoo, installed)
    >=x11-libs/gtk+-2.24.15:2 required by (x11-themes/gnome-themes-standard-3.8.4::gentoo, ebuild scheduled for merge)
    x11-libs/gtk+:2 required by (media-sound/asunder-2.2::gentoo, installed)
    >=x11-libs/gtk+-2.24:2 required by (dev-cpp/gtkmm-2.24.4::gentoo, installed)
    >=x11-libs/gtk+-2.14:2 required by (gnome-base/gconf-2.32.4-r1::gentoo, installed)
    >=x11-libs/gtk+-2.6:2 required by (dev-python/gnome-python-base-2.28.1::gentoo, installed)
    >=x11-libs/gtk+-2.24:2 required by (x11-wm/metacity-2.34.13::gentoo, installed)
    x11-libs/gtk+:2 required by (www-client/google-chrome-31.0.1650.34_beta1::gentoo, ebuild scheduled for merge)
    >=x11-libs/gtk+-2.8.6:2 required by (mail-client/thunderbird-17.0.9::gentoo, ebuild scheduled for merge)
    >=x11-libs/gtk+-2.18.0:2 required by (gnome-extra/gnome-media-2.32.0-r1::gentoo, installed)
    >=x11-libs/gtk+-2.18:2 required by (net-libs/gtk-vnc-0.5.2::gentoo, ebuild scheduled for merge)
    x11-libs/gtk+:2 required by (games-emulation/mupen64plus-1.5-r2::gentoo, installed)
    >=x11-libs/gtk+-2.18:2 required by (gnome-base/gnome-desktop-2.32.1::gentoo, installed)
    >=x11-libs/gtk+-2.18:2[introspection?] (>=x11-libs/gtk+-2.18:2) required by (app-crypt/seahorse-2.32.0::gentoo, installed)
    >=x11-libs/gtk+-2.13:2[aqua=,introspection?] (>=x11-libs/gtk+-2.13:2[-aqua,introspection]) required by (net-libs/webkit-gtk-1.8.3-r201::gentoo, installed)
    >=x11-libs/gtk+-2.12:2 required by (x11-libs/libgksu-2.0.12-r1::gentoo, installed)
    x11-libs/gtk+:2 required by (gnome-extra/libgsf-1.14.25::gentoo, installed)
    x11-libs/gtk+:2 required by (app-crypt/pinentry-0.8.2::gentoo, installed)
    >=x11-libs/gtk+-2.10:2 required by (dev-ml/lablgtk-2.16.0::gentoo, installed)
    >=x11-libs/gtk+-2.19.0:2 required by (app-editors/gedit-2.30.4::gentoo, ebuild scheduled for merge)
    >=x11-libs/gtk+-2.13:2 required by (gnome-base/libgnomecanvas-2.30.3::gentoo, installed)
    >=x11-libs/gtk+-2.20:2 required by (gnome-extra/gtkhtml-3.32.2::gentoo, installed)

  (x11-drivers/xf86-video-sis-0.10.7::gentoo, installed) pulled in by
    x11-drivers/xf86-video-sis required by @selected

  (dev-libs/gobject-introspection-1.36.0-r1::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/gobject-introspection required by (gnome-extra/gnome-games-3.6.1-r1::gentoo, installed)
    >=dev-libs/gobject-introspection-1.29 required by (dev-libs/libgusb-0.1.4::gentoo, installed)
    >=dev-libs/gobject-introspection-1 required by (gnome-extra/libgsf-1.14.25::gentoo, installed)
    >=dev-libs/gobject-introspection-1.34.2 required by (media-libs/cogl-1.14.1_pre20130901::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.9.5 required by (x11-libs/pango-1.34.1::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-1.31.1 required by (sys-fs/udev-208::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.6.7 required by (dev-libs/atk-2.8.0::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.6 required by (app-text/evince-2.32.0-r4::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5:= required by (gnome-base/gconf-2.32.4-r1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.8 required by (media-libs/gstreamer-0.10.36::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.3 required by (x11-libs/gdk-pixbuf-2.28.2::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.7 required by (gnome-base/gnome-desktop-3.4.2::gentoo, installed)
    >=dev-libs/gobject-introspection-1.32.0 required by (net-libs/webkit-gtk-2.0.4::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.6.7 required by (media-video/cheese-3.8.3::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-1.32 required by (media-libs/harfbuzz-0.9.20::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.6.4 required by (net-libs/gupnp-0.18.4::gentoo, installed)
    >=dev-libs/gobject-introspection-1.30 required by (sys-fs/udisks-2.1.1::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.6.2 required by (gnome-extra/polkit-gnome-0.102::gentoo, installed)
    >=dev-libs/gobject-introspection-1.32 required by (x11-libs/gtk+-3.8.6::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.10.1 required by (dev-libs/libpeas-1.6.0::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5 required by (net-libs/webkit-gtk-1.8.3-r201::gentoo, installed)
    >=dev-libs/gobject-introspection-1.30.0 required by (gnome-base/libgnome-keyring-3.8.0::gentoo, ebuild scheduled for merge)
    dev-libs/gobject-introspection required by (net-dns/avahi-0.6.31-r2::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-1.32 required by (x11-libs/libnotify-0.7.5-r1::gentoo, installed)
    >=dev-libs/gobject-introspection-1.34.2 required by (media-libs/cogl-1.12.2-r1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5 required by (net-libs/libsoup-gnome-2.42.2::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-1 required by (sys-auth/polkit-0.112-r1::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.6.4 required by (gnome-base/nautilus-2.32.2.1-r2::gentoo, installed)
    >=dev-libs/gobject-introspection-0.10.8 required by (app-text/liblangtag-0.5.1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.12 required by (media-libs/gst-plugins-base-0.10.36::gentoo, installed)
    >=dev-libs/gobject-introspection-0.10.8 required by (gnome-base/librsvg-2.36.4-r1::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-1.30 required by (x11-libs/libxklavier-5.2.1::gentoo, installed)
    >=dev-libs/gobject-introspection-1.29 required by (app-crypt/libsecret-0.15-r1::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.6.7 required by (net-libs/gssdp-0.12.2.1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.10 required by (net-libs/gupnp-igd-0.2.1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.8 required by (media-libs/clutter-gst-2.0.8::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.6.7 required by (gnome-base/gnome-panel-2.32.1-r3::gentoo, installed)
    >=dev-libs/gobject-introspection-1.31.1 required by (media-libs/gst-plugins-base-1.2.0::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.9.12 required by (media-libs/clutter-gtk-1.4.2::gentoo, installed)
    >=dev-libs/gobject-introspection-1.30 required by (net-libs/telepathy-glib-0.20.4::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.9.5 required by (net-libs/libsoup-2.42.2-r1::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.9.0 required by (x11-libs/vte-0.28.2-r204::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.7 required by (dev-libs/libgdata-0.8.1-r2::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.0 required by (x11-libs/gtksourceview-3.8.2::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.6.3 required by (app-cdr/brasero-2.32.1-r1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5 required by (dev-libs/totem-pl-parser-2.32.6-r3::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5 required by (dev-libs/json-glib-0.16.2::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-1.31.1 required by (media-libs/gstreamer-1.2.0::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-1.32.1 required by (app-text/poppler-0.22.2-r2::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.5 required by (gnome-extra/libgda-5.0.3-r1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.14 required by (x11-libs/libwnck-2.31.0::gentoo, installed)
    dev-libs/gobject-introspection required by (sys-power/upower-0.9.21::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.9.4 required by (net-libs/gtk-vnc-0.5.2::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.9.0 required by (gnome-extra/gucharmap-3.0.1-r200::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.0 required by (x11-libs/vte-0.34.2::gentoo, installed)
    >=dev-libs/gobject-introspection-1.32.1 required by (app-text/poppler-0.22.5::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-1.34 required by (app-crypt/gcr-3.8.2::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-1.34.2 required by (dev-python/pygobject-3.8.3::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-1.31.1 required by (media-libs/gst-plugins-bad-1.2.0-r1::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.9.5:0/0= required by (gnome-base/gconf-2.32.4-r1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.14 required by (x11-libs/libwnck-3.4.7::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.9.6 required by (media-libs/clutter-1.14.4-r1::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.9.8 required by (x11-misc/colord-1.0.3::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.9.6 required by (app-accessibility/at-spi2-core-2.8.0::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-1.31.0 required by (gnome-base/gsettings-desktop-schemas-3.6.1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5 required by (dev-util/anjuta-3.6.2-r1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.7 required by (dev-libs/gdl-3.6.2::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.7 required by (gnome-base/gnome-menus-2.30.5-r1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.0 required by (gnome-extra/gucharmap-3.6.1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.3 required by (x11-libs/gtk+-2.24.22::gentoo, ebuild scheduled for merge)

  (x11-base/xorg-drivers-1.14::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-base/xorg-drivers-1.14 required by (x11-base/xorg-server-1.14.3-r2::gentoo, ebuild scheduled for merge)
    x11-base/xorg-drivers required by @selected

  (dev-util/gtk-builder-convert-2.24.16::gentoo, ebuild scheduled for merge) pulled in by
    dev-util/gtk-builder-convert required by (x11-terms/gnome-terminal-2.32.1-r1::gentoo, ebuild scheduled for merge)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


!!! The following installed packages are masked:
- dev-java/sun-jre-bin-1.6.0.45::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Tom Wijsman <TomWij@gentoo.org> (30 Jun 2013)
# Sun JDK and JRE contain critical vulnerabilities and receive no further
# updates; masking to make users aware of this, users that still need this
# package and have no alternative can unmask at their own risk. See bug #473830.
#
# This is continued by Oracle Corproation, which has acquired Sun Microsystems
# in early 2010; as per http://en.wikipedia.org/wiki/Sun_acquisition_by_Oracle
#
# Users are suggested to upgrade to one of the newer Oracle packages like
# dev-java/oracle-jdk-bin or dev-java/oracle/jre-bin or choose another
# alternative we provide; eg. the IBM JDK/JRE or the open source IcedTea.
#
# Most of these packages provide a jce USE flag for those whom need the
# Java Cryptographic Extension Unlimited Strength Policy USE flag; whether that
# works depends from VM to VM, it seems to work for most except for the IBM VMs.

- sci-geosciences/googleearth-7.1.1.1871::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Julian Ospald <hasufell@gentoo.org> (21 Jul 2013)
# Mask all unfetchable versions and those with tons of random
# bugs and segfaults (all). Don't ask for a version bump unless
# there is a working release.

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


Once again, I deeply appreciate any help I can get to clear this up.

Thanks!!

Todd


Last edited by todd93 on Fri Nov 01, 2013 10:35 pm; edited 1 time in total
Back to top
View user's profile Send private message
dol-sen
Developer
Developer


Joined: 30 Jun 2002
Posts: 2503
Location: Richmond, BC, Canada

PostPosted: Sun Oct 27, 2013 3:12 pm    Post subject: Reply with quote

Well, your system is getting quite far behind since there are so many packages that want to update.

I find that when that happens, it works better to split up the updates into some chunks. It tends to reduce the amount of conflicts you get.
so update system first, then proceed to world. sometimes even splitting system into
Code:
emerge -auv @system
emerge -auvD @system
, then similarly for @world

to start off:
Code:
[blocks B      ] <dev-lang/vala-0.20.0 ("<dev-lang/vala-0.20.0" is blocking dev-libs/gobject-introspection-1.36.0-r1)
[blocks B      ] <=x11-drivers/xf86-video-sis-0.10.7 ("<=x11-drivers/xf86-video-sis-0.10.7" is blocking x11-base/xorg-drivers-1.14)

The capital "B"'s mean they are hard blocks that portage can't fix by itself. They tell you that you need to upgrade 2 pkgs before it install the 2 other pkg-versions
so:
Code:
emerge -au1v vala xf86-video-sis
should fix those 2. This has to be done by itself, not part f a world update.

The other conflicts can sometimes be resolved by telling portage to try harder to resolve them by itself. This is done by increasing the backtrack setting
Code:
emerge --backtrack=30 -uDNv @world

If that doesn't work, then you have to process them one at a time, possibly mask a conflicting package version, etc...
_________________
Brian
Porthole, the Portage GUI frontend irc@freenode: #gentoo-guis, #porthole, Blog
layman, gentoolkit, CoreBuilder, esearch...
Back to top
View user's profile Send private message
Hu
Watchman
Watchman


Joined: 06 Mar 2007
Posts: 8592

PostPosted: Sun Oct 27, 2013 4:10 pm    Post subject: Reply with quote

There was a recent thread on the Gentoo forums about x11-drivers/xf86-video-sis being incompatible with >=x11-base/xorg-drivers-1.14. If you have a SIS card, you should check that thread for details. If you do not have it, you should adjust your VIDEO_CARDS to remove use of it.

For some packages, the fastest way around a block is to unmerge the conflicting packages and then let Portage install the new ones. However, doing this carelessly can break functionality you want, or even your entire system. Only use this if you are certain the packages being removed are not critical to the system.
Back to top
View user's profile Send private message
TheLexx
Tux's lil' helper
Tux's lil' helper


Joined: 04 Dec 2005
Posts: 84
Location: Austin Tx

PostPosted: Sun Oct 27, 2013 7:01 pm    Post subject: Reply with quote

todd93 wrote:
First of all, I really need to apologize, more to myself really, I have not ran a successful emerge -uDNv world in a little while. now I am running into some trouble when I do it. I will post the output that I can, but I can't get the entire package list (I'm sure there is a way, but I'm not sure how to do it). I will mention that I have been working to have a mostly stable system, but we all know how that goes. I will post what I can, and if someone could tell me how to get the entire output, I'll be happy to post that.


I wrote get-gentoo.sh as a way of dealing with situations like yours where things get behind and the general "upgrade all" commands crap-out and don't upgrade anything at all. My philosophy is that even if everything can't be upgraded, you should at least be able to upgrade those things that do not require administrator intervention.

When I posted my solution, I guess I did not take into account all the work I had to do in order to find out which packages required fewer dependencies. Potting things in order is the key to allow a partial upgrade without administrator intervention. On the plus side, once a reasonable order of precedence is established, the script can be used again in the future with muck less hassle.

Another advantage to using something like my script is that if you must use the following advice.

Hu wrote:
For some packages, the fastest way around a block is to unmerge the conflicting packages and then let Portage install the new ones. However, doing this carelessly can break functionality you want, or even your entire system. Only use this if you are certain the packages being removed are not critical to the system.


When I had to do this I would simply comment out the package in get-gentoo.sh with "#skip unmerge" then I would unmerge the package with emerge. The advantage being that this would create a record of which packages were "temporarily" remove and it was much easier to replace them in the future by removing "#skip unmerge" and re-running get-gentoo.

If you are interested in using a script like mine, I will try and offer what help I can.
Back to top
View user's profile Send private message
todd93
Guru
Guru


Joined: 30 Oct 2006
Posts: 436
Location: Missouri

PostPosted: Sun Oct 27, 2013 10:48 pm    Post subject: Reply with quote

dol-sen, thank you so much, I really appreciate your help. using your advice, I got past the first hard block and am now onto another. here is the output of emerge -auvD @system:
Code:

# emerge -auvD @system

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] sys-libs/timezone-data-2013d [2013b] USE="nls" 349 kB
[ebuild   R    ] dev-libs/expat-2.1.0-r2  USE="unicode -examples -static-libs" 0 kB
[ebuild   R    ] virtual/libiconv-0  0 kB
[ebuild     U  ] sys-devel/autoconf-wrapper-13 [12] 0 kB
[ebuild     U  ] sys-devel/automake-wrapper-9 [7] 0 kB
[ebuild   R    ] virtual/libffi-3.0.11  0 kB
[ebuild     U ~] dev-libs/gobject-introspection-common-1.36.0 [1.34.2] 1,173 kB
[ebuild     U  ] dev-lang/nasm-2.10.07 [2.10.05] USE="-doc" 665 kB
[ebuild     U  ] media-libs/libjpeg-turbo-1.3.0 [1.2.1] USE="-java -static-libs" 1,330 kB
[ebuild     U  ] sys-kernel/linux-headers-3.9 [3.7] 3,614 kB
[uninstall     ] media-sound/alsa-headers-1.0.25
[blocks b      ] media-sound/alsa-headers ("media-sound/alsa-headers" is blocking sys-kernel/linux-headers-3.9)
[ebuild  NS   ~] dev-python/python-exec-2.0-r1:2 [0.3.1:0] PYTHON_TARGETS="(jython2_5) (jython2_7) (pypy2_0) (python2_6) (python2_7) (python3_2) (python3_3)" 79 kB
[ebuild     U  ] dev-libs/libgpg-error-1.12 [1.10] USE="nls static-libs -common-lisp" 478 kB
[ebuild     U  ] sys-apps/attr-2.4.46-r2 [2.4.46-r1] USE="nls -static-libs" 0 kB
[ebuild  NS    ] sys-devel/automake-1.13.4:1.13 [1.11.6:1.11, 1.12.6:1.12] 1,416 kB
[ebuild     U  ] sys-devel/libtool-2.4.2:2 [2.4-r1:2] USE="-static-libs% {-test} -vanilla" 849 kB
[ebuild     U ~] sys-libs/zlib-1.2.8-r1 [1.2.8] USE="minizip -static-libs" ABI_X86="(64%*) -32% (-x32)" 0 kB
[ebuild     U  ] dev-db/sqlite-3.7.17:3 [3.7.16.2:3] USE="extensions readline -debug -doc -icu -secure-delete -static-libs -tcl {-test}" 1,833 kB
[ebuild     U  ] dev-libs/libgcrypt-1.5.3:0/11 [1.5.2-r1:0/11] USE="static-libs" 1,474 kB
[ebuild     U ~] dev-libs/nspr-4.10.1 [4.10] USE="-debug" 1,078 kB
[ebuild     U  ] sys-libs/libcap-ng-0.7.3 [0.6.6] USE="-python -static-libs" 384 kB
[ebuild     U ~] media-libs/libpng-1.6.6:0/16 [1.6.3:0/16] USE="apng (-neon) -static-libs" ABI_X86="(64%*) -32% (-x32)" 860 kB
[ebuild     U  ] media-libs/tiff-4.0.3-r4 [4.0.3-r2] USE="cxx jpeg zlib -jbig -lzma -static-libs" 0 kB
[ebuild     U  ] app-admin/eselect-1.3.8 [1.3.4] USE="-doc -emacs% -vim-syntax%" 165 kB
[ebuild     U  ] dev-libs/openssl-1.0.1e-r1 [1.0.1c] USE="(sse2) tls-heartbeat%* zlib -bindist -gmp -kerberos -rfc3779 -static-libs {-test} -vanilla" 4,356 kB
[ebuild     UD ] media-libs/lcms-1.19 [1.19-r1] USE="jpeg python tiff zlib -static-libs" PYTHON_TARGETS="(-python2_5%) (-python2_6%) (-python2_7%*) (-python3_2%*) (-python3_3%)" 0 kB
[ebuild     U  ] app-admin/python-updater-0.11 [0.10] 10 kB
[ebuild     U ~] dev-util/gdbus-codegen-2.36.4-r1 [2.34.3] PYTHON_TARGETS="python2_7 python3_2 -python2_6 -python3_3 (-python2_5%) (-python3_1%)" 6,417 kB
[ebuild     U ~] dev-libs/glib-2.36.4-r1:2 [2.34.3:2] USE="-debug (-fam) (-selinux) -static-libs -systemtap {-test} -utils -xattr" ABI_X86="(64%*) -32% (-x32)" PYTHON_TARGETS="python2_7%* -python2_6%" 0 kB
[ebuild     U  ] x11-proto/xproto-7.0.24 [7.0.23-r1] USE="-doc" ABI_X86="(64%*) (-32) (-x32)" 286 kB
[ebuild     U  ] x11-proto/xextproto-7.2.1-r1 [7.2.1] USE="-doc" ABI_X86="(64%*) (-32) (-x32)" 0 kB
[ebuild     U  ] x11-proto/renderproto-0.11.1-r1 [0.11.1] ABI_X86="(64%*) (-32) (-x32)" 0 kB
[ebuild     U  ] x11-proto/kbproto-1.0.6-r1 [1.0.6] ABI_X86="(64%*) (-32) (-x32)" 0 kB
[ebuild     U  ] x11-proto/damageproto-1.2.1-r1 [1.2.1] ABI_X86="(64%*) (-32) (-x32)" 0 kB
[ebuild     U ~] sys-apps/kmod-15 [13-r1] USE="openrc%* tools zlib -debug -doc -lzma -static-libs" 1,420 kB
[ebuild     U  ] x11-libs/pixman-0.30.2 [0.28.0] USE="sse2 (-altivec) (-iwmmxt) (-loongson2f) -mmxext (-neon) -static-libs" 651 kB
[ebuild     U  ] x11-proto/xcb-proto-1.8-r3 [1.8-r1] ABI_X86="(64%*) (-32) (-x32)" PYTHON_SINGLE_TARGET="(-python2_5%) (-python2_6%) (-python2_7%*) (-python3_1%) (-python3_2%) (-python3_3%)" PYTHON_TARGETS="python2_7 python3_2 -python2_6 (-python3_3) (-python2_5%) (-python3_1%)" 0 kB
[ebuild     U  ] dev-libs/libpthread-stubs-0.3-r1 [0.3] USE="-static-libs" ABI_X86="(64%*) (-32) (-x32)" 0 kB
[ebuild     U  ] x11-proto/xf86vidmodeproto-2.3.1-r1 [2.3.1] ABI_X86="(64%*) (-32) (-x32)" 0 kB
[ebuild     U  ] sys-libs/gpm-1.20.7-r1 [1.20.6] USE="(-selinux) -static-libs%" 772 kB
[ebuild     U  ] x11-proto/xf86bigfontproto-1.2.0-r1 [1.2.0] ABI_X86="(64%*) (-32) (-x32)" 0 kB
[ebuild  NS   ~] dev-lang/spidermonkey-17.0.0-r1:17 [1.8.5-r4:0/mozjs185] USE="-debug -jit -minimal -static-libs {-test}" 6,621 kB
[ebuild     U  ] x11-proto/recordproto-1.14.2-r1 [1.14.2] USE="-doc" ABI_X86="(64%*) (-32) (-x32)" 0 kB
[ebuild     U  ] x11-proto/videoproto-2.3.2 [2.3.1] ABI_X86="(64%*) (-32) (-x32)" 117 kB
[ebuild     U  ] dev-libs/nss-3.15.2 [3.15.1] USE="-utils" 6,142 kB
[ebuild     U  ] x11-proto/compositeproto-0.4.2-r1 [0.4.2] ABI_X86="(64%*) (-32) (-x32)" 0 kB
[ebuild     U  ] x11-misc/util-macros-1.17.1 [1.17] 78 kB
[ebuild     U ~] x11-proto/dri2proto-2.8-r1 [2.8] ABI_X86="(64%*) -32% (-x32)" 0 kB
[ebuild     U ~] x11-proto/glproto-1.4.16-r1 [1.4.16] ABI_X86="(64%*) -32% (-x32)" 0 kB
[ebuild     U  ] x11-libs/libICE-1.0.8-r1 [1.0.8] USE="ipv6 -doc -static-libs" ABI_X86="(64%*) (-32) (-x32)" 0 kB
[ebuild     U  ] x11-libs/libXau-1.0.8 [1.0.7] USE="-static-libs" ABI_X86="(64%*) (-32) (-x32)" 289 kB
[ebuild     U  ] x11-libs/libXdmcp-1.1.1-r1 [1.1.1] USE="-doc -static-libs" ABI_X86="(64%*) (-32) (-x32)" 0 kB
[ebuild     U  ] x11-proto/fixesproto-5.0-r1 [5.0] ABI_X86="(64%*) (-32) (-x32)" 0 kB
[ebuild     U  ] x11-libs/libxcb-1.9.1 [1.9] USE="-doc (-selinux) -static-libs -xkb%" ABI_X86="(64%*) (-32) (-x32)" PYTHON_SINGLE_TARGET="python2_7%* -python2_6% -python3_2% (-python3_3)" PYTHON_TARGETS="python2_7%* python3_2%* -python2_6% (-python3_3)" 365 kB
[ebuild     U  ] x11-libs/libX11-1.6.2 [1.6.0] USE="ipv6 -doc -static-libs {-test}" ABI_X86="(64) -32 (-x32)" 2,286 kB
[ebuild     U  ] x11-libs/libXext-1.3.2 [1.3.1] USE="-doc -static-libs" ABI_X86="(64%*) (-32) (-x32)" 371 kB
[ebuild     U  ] x11-libs/libXrender-0.9.8 [0.9.7] USE="-static-libs" ABI_X86="(64%*) (-32) (-x32)" 299 kB
[ebuild     U  ] x11-libs/libXfixes-5.0.1 [5.0] USE="-static-libs" ABI_X86="(64%*) (-32) (-x32)" 286 kB
[ebuild   R    ] media-libs/freetype-2.4.11:2  USE="X bzip2 -auto-hinter -bindist -debug -doc -fontforge -infinality -static-libs -utils" 0 kB
[ebuild     U  ] x11-apps/xprop-1.2.2 [1.2.1] 143 kB
[ebuild     U  ] x11-libs/libXcomposite-0.4.4-r1 [0.4.3-r1] USE="-doc -static-libs" ABI_X86="(64%*) (-32) (-x32)" 278 kB
[ebuild     U  ] x11-libs/libXxf86vm-1.1.3 [1.1.2] USE="-static-libs" ABI_X86="(64%*) (-32) (-x32)" 278 kB
[ebuild     U  ] x11-libs/libXi-1.7.2 [1.6.1] USE="-doc -static-libs" ABI_X86="(64%*) (-32) (-x32)" 431 kB
[ebuild     U  ] x11-libs/libXcursor-1.1.14 [1.1.13] USE="-static-libs" ABI_X86="(64%*) (-32) (-x32)" 305 kB
[ebuild     U  ] x11-libs/libXrandr-1.4.2 [1.4.0] USE="-static-libs" ABI_X86="(64%*) (-32) (-x32)" 308 kB
[ebuild     U  ] x11-libs/libXv-1.0.10 [1.0.7] USE="-static-libs" ABI_X86="(64%*) (-32) (-x32)" 294 kB
[ebuild     U  ] x11-libs/libXdamage-1.1.4-r1 [1.1.3] USE="-static-libs" ABI_X86="(64%*) (-32) (-x32)" 273 kB
[ebuild     U  ] x11-libs/libXtst-1.2.2 [1.2.1] USE="-doc -static-libs" ABI_X86="(64%*) (-32) (-x32)" 315 kB
[ebuild     U ~] dev-libs/gobject-introspection-1.36.0-r1 [1.34.2-r1] USE="cairo%* -doctool {-test}" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7" 0 kB
[blocks b      ] <dev-libs/gobject-introspection-1.36 ("<dev-libs/gobject-introspection-1.36" is blocking dev-libs/glib-2.36.4-r1)
[blocks b      ] <dev-libs/gobject-introspection-1.36.0 ("<dev-libs/gobject-introspection-1.36.0" is blocking dev-libs/gobject-introspection-common-1.36.0)
[ebuild     U ~] dev-libs/atk-2.8.0 [2.6.0] USE="introspection nls {-test%}" 620 kB
[ebuild     U ~] app-accessibility/at-spi2-core-2.8.0:2 [2.6.3:2] USE="introspection" 427 kB
[ebuild     U ~] app-accessibility/at-spi2-atk-2.8.1:2 [2.6.2:2] USE="{-test}" 261 kB
[ebuild     U  ] media-libs/fontconfig-2.10.92:1.0 [2.8.0-r1:1.0] USE="-doc -static-libs%" ABI_X86="(64%*) (-32) (-x32)" 1,490 kB
[ebuild     U  ] x11-libs/libXft-2.3.1-r1 [2.3.1] USE="-static-libs" ABI_X86="(64%*) (-32) (-x32)" 0 kB
[ebuild  N     ] dev-libs/libusb-compat-0.1.5  USE="-debug -static-libs" 271 kB
[uninstall     ] dev-libs/libusb-0.1.12-r7  USE="cxx -debug -doc -static-libs"
[blocks b      ] dev-libs/libusb:0 ("dev-libs/libusb:0" is blocking dev-libs/libusb-compat-0.1.5)
[blocks b      ] dev-libs/libusb-compat ("dev-libs/libusb-compat" is blocking dev-libs/libusb-0.1.12-r7)
[ebuild     U ~] x11-libs/libdrm-2.4.47 [2.4.46] USE="libkms -static-libs" ABI_X86="(64%*) -32% (-x32)" VIDEO_CARDS="intel radeon vmware (-exynos) (-freedreno) -nouveau (-omap)" 541 kB
[ebuild     U  ] media-libs/mesa-9.1.6 [9.1.2-r1] USE="classic egl gallium nptl shared-glapi xa -bindist -debug -gbm -gles1 -gles2 -llvm -openvg -osmesa -pax_kernel -pic (-r600-llvm-compiler) (-selinux) -vdpau (-wayland) -xorg -xvmc" PYTHON_SINGLE_TARGET="python2_7 -python2_6" PYTHON_TARGETS="python2_7 -python2_6" VIDEO_CARDS="radeon -i915 -i965 -intel -nouveau -r100 -r200 -r300 -r600 (-radeonsi) -vmware" 5,991 kB
[ebuild     U  ] x11-libs/cairo-1.12.14-r4 [1.10.2-r3] USE="X glib opengl svg xcb (-aqua) -debug -directfb -doc (-drm) (-gallium) (-gles2) -legacy-drivers% -openvg (-qt4) -static-libs -valgrind% -xlib-xcb%" 41,145 kB
[ebuild     U ~] media-libs/harfbuzz-0.9.20:0/0.9.18 [0.9.18-r1:0/0.9.18] USE="cairo glib graphite icu introspection%* truetype -static-libs" 1,007 kB
[ebuild     U ~] x11-libs/pango-1.34.1 [1.32.5] USE="X introspection -debug" 992 kB
[ebuild     U ~] x11-libs/gtk+-2.24.22:2 [2.24.20:2] USE="cups introspection (-aqua) -debug -examples {-test} -vim-syntax -xinerama" 13,063 kB
[ebuild     U  ] dev-perl/DBD-mysql-4.20.0 [4.01.7] USE="-embedded%" 135 kB
[ebuild     U  ] net-print/foomatic-filters-4.0.17-r1 [4.0.17] USE="cups dbus" 0 kB
[ebuild     U ~] sys-auth/polkit-0.112-r1 [0.111] USE="gtk introspection nls pam -examples -kde (-selinux) -systemd" 1,396 kB
[ebuild     U  ] app-text/poppler-0.22.5:0/37 [0.22.2-r2:0/35] USE="cairo cxx introspection jpeg lcms png qt4 tiff utils -cjk -curl -debug -doc -jpeg2k" 2,187 kB
[ebuild     U  ] x11-libs/libSM-1.2.2 [1.2.1] USE="ipv6 uuid -doc -static-libs" ABI_X86="(64%*) (-32) (-x32)" 341 kB
[ebuild     U  ] x11-libs/libXt-1.1.4 [1.1.3] USE="-static-libs" ABI_X86="(64%*) (-32) (-x32)" 745 kB
[ebuild     U  ] x11-libs/libXmu-1.1.2 [1.1.1] USE="ipv6 -doc -static-libs" ABI_X86="(64%*) (-32) (-x32)" 387 kB
[ebuild     U  ] x11-libs/libXpm-3.5.11 [3.5.10] USE="-static-libs" ABI_X86="(64%*) (-32) (-x32)" 434 kB
[ebuild     U  ] x11-apps/xset-1.2.3 [1.2.2] 139 kB
[ebuild     U  ] x11-libs/libXaw-1.0.12 [1.0.11-r1] USE="-deprecated -doc -static-libs" ABI_X86="(64%*) (-32) (-x32)" 662 kB
[ebuild     U  ] sys-apps/groff-1.22.2 [1.21] USE="X -examples" LINGUAS="-ja" 3,926 kB
[ebuild     U  ] net-nds/openldap-2.4.35-r1 [2.4.30] USE="berkdb crypt gnutls ipv6 minimal ssl syslog tcpd -cxx -debug -experimental -icu -iodbc -kerberos -odbc -overlays -perl -samba -sasl (-selinux) -slp -smbkrb5passwd" 5,370 kB
[ebuild     U  ] net-misc/curl-7.31.0 [7.30.0] USE="ipv6 ldap ssl -adns -idn -kerberos -metalink -rtmp -ssh -static-libs {-test} -threads" CURL_SSL="nss -axtls -cyassl -gnutls -openssl -polarssl" 2,617 kB
[ebuild     U  ] app-crypt/gnupg-2.0.22 [2.0.20] USE="bzip2 ldap nls readline usb -adns -doc -mta (-selinux) -smartcard -static" 4,177 kB
[ebuild     U ~] x11-libs/gtk+-3.8.6:3 [3.6.3-r2:3] USE="X colord cups introspection (-aqua) -debug -examples (-packagekit) {-test} -vim-syntax -wayland -xinerama (-egl%)" 13,531 kB
[ebuild     U ~] app-crypt/gcr-3.8.2:0/1 [3.6.2:0/1] USE="gtk%* introspection -debug {-test}" 1,362 kB
[ebuild     U ~] gnome-base/gnome-keyring-3.8.2 [3.6.3] USE="caps filecaps pam -debug (-selinux) {-test}" 1,113 kB
[ebuild     U ~] gnome-base/libgnome-keyring-3.8.0 [3.6.0] USE="introspection -debug {-test} -vala" 417 kB
[ebuild     U ~] sys-fs/udev-208 [205] USE="acl firmware-loader gudev introspection kmod openrc static-libs -doc (-selinux) (-hwdb%*) (-keymap%*)" ABI_X86="(64%*) -32% (-x32)" 2,328 kB
[ebuild     U ~] virtual/udev-206-r3 [200] USE="gudev introspection kmod (-selinux) -static-libs (-hwdb%*) (-keymap%*)" ABI_X86="(64%*) -32% (-x32)" 0 kB
[ebuild     U ~] sys-apps/hwids-20130915.1 [20130717] USE="udev" 1,535 kB
[ebuild     U ~] x11-misc/colord-1.0.3:0/1 [0.1.28:0/1] USE="gusb introspection scanner%* udev -examples -extra-print-profiles -systemd -vala (-doc%)" 1,058 kB
[blocks B      ] <dev-lang/vala-0.20.0 ("<dev-lang/vala-0.20.0" is blocking dev-libs/gobject-introspection-1.36.0-r1)

Total: 102 packages (93 upgrades, 1 downgrade, 1 new, 3 in new slots, 4 reinstalls, 2 uninstalls), Size of downloads: 158,768 kB
Conflict: 6 blocks (1 unsatisfied)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/expat:0

  (dev-libs/expat-2.1.0-r2::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/expat-2.1.0-r2::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/expat-1.95.3[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (media-libs/fontconfig-2.10.92::gentoo, ebuild scheduled for merge)

media-libs/freetype:2

  (media-libs/freetype-2.4.11::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (media-libs/freetype-2.4.11::gentoo, ebuild scheduled for merge) pulled in by
    media-libs/freetype[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (x11-libs/libXft-2.3.1-r1::gentoo, ebuild scheduled for merge)
    >=media-libs/freetype-2.2.1[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (media-libs/fontconfig-2.10.92::gentoo, ebuild scheduled for merge)

app-text/poppler:0

  (app-text/poppler-0.22.2-r2::gentoo, installed) pulled in by
    >=app-text/poppler-0.16:0/35=[xpdf-headers(+),cxx] required by (app-office/libreoffice-4.1.2.3::gentoo, installed)
    app-text/poppler:0/35=[cxx,jpeg,lcms,tiff,xpdf-headers(+)] required by (net-print/cups-filters-1.0.34-r1::gentoo, installed)

  (app-text/poppler-0.22.5::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

virtual/libiconv:0

  (virtual/libiconv-0::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (virtual/libiconv-0::gentoo, ebuild scheduled for merge) pulled in by
    virtual/libiconv[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (dev-libs/glib-2.36.4-r1::gentoo, ebuild scheduled for merge)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (dev-lang/vala-0.14.2-r2::gentoo, installed) pulled in by
    dev-lang/vala required by @selected
    dev-lang/vala:0.14[vapigen] required by (net-libs/gssdp-0.12.2.1::gentoo, installed)

  (dev-libs/gobject-introspection-1.36.0-r1::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/gobject-introspection required by (gnome-extra/gnome-games-3.6.1-r1::gentoo, installed)
    >=dev-libs/gobject-introspection-1.29 required by (dev-libs/libgusb-0.1.4::gentoo, installed)
    >=dev-libs/gobject-introspection-1.34.1.1 required by (dev-python/pygobject-3.4.2-r1::gentoo, installed)
    >=dev-libs/gobject-introspection-1 required by (gnome-extra/libgsf-1.14.25::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.7 required by (media-video/cheese-3.6.2::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5 required by (x11-libs/pango-1.34.1::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.6.5 required by (gnome-extra/libgda-5.0.3-r1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.7 required by (dev-libs/atk-2.8.0::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.6 required by (app-text/evince-2.32.0-r4::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5:= required by (gnome-base/gconf-2.32.4-r1::gentoo, installed)
    >=dev-libs/gobject-introspection-1.31.1 required by (media-libs/gstreamer-1.0.7::gentoo, installed)
    dev-libs/gobject-introspection required by (net-dns/avahi-0.6.31-r2::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.8 required by (media-libs/gstreamer-0.10.36::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.3 required by (x11-libs/gdk-pixbuf-2.28.2::gentoo, installed)
    >=dev-libs/gobject-introspection-1.31.1 required by (media-libs/gst-plugins-base-1.0.7::gentoo, installed)
    >=dev-libs/gobject-introspection-1.32 required by (media-libs/harfbuzz-0.9.20::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.6.4 required by (net-libs/gupnp-0.18.4::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.8 required by (media-libs/clutter-gst-2.0.6::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.2 required by (gnome-extra/polkit-gnome-0.102::gentoo, installed)
    >=dev-libs/gobject-introspection-1.32 required by (x11-libs/gtk+-3.8.6::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.9.6:= required by (dev-libs/libgee-0.6.7::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5 required by (net-libs/webkit-gtk-1.8.3-r201::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.7 required by (gnome-base/gnome-desktop-3.4.2::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.8 required by (x11-misc/colord-1.0.3::gentoo, ebuild scheduled for merge)
    dev-libs/gobject-introspection required by (sys-power/upower-0.9.20-r2::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.0 required by (x11-libs/gtksourceview-3.6.3::gentoo, installed)
    >=dev-libs/gobject-introspection-1.32 required by (x11-libs/libnotify-0.7.5-r1::gentoo, installed)
    >=dev-libs/gobject-introspection-1.34.2 required by (media-libs/cogl-1.12.2-r1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.6 required by (app-accessibility/at-spi2-core-2.8.0::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-1.30.0 required by (gnome-base/libgnome-keyring-3.8.0::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.6.4 required by (gnome-base/nautilus-2.32.2.1-r2::gentoo, installed)
    >=dev-libs/gobject-introspection-0.10.8 required by (app-text/liblangtag-0.5.1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.6:0/0= required by (dev-libs/libgee-0.6.7::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.12 required by (media-libs/gst-plugins-base-0.10.36::gentoo, installed)
    >=dev-libs/gobject-introspection-1.30 required by (sys-fs/udisks-2.1.0::gentoo, installed)
    >=dev-libs/gobject-introspection-1.30 required by (net-libs/telepathy-glib-0.20.3::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5 required by (dev-libs/json-glib-0.16.0-r1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.7 required by (net-libs/gssdp-0.12.2.1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.10 required by (net-libs/gupnp-igd-0.2.1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.7 required by (gnome-base/gnome-panel-2.32.1-r3::gentoo, installed)
    >=dev-libs/gobject-introspection-1.31.1 required by (sys-fs/udev-208::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.9.12 required by (media-libs/clutter-gtk-1.4.2::gentoo, installed)
    >=dev-libs/gobject-introspection-1.29 required by (app-crypt/libsecret-0.15::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.0 required by (x11-libs/vte-0.28.2-r204::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.3 required by (x11-libs/gtk+-2.24.22::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.9.7 required by (dev-libs/libgdata-0.8.1-r2::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.0 required by (gnome-extra/gucharmap-3.6.1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.3 required by (app-cdr/brasero-2.32.1-r1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5:0/0= required by (gnome-base/gconf-2.32.4-r1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.10.1 required by (dev-libs/libpeas-1.6.0::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.7 required by (gnome-base/gnome-menus-2.30.5-r1::gentoo, installed)
    >=dev-libs/gobject-introspection-1.32.1 required by (app-text/poppler-0.22.2-r2::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5 required by (net-libs/libsoup-gnome-2.40.3::gentoo, installed)
    >=dev-libs/gobject-introspection-1.30 required by (x11-libs/libxklavier-5.2.1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.14 required by (x11-libs/libwnck-2.31.0::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.6 required by (media-libs/clutter-1.12.2-r1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.0 required by (gnome-extra/gucharmap-3.0.1-r200::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5 required by (www-client/epiphany-3.6.1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.0 required by (x11-libs/vte-0.34.2::gentoo, installed)
    >=dev-libs/gobject-introspection-1 required by (sys-auth/polkit-0.112-r1::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-1.34 required by (app-crypt/gcr-3.8.2::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.9.5 required by (net-libs/libsoup-2.40.3::gentoo, installed)
    >=dev-libs/gobject-introspection-1.32.1 required by (app-text/poppler-0.22.5::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.9.5 required by (dev-libs/totem-pl-parser-2.32.6-r3::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.4 required by (net-libs/gtk-vnc-0.5.1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.10.8 required by (gnome-base/librsvg-2.36.4::gentoo, installed)
    >=dev-libs/gobject-introspection-1.31.0 required by (gnome-base/gsettings-desktop-schemas-3.6.1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5 required by (dev-util/anjuta-3.6.2-r1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.7 required by (dev-libs/gdl-3.6.2::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.3 required by (app-editors/gedit-3.6.2-r1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5 required by (net-libs/webkit-gtk-1.10.2-r300::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


!!! The following installed packages are masked:
- dev-java/sun-jre-bin-1.6.0.45::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Tom Wijsman <TomWij@gentoo.org> (30 Jun 2013)
# Sun JDK and JRE contain critical vulnerabilities and receive no further
# updates; masking to make users aware of this, users that still need this
# package and have no alternative can unmask at their own risk. See bug #473830.
#
# This is continued by Oracle Corproation, which has acquired Sun Microsystems
# in early 2010; as per http://en.wikipedia.org/wiki/Sun_acquisition_by_Oracle
#
# Users are suggested to upgrade to one of the newer Oracle packages like
# dev-java/oracle-jdk-bin or dev-java/oracle/jre-bin or choose another
# alternative we provide; eg. the IBM JDK/JRE or the open source IcedTea.
#
# Most of these packages provide a jce USE flag for those whom need the
# Java Cryptographic Extension Unlimited Strength Policy USE flag; whether that
# works depends from VM to VM, it seems to work for most except for the IBM VMs.

- sci-geosciences/googleearth-7.1.1.1871::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Julian Ospald <hasufell@gentoo.org> (21 Jul 2013)
# Mask all unfetchable versions and those with tons of random
# bugs and segfaults (all). Don't ask for a version bump unless
# there is a working release.

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

I tried emerge -au1v vala gobject-introspection, thinking it may work the same way that emerge -au1v vala xf86-video-sis, but to no avail. emerge --backtrack=30 -uDNv @world only makes the hard blocks worse.

Thanks

Todd
Back to top
View user's profile Send private message
dol-sen
Developer
Developer


Joined: 30 Jun 2002
Posts: 2503
Location: Richmond, BC, Canada

PostPosted: Mon Oct 28, 2013 4:40 am    Post subject: Reply with quote

Code:
[blocks B      ] <dev-lang/vala-0.20.0 ("<dev-lang/vala-0.20.0" is blocking dev-libs/gobject-introspection-1.36.0-r1)

You said you have mostly a stable system. The versions of vala that satisfy that dependency are ~arch keyworded.
Add an entry to package.accept_keywords for it.
Code:
dev-lang/vala ~amd64
Of course change ~amd64 to your arch.
_________________
Brian
Porthole, the Portage GUI frontend irc@freenode: #gentoo-guis, #porthole, Blog
layman, gentoolkit, CoreBuilder, esearch...
Back to top
View user's profile Send private message
todd93
Guru
Guru


Joined: 30 Oct 2006
Posts: 436
Location: Missouri

PostPosted: Mon Oct 28, 2013 9:45 am    Post subject: Reply with quote

dol-sen wrote:
Code:
[blocks B      ] <dev-lang/vala-0.20.0 ("<dev-lang/vala-0.20.0" is blocking dev-libs/gobject-introspection-1.36.0-r1)

You said you have mostly a stable system. The versions of vala that satisfy that dependency are ~arch keyworded.
Add an entry to package.accept_keywords for it.
Code:
dev-lang/vala ~amd64
Of course change ~amd64 to your arch.


True, my system is mostly stable, but I have worked to try and achieve a happy medium of stable and ~arch. I think I have that medium, however, I do still have to work to preserve it. after looking in package.accept_keywords, I did notice that I already have an entry for dev-lang/vala.

Thanks

Todd
Back to top
View user's profile Send private message
todd93
Guru
Guru


Joined: 30 Oct 2006
Posts: 436
Location: Missouri

PostPosted: Fri Nov 01, 2013 10:32 pm    Post subject: Reply with quote

Okay, I'm still stuck here, not sure what I need to do, I've tried a few things, but they haven't worked. here is the output I'm still getting:

Code:

# emerge -auvD @system

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] sys-libs/timezone-data-2013d [2013b] USE="nls" 349 kB
[ebuild   R    ] dev-libs/expat-2.1.0-r2  USE="unicode -examples -static-libs" 0 kB
[ebuild   R    ] virtual/libiconv-0  0 kB
[ebuild     U  ] sys-devel/autoconf-wrapper-13 [12] 0 kB
[ebuild     U  ] sys-devel/automake-wrapper-9 [7] 0 kB
[ebuild   R    ] virtual/libffi-3.0.11  0 kB
[ebuild     U ~] dev-libs/gobject-introspection-common-1.36.0 [1.34.2] 1,173 kB
[ebuild     U  ] dev-lang/nasm-2.10.07 [2.10.05] USE="-doc" 665 kB
[ebuild     U  ] media-libs/libjpeg-turbo-1.3.0 [1.2.1] USE="-java -static-libs" 1,330 kB
[ebuild     U  ] sys-kernel/linux-headers-3.9 [3.7] 3,614 kB
[uninstall     ] media-sound/alsa-headers-1.0.25
[blocks b      ] media-sound/alsa-headers ("media-sound/alsa-headers" is blocking sys-kernel/linux-headers-3.9)
[ebuild  NS   ~] dev-python/python-exec-2.0-r1:2 [0.3.1:0] PYTHON_TARGETS="(jython2_5) (jython2_7) (pypy2_0) (python2_6) (python2_7) (python3_2) (python3_3)" 79 kB
[ebuild     U  ] dev-libs/libgpg-error-1.12 [1.10] USE="nls static-libs -common-lisp" 478 kB
[ebuild     U  ] sys-apps/attr-2.4.46-r2 [2.4.46-r1] USE="nls -static-libs" 0 kB
[ebuild  NS    ] sys-devel/automake-1.13.4:1.13 [1.11.6:1.11, 1.12.6:1.12] 1,416 kB
[ebuild     U  ] sys-devel/libtool-2.4.2:2 [2.4-r1:2] USE="-static-libs% {-test} -vanilla" 849 kB
[ebuild     U ~] sys-libs/zlib-1.2.8-r1 [1.2.8] USE="minizip -static-libs" ABI_X86="(64%*) -32% (-x32)" 0 kB
[ebuild     U  ] dev-db/sqlite-3.7.17:3 [3.7.16.2:3] USE="extensions readline -debug -doc -icu -secure-delete -static-libs -tcl {-test}" 1,833 kB
[ebuild     U  ] dev-libs/libgcrypt-1.5.3:0/11 [1.5.2-r1:0/11] USE="static-libs" 1,474 kB
[ebuild     U ~] dev-libs/nspr-4.10.1 [4.10] USE="-debug" 1,078 kB
[ebuild     U  ] sys-libs/libcap-ng-0.7.3 [0.6.6] USE="-python -static-libs" 384 kB
[ebuild     U ~] media-libs/libpng-1.6.6:0/16 [1.6.3:0/16] USE="apng (-neon) -static-libs" ABI_X86="(64%*) -32% (-x32)" 860 kB
[ebuild     U  ] media-libs/tiff-4.0.3-r4 [4.0.3-r2] USE="cxx jpeg zlib -jbig -lzma -static-libs" 0 kB
[ebuild     U  ] app-admin/eselect-1.3.8 [1.3.4] USE="-doc -emacs% -vim-syntax%" 165 kB
[ebuild     U  ] dev-libs/openssl-1.0.1e-r1 [1.0.1c] USE="(sse2) tls-heartbeat%* zlib -bindist -gmp -kerberos -rfc3779 -static-libs {-test} -vanilla" 4,356 kB
[ebuild     UD ] media-libs/lcms-1.19 [1.19-r1] USE="jpeg python tiff zlib -static-libs" PYTHON_TARGETS="(-python2_5%) (-python2_6%) (-python2_7%*) (-python3_2%*) (-python3_3%)" 0 kB
[ebuild     U  ] app-admin/python-updater-0.11 [0.10] 10 kB
[ebuild     U ~] dev-util/gdbus-codegen-2.36.4-r1 [2.34.3] PYTHON_TARGETS="python2_7 python3_2 -python2_6 -python3_3 (-python2_5%) (-python3_1%)" 6,417 kB
[ebuild     U ~] dev-libs/glib-2.36.4-r1:2 [2.34.3:2] USE="-debug (-fam) (-selinux) -static-libs -systemtap {-test} -utils -xattr" ABI_X86="(64%*) -32% (-x32)" PYTHON_TARGETS="python2_7%* -python2_6%" 0 kB
[ebuild     U  ] x11-proto/xproto-7.0.24 [7.0.23-r1] USE="-doc" ABI_X86="(64%*) (-32) (-x32)" 286 kB
[ebuild     U  ] x11-proto/xextproto-7.2.1-r1 [7.2.1] USE="-doc" ABI_X86="(64%*) (-32) (-x32)" 0 kB
[ebuild     U  ] x11-proto/renderproto-0.11.1-r1 [0.11.1] ABI_X86="(64%*) (-32) (-x32)" 0 kB
[ebuild     U  ] x11-proto/kbproto-1.0.6-r1 [1.0.6] ABI_X86="(64%*) (-32) (-x32)" 0 kB
[ebuild     U  ] x11-proto/damageproto-1.2.1-r1 [1.2.1] ABI_X86="(64%*) (-32) (-x32)" 0 kB
[ebuild     U ~] sys-apps/kmod-15 [13-r1] USE="openrc%* tools zlib -debug -doc -lzma -static-libs" 1,420 kB
[ebuild     U  ] x11-libs/pixman-0.30.2 [0.28.0] USE="sse2 (-altivec) (-iwmmxt) (-loongson2f) -mmxext (-neon) -static-libs" 651 kB
[ebuild     U  ] x11-proto/xcb-proto-1.8-r3 [1.8-r1] ABI_X86="(64%*) (-32) (-x32)" PYTHON_SINGLE_TARGET="(-python2_5%) (-python2_6%) (-python2_7%*) (-python3_1%) (-python3_2%) (-python3_3%)" PYTHON_TARGETS="python2_7 python3_2 -python2_6 (-python3_3) (-python2_5%) (-python3_1%)" 0 kB
[ebuild     U  ] dev-libs/libpthread-stubs-0.3-r1 [0.3] USE="-static-libs" ABI_X86="(64%*) (-32) (-x32)" 0 kB
[ebuild     U  ] x11-proto/xf86vidmodeproto-2.3.1-r1 [2.3.1] ABI_X86="(64%*) (-32) (-x32)" 0 kB
[ebuild     U  ] sys-libs/gpm-1.20.7-r1 [1.20.6] USE="(-selinux) -static-libs%" 772 kB
[ebuild     U  ] x11-proto/xf86bigfontproto-1.2.0-r1 [1.2.0] ABI_X86="(64%*) (-32) (-x32)" 0 kB
[ebuild  NS   ~] dev-lang/spidermonkey-17.0.0-r1:17 [1.8.5-r4:0/mozjs185] USE="-debug -jit -minimal -static-libs {-test}" 6,621 kB
[ebuild     U  ] x11-proto/recordproto-1.14.2-r1 [1.14.2] USE="-doc" ABI_X86="(64%*) (-32) (-x32)" 0 kB
[ebuild     U  ] x11-proto/videoproto-2.3.2 [2.3.1] ABI_X86="(64%*) (-32) (-x32)" 117 kB
[ebuild     U  ] dev-libs/nss-3.15.2 [3.15.1] USE="-utils" 6,142 kB
[ebuild     U  ] x11-proto/compositeproto-0.4.2-r1 [0.4.2] ABI_X86="(64%*) (-32) (-x32)" 0 kB
[ebuild     U  ] x11-misc/util-macros-1.17.1 [1.17] 78 kB
[ebuild     U ~] x11-proto/dri2proto-2.8-r1 [2.8] ABI_X86="(64%*) -32% (-x32)" 0 kB
[ebuild     U ~] x11-proto/glproto-1.4.16-r1 [1.4.16] ABI_X86="(64%*) -32% (-x32)" 0 kB
[ebuild     U  ] x11-libs/libICE-1.0.8-r1 [1.0.8] USE="ipv6 -doc -static-libs" ABI_X86="(64%*) (-32) (-x32)" 0 kB
[ebuild     U  ] x11-libs/libXau-1.0.8 [1.0.7] USE="-static-libs" ABI_X86="(64%*) (-32) (-x32)" 289 kB
[ebuild     U  ] x11-libs/libXdmcp-1.1.1-r1 [1.1.1] USE="-doc -static-libs" ABI_X86="(64%*) (-32) (-x32)" 0 kB
[ebuild     U  ] x11-proto/fixesproto-5.0-r1 [5.0] ABI_X86="(64%*) (-32) (-x32)" 0 kB
[ebuild     U  ] x11-libs/libxcb-1.9.1 [1.9] USE="-doc (-selinux) -static-libs -xkb%" ABI_X86="(64%*) (-32) (-x32)" PYTHON_SINGLE_TARGET="python2_7%* -python2_6% -python3_2% (-python3_3)" PYTHON_TARGETS="python2_7%* python3_2%* -python2_6% (-python3_3)" 365 kB
[ebuild     U  ] x11-libs/libX11-1.6.2 [1.6.0] USE="ipv6 -doc -static-libs {-test}" ABI_X86="(64) -32 (-x32)" 2,286 kB
[ebuild     U  ] x11-libs/libXext-1.3.2 [1.3.1] USE="-doc -static-libs" ABI_X86="(64%*) (-32) (-x32)" 371 kB
[ebuild     U  ] x11-libs/libXrender-0.9.8 [0.9.7] USE="-static-libs" ABI_X86="(64%*) (-32) (-x32)" 299 kB
[ebuild     U  ] x11-libs/libXfixes-5.0.1 [5.0] USE="-static-libs" ABI_X86="(64%*) (-32) (-x32)" 286 kB
[ebuild   R    ] media-libs/freetype-2.4.11:2  USE="X bzip2 -auto-hinter -bindist -debug -doc -fontforge -infinality -static-libs -utils" 0 kB
[ebuild     U  ] x11-apps/xprop-1.2.2 [1.2.1] 143 kB
[ebuild     U  ] x11-libs/libXcomposite-0.4.4-r1 [0.4.3-r1] USE="-doc -static-libs" ABI_X86="(64%*) (-32) (-x32)" 278 kB
[ebuild     U  ] x11-libs/libXxf86vm-1.1.3 [1.1.2] USE="-static-libs" ABI_X86="(64%*) (-32) (-x32)" 278 kB
[ebuild     U  ] x11-libs/libXi-1.7.2 [1.6.1] USE="-doc -static-libs" ABI_X86="(64%*) (-32) (-x32)" 431 kB
[ebuild     U  ] x11-libs/libXcursor-1.1.14 [1.1.13] USE="-static-libs" ABI_X86="(64%*) (-32) (-x32)" 305 kB
[ebuild     U  ] x11-libs/libXrandr-1.4.2 [1.4.0] USE="-static-libs" ABI_X86="(64%*) (-32) (-x32)" 308 kB
[ebuild     U  ] x11-libs/libXv-1.0.10 [1.0.7] USE="-static-libs" ABI_X86="(64%*) (-32) (-x32)" 294 kB
[ebuild     U  ] x11-libs/libXdamage-1.1.4-r1 [1.1.3] USE="-static-libs" ABI_X86="(64%*) (-32) (-x32)" 273 kB
[ebuild     U  ] x11-libs/libXtst-1.2.2 [1.2.1] USE="-doc -static-libs" ABI_X86="(64%*) (-32) (-x32)" 315 kB
[ebuild     U ~] dev-libs/gobject-introspection-1.36.0-r1 [1.34.2-r1] USE="cairo%* -doctool {-test}" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7" 0 kB
[blocks b      ] <dev-libs/gobject-introspection-1.36 ("<dev-libs/gobject-introspection-1.36" is blocking dev-libs/glib-2.36.4-r1)
[blocks b      ] <dev-libs/gobject-introspection-1.36.0 ("<dev-libs/gobject-introspection-1.36.0" is blocking dev-libs/gobject-introspection-common-1.36.0)
[ebuild     U ~] dev-libs/atk-2.8.0 [2.6.0] USE="introspection nls {-test%}" 620 kB
[ebuild     U ~] app-accessibility/at-spi2-core-2.8.0:2 [2.6.3:2] USE="introspection" 427 kB
[ebuild     U  ] media-libs/fontconfig-2.10.92:1.0 [2.8.0-r1:1.0] USE="-doc -static-libs%" ABI_X86="(64%*) (-32) (-x32)" 1,490 kB
[ebuild     U  ] x11-libs/libXft-2.3.1-r1 [2.3.1] USE="-static-libs" ABI_X86="(64%*) (-32) (-x32)" 0 kB
[ebuild  N     ] dev-libs/libusb-compat-0.1.5  USE="-debug -static-libs" 271 kB
[uninstall     ] dev-libs/libusb-0.1.12-r7  USE="cxx -debug -doc -static-libs"
[blocks b      ] dev-libs/libusb:0 ("dev-libs/libusb:0" is blocking dev-libs/libusb-compat-0.1.5)
[blocks b      ] dev-libs/libusb-compat ("dev-libs/libusb-compat" is blocking dev-libs/libusb-0.1.12-r7)
[ebuild     U ~] x11-libs/libdrm-2.4.47 [2.4.46] USE="libkms -static-libs" ABI_X86="(64%*) -32% (-x32)" VIDEO_CARDS="intel radeon vmware (-exynos) (-freedreno) -nouveau (-omap)" 541 kB
[ebuild     U  ] media-libs/mesa-9.1.6 [9.1.2-r1] USE="classic egl gallium nptl shared-glapi xa -bindist -debug -gbm -gles1 -gles2 -llvm -openvg -osmesa -pax_kernel -pic (-r600-llvm-compiler) (-selinux) -vdpau (-wayland) -xorg -xvmc" PYTHON_SINGLE_TARGET="python2_7 -python2_6" PYTHON_TARGETS="python2_7 -python2_6" VIDEO_CARDS="radeon -i915 -i965 -intel -nouveau -r100 -r200 -r300 -r600 (-radeonsi) -vmware" 5,991 kB
[ebuild     U  ] x11-libs/cairo-1.12.14-r4 [1.10.2-r3] USE="X glib opengl svg xcb (-aqua) -debug -directfb -doc (-drm) (-gallium) (-gles2) -legacy-drivers% -openvg (-qt4) -static-libs -valgrind% -xlib-xcb%" 41,145 kB
[ebuild     U ~] media-libs/harfbuzz-0.9.20:0/0.9.18 [0.9.18-r1:0/0.9.18] USE="cairo glib graphite icu introspection%* truetype -static-libs" 1,007 kB
[ebuild     U ~] x11-libs/pango-1.34.1 [1.32.5] USE="X introspection -debug" 992 kB
[ebuild     U ~] x11-libs/gtk+-2.24.22:2 [2.24.20:2] USE="cups introspection (-aqua) -debug -examples {-test} -vim-syntax -xinerama" 13,063 kB
[ebuild     U  ] dev-perl/DBD-mysql-4.20.0 [4.01.7] USE="-embedded%" 135 kB
[ebuild     U  ] net-print/foomatic-filters-4.0.17-r1 [4.0.17] USE="cups dbus" 0 kB
[ebuild     U ~] sys-auth/polkit-0.112-r1 [0.111] USE="gtk introspection nls pam -examples -kde (-selinux) -systemd" 1,396 kB
[ebuild     U  ] app-text/poppler-0.22.5:0/37 [0.22.2-r2:0/35] USE="cairo cxx introspection jpeg lcms png qt4 tiff utils -cjk -curl -debug -doc -jpeg2k" 2,187 kB
[ebuild     U  ] x11-libs/libSM-1.2.2 [1.2.1] USE="ipv6 uuid -doc -static-libs" ABI_X86="(64%*) (-32) (-x32)" 341 kB
[ebuild     U  ] x11-libs/libXt-1.1.4 [1.1.3] USE="-static-libs" ABI_X86="(64%*) (-32) (-x32)" 745 kB
[ebuild     U  ] x11-libs/libXmu-1.1.2 [1.1.1] USE="ipv6 -doc -static-libs" ABI_X86="(64%*) (-32) (-x32)" 387 kB
[ebuild     U  ] x11-libs/libXpm-3.5.11 [3.5.10] USE="-static-libs" ABI_X86="(64%*) (-32) (-x32)" 434 kB
[ebuild     U  ] x11-apps/xset-1.2.3 [1.2.2] 139 kB
[ebuild     U  ] x11-libs/libXaw-1.0.12 [1.0.11-r1] USE="-deprecated -doc -static-libs" ABI_X86="(64%*) (-32) (-x32)" 662 kB
[ebuild     U  ] sys-apps/groff-1.22.2 [1.21] USE="X -examples" LINGUAS="-ja" 3,926 kB
[ebuild     U  ] net-nds/openldap-2.4.35-r1 [2.4.30] USE="berkdb crypt gnutls ipv6 minimal ssl syslog tcpd -cxx -debug -experimental -icu -iodbc -kerberos -odbc -overlays -perl -samba -sasl (-selinux) -slp -smbkrb5passwd" 5,370 kB
[ebuild     U  ] net-misc/curl-7.31.0 [7.30.0] USE="ipv6 ldap ssl -adns -idn -kerberos -metalink -rtmp -ssh -static-libs {-test} -threads" CURL_SSL="nss -axtls -cyassl -gnutls -openssl -polarssl" 2,617 kB
[ebuild     U  ] app-crypt/gnupg-2.0.22 [2.0.20] USE="bzip2 ldap nls readline usb -adns -doc -mta (-selinux) -smartcard -static" 4,177 kB
[ebuild     U ~] x11-libs/gtk+-3.8.6:3 [3.6.3-r2:3] USE="X colord cups introspection (-aqua) -debug -examples (-packagekit) {-test} -vim-syntax -wayland -xinerama (-egl%)" 13,531 kB
[ebuild     U ~] app-crypt/gcr-3.8.2:0/1 [3.6.2:0/1] USE="gtk%* introspection -debug {-test}" 1,362 kB
[ebuild     U ~] gnome-base/gnome-keyring-3.8.2 [3.6.3] USE="caps filecaps pam -debug (-selinux) {-test}" 1,113 kB
[ebuild     U ~] gnome-base/libgnome-keyring-3.8.0 [3.6.0] USE="introspection -debug {-test} -vala" 417 kB
[ebuild     U ~] sys-fs/udev-208 [205] USE="acl firmware-loader gudev introspection kmod openrc static-libs -doc (-selinux) (-hwdb%*) (-keymap%*)" ABI_X86="(64%*) -32% (-x32)" 2,328 kB
[ebuild     U ~] virtual/udev-206-r3 [200] USE="gudev introspection kmod (-selinux) -static-libs (-hwdb%*) (-keymap%*)" ABI_X86="(64%*) -32% (-x32)" 0 kB
[ebuild     U ~] sys-apps/hwids-20130915.1 [20130717] USE="udev" 1,535 kB
[ebuild     U ~] x11-misc/colord-1.0.3:0/1 [0.1.28:0/1] USE="gusb introspection scanner%* udev -examples -extra-print-profiles -systemd -vala (-doc%)" 1,058 kB
[blocks B      ] <dev-lang/vala-0.20.0 ("<dev-lang/vala-0.20.0" is blocking dev-libs/gobject-introspection-1.36.0-r1)

Total: 101 packages (92 upgrades, 1 downgrade, 1 new, 3 in new slots, 4 reinstalls, 2 uninstalls), Size of downloads: 158,508 kB
Conflict: 6 blocks (1 unsatisfied)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/expat:0

  (dev-libs/expat-2.1.0-r2::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/expat-2.1.0-r2::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/expat-1.95.3[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (media-libs/fontconfig-2.10.92::gentoo, ebuild scheduled for merge)

media-libs/freetype:2

  (media-libs/freetype-2.4.11::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (media-libs/freetype-2.4.11::gentoo, ebuild scheduled for merge) pulled in by
    media-libs/freetype[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (x11-libs/libXft-2.3.1-r1::gentoo, ebuild scheduled for merge)
    >=media-libs/freetype-2.2.1[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (media-libs/fontconfig-2.10.92::gentoo, ebuild scheduled for merge)

app-text/poppler:0

  (app-text/poppler-0.22.2-r2::gentoo, installed) pulled in by
    >=app-text/poppler-0.16:0/35=[xpdf-headers(+),cxx] required by (app-office/libreoffice-4.1.2.3::gentoo, installed)
    app-text/poppler:0/35=[cxx,jpeg,lcms,tiff,xpdf-headers(+)] required by (net-print/cups-filters-1.0.34-r1::gentoo, installed)

  (app-text/poppler-0.22.5::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

virtual/libiconv:0

  (virtual/libiconv-0::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (virtual/libiconv-0::gentoo, ebuild scheduled for merge) pulled in by
    virtual/libiconv[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (dev-libs/glib-2.36.4-r1::gentoo, ebuild scheduled for merge)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (dev-lang/vala-0.14.2-r2::gentoo, installed) pulled in by
    dev-lang/vala required by @selected
    dev-lang/vala:0.14[vapigen] required by (net-libs/gssdp-0.12.2.1::gentoo, installed)

  (dev-libs/gobject-introspection-1.36.0-r1::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/gobject-introspection required by (gnome-extra/gnome-games-3.6.1-r1::gentoo, installed)
    >=dev-libs/gobject-introspection-1.29 required by (dev-libs/libgusb-0.1.4::gentoo, installed)
    >=dev-libs/gobject-introspection-1.34.1.1 required by (dev-python/pygobject-3.4.2-r1::gentoo, installed)
    >=dev-libs/gobject-introspection-1 required by (gnome-extra/libgsf-1.14.25::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.7 required by (media-video/cheese-3.6.2::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5 required by (x11-libs/pango-1.34.1::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.6.5 required by (gnome-extra/libgda-5.0.3-r1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.7 required by (dev-libs/atk-2.8.0::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.6 required by (app-text/evince-2.32.0-r4::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5:= required by (gnome-base/gconf-2.32.4-r1::gentoo, installed)
    >=dev-libs/gobject-introspection-1.31.1 required by (media-libs/gstreamer-1.0.7::gentoo, installed)
    dev-libs/gobject-introspection required by (net-dns/avahi-0.6.31-r2::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.8 required by (media-libs/gstreamer-0.10.36::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.3 required by (x11-libs/gdk-pixbuf-2.28.2::gentoo, installed)
    >=dev-libs/gobject-introspection-1.31.1 required by (media-libs/gst-plugins-base-1.0.7::gentoo, installed)
    >=dev-libs/gobject-introspection-1.32 required by (media-libs/harfbuzz-0.9.20::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.6.4 required by (net-libs/gupnp-0.18.4::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.8 required by (media-libs/clutter-gst-2.0.6::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.2 required by (gnome-extra/polkit-gnome-0.102::gentoo, installed)
    >=dev-libs/gobject-introspection-1.32 required by (x11-libs/gtk+-3.8.6::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.9.6:= required by (dev-libs/libgee-0.6.7::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5 required by (net-libs/webkit-gtk-1.8.3-r201::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.7 required by (gnome-base/gnome-desktop-3.4.2::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.8 required by (x11-misc/colord-1.0.3::gentoo, ebuild scheduled for merge)
    dev-libs/gobject-introspection required by (sys-power/upower-0.9.20-r2::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.0 required by (x11-libs/gtksourceview-3.6.3::gentoo, installed)
    >=dev-libs/gobject-introspection-1.32 required by (x11-libs/libnotify-0.7.5-r1::gentoo, installed)
    >=dev-libs/gobject-introspection-1.34.2 required by (media-libs/cogl-1.12.2-r1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.6 required by (app-accessibility/at-spi2-core-2.8.0::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-1.30.0 required by (gnome-base/libgnome-keyring-3.8.0::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.6.4 required by (gnome-base/nautilus-2.32.2.1-r2::gentoo, installed)
    >=dev-libs/gobject-introspection-0.10.8 required by (app-text/liblangtag-0.5.1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.6:0/0= required by (dev-libs/libgee-0.6.7::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.12 required by (media-libs/gst-plugins-base-0.10.36::gentoo, installed)
    >=dev-libs/gobject-introspection-1.30 required by (sys-fs/udisks-2.1.0::gentoo, installed)
    >=dev-libs/gobject-introspection-1.30 required by (net-libs/telepathy-glib-0.20.3::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5 required by (dev-libs/json-glib-0.16.0-r1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.7 required by (net-libs/gssdp-0.12.2.1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.10 required by (net-libs/gupnp-igd-0.2.1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.7 required by (gnome-base/gnome-panel-2.32.1-r3::gentoo, installed)
    >=dev-libs/gobject-introspection-1.31.1 required by (sys-fs/udev-208::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.9.12 required by (media-libs/clutter-gtk-1.4.2::gentoo, installed)
    >=dev-libs/gobject-introspection-1.29 required by (app-crypt/libsecret-0.15::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.0 required by (x11-libs/vte-0.28.2-r204::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.3 required by (x11-libs/gtk+-2.24.22::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.9.7 required by (dev-libs/libgdata-0.8.1-r2::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.0 required by (gnome-extra/gucharmap-3.6.1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.3 required by (app-cdr/brasero-2.32.1-r1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5:0/0= required by (gnome-base/gconf-2.32.4-r1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.10.1 required by (dev-libs/libpeas-1.6.0::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.7 required by (gnome-base/gnome-menus-2.30.5-r1::gentoo, installed)
    >=dev-libs/gobject-introspection-1.32.1 required by (app-text/poppler-0.22.2-r2::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5 required by (net-libs/libsoup-gnome-2.40.3::gentoo, installed)
    >=dev-libs/gobject-introspection-1.30 required by (x11-libs/libxklavier-5.2.1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.14 required by (x11-libs/libwnck-2.31.0::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.6 required by (media-libs/clutter-1.12.2-r1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.0 required by (gnome-extra/gucharmap-3.0.1-r200::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5 required by (www-client/epiphany-3.6.1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.0 required by (x11-libs/vte-0.34.2::gentoo, installed)
    >=dev-libs/gobject-introspection-1 required by (sys-auth/polkit-0.112-r1::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-1.34 required by (app-crypt/gcr-3.8.2::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.9.5 required by (net-libs/libsoup-2.40.3::gentoo, installed)
    >=dev-libs/gobject-introspection-1.32.1 required by (app-text/poppler-0.22.5::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.9.5 required by (dev-libs/totem-pl-parser-2.32.6-r3::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.4 required by (net-libs/gtk-vnc-0.5.1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.10.8 required by (gnome-base/librsvg-2.36.4::gentoo, installed)
    >=dev-libs/gobject-introspection-1.31.0 required by (gnome-base/gsettings-desktop-schemas-3.6.1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5 required by (dev-util/anjuta-3.6.2-r1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.7 required by (dev-libs/gdl-3.6.2::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.3 required by (app-editors/gedit-3.6.2-r1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5 required by (net-libs/webkit-gtk-1.10.2-r300::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


!!! The following installed packages are masked:
- dev-java/sun-jre-bin-1.6.0.45::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Tom Wijsman <TomWij@gentoo.org> (30 Jun 2013)
# Sun JDK and JRE contain critical vulnerabilities and receive no further
# updates; masking to make users aware of this, users that still need this
# package and have no alternative can unmask at their own risk. See bug #473830.
#
# This is continued by Oracle Corproation, which has acquired Sun Microsystems
# in early 2010; as per http://en.wikipedia.org/wiki/Sun_acquisition_by_Oracle
#
# Users are suggested to upgrade to one of the newer Oracle packages like
# dev-java/oracle-jdk-bin or dev-java/oracle/jre-bin or choose another
# alternative we provide; eg. the IBM JDK/JRE or the open source IcedTea.
#
# Most of these packages provide a jce USE flag for those whom need the
# Java Cryptographic Extension Unlimited Strength Policy USE flag; whether that
# works depends from VM to VM, it seems to work for most except for the IBM VMs.

- sci-geosciences/googleearth-7.1.1.1871::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Julian Ospald <hasufell@gentoo.org> (21 Jul 2013)
# Mask all unfetchable versions and those with tons of random
# bugs and segfaults (all). Don't ask for a version bump unless
# there is a working release.

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


I tried going even more stable, but that seemed to cause me even more trouble. I have no problem going more stable, it's just a matter of making everything work right.

Again, I would appreciate any help I can get on this.

Thanks!!

Todd
Back to top
View user's profile Send private message
TomWij
Developer
Developer


Joined: 04 Jul 2012
Posts: 1342

PostPosted: Fri Nov 01, 2013 10:34 pm    Post subject: Reply with quote

Quote:
[blocks B ] <dev-lang/vala-0.20.0 ("<dev-lang/vala-0.20.0" is blocking dev-libs/gobject-introspection-1.36.0-r1)


It means that gobject-introspection doesn't want dev-lang/vala-0.20.0 or lower. Upgrade to a newer version of dev-lang/vala; alternatively, find a version of gobject-introspection that does not have this restriction.
Back to top
View user's profile Send private message
todd93
Guru
Guru


Joined: 30 Oct 2006
Posts: 436
Location: Missouri

PostPosted: Fri Nov 01, 2013 10:39 pm    Post subject: Reply with quote

TomWij wrote:
Quote:
[blocks B ] <dev-lang/vala-0.20.0 ("<dev-lang/vala-0.20.0" is blocking dev-libs/gobject-introspection-1.36.0-r1)


It means that gobject-introspection doesn't want dev-lang/vala-0.20.0 or lower. Upgrade to a newer version of dev-lang/vala; alternatively, find a version of gobject-introspection that does not have this restriction.


Yes, I do understand what it means, and on my system, I have the following version of dev-lang/vala:

Code:

 # emerge -pv dev-lang/vala

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ~] dev-lang/vala-0.22.0:0.22  USE="vapigen {-test}" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB


Thanks

Todd
Back to top
View user's profile Send private message
TomWij
Developer
Developer


Joined: 04 Jul 2012
Posts: 1342

PostPosted: Fri Nov 01, 2013 11:28 pm    Post subject: Reply with quote

You actually have both:

Quote:
(dev-lang/vala-0.14.2-r2::gentoo, installed) pulled in by
dev-lang/vala required by @selected
dev-lang/vala:0.14[vapigen] required by (net-libs/gssdp-0.12.2.1::gentoo, installed)


So, I think `emerge -C dev-lang/vala:0.14` might work. But you will probably need to find a version of net-libs/gssdp that does not need that version of vala.
Back to top
View user's profile Send private message
todd93
Guru
Guru


Joined: 30 Oct 2006
Posts: 436
Location: Missouri

PostPosted: Sat Nov 02, 2013 11:34 am    Post subject: Reply with quote

TomWij wrote:
You actually have both:

Quote:
(dev-lang/vala-0.14.2-r2::gentoo, installed) pulled in by
dev-lang/vala required by @selected
dev-lang/vala:0.14[vapigen] required by (net-libs/gssdp-0.12.2.1::gentoo, installed)


So, I think `emerge -C dev-lang/vala:0.14` might work. But you will probably need to find a version of net-libs/gssdp that does not need that version of vala.

okay, that made sense, I kind of feel foolish for missing that. it eliminated the block, and now I have run into another hard block while attempting to run emerge -auvD @system .

it is as follows:
Code:

I edited this out because it was messing up the format of the thread.

I do apologize if I am missing something in plain sight here, and do appreciate everyone's patience with assisting me.

Todd


Last edited by todd93 on Sun Nov 03, 2013 10:00 pm; edited 1 time in total
Back to top
View user's profile Send private message
TomWij
Developer
Developer


Joined: 04 Jul 2012
Posts: 1342

PostPosted: Sat Nov 02, 2013 11:43 am    Post subject: Reply with quote

python-exec is currently problematic due to some mistake that has happened; it'll be resolved as soon as the right way to go forward and the work to do so is done, there might be workarounds available on the forum.
Back to top
View user's profile Send private message
todd93
Guru
Guru


Joined: 30 Oct 2006
Posts: 436
Location: Missouri

PostPosted: Sun Nov 03, 2013 2:38 pm    Post subject: Reply with quote

Okay, I did find a workaround for python-exec here. Now that's done, and I successfully completed:
Code:
emerge -auvD @system


I still had a hard block on x11-libs/gtk+, so I commented it out in /etc/portage/package.accept_keywords, and the hard block is gone. emerge -uDNv world is now running. The only issue is that I have 424 packages to update, I assume there will be a failure in there somewhere, so I will withhold calling this one "solved" until I have completed my update. I would like to say thank you to everyone who helped me here, I really appreciate everyone's patience with me. I do search out the forums quite extensively when I have a problem, only posting as a last resort. Sometimes I get tremendous help from others who post, sometimes my issue is unique requiring me to post.

Thanks

Todd!
Back to top
View user's profile Send private message
todd93
Guru
Guru


Joined: 30 Oct 2006
Posts: 436
Location: Missouri

PostPosted: Sun Nov 03, 2013 9:59 pm    Post subject: Reply with quote

okay, I think all the packages merged properly, but it wanted me to complete the following command: emerge @preserved-rebuild. I did, and it fails with the following error:

Code:

            from pdfdataset.cpp:41:
/usr/include/poppler/Stream.h:313:16: note:    virtual void BaseStream::setPos(Goffset, int)
/usr/include/poppler/Stream.h:310:23: note:    virtual BaseStream* BaseStream::copy()
/usr/include/poppler/Stream.h:311:19: note:    virtual Stream* BaseStream::makeSubStream(Goffset, GBool, Goffset, Object*)
/usr/include/poppler/Stream.h:323:16: note:    virtual void BaseStream::moveStart(Goffset)
pdfdataset.cpp:623:67: warning: ignoring return value of ‘char* fgets(char*, int, FILE*)’, declared with attribute warn_unused_result [-Wunused-result]
make[2]: *** [../o/pdfdataset.o] Error 1
make[2]: Leaving directory `/var/tmp/portage/sci-libs/gdal-1.9.2/work/gdal-1.9.2/frmts/pdf'
make[1]: *** [pdf-install-obj] Error 2
make[1]: Leaving directory `/var/tmp/portage/sci-libs/gdal-1.9.2/work/gdal-1.9.2/frmts'
make: *** [frmts-target] Error 2
 * ERROR: sci-libs/gdal-1.9.2::gentoo failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=sci-libs/gdal-1.9.2::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=sci-libs/gdal-1.9.2::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/sci-libs/gdal-1.9.2/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sci-libs/gdal-1.9.2/temp/environment'.
 * Working directory: '/var/tmp/portage/sci-libs/gdal-1.9.2/work/gdal-1.9.2'
 * S: '/var/tmp/portage/sci-libs/gdal-1.9.2/work/gdal-1.9.2'
!!! When you file a bug report, please include the following information:
GENTOO_VM=  CLASSPATH="" JAVA_HOME="/etc/java-config-2/current-system-vm"
JAVACFLAGS="" COMPILER=""
and of course, the output of emerge --info =gdal-1.9.2

>>> Failed to emerge sci-libs/gdal-1.9.2, Log file:

>>>  '/var/tmp/portage/sci-libs/gdal-1.9.2/temp/build.log'

 * Messages for package dev-python/mygpoclient-1.4:

 * EAPI assignment in ebuild 'dev-python/mygpoclient-1.4::my-overlay'
 * does not conform with PMS section 7.3.1 (see bug #402167):
 *    valid EAPI assignment must occur on or before line: 5

 * Messages for package sci-libs/gdal-1.9.2:

 * ERROR: sci-libs/gdal-1.9.2::gentoo failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=sci-libs/gdal-1.9.2::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=sci-libs/gdal-1.9.2::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/sci-libs/gdal-1.9.2/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sci-libs/gdal-1.9.2/temp/environment'.
 * Working directory: '/var/tmp/portage/sci-libs/gdal-1.9.2/work/gdal-1.9.2'
 * S: '/var/tmp/portage/sci-libs/gdal-1.9.2/work/gdal-1.9.2'

 * GNU info directory index is up-to-date.

!!! existing preserved libs:
>>> package: media-gfx/imagemagick-6.8.6.8
 *  - /usr/lib64/libMagickWand.so.5
 *  - /usr/lib64/libMagickWand.so.5.0.0
 *  - /usr/lib64/libMagickCore.so.5
 *  - /usr/lib64/libMagickCore.so.5.0.0
 *  - /usr/lib64/libMagick++.so.5
 *  - /usr/lib64/libMagick++.so.5.0.0
 *      used by /usr/bin/inkscape (media-gfx/inkscape-0.48.4)
 *      used by /usr/bin/inkview (media-gfx/inkscape-0.48.4)
>>> package: app-text/poppler-0.24.3
 *  - /usr/lib64/libpoppler.so.35
 *  - /usr/lib64/libpoppler.so.35.0.0
 *      used by /usr/bin/inkscape (media-gfx/inkscape-0.48.4)
 *      used by /usr/bin/inkview (media-gfx/inkscape-0.48.4)
 *      used by /usr/lib64/libgdal.so.1.9.2 (sci-libs/gdal-1.9.2)
>>> package: x11-libs/gtksourceview-3.8.2
 *  - /usr/lib64/libgtksourceview-3.0.so.0
 *  - /usr/lib64/libgtksourceview-3.0.so.0.0.0
 *      used by /usr/bin/anjuta (dev-util/anjuta-3.6.2-r1)
 *      used by /usr/bin/gda-browser-5.0 (gnome-extra/libgda-5.0.3-r1)
 *      used by /usr/lib64/anjuta/libanjuta-sourceview.so (dev-util/anjuta-3.6.2-r1)
 *      used by /usr/lib64/libgda-5.0/plugins/libgda-ui-plugins.so (gnome-extra/libgda-5.0.3-r1)
>>> package: media-libs/cogl-1.14.1_pre20130901
 *  - /usr/lib64/libcogl-pango.so.0
 *  - /usr/lib64/libcogl-pango.so.0.0.0
 *      used by /usr/lib64/libmx-1.0.so.2.405.0 (x11-libs/mx-1.4.7)
 *  - /usr/lib64/libcogl.so.11
 *  - /usr/lib64/libcogl.so.11.0.3
 *      used by /usr/lib64/gstreamer-0.10/libgstclutter.so (media-libs/clutter-gst-1.6.0-r1)
 *      used by /usr/lib64/libclutter-gst-1.0.so.0.600.0 (media-libs/clutter-gst-1.6.0-r1)
 *      used by /usr/lib64/libmx-1.0.so.2.405.0 (x11-libs/mx-1.4.7)
Use emerge @preserved-rebuild to rebuild packages using these libraries


I did see some things on EAPI and python, but it just confuses me. And I did see that there is a bug on this issue as well. Not sure how important sci-libs/gdal, or if this is even an important issue.

Thanks!!
Todd
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5268

PostPosted: Mon Nov 04, 2013 1:04 am    Post subject: Reply with quote

Most of the portage message is not important here.
The important part are those warnings/errors about poppler headers.
While higher level poppler libraries are quite API/ABI stable, libpoppler itself is by upstream choice not.

Check which versions of poppler/gdal you have installed. If both are from either stable or unstable, report a bug (check though if it's not simply a stable request for a version already in the tree), if you're mixing, you'll need to figure it out on your own.
Back to top
View user's profile Send private message
TomWij
Developer
Developer


Joined: 04 Jul 2012
Posts: 1342

PostPosted: Mon Nov 04, 2013 11:18 am    Post subject: Reply with quote

The actual error is not in the output, but is somewhere in the build log:

Quote:
* The complete build log is located at '/var/tmp/portage/sci-libs/gdal-1.9.2/temp/build.log'.


Can you upload that file?
Back to top
View user's profile Send private message
Progman3K
Guru
Guru


Joined: 03 Jan 2004
Posts: 520

PostPosted: Mon Nov 04, 2013 1:29 pm    Post subject: Reply with quote

TomWij wrote:
The actual error is not in the output, but is somewhere in the build log:

Quote:
* The complete build log is located at '/var/tmp/portage/sci-libs/gdal-1.9.2/temp/build.log'.


Can you upload that file?


Looks like he is having the same problem as I am and both poppler and gdal are from stable on my system.

Quote:
make[2]: Entering directory `/var/tmp/portage/sci-libs/gdal-1.9.2/work/gdal-1.9.2/frmts/pdf'
x86_64-pc-linux-gnu-g++ -O2 -pipe -march=core2 -fPIC -Wall -I/var/tmp/portage/sci-libs/gdal-1.9.2/work/gdal-1.9.2/port -I/var/tmp/portage/sci-libs/gdal-1.9.2/work/gdal-1.9.2/gcore -I/var/tmp/portage/sci-libs/gdal-1.9.2/work/gdal-1.9.2/alg -I/var/tmp/portage/sci-libs/gdal-1.9.2/work/gdal-1.9.2/ogr -I/var/tmp/portage/sci-libs/gdal-1.9.2/work/gdal-1.9.2/ogr/ogrsf_frmts -DOGR_ENABLED -I/var/tmp/portage/sci-libs/gdal-1.9.2/work/gdal-1.9.2/port -Iexternal/include -I/usr/ -I/usr//include -DUSE_POPPLER -DPOPPLER_HAS_OPTCONTENT -I/usr/include -I/usr/include/poppler -c -o ../o/pdfdataset.o pdfdataset.cpp
In file included from pdfdataset.cpp:41:0:
pdfio.h:60:28: error: conflicting return type specified for 'virtual int VSIPDFFileStream::getPos()'
/usr/include/poppler/Stream.h:
193:19: error: overriding 'virtual Goffset Stream::getPos()'
pdfio.h:61:28: error: conflicting return type specified for 'virtual Guint VSIPDFFileStream::getStart()'
/usr/include/poppler/Stream.h:322:19: error: overriding 'virtual Goffset BaseStream::getStart()'
pdfdataset.cpp: In member function 'virtual CPLErr PDFRasterBand::IReadBlock(int, int, void*)':
pdfdataset.cpp:332:47: error: no matching function for call to 'SplashOutputDev::startDoc(XRef*)'
pdfdataset.cpp:332:47: note: candidate is:
/usr/include/poppler/SplashOutputDev.h:313:8: note: void SplashOutputDev::startDoc(PDFDoc*)
/usr/include/poppler/SplashOutputDev.h:313:8: note: no known conversion for argument 1 from 'XRef*' to 'PDFDoc*'
pdfdataset.cpp: In static member function 'static GDALDataset* PDFDataset::Open(GDALOpenInfo*)':
pdfdataset.cpp:592:45: error: 'setErrorFunction' was not declared in this scope
pdfdataset.cpp:613:85: error: cannot allocate an object of abstract type 'VSIPDFFileStream'
pdfio.h:47:7: note: because the following virtual functions are pure within 'VSIPDFFileStream':
/usr/include/poppler/Stream.h:313:16: note: virtual void BaseStream::setPos(Goffset, int)
/usr/include/poppler/Stream.h:310:23: note: virtual BaseStream* BaseStream::copy()
/usr/include/poppler/Stream.h:311:19: note: virtual Stream* BaseStream::makeSubStream(Goffset, GBool, Goffset, Object*)
/usr/include/poppler/Stream.h:323:16: note: virtual void BaseStream::moveStart(Goffset)
pdfdataset.cpp:623:67: warning: ignoring return value of 'char* fgets(char*, int, FILE*)', declared with attribute warn_unused_result [-Wunused-result]
make[2]: *** [../o/pdfdataset.o] Error 1
make[2]: Leaving directory `/var/tmp/portage/sci-libs/gdal-1.9.2/work/gdal-1.9.2/frmts/pdf'
make[1]: *** [pdf-install-obj] Error 2
make[1]: Leaving directory `/var/tmp/portage/sci-libs/gdal-1.9.2/work/gdal-1.9.2/frmts'
make: *** [frmts-target] Error 2
* ERROR: sci-libs/gdal-1.9.2::gentoo failed (compile phase):
* emake failed


So some header files are not the proper versions...
Back to top
View user's profile Send private message
TomWij
Developer
Developer


Joined: 04 Jul 2012
Posts: 1342

PostPosted: Mon Nov 04, 2013 1:31 pm    Post subject: Reply with quote

This is tracked in https://bugs.gentoo.org/show_bug.cgi?id=490046
Back to top
View user's profile Send private message
Progman3K
Guru
Guru


Joined: 03 Jan 2004
Posts: 520

PostPosted: Mon Nov 04, 2013 1:32 pm    Post subject: Reply with quote

According to this post, https://forums.gentoo.org/viewtopic-t-932640-highlight-gdal.html

Compiling gdal without pdf support (removing pdf from gdal's USE flags) would permit gdal to build but of course, you lose pdf support
Back to top
View user's profile Send private message
Progman3K
Guru
Guru


Joined: 03 Jan 2004
Posts: 520

PostPosted: Mon Nov 04, 2013 1:35 pm    Post subject: Reply with quote

TomWij wrote:
This is tracked in https://bugs.gentoo.org/show_bug.cgi?id=490046


Thank you TomWij! If I understand, this result is from a security update, which users should definitely apply.

The safe course of action is to compile without the pdf USE flag to get the patch and wait for a future update which fixes the compilation issue.

Thanks again, TomWij!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum