Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
cannot emerge any package
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
siaton
n00b
n00b


Joined: 15 Oct 2013
Posts: 16

PostPosted: Tue Oct 15, 2013 4:34 pm    Post subject: cannot emerge any package Reply with quote

Running
emerge sys-apps/portage
with portage-2.2.1 and python2.6
gives

Traceback (most recent call last):
File "/usr/bin/emerge", line 50, in <module>
retval = emerge_main()
File "/usr/lib64/portage/pym/_emerge/main.py", line 1030, in emerge_main
return run_action(emerge_config)
File "/usr/lib64/portage/pym/_emerge/actions.py", line 4025, in run_action
emerge_config.target_config, emerge_config.opts)
File "/usr/lib64/portage/pym/portage/proxy/objectproxy.py", line 31, in __call__
return result(*args, **kwargs)
File "/usr/lib64/portage/pym/_emerge/post_emerge.py", line 43, in display_news_notification
news_counts = count_unread_news(portdb, vardb)
File "/usr/lib64/portage/pym/portage/news.py", line 388, in count_unread_news
count = manager.getUnreadItems(repo, update=True)
File "/usr/lib64/portage/pym/portage/news.py", line 175, in getUnreadItems
self.updateItems(repoid)
File "/usr/lib64/portage/pym/portage/news.py", line 151, in updateItems
"".join("%s\n" % x for x in sorted(unread)))
File "/usr/lib64/portage/pym/portage/util/__init__.py", line 1339, in write_atomic
f = atomic_ofstream(file_path, **kwargs)
File "/usr/lib64/portage/pym/portage/util/__init__.py", line 1240, in __init__
mode=mode, **kargs))
TypeError: open() keywords must be strings

I already reinstalled portage manually without any change.

Amy help much appreciated.

Werner
Back to top
View user's profile Send private message
Clad in Sky
l33t
l33t


Joined: 04 May 2007
Posts: 753
Location: Germany

PostPosted: Wed Oct 16, 2013 5:47 am    Post subject: Reply with quote

Are there some more error messages?
I've had a similar issue recently and in fact I was lacking space on /root.
What does df -h say?
_________________
Kali Ma
Now it's autumn of the aeons
Dance with your sword
Now it's time for the harvest
Back to top
View user's profile Send private message
siaton
n00b
n00b


Joined: 15 Oct 2013
Posts: 16

PostPosted: Wed Oct 16, 2013 12:38 pm    Post subject: cannot emerge any package Reply with quote

All my partitions have definitely enough space. What I have is an old system which I have recently updated with a new gcc and binutils. But I wasn't able to update the whole system. emerge was nevertheless working after the gcc upgrade.[/url]

There have been users with similar problems which are related to UNICODE conversions which python versions <= 2.6 couldn't handle properly:

http://www.google.ch/url?sa=t&rct=j&q=&esrc=s&source=web&cd=6&cad=rja&ved=0CFQQFjAF&url=http%3A%2F%2Fcuu508.wordpress.com%2F2011%2F01%2F27%2Fkeywords-must-be-strings%2F&ei=Q4ZeUqzCJ4KytAaksIHQAw&usg=AFQjCNGTz09mK0H9xO8hUQ5uVh4T_ypT4Q&bvm=bv.54176721,d.Yms

I was thinking about to manually install python v2.7. Is this possible?

Werner

Added closing tag to the link. -- desultory
Back to top
View user's profile Send private message
666threesixes666
Veteran
Veteran


Joined: 31 May 2011
Posts: 1223
Location: 42.68n 85.41w

PostPosted: Wed Oct 16, 2013 12:53 pm    Post subject: Reply with quote

as root

eselect python list
eselect python set python3.2

python3.2 is what portage shipped with on my systems, and is known to work under those for me. 2.6 2.7 probably not so much, there are big big differences in python between 2.x series and 3.x
_________________
cat /etc/*-release
Funtoo Linux - baselayout 2.2.0
consider this warning no. 1
http://ecx.images-amazon.com/images/I/81Ku-vxIb3L._SL1500_.jpg
http://wiki.gentoo.org/wiki/Special:Contributions/666threesixes666
Back to top
View user's profile Send private message
gringo
Advocate
Advocate


Joined: 27 Apr 2003
Posts: 3706

PostPosted: Wed Oct 16, 2013 1:25 pm    Post subject: Reply with quote

maybe related to https://forums.gentoo.org/viewtopic-p-7399786.html ?
if it is perhaps manually upgrading portage ( as described here -> http://www.gentoo.org/proj/en/portage/doc/manually-fixing-portage.xml ) to the latest one helps ?

Make sure to run python-updater in case you switch to 3.x.

cheers
Back to top
View user's profile Send private message
siaton
n00b
n00b


Joined: 15 Oct 2013
Posts: 16

PostPosted: Wed Oct 16, 2013 2:32 pm    Post subject: cannot emerge any package Reply with quote

A small step forward. I manually installed portage-2.2.7 according to

[/http://www.gentoo.org/proj/en/portage/doc/manually-fixing-portage.xml]

I didn't copied the directories bin cnf doc man misc which arenot in portage-2.2.1.

I was able to run emerge sys-apps/portage and emerge --sync but when trying to emerge portage-utils
the TypeError popped up again:

>>> Completed installing portage-utils-0.30 into /var/tmp/portage/app-portage/portage-utils-0.30/image/

Quote:
Traceback (most recent call last):
File "/usr/bin/emerge", line 50, in <module>
retval = emerge_main()
.....
.....
File "/usr/lib64/portage/pym/portage/util/__init__.py", line 1240, in __init__
mode=mode, **kargs))
TypeError: open() keywords must be strings


Currently I see only two options to proceed:

1.Manually installing portage-2.2.7
- trying to upgrade python to v.2.7
- emerging portage-2.2.1 again
2. Manually installing python-2.7 if possible.

Any hints appreciated.

Added link tags, as the surrounding punctuation was preventing correct link generation. -- desultory
Back to top
View user's profile Send private message
siaton
n00b
n00b


Joined: 15 Oct 2013
Posts: 16

PostPosted: Wed Oct 16, 2013 7:42 pm    Post subject: Solved: cannot emerge any package Reply with quote

After manually installing portage-2.2.7 I was able to emerge python-3.2.

Then I did

Quote:
eselect python set python3.2


and started

Quote:
python-updater


I am still in this update process since I have an old system.

I emerged portage (v.2.2.1) and was able to work with this version.

I don't know the root cause of this problem but I am happy to have again a system I can work with.

Thanks to all who replied.
Back to top
View user's profile Send private message
chiefbag
Guru
Guru


Joined: 01 Oct 2010
Posts: 440
Location: The Kingdom of Kerry

PostPosted: Thu Oct 17, 2013 9:25 am    Post subject: Reply with quote

This worked for me:

Code:
eselect python set python3.2


Code:
python-updater
# python-updater
 * Starting Python Updater from 2.7 to 3.2 :
 * No packages needs to be remerged.


For good measure:

Code:
emerge --oneshot portage

_________________
A place for useful technical information
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum