Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
SYSTEMD LVM2 MDADM and UDEV Problems
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
bmadonna1401
n00b
n00b


Joined: 31 Jul 2009
Posts: 22
Location: Washington, DC

PostPosted: Mon Oct 14, 2013 10:20 pm    Post subject: SYSTEMD LVM2 MDADM and UDEV Problems Reply with quote

Good Afternoon Everyone,

I've been searching the web and forums for a few days now and haven't seen anything to help me resolve wanting to run systemd alogn with lvm2 and mdadm at the same time. I've seen peopel with the same problem as me but none of the susgestions have helped Any susgestions in resolving this would be greatly appreciated please see the attached info for my problem:


bmadonnaster@funtoo ~ $ sudo emerge systemd

* IMPORTANT: 12 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.

Calculating dependencies... done!
[ebuild N ] dev-libs/gobject-introspection-1.36.0-r1 USE="-cairo -doctool {-test}" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7"
[ebuild N ] dev-lang/swig-2.0.11 USE="pcre -ccache -doc"
[ebuild N ] sys-libs/libcap-ng-0.7.3-r1000 USE="python static-libs" PYTHON_ABIS="2.7 3.3 -2.6 -3.1 -3.2 (-3.4)"
[ebuild N ] sys-process/audit-2.2.2 USE="python -ldap (-prelude)"
[ebuild N ] sys-apps/systemd-208-r2 USE="acl audit cryptsetup doc filecaps firmware-loader gudev introspection kmod lzma pam policykit python tcpd xattr -gcrypt -http -qrcode (-selinux) {-test} -vanilla" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7"
[ebuild N ] sys-apps/gentoo-systemd-integration-2
[blocks B ] sys-apps/systemd ("sys-apps/systemd" is blocking sys-fs/udev-204)
[blocks B ] sys-fs/udev ("sys-fs/udev" is blocking sys-apps/systemd-208-r2)

* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.

(sys-fs/udev-204::gentoo, installed) pulled in by
>=sys-fs/udev-197-r8[gudev?,hwdb?,introspection?,keymap?,kmod?,selinux?,static-libs?] (>=sys-fs/udev-197-r8[gudev,hwdb,kmod,static-libs]) required by (virtual/udev-197-r3::gentoo, installed)
>=sys-fs/udev-151-r4 required by (sys-fs/lvm2-2.02.95-r2::gentoo, installed)

(sys-apps/systemd-208-r2::gentoo, ebuild scheduled for merge) pulled in by
systemd
>=sys-apps/systemd-207 required by (sys-apps/gentoo-systemd-integration-2::gentoo, ebuild scheduled for merge)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


sudo emerge --info
Portage 2.3.6-r5 (funtoo/1.0/linux-gnu/arch/x86-64bit, gcc-4.8.1, glibc-2.15-r4, 3.11.4-gentoo x86_64)
=================================================================
System uname: Linux-3.11.4-gentoo-x86_64-AMD_FX-tm-8350_Eight-Core_Processor-with-gentoo-2.2.0
KiB Mem: 16338820 total, 13654984 free
KiB Swap: 33554416 total, 33554416 free
Timestamp of tree: Sun, 13 Oct 2013 23:45:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
app-shells/bash: 4.2_p45-r1
dev-java/java-config: 2.2.0-r1000
dev-lang/python: 2.7.5-r1000, 3.3.2-r1000
dev-util/cmake: 2.8.11.2
sys-apps/baselayout: 2.2.0-r4
sys-apps/openrc: 0.12.1
sys-apps/sandbox: 2.6-r2
sys-devel/autoconf: 2.13, 2.69
sys-devel/automake: 1.11.6, 1.12.6, 1.13.4
sys-devel/binutils: 2.23.1
sys-devel/gcc: 4.6.4-r2, 4.8.1-r3
sys-devel/gcc-config: 1.8
sys-devel/libtool: 2.4.2
sys-devel/make: 3.82-r4
sys-kernel/linux-headers: 3.4-r2 (virtual/os-headers)
sys-libs/glibc: 2.15-r4
Repositories: gentoo
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=barcelona -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=barcelona -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--jobs=8 --load-average=16 --keep-going=y --with-bdeps=y --complete-graph"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--sort-common -Wl,--as-needed"
MAKEOPTS="-j9"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="git://github.com/funtoo/ports-2012.git"
SYNC_USER="root"
USE="X acl adobe-flash alsa amd64 apng asyncns bash-completion berkdb bluetooth busybox bzip2 cdr chromium consolekit cracklib crypt cups cxx dbus device-mapper dmraid dri dvd dvdr dvdread flac flash gdbm gif google gpm gtk handbook iconv icu ipv6 jpeg kde lame mad mdraid mem-scramble mmx modules mp3 mpeg mudflap multilib ncurses net nls nptl ogg opengl openmp pam pcre png policykit pppd pulseaudio python readline resolvconf semantic-desktop spell sse sse2 ssl static-libs sudo tcpd tiff truetype udev udidisks unicode vorbis wavpack webrtc-aec win32codecs xml zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel ice1724 intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw copy dshare dsnoop extplug file hooks ladspa lfloat linear meter mulaw multi null rate route share shm" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias authn_core authz_core socache_shmcb unixd" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" DRACUT_MODULES="dmraid lvm mdraid ssh-client dm device-mapper dracut_modules_lvm" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" GRUB_PLATFORMS="efi-32 efi-64 pc" INPUT_DEVICES="evdev synaptics keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_ABIS="2.7 3.3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" QEMU_SOFTMMU_TARGETS="i386 x86_64" QEMU_USER_TARGETS="i386 x86_64" RUBY_TARGETS="ruby18 ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="nouveau" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset: CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, SYNC_UMASK


cat package.keywords
net-im/skype
# required by sys-apps/systemd-208-r2
# required by sys-apps/gentoo-systemd-integration-2
=sys-apps/hwids-99999999 **
sys-apps/hwids
virtual/udev
sys-fs/udev
>=sys-apps/systemd-208-r2

/etc/portage $ cat package.license
# required by adobe-flash (argument)
>=www-plugins/adobe-flash-11.2.202.310-r1 AdobeFlash-11.x
net-im/skype skype-eula

cat package.mask
sys-fs/udev
sys-fs/eudev

/etc/portage $ cat package.use
x11-apps/xinit -minimal
>=media-gfx/exiv2-0.23-r1 xmp

# required by media-sound/paprefs-0.9.10
# required by paprefs (argument)
>=media-sound/pulseaudio-4.0 gnome
# required by sys-power/upower-0.9.20-r1
# required by kde-base/kdelibs-4.11.2-r1[upower]
# required by kde-base/kdm-4.11.2
# required by kde-base/kdebase-meta-4.11.2
# required by kde-base/kde-meta-4.11.2-r1
# required by @selected
# required by @world (argument)
>=virtual/udev-197-r3 hwdb gudev
>=sys-apps/systemd-208-r2 USE="acl audit cryptsetup mdadm lvm doc efi gudev introspection kmod lzma pam python tcpd xattr -gcrypt -http -qrcode (-selinux) -vanilla" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7"
Back to top
View user's profile Send private message
eyoung100
Veteran
Veteran


Joined: 23 Jan 2004
Posts: 1421

PostPosted: Mon Oct 14, 2013 10:52 pm    Post subject: Reply with quote

Follow the Gentoo Wiki: Systemd. In a nutshell:

Code:
emerge portage-utils ufed
equery hasuse systemd >> ~/systemd.packages
nano -w systemd.packages <-- All these packages must be compiled with the systemd use flag before removing udev
ufed<--Enable systemd USE Flag, Enable openrc USE Flag if something doesnt work
sudo emerge -uN world <-- Add systemd Support
Empty out package.mask


Now, you must do the next command all in one swoop, as you're system will be unbootable otherwise:
Code:
emerge -C sys-fs/udev virtual/udev && emerge -av sys-apps/systemd

_________________
The Birth and Growth of Science is the Death and Atrophy of Art -- Unknown
Registerd Linux User #363735
Adopt a Post | Strip Comments| Emerge Wrapper
Back to top
View user's profile Send private message
bmadonna1401
n00b
n00b


Joined: 31 Jul 2009
Posts: 22
Location: Washington, DC

PostPosted: Tue Oct 15, 2013 1:50 am    Post subject: Didn't help Reply with quote

I"m still getting a dependency loop and am unable to run ufed because I am running funtoo. I'm wondering if there is something that Funtoo is blocking. I wouldn't think funtoo is that much different then Gentoo but who knows.
Back to top
View user's profile Send private message
eyoung100
Veteran
Veteran


Joined: 23 Jan 2004
Posts: 1421

PostPosted: Tue Oct 15, 2013 1:38 pm    Post subject: Re: Didn't help Reply with quote

bmadonna1401 wrote:
I"m still getting a dependency loop and am unable to run ufed because I am running funtoo. I'm wondering if there is something that Funtoo is blocking. I wouldn't think funtoo is that much different then Gentoo but who knows.


Post Please...
_________________
The Birth and Growth of Science is the Death and Atrophy of Art -- Unknown
Registerd Linux User #363735
Adopt a Post | Strip Comments| Emerge Wrapper
Back to top
View user's profile Send private message
bmadonna1401
n00b
n00b


Joined: 31 Jul 2009
Posts: 22
Location: Washington, DC

PostPosted: Wed Oct 16, 2013 2:23 am    Post subject: Ufed Reply with quote

bmadonnaster@funtoo ~ $ sudo ufed
/etc{,/portage}/make.profile is not a symlink
INIT failed--call queue aborted.

$ ls
parent
bmadonnaster@funtoo /etc/portage/make.profile $ cat /etc/portage/make.profile/parent
gentoo:funtoo/1.0/linux-gnu/arch/x86-64bit
gentoo:funtoo/1.0/linux-gnu/build/current
gentoo:funtoo/1.0/linux-gnu/flavor/desktop
gentoo:funtoo/1.0/linux-gnu/mix-ins/audio
gentoo:funtoo/1.0/linux-gnu/mix-ins/dvd
gentoo:funtoo/1.0/linux-gnu/mix-ins/kde
gentoo:funtoo/1.0/linux-gnu/mix-ins/print
gentoo:funtoo/1.0/linux-gnu/mix-ins/X
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum