Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Update error. Slot conflicts. Abi and x11-libs
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
kaszynek
n00b
n00b


Joined: 22 Mar 2011
Posts: 44
Location: Warsaw, Poland

PostPosted: Tue Oct 08, 2013 10:00 pm    Post subject: [SOLVED] Update error. Slot conflicts. Abi and x11-libs Reply with quote

After while of not using my gentoo I'm trying to update whole system.

I'm not able to emerge system. I get a lot of errors "Multiple packages in same slot". Thats full error: http://bpaste.net/show/138863/

It seems to be partially similar to problem with abi https://forums.gentoo.org/viewtopic-p-7412800.html
How can I resolve that problem?

Code:



!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

net-libs/libsoup:2.4

  (net-libs/libsoup-2.42.2-r1::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (net-libs/libsoup-2.40.3::gentoo, installed) pulled in by
    ~net-libs/libsoup-2.40.3[introspection?] required by (net-libs/libsoup-gnome-2.40.3::gentoo, installed)

kde-base/kdelibs:4

  (kde-base/kdelibs-4.10.2::gentoo, installed) pulled in by
    >=kde-base/kdelibs-4.10.2:4[-aqua,semantic-desktop] required by (kde-base/nepomuk-4.10.2::gentoo, installed)
  ...
    >=kde-base/kdelibs-4.10.2:4[-aqua,semantic-desktop] required by (kde-base/dolphin-4.10.2::gentoo, installed)

  (kde-base/kdelibs-4.11.1::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-base/kdelibs-4.11.1:4[aqua=] required by (kde-base/kdesu-4.11.1::gentoo, ebuild scheduled for merge)
    (and 8 more with the same problem)

dev-libs/boost:0

  (dev-libs/boost-1.53.0::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/boost-1.52.0-r6::gentoo, installed) pulled in by
    dev-libs/boost:0/1.52= required by (kde-base/kdepim-runtime-4.10.2::gentoo, installed)
    >=dev-libs/boost-1.43:0/1.52= required by (kde-base/rocs-4.10.2::gentoo, installed)
    dev-libs/boost:0/1.52= required by (kde-base/kleopatra-4.10.2::gentoo, installed)
    (and 1 more with the same problems)

app-text/poppler:0

  (app-text/poppler-0.22.3::gentoo, installed) pulled in by
    >=app-text/poppler-0.20:0/36=[cairo] required by (app-text/evince-3.6.1::gentoo, installed)
    app-text/poppler:0/36=[qt4] required by (app-office/texmaker-4.0.1::gentoo, installed)
    app-text/poppler:0/36=[xpdf-headers(+)] required by (dev-tex/luatex-0.70.1-r2::gentoo, installed)
    (and 2 more with the same problems)

  (app-text/poppler-0.24.2::gentoo, ebuild scheduled for merge) pulled in by
    app-text/poppler:=[cxx,jpeg?,lcms,tiff?,xpdf-headers(+)] required by (net-print/cups-filters-1.0.36-r2::gentoo, ebuild scheduled for merge)



 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (media-libs/glu-9.0.0-r1::gentoo, ebuild scheduled for merge) pulled in by
    media-libs/glu[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] (media-libs/glu[abi_x86_32(-),abi_x86_64(-)]) required by (virtual/glu-9.0-r1::gentoo, ebuild scheduled for merge)

  (media-libs/freetype-2.5.0.1::gentoo, ebuild scheduled for merge) pulled in by
    media-libs/freetype required by (sys-boot/grub-2.00-r2::gentoo, installed)
  ...
 
    media-libs/freetype[abi_x86_32] required by (app-emulation/emul-linux-x86-xlibs-20130224-r1::gentoo, installed)
    >=media-libs/freetype-2.2.1[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] (>=media-libs/freetype-2.2.1[abi_x86_32(-),abi_x86_64(-)]) required by (media-libs/fontconfig-2.10.93::gentoo, ebuild scheduled for merge)

  (media-libs/xvid-1.3.2-r1::gentoo, ebuild scheduled for merge) pulled in by
    media-libs/xvid required by (media-plugins/gst-plugins-xvid-0.10.23::gentoo, installed)
    media-libs/xvid required by (media-video/mplayer-1.1-r1::gentoo, installed)
    >=media-libs/xvid-1.1.0 required by (media-video/ffmpeg-1.2.3::gentoo, ebuild scheduled for merge)

  (media-libs/speex-1.2_rc1-r2::gentoo, ebuild scheduled for merge) pulled in by
    >=media-libs/speex-1.2_rc1 required by (media-sound/pulseaudio-4.0::gentoo, ebuild scheduled for merge)
    media-libs/speex required by (media-video/mplayer-1.1-r1::gentoo, installed)

  (x11-libs/libXext-1.3.2::gentoo, ebuild scheduled for merge) pulled in by
    x11-libs/libXext required by (kde-base/kig-4.10.2::gentoo, installed)
    ...
     x11-libs/libXext[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] (x11-libs/libXext[abi_x86_32(-),abi_x86_64(-)]) required by (x11-libs/libXrandr-1.4.2::gentoo, ebuild scheduled for merge)

  (media-libs/libdvdnav-4.2.0-r1::gentoo, ebuild scheduled for merge) pulled in by
    >=media-libs/libdvdnav-0.1.9 required by (media-video/vlc-2.0.6::gentoo, installed)
    >=media-libs/libdvdnav-4.1.3 required by (media-video/mplayer-1.1-r1::gentoo, installed)
    >=media-libs/libdvdnav-4.1.2 required by (media-plugins/gst-plugins-resindvd-0.10.23::gentoo, installed)

  (media-libs/x264-0.0.20130912::gentoo, ebuild scheduled for merge) pulled in by
    >=media-libs/x264-0.0.20090923:= required by (media-video/vlc-2.0.6::gentoo, installed)
    >=media-libs/x264-0.0.20111220:= required by (media-plugins/gst-plugins-x264-0.10.19::gentoo, installed)
    >=media-libs/x264-0.0.20111017 required by (media-video/ffmpeg-1.2.3::gentoo, ebuild scheduled for merge)
    >=media-libs/x264-0.0.20100423 required by (media-video/mplayer-1.1-r1::gentoo, installed)

  (media-libs/a52dec-0.7.4-r7::gentoo, ebuild scheduled for merge) pulled in by
    media-libs/a52dec required by (media-video/mplayer-1.1-r1::gentoo, installed)
    >=media-libs/a52dec-0.7.3 required by (media-plugins/gst-plugins-a52dec-0.10.19::gentoo, installed)
    >=media-libs/a52dec-0.7.4-r3 required by (media-video/vlc-2.0.6::gentoo, installed)

  (media-libs/libvorbis-1.3.3-r1::gentoo, ebuild scheduled for merge) pulled in by
    media-libs/libvorbis required by (media-video/ffmpeg-1.2.3::gentoo, ebuild scheduled for merge)
    ...
    media-libs/libvorbis:= required by (media-libs/libtheora-1.1.1-r1::gentoo, ebuild scheduled for merge)

  (media-libs/faad2-2.7-r3::gentoo, ebuild scheduled for merge) pulled in by
    media-libs/faad2 required by (media-video/mplayer-1.1-r1::gentoo, installed)
    media-libs/faad2 required by (media-plugins/gst-plugins-faad-0.10.23::gentoo, installed)
    >=media-libs/faad2-2.6.1 required by (media-video/vlc-2.0.6::gentoo, installed)

  (media-libs/libmpeg2-0.5.1-r2::gentoo, ebuild scheduled for merge) pulled in by
    >=media-libs/libmpeg2-0.4 required by (media-plugins/gst-plugins-mpeg2dec-0.10.19::gentoo, installed)
    >=media-libs/libmpeg2-0.3.2 required by (media-video/vlc-2.0.6::gentoo, installed)

  (x11-libs/libXt-1.1.4::gentoo, ebuild scheduled for merge) pulled in by
    x11-libs/libXt required by (kde-base/kjots-4.10.2::gentoo, installed)
  ...
    x11-libs/libXt[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] (x11-libs/libXt[abi_x86_32(-),abi_x86_64(-)]) required by (x11-libs/libXaw-1.0.12::gentoo, ebuild scheduled for merge)

  (media-libs/fontconfig-2.10.93::gentoo, ebuild scheduled for merge) pulled in by
    media-libs/fontconfig required by (www-plugins/adobe-flash-11.2.202.280::gentoo, installed)
    ...
    media-libs/fontconfig[abi_x86_32] required by (app-emulation/emul-linux-x86-xlibs-20130224-r1::gentoo, installed)

  (media-libs/libsamplerate-0.1.8-r1::gentoo, ebuild scheduled for merge) pulled in by
    media-libs/libsamplerate required by (media-plugins/alsa-plugins-1.0.27::gentoo, ebuild scheduled for merge)
    ...
    media-libs/libsamplerate required by (net-misc/rdesktop-1.7.1::gentoo, installed)

  (media-libs/libdca-0.0.5-r3::gentoo, ebuild scheduled for merge) pulled in by
    media-libs/libdca required by (media-video/mplayer-1.1-r1::gentoo, installed)
  ...
    media-libs/libdca required by (media-plugins/gst-plugins-dts-0.10.23::gentoo, installed)

  (media-libs/libtheora-1.1.1-r1::gentoo, ebuild scheduled for merge) pulled in by
    media-libs/libtheora[encode] required by (media-video/recordmydesktop-0.3.8.1-r4::gentoo, installed)
    media-libs/libtheora[encode] required by (media-video/mplayer-1.1-r1::gentoo, installed)

  (app-emulation/emul-linux-x86-soundlibs-20130224::gentoo, installed) pulled in by
    >=app-emulation/emul-linux-x86-soundlibs-20120520 required by (net-im/skype-4.1.0.20::gentoo, installed)
    ~app-emulation/emul-linux-x86-soundlibs-20130224 required by (app-emulation/emul-linux-x86-medialibs-20130224::gentoo, installed)

  (x11-libs/libXmu-1.1.2::gentoo, ebuild scheduled for merge) pulled in by
    x11-libs/libXmu required by (app-text/texlive-core-2012-r1::gentoo, installed)
    ...
    x11-libs/libXmu[abi_x86_32] required by (app-emulation/emul-linux-x86-xlibs-20130224-r1::gentoo, installed)

  (media-libs/libmad-0.15.1b-r8::gentoo, ebuild scheduled for merge) pulled in by
    >=media-libs/libmad-0.14.2b required by (media-sound/audacity-2.0.3::gentoo, installed)
    ...
    media-libs/libmad required by (media-video/vlc-2.0.6::gentoo, installed)

  (media-sound/musepack-tools-465-r1::gentoo, ebuild scheduled for merge) pulled in by
    >=media-sound/musepack-tools-444 required by (media-plugins/gst-plugins-musepack-0.10.23::gentoo, installed)
    >=media-sound/musepack-tools-444 required by (media-video/vlc-2.0.6::gentoo, installed)

  (x11-libs/libxcb-1.9.1::gentoo, ebuild scheduled for merge) pulled in by
    x11-libs/libxcb required by (app-emulation/vmware-workstation-9.0.2.1031769::gentoo, installed)
    ...
    >=x11-libs/libxcb-1.8.1[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] (>=x11-libs/libxcb-1.8.1[abi_x86_32(-),abi_x86_64(-)]) required by (x11-libs/libX11-1.6.2::gentoo, ebuild scheduled for merge)

  (x11-libs/libSM-1.2.2::gentoo, ebuild scheduled for merge) pulled in by
    x11-libs/libSM required by (xfce-base/xfdesktop-4.10.2::gentoo, installed)
    ...
    x11-libs/libSM required by (media-libs/libmpeg2-0.5.1-r2::gentoo, ebuild scheduled for merge)

  (x11-libs/libXaw-1.0.12::gentoo, ebuild scheduled for merge) pulled in by
    x11-libs/libXaw required by (app-editors/xemacs-21.5.31::gentoo, installed)
    ...
    x11-libs/libXaw[abi_x86_32] required by (app-emulation/emul-linux-x86-xlibs-20130224-r1::gentoo, installed)

  (x11-libs/libXi-1.7.2::gentoo, ebuild scheduled for merge) pulled in by
    x11-libs/libXi required by (dev-java/oracle-jdk-bin-1.7.0.40::gentoo, installed)
    ...
    x11-libs/libXi[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] (x11-libs/libXi[abi_x86_32(-),abi_x86_64(-)]) required by (x11-libs/libXtst-1.2.2::gentoo, ebuild scheduled for merge)

  (media-libs/libv4l-1.0.0::gentoo, ebuild scheduled for merge) pulled in by
    media-libs/libv4l required by (media-plugins/gst-plugins-v4l2-1.0.6::gentoo, installed)
    ...
    media-libs/libv4l required by (app-emulation/wine-1.5.28::gentoo, installed)

  (x11-libs/libvdpau-0.7::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-libs/libvdpau-0.3-r1 required by (x11-drivers/nvidia-drivers-313.30::gentoo, installed)
    ...
    >=x11-libs/libvdpau-0.4.1[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] (>=x11-libs/libvdpau-0.4.1[abi_x86_32(-),abi_x86_64(-)]) required by (media-libs/mesa-9.2.0-r1::gentoo, ebuild scheduled for merge)

  (app-emulation/emul-linux-x86-xlibs-20130224-r1::gentoo, installed) pulled in by
    ~app-emulation/emul-linux-x86-xlibs-20130224 required by (app-emulation/emul-linux-x86-sdl-20130224::gentoo, installed)
    ...
    >=app-emulation/emul-linux-x86-xlibs-20100611 required by (app-emulation/emul-linux-x86-opengl-20130224::gentoo, installed)

  (media-sound/lame-3.99.5-r1::gentoo, ebuild scheduled for merge) pulled in by
    media-sound/lame required by (media-video/mplayer-1.1-r1::gentoo, installed)
    >=media-sound/lame-3.70 required by (media-sound/audacity-2.0.3::gentoo, installed)
    >=media-sound/lame-3.98.3 required by (media-video/ffmpeg-1.2.3::gentoo, ebuild scheduled for merge)

  (x11-libs/libXrender-0.9.8::gentoo, ebuild scheduled for merge) pulled in by
    x11-libs/libXrender required by (x11-apps/x11perf-1.5.4::gentoo, installed)
    ...
    x11-libs/libXrender[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] (x11-libs/libXrender[abi_x86_32(-),abi_x86_64(-)]) required by (x11-libs/libXrandr-1.4.2::gentoo, ebuild scheduled for merge)

  (x11-libs/libX11-1.6.2::gentoo, ebuild scheduled for merge) pulled in by
    x11-libs/libX11 required by (x11-apps/xset-1.2.3::gentoo, ebuild scheduled for merge)
    ...
    x11-libs/libX11[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] (x11-libs/libX11[abi_x86_32(-),abi_x86_64(-)]) required by (x11-libs/libXmu-1.1.2::gentoo, ebuild scheduled for merge)

  (app-emulation/emul-linux-x86-medialibs-20130224::gentoo, installed) pulled in by
    ~app-emulation/emul-linux-x86-medialibs-20130224 required by (app-emulation/emul-linux-x86-sdl-20130224::gentoo, installed)
    ...
    ~app-emulation/emul-linux-x86-medialibs-20130224 required by (app-emulation/emul-linux-x86-soundlibs-20130224::gentoo, installed)

  (x11-libs/libXvMC-1.0.8::gentoo, ebuild scheduled for merge) pulled in by
    x11-libs/libXvMC required by (media-video/mplayer-1.1-r1::gentoo, installed)
    ...
    >=x11-libs/libXvMC-1.0.6[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] (>=x11-libs/libXvMC-1.0.6[abi_x86_32(-),abi_x86_64(-)]) required by (media-libs/mesa-9.2.0-r1::gentoo, ebuild scheduled for merge)

  (media-libs/alsa-lib-1.0.27.2::gentoo, ebuild scheduled for merge) pulled in by
    media-libs/alsa-lib required by (app-editors/xemacs-21.5.31::gentoo, installed)
    ...
    media-libs/alsa-lib required by (media-libs/libsndfile-1.0.25-r1::gentoo, ebuild scheduled for merge)

  (media-libs/libsndfile-1.0.25-r1::gentoo, ebuild scheduled for merge) pulled in by
    media-libs/libsndfile required by (kde-base/kgoldrunner-4.10.2::gentoo, installed)
    ...
    >=media-libs/libsndfile-1.0.20 required by (media-sound/pulseaudio-4.0::gentoo, ebuild scheduled for merge)

  (media-libs/flac-1.2.1-r5::gentoo, ebuild scheduled for merge) pulled in by
    >=media-libs/flac-1.1.2 required by (kde-base/audiocd-kio-4.10.2::gentoo, installed)
    ...
    >=media-libs/flac-1.2.1[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] (>=media-libs/flac-1.2.1[abi_x86_32(-),abi_x86_64(-)]) required by (media-libs/audiofile-0.3.6-r1::gentoo, ebuild scheduled for merge)

  (media-libs/audiofile-0.3.6-r1::gentoo, ebuild scheduled for merge) pulled in by
    >=media-libs/audiofile-0.2.3 required by (app-editors/xemacs-21.5.31::gentoo, installed)
    ...
    >=media-libs/audiofile-0.2.3 required by (app-emulation/fuse-utils-1.0.0::gentoo, installed)

  (app-emulation/emul-linux-x86-opengl-20130224::gentoo, installed) pulled in by
    app-emulation/emul-linux-x86-opengl[development] required by (app-emulation/wine-1.5.28::gentoo, installed)
    ...
    app-emulation/emul-linux-x86-opengl required by (app-emulation/emul-linux-x86-xlibs-20130224-r1::gentoo, installed)

  (x11-libs/libdrm-2.4.46-r1::gentoo, ebuild scheduled for merge) pulled in by
    x11-libs/libdrm:0/0= required by (media-libs/clutter-1.12.2::gentoo, installed)
    ...
    >=x11-libs/libdrm-2.4.46[video_cards_freedreno?,video_cards_nouveau?,video_cards_vmware?,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] (>=x11-libs/libdrm-2.4.46[abi_x86_32(-),abi_x86_64(-)]) required by (media-libs/mesa-9.2.0-r1::gentoo, ebuild scheduled for merge)

  (x11-libs/libXrandr-1.4.2::gentoo, ebuild scheduled for merge) pulled in by
    x11-libs/libXrandr required by (x11-wm/fluxbox-1.3.5::gentoo, installed)
    ...
    x11-libs/libXrandr[abi_x86_32] required by (app-emulation/emul-linux-x86-xlibs-20130224-r1::gentoo, installed)

  (x11-libs/libXtst-1.2.2::gentoo, ebuild scheduled for merge) pulled in by
    x11-libs/libXtst required by (kde-base/kscreensaver-4.10.2::gentoo, installed)
    ...
    x11-libs/libXtst[abi_x86_32] required by (app-emulation/emul-linux-x86-xlibs-20130224-r1::gentoo, installed)

  (x11-libs/libXfixes-5.0.1::gentoo, ebuild scheduled for merge) pulled in by
    x11-libs/libXfixes required by (kde-base/kdelibs-4.10.2::gentoo, installed)
    ...
    x11-libs/libXfixes[abi_x86_32] required by (app-emulation/emul-linux-x86-xlibs-20130224-r1::gentoo, installed)

  (x11-libs/libXcursor-1.1.14::gentoo, ebuild scheduled for merge) pulled in by
    x11-libs/libXcursor required by (x11-apps/xsetroot-1.1.1::gentoo, installed)
    ...
    x11-libs/libXcursor[abi_x86_32] required by (app-emulation/emul-linux-x86-xlibs-20130224-r1::gentoo, installed)

  (x11-proto/xproto-7.0.24::gentoo, ebuild scheduled for merge) pulled in by
    x11-proto/xproto required by (x11-apps/iceauth-1.0.6::gentoo, ebuild scheduled for merge)
    ...
    x11-proto/xproto[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] (x11-proto/xproto[abi_x86_32(-),abi_x86_64(-)]) required by (x11-libs/libXau-1.0.8::gentoo, ebuild scheduled for merge)

  (media-libs/libdvdread-4.2.0-r1::gentoo, ebuild scheduled for merge) pulled in by
    media-libs/libdvdread required by (media-plugins/gst-plugins-dvdread-0.10.19::gentoo, installed)
    ...
    >=media-libs/libdvdread-4.2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] (>=media-libs/libdvdread-4.2[abi_x86_32(-),abi_x86_64(-)]) required by (media-libs/libdvdnav-4.2.0-r1::gentoo, ebuild scheduled for merge)

  (x11-libs/libXpm-3.5.11::gentoo, ebuild scheduled for merge) pulled in by
    x11-libs/libXpm required by (app-text/texlive-core-2012-r1::gentoo, installed)
    ...
    x11-libs/libXpm[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] (x11-libs/libXpm[abi_x86_32(-),abi_x86_64(-)]) required by (x11-libs/libXaw-1.0.12::gentoo, ebuild scheduled for merge)

  (x11-proto/xcb-proto-1.8-r3::gentoo, ebuild scheduled for merge) pulled in by
    x11-proto/xcb-proto required by (x11-libs/xcb-util-wm-0.3.9::gentoo, installed)
    >=x11-proto/xcb-proto-1.7.1[python_targets_python2_6(-)?,python_targets_python2_7(-)?,-python_single_target_python2_6(-),-python_single_target_python2_7(-)] (>=x11-proto/xcb-proto-1.7.1[python_targets_python2_7(-),-python_single_target_python2_6(-),-python_single_target_python2_7(-)]) required by (x11-libs/xpyb-1.3.1-r2::gentoo, ebuild scheduled for merge)
    >=x11-proto/xcb-proto-1.7-r1[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,python_targets_python2_6(-)?,python_targets_python2_7(-)?,python_targets_python3_2(-)?,python_targets_python3_3(-)?,python_single_target_python2_6(+)?,python_single_target_python2_7(+)?,python_single_target_python3_2(+)?,python_single_target_python3_3(+)?] (>=x11-proto/xcb-proto-1.7-r1[abi_x86_32(-),abi_x86_64(-),python_targets_python2_7(-),python_targets_python3_2(-),python_targets_python3_3(-),python_single_target_python2_7(+)]) required by (x11-libs/libxcb-1.9.1::gentoo, ebuild scheduled for merge)

  (x11-libs/libXau-1.0.8::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-libs/libXau-1.0.4 required by (x11-base/xorg-server-1.14.3-r1::gentoo, installed)
    x11-libs/libXau required by (kde-base/kdelibs-4.11.1::gentoo, ebuild scheduled for merge)
    ...
    x11-libs/libXau[abi_x86_32] required by (app-emulation/emul-linux-x86-xlibs-20130224-r1::gentoo, installed)

  (x11-libs/libXv-1.0.10::gentoo, ebuild scheduled for merge) pulled in by
    x11-libs/libXv required by (dev-qt/qtgui-4.8.5-r1::gentoo, installed)
    ...
    x11-libs/libXv required by (media-libs/libmpeg2-0.5.1-r2::gentoo, ebuild scheduled for merge)

  (net-libs/libsoup-gnome-2.40.3::gentoo, installed) pulled in by
    >=net-libs/libsoup-gnome-2.26.0 required by (gnome-base/gvfs-1.14.2::gentoo, installed)

  (media-libs/mesa-9.2.0-r1::gentoo, ebuild scheduled for merge) pulled in by
    media-libs/mesa[egl] required by (x11-libs/cairo-1.12.16::gentoo, ebuild scheduled for merge)
    ...
    media-libs/mesa required by (app-emulation/emul-linux-x86-opengl-20130224::gentoo, installed)

  (x11-libs/libXxf86vm-1.1.3::gentoo, ebuild scheduled for merge) pulled in by
    x11-libs/libXxf86vm required by (kde-base/libkdcraw-4.10.2::gentoo, installed)
    ...
    x11-libs/libXxf86vm[abi_x86_32] required by (app-emulation/emul-linux-x86-xlibs-20130224-r1::gentoo, installed)
    x11-libs/libXxf86vm[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] (x11-libs/libXxf86vm[abi_x86_32(-),abi_x86_64(-)]) required by (media-libs/mesa-9.2.0-r1::gentoo, ebuild scheduled for merge)

  (x11-libs/libXinerama-1.1.3::gentoo, ebuild scheduled for merge) pulled in by
    x11-libs/libXinerama required by (x11-misc/xdotool-2.20110530.1::gentoo, installed)
    ...



Last edited by kaszynek on Thu Oct 10, 2013 5:09 am; edited 1 time in total
Back to top
View user's profile Send private message
eyoung100
Veteran
Veteran


Joined: 23 Jan 2004
Posts: 1406

PostPosted: Tue Oct 08, 2013 10:34 pm    Post subject: Reply with quote

Use the post you referred to to solve the Xorg upgrade, then emerge xorg-x11 or xorg-server. Its easier to break lists like this into smaller chunks.
_________________
The Birth and Growth of Science is the Death and Atrophy of Art -- Unknown
Registerd Linux User #363735
Adopt a Post | Strip Comments| Emerge Wrapper
Back to top
View user's profile Send private message
kaszynek
n00b
n00b


Joined: 22 Mar 2011
Posts: 44
Location: Warsaw, Poland

PostPosted: Wed Oct 09, 2013 1:49 pm    Post subject: Reply with quote

Ok, emerging manualy xorg-server and xorg-libs helped me to solve one issue.
Now I still have problem between glibc and gobject-introspection, emul_linux-x86-baselibs. I'm not able to update any of them.

Code:

[ebuild     U  ] dev-libs/glib-2.36.4-r1 [2.34.3] ABI_X86="32%* (64%*) (-x32)" PYTHON_TARGETS="python2_7%* -python2_6%"
[blocks B      ] app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)] ("app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]" is blocking dev-libs/glib-2.36.4-r1)
[blocks B      ] <dev-libs/gobject-introspection-1.36 ("<dev-libs/gobject-introspection-1.36" is blocking dev-libs/glib-2.36.4-r1)
[blocks B      ] <=app-emulation/emul-linux-x86-baselibs-20130224-r9 ("<=app-emulation/emul-linux-x86-baselibs-20130224-r9" is blocking dev-libs/glib-2.36.4-r1)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

Back to top
View user's profile Send private message
eyoung100
Veteran
Veteran


Joined: 23 Jan 2004
Posts: 1406

PostPosted: Wed Oct 09, 2013 2:01 pm    Post subject: Reply with quote

/etc/portage/package.keywords
#Needed By dev-libs/glib-2.36.4-r1
app-emulation/emul-linux-x86-baselibs
dev-libs/gobject-introspection
_________________
The Birth and Growth of Science is the Death and Atrophy of Art -- Unknown
Registerd Linux User #363735
Adopt a Post | Strip Comments| Emerge Wrapper
Back to top
View user's profile Send private message
kaszynek
n00b
n00b


Joined: 22 Mar 2011
Posts: 44
Location: Warsaw, Poland

PostPosted: Wed Oct 09, 2013 2:15 pm    Post subject: Reply with quote

Still same output :/
Back to top
View user's profile Send private message
eyoung100
Veteran
Veteran


Joined: 23 Jan 2004
Posts: 1406

PostPosted: Wed Oct 09, 2013 2:43 pm    Post subject: Reply with quote

After adding package.keywords:
Code:
emerge -C app-emulation/emul-linux-x86-baselibs && emerge app-emulation/emul-linux-x86-baselibs

_________________
The Birth and Growth of Science is the Death and Atrophy of Art -- Unknown
Registerd Linux User #363735
Adopt a Post | Strip Comments| Emerge Wrapper
Back to top
View user's profile Send private message
kaszynek
n00b
n00b


Joined: 22 Mar 2011
Posts: 44
Location: Warsaw, Poland

PostPosted: Wed Oct 09, 2013 3:59 pm    Post subject: Reply with quote

I've got ACCEPT_KEYWORDS="~amd64" in /etc/make.conf. All of them are selected unstable. If I unmarege emul-linux-x86-baselibs than I have same output when I want to emerge it.

Code:

[ebuild  N     ] app-emulation/emul-linux-x86-baselibs-20131008-r1  USE="development" ABI_X86="32"
[blocks B      ] dev-libs/elfutils ("dev-libs/elfutils" is blocking dev-libs/libelf-0.8.13-r2)
[blocks B      ] <dev-libs/gobject-introspection-1.36 ("<dev-libs/gobject-introspection-1.36" is blocking dev-libs/glib-2.36.4-r1)
[blocks B      ] dev-libs/libelf ("dev-libs/libelf" is blocking sys-devel/prelink-20120628, dev-libs/elfutils-0.155)


But now I'm able to emerge gobject-introspection and glib.

Now I'm fighting with emul-linux-x86-opengl

Code:

[blocks B     ] app-emulation/emul-linux-x86-opengl[-abi_x86_32(-)] ("app-emulation/emul-linux-x86-opengl[-abi_x86_32(-)]" is blocking media-libs/mesa-9.2.0-r1, media-libs/glu-9.0.0-r1, x11-libs/libdrm-2.4.46-r1)
[blocks B     ] >=net-libs/libsoup-2.42 (">=net-libs/libsoup-2.42" is blocking net-libs/libsoup-gnome-2.40.3)

Do you know what to do with them?
Back to top
View user's profile Send private message
eyoung100
Veteran
Veteran


Joined: 23 Jan 2004
Posts: 1406

PostPosted: Wed Oct 09, 2013 4:19 pm    Post subject: Reply with quote

Code:
emerge portage-utils
equery depends libsoup-gnome
equery depends mesa
equery depends glu
equery depends libdrm

_________________
The Birth and Growth of Science is the Death and Atrophy of Art -- Unknown
Registerd Linux User #363735
Adopt a Post | Strip Comments| Emerge Wrapper
Back to top
View user's profile Send private message
kaszynek
n00b
n00b


Joined: 22 Mar 2011
Posts: 44
Location: Warsaw, Poland

PostPosted: Wed Oct 09, 2013 4:27 pm    Post subject: Reply with quote

Code:

 * These packages depend on mesa:
app-emulation/emul-linux-x86-opengl-20130224 (media-libs/mesa)
dev-qt/qtgui-4.8.5-r1 (egl ? media-libs/mesa[egl])
dev-qt/qtopenvg-4.8.5 (media-libs/mesa[egl,openvg])
kde-base/kwin-4.10.2 (>=media-libs/mesa-7.10)
media-libs/cogl-1.12.2 (media-libs/mesa[gles2])
virtual/glu-9.0 (<media-libs/mesa-9)
virtual/opengl-7.0 (media-libs/mesa)
www-client/firefox-20.0.1 (>=media-libs/mesa-7.10)
www-client/seamonkey-2.17.1 (>=media-libs/mesa-7.10)
x11-base/xorg-server-1.14.3-r1 (!minimal ? >=media-libs/mesa-8[nptl=])
x11-libs/cairo-1.12.14 (media-libs/mesa[egl])
                       (media-libs/mesa[openvg])
x11-libs/gtk+-3.6.3-r2 (wayland ? media-libs/mesa[egl?,wayland])
x11-libs/libva-1.1.1 (egl ? media-libs/mesa[egl])

 * These packages depend on libsoup-gnome:
gnome-base/gvfs-1.14.2 (http ? >=net-libs/libsoup-gnome-2.26.0)
www-client/epiphany-3.6.1 (>=net-libs/libsoup-gnome-2.39.6:2.4)

 * These packages depend on glu:
app-office/libreoffice-4.0.2.2 (virtual/glu)
dev-games/openscenegraph-3.0.1-r1 (virtual/glu)
dev-java/swt-4.2 (opengl ? virtual/glu)
kde-base/kdeartwork-kscreensaver-4.10.2 (virtual/glu)
kde-base/kinfocenter-4.10.2 (virtual/glu)
kde-base/ksudoku-4.10.2 (virtual/glu)
kde-base/kubrick-4.10.2 (virtual/glu)
media-libs/freeglut-2.8.0-r1 (virtual/glu)
media-libs/glew-1.9.0 (virtual/glu)
media-libs/libsdl-1.2.15-r2 (opengl ? virtual/glu)
media-libs/openimageio-1.1.7 (opengl ? virtual/glu)
sci-mathematics/octave-3.6.4 (opengl ? virtual/glu)
virtual/glu-9.0 (media-libs/glu)
x11-libs/gtkglext-1.2.0-r1 (virtual/glu)
x11-libs/wxGTK-2.8.12.1 (opengl ? virtual/glu)
x11-libs/wxGTK-2.9.4.1 (opengl ? virtual/glu)

 * These packages depend on libdrm:
media-libs/clutter-1.12.2 (x11-libs/libdrm)
media-libs/cogl-1.12.2 (x11-libs/libdrm:0)
media-libs/mesa-9.1.1 (xorg ? x11-libs/libdrm[libkms])
                      (>=x11-libs/libdrm-2.4.42[video_cards_nouveau?,video_cards_vmware?])
                      (video_cards_i915 ? >=x11-libs/libdrm-2.4.42[video_cards_intel])
                      (video_cards_i965 ? >=x11-libs/libdrm-2.4.42[video_cards_intel])
                      (video_cards_intel ? >=x11-libs/libdrm-2.4.42[video_cards_intel])
                      (video_cards_r100 ? >=x11-libs/libdrm-2.4.42[video_cards_radeon])
                      (video_cards_r200 ? >=x11-libs/libdrm-2.4.42[video_cards_radeon])
                      (video_cards_r300 ? >=x11-libs/libdrm-2.4.42[video_cards_radeon])
                      (video_cards_r600 ? >=x11-libs/libdrm-2.4.42[video_cards_radeon])
                      (video_cards_radeon ? >=x11-libs/libdrm-2.4.42[video_cards_radeon])
                      (video_cards_radeonsi ? >=x11-libs/libdrm-2.4.42[video_cards_radeon])
x11-base/xorg-server-1.14.3-r1 (>=x11-libs/libdrm-2.4.20)
x11-libs/libva-1.1.1 (>=x11-libs/libdrm-2.4)

Back to top
View user's profile Send private message
eyoung100
Veteran
Veteran


Joined: 23 Jan 2004
Posts: 1406

PostPosted: Wed Oct 09, 2013 5:19 pm    Post subject: Reply with quote

Using that list, work Backwards, for example:
Code:
emerge -C gnome-base/gvfs www-client/epiphany
emerge -av libsoup <--This should be 2.42(the verion that was blocked previously)


From the looks of the list I assume you're trying to get to GNOME 3.8 :?:
_________________
The Birth and Growth of Science is the Death and Atrophy of Art -- Unknown
Registerd Linux User #363735
Adopt a Post | Strip Comments| Emerge Wrapper
Back to top
View user's profile Send private message
kaszynek
n00b
n00b


Joined: 22 Mar 2011
Posts: 44
Location: Warsaw, Poland

PostPosted: Wed Oct 09, 2013 9:14 pm    Post subject: Reply with quote

Ok, now I was able to update system.
Thanks for help.

Few more questions from me:
1. How had package.keywords helped with first issue? What was it doing?
2. What does deleting of dependent packages do? Why does it help and is it normal way of solving such issue?
Back to top
View user's profile Send private message
eyoung100
Veteran
Veteran


Joined: 23 Jan 2004
Posts: 1406

PostPosted: Wed Oct 09, 2013 9:28 pm    Post subject: Reply with quote

1. Package.keywords is the default way to mix unstable packages on a stable system. I assumed you weren't using ~testing in make.conf. Since you are package.keywords can be emptied.
2. Deleting a dependent package solves the Blocker issues. Most people, after updating their system will attempt to replace the packages removed.
Example:
Code:
emerge -av epiphany


libsoup-gnome was merged into libsoup, so installing epiphany for GNOME 3.8 is now possible, but you couldn't get it installed because the epiphany for GNOME 3.6 needed libsoup-gnome. The blocker was occurring because epiphany was already installed in GNOME 3.6.
_________________
The Birth and Growth of Science is the Death and Atrophy of Art -- Unknown
Registerd Linux User #363735
Adopt a Post | Strip Comments| Emerge Wrapper
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5271

PostPosted: Thu Oct 10, 2013 4:26 am    Post subject: Reply with quote

That merge of libsoup and libsoup-gnome was reverted for the convenience of other packages (even though chances are that in unstable very little of significance depends on libsoup-gnome any longer).
Back to top
View user's profile Send private message
kaszynek
n00b
n00b


Joined: 22 Mar 2011
Posts: 44
Location: Warsaw, Poland

PostPosted: Thu Oct 10, 2013 5:12 am    Post subject: Reply with quote

Thanks for explanation. I will know for the future how to work with such problems.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum