Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] cifs-utils unmet requirements? still?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
Schnulli
Apprentice
Apprentice


Joined: 25 Jun 2010
Posts: 155

PostPosted: Fri Sep 20, 2013 7:23 am    Post subject: [solved] cifs-utils unmet requirements? still? Reply with quote

running a emerge --update --deep --newuse world ends up in....

!!! The ebuild selected to satisfy "net-fs/cifs-utils" has unmet requirements.
- net-fs/cifs-utils-6.1::gentoo USE="acl caps caps-ng -ads -creds -upcall"

The following REQUIRED_USE flag constraints are unsatisfied:
acl? ( upcall )

(dependency required by "net-fs/samba-3.6.18[client]" [ebuild])
(dependency required by "app-misc/mc-4.8.10[samba]" [ebuild])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])


SOLVED

got the reason.....
double slottet >> libpng::0

solution:
emerge --unmerge libpng && emerge libpng
you should check if some other will be removed when unmerging libpng and reinstall


regards


Last edited by Schnulli on Sat Sep 21, 2013 11:12 am; edited 1 time in total
Back to top
View user's profile Send private message
DawgG
Guru
Guru


Joined: 17 Sep 2003
Posts: 595

PostPosted: Fri Sep 20, 2013 8:44 am    Post subject: Reply with quote

so what's your question?
Code:
The following REQUIRED_USE flag constraints are unsatisfied:
acl? ( upcall )

so if you want acl you also need upcall for cifs-utils (and maybe some others).
pass the config you want to the emerge-command or, better, write it to package.use.

btw, it is NOT a good idea to run
Code:
emerge --update --deep --newuse world

only install updates you need and keep your (local) useflags in package.use to avoid situations like this.
GOOD LUCK!
_________________
DUMM KLICKT GUT.
Back to top
View user's profile Send private message
Schnulli
Apprentice
Apprentice


Joined: 25 Jun 2010
Posts: 155

PostPosted: Fri Sep 20, 2013 9:00 am    Post subject: Reply with quote

emerge cifs-utils ends up in the same:

!!! Problem resolving dependencies for net-fs/cifs-utils
... done!

!!! The ebuild selected to satisfy "cifs-utils" has unmet requirements.
- net-fs/cifs-utils-6.1::gentoo USE="acl caps caps-ng -ads -creds -upcall"

The following REQUIRED_USE flag constraints are unsatisfied:
acl? ( upcall )
Back to top
View user's profile Send private message
DawgG
Guru
Guru


Joined: 17 Sep 2003
Posts: 595

PostPosted: Fri Sep 20, 2013 12:47 pm    Post subject: Reply with quote

this:
Quote:
The following REQUIRED_USE flag constraints are unsatisfied:
acl? ( upcall )

means that if you want the acl-useflag then upcall is also required. you ARE certain that you need the acl-useflag?
Code:
USE="acl upcall" emerge -pv1 net-fs/cifs-utils

if you don't need it:
Code:
USE="-acl -upcall" emerge -pv1 net-fs/cifs-utils

should do it.
if there is another pkg that has this as its dep and which you did not intentionally set but use as default because of
Code:
emerge -ND world
you might be pulling in a lot of unintended/unwanted deps.

GOOD LUCK!
_________________
DUMM KLICKT GUT.
Back to top
View user's profile Send private message
Schnulli
Apprentice
Apprentice


Joined: 25 Jun 2010
Posts: 155

PostPosted: Fri Sep 20, 2013 1:26 pm    Post subject: Reply with quote

Hi DAG, ACL benötige ich natürlich nicht "unbedingt"
selbst mit den USE Flags klemmt das mal wieder ^^ nuja, wird schon.

and in english

Hi DAG, i dont need ACL
even with the use flags it dosn work, well, with a few time this will be solved also then ;)

cheers
Back to top
View user's profile Send private message
Hu
Watchman
Watchman


Joined: 06 Mar 2007
Posts: 8592

PostPosted: Fri Sep 20, 2013 5:14 pm    Post subject: Reply with quote

DawgG wrote:
btw, it is NOT a good idea to run
Code:
emerge --update --deep --newuse world
Why not? How does he know whether he needs an update if he never looks at the full list of available updates? How do you decide whether an update is necessary if you want all security fixes, given that the GLSA project falls behind sometimes?

DawgG wrote:
if you don't need it:
Code:
USE="-acl -upcall" emerge -pv1 net-fs/cifs-utils

should do it.
Although this is fine for testing, it should never be advocated for installing a package, since the environment USE flag is not recorded, so the next rebuild will switch back to the saved values.
Back to top
View user's profile Send private message
Schnulli
Apprentice
Apprentice


Joined: 25 Jun 2010
Posts: 155

PostPosted: Sat Sep 21, 2013 11:11 am    Post subject: Reply with quote

got the reason.....
double slottet >> libpng::0

solution:
emerge --unmerge libpng && emerge libpng
you should check if some other will be removed when unmerging libpng and reinstall


regards
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum