Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
mono overlay and blocking
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
akbarstatx
n00b
n00b


Joined: 14 Oct 2002
Posts: 66
Location: Minneapolis, MN

PostPosted: Wed Sep 11, 2013 2:31 am    Post subject: mono overlay and blocking Reply with quote

I have installed a mono ebuild:

quad dev-lang # equery l mono
* Searching for mono ...
[I-O] [ ] dev-lang/mono-3.2.1:0

And now I getting lots of blocked packages durring emerge -auvDN world.

Any help getting these dep's/blocks resolved would be much appreciated.


[blocks B ] dev-dotnet/gconf-sharp ("dev-dotnet/gconf-sharp" is blocking dev-dotnet/gnome-sharp-2.24.2-r1)
[blocks B ] dev-dotnet/gtk-sharp-gapi ("dev-dotnet/gtk-sharp-gapi" is blocking dev-dotnet/gtk-sharp-2.12.21)
[blocks B ] dev-dotnet/pango-sharp ("dev-dotnet/pango-sharp" is blocking dev-dotnet/gtk-sharp-2.12.21)
[blocks B ] dev-dotnet/atk-sharp ("dev-dotnet/atk-sharp" is blocking dev-dotnet/gtk-sharp-2.12.21)
[blocks B ] dev-dotnet/glade-sharp ("dev-dotnet/glade-sharp" is blocking dev-dotnet/gtk-sharp-2.12.21)
[blocks B ] dev-dotnet/gnomevfs-sharp ("dev-dotnet/gnomevfs-sharp" is blocking dev-dotnet/gnome-sharp-2.24.2-r1)
[blocks B ] dev-dotnet/glib-sharp ("dev-dotnet/glib-sharp" is blocking dev-dotnet/gtk-sharp-2.12.21)
[blocks B ] dev-dotnet/gdk-sharp ("dev-dotnet/gdk-sharp" is blocking dev-dotnet/gtk-sharp-2.12.21)
[blocks B ] dev-dotnet/art-sharp ("dev-dotnet/art-sharp" is blocking dev-dotnet/gnome-sharp-2.24.2-r1)

Total: 53 packages (18 upgrades, 1 downgrade, 3 new, 2 in new slots, 29 reinstalls), Size of downloads: 153,227 kB
Conflict: 9 blocks (9 unsatisfied)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-dotnet/gtk-sharp:2

(dev-dotnet/gtk-sharp-2.12.10::gentoo, installed) pulled in by
~dev-dotnet/gtk-sharp-2.12.10 required by (dev-dotnet/glade-sharp-2.12.10::gentoo, ebuild scheduled for merge)

(dev-dotnet/gtk-sharp-2.12.21::dotnet, ebuild scheduled for merge) pulled in by
>=dev-dotnet/gtk-sharp-2.12.21 required by (dev-util/monodevelop-4.0.12::dotnet, ebuild scheduled for merge)
(and 2 more with the same problem)

dev-lang/mono:0

(dev-lang/mono-3.2.1::dotnet, installed) pulled in by
>=dev-lang/mono-3.0 required by (dev-util/monodevelop-4.0.12::dotnet, ebuild scheduled for merge)
(and 2 more with the same problem)

(dev-lang/mono-2.10.9-r2::gentoo, ebuild scheduled for merge) pulled in by
<dev-lang/mono-3 required by (gnome-extra/gnome-do-0.9::gentoo, ebuild scheduled for merge)
Back to top
View user's profile Send private message
eyoung100
Veteran
Veteran


Joined: 23 Jan 2004
Posts: 1428

PostPosted: Wed Sep 11, 2013 3:15 pm    Post subject: Reply with quote

/etc/portage/package.mask
Code:
#Always Add a Comment here as this
#is a User Mask, so you know why you
#added it.
#Required by Mono 3.0 from dotnet overlay
<dev-dotnet/gtk-sharp-2.12.21
<dev-lang/mono-3.0


/etc/portage/package.unmask
Code:
##Always Add a Comment here as this
#is a User Unmask, so you know why you
#added it.
#Added just in case portage tries a package block
#by keyword
*/*::dotnet

_________________
The Birth and Growth of Science is the Death and Atrophy of Art -- Unknown
Registerd Linux User #363735
Adopt a Post | Strip Comments| Emerge Wrapper
Back to top
View user's profile Send private message
Cynede
Developer
Developer


Joined: 30 Nov 2012
Posts: 49

PostPosted: Thu Sep 12, 2013 4:53 am    Post subject: Reply with quote

Hello there, the blocking problem is not because of mono.

But it's monolithic gtk-sharp using in overlay : https://github.com/Heather/gentoo-dotnet/blob/master/dev-dotnet/gtk-sharp/gtk-sharp-2.12.21.ebuild

this ebuild provides all of this:

Code:

   !dev-dotnet/gtk-sharp-gapi
   !dev-dotnet/gtk-sharp-docs
   !dev-dotnet/gtk-dotnet-sharp
   !dev-dotnet/gdk-sharp
   !dev-dotnet/glib-sharp
   !dev-dotnet/glade-sharp
   !dev-dotnet/pango-sharp
   !dev-dotnet/atk-sharp


Also there is

Code:
<dev-lang/mono-3 required by (gnome-extra/gnome-do



I can see three possible solutions for situation with monolithic ebuild:

1. get / rewrite gtk-sharp implemented in modular way.
2. drop blocking packages
3. correct blocking ebuilds to point monolithic gtk-sharp instead of other

I've got gnome-light ( but 3.9.91 ) setup and mono-develop and there are no conflicts with it for me. So it's not major bug for me personally, but I will back to it when I will have some more free time.

In addition: Gentoo forum is great place but if you want to be sure that your message is delivered to proper people you can contact overlay maintainers via email from metadata or irc channel. Maybe just point to this forum thread but it's really random how I found this thread.
Back to top
View user's profile Send private message
akbarstatx
n00b
n00b


Joined: 14 Oct 2002
Posts: 66
Location: Minneapolis, MN

PostPosted: Tue Sep 17, 2013 11:52 pm    Post subject: Reply with quote

Thanks for updates/replies. I did email the overlay dev. I will also try posting again. I have tried dropping some of the blockers but that just seems to uncover more or the blockers are being re-installed by some other gnome package. Pretty that's why I ask for help on this one, I was getting head aches trying to figure it out. I am going play around a bit a I will try pointing the blockers to the monolithic ebuild.
Back to top
View user's profile Send private message
Cynede
Developer
Developer


Joined: 30 Nov 2012
Posts: 49

PostPosted: Wed Sep 18, 2013 9:04 am    Post subject: Reply with quote

akbarstatx wrote:
I did email the overlay dev.


I saw no emails. Strange maybe some metadata shows wrong packages :?

Some things alike banshee are really mess and I feel that it's not that simple to port them. What's your current blocker and progress?
By the way I'm usually on #gentoo-dotnet, but not today...
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6033
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Sun Feb 28, 2016 7:03 pm    Post subject: Reply with quote

Cynede wrote:
Hello there, the blocking problem is not because of mono.

But it's monolithic gtk-sharp using in overlay : https://github.com/Heather/gentoo-dotnet/blob/master/dev-dotnet/gtk-sharp/gtk-sharp-2.12.21.ebuild

this ebuild provides all of this:

Code:

   !dev-dotnet/gtk-sharp-gapi
   !dev-dotnet/gtk-sharp-docs
   !dev-dotnet/gtk-dotnet-sharp
   !dev-dotnet/gdk-sharp
   !dev-dotnet/glib-sharp
   !dev-dotnet/glade-sharp
   !dev-dotnet/pango-sharp
   !dev-dotnet/atk-sharp


Also there is

Code:
<dev-lang/mono-3 required by (gnome-extra/gnome-do



I can see three possible solutions for situation with monolithic ebuild:

1. get / rewrite gtk-sharp implemented in modular way.
2. drop blocking packages
3. correct blocking ebuilds to point monolithic gtk-sharp instead of other

I've got gnome-light ( but 3.9.91 ) setup and mono-develop and there are no conflicts with it for me. So it's not major bug for me personally, but I will back to it when I will have some more free time.

In addition: Gentoo forum is great place but if you want to be sure that your message is delivered to proper people you can contact overlay maintainers via email from metadata or irc channel. Maybe just point to this forum thread but it's really random how I found this thread.



Thanks for this


I've been wondering for some time why app-misc/tomboy and the dev-lang/mono stuff was clashing that much :lol:


Let's see if the ebuild can be adapted to get this working :)



Some folks might say that app-misc/gnote would be the better alternative to get away from Mono - well yeah,

I tried it out and it was really slow (taking 30+ seconds or even minutes to create a new note with the amount of notes I have,

so NOT an option :cry: )


Also: dev-lang/mono + app-misc/tomboy gets keeping faster and faster with all the improvements to Mono,


I only wish that tomboy would still be updated instead of only adding (or updating) languages and bumping the version :(
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.6.1
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum