Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Kein Update von thin-provisioning-tool möglich
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Jefferson
n00b
n00b


Joined: 10 Nov 2005
Posts: 66

PostPosted: Sun Sep 15, 2013 12:58 pm    Post subject: [SOLVED] Kein Update von thin-provisioning-tool möglich Reply with quote

Beim Systemupdate komme ich beim "thin-provisioning-tool"-Update nicht weiter.

Ich bekomme die folgende Fehlermeldung:

Code:

>>> Running pre-merge checks for sys-block/thin-provisioning-tools-0.2.1
 * ERROR: sys-block/thin-provisioning-tools-0.2.1::gentoo failed (pretend phase):
 *   Need gcc 4.7 or later to build, current version is 4.6.3
 *
 * Call stack:
 *                              ebuild.sh, line  93:  Called pkg_pretend
 *   thin-provisioning-tools-0.2.1.ebuild, line  26:  Called die
 * The specific snippet of code:
 *              die "Need gcc 4.7 or later to build, current version is `gcc-fullversion`"
 *
 * If you need support, post the output of `emerge --info '=sys-block/thin-provisioning-tools-0.2.1::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=sys-block/thin-provisioning-tools-0.2.1::gentoo'`.
 * The complete build log is located at '/var/log/portage/sys-block:thin-provisioning-tools-0.2.1:20130915-124618.log'.
 * For convenience, a symlink to the build log is located at '/var/tmp/portage/sys-block/thin-provisioning-tools-0.2.1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-block/thin-provisioning-tools-0.2.1/temp/die.env'.
 * Working directory: '/usr/lib64/portage/pym'
 * S: '/var/tmp/portage/sys-block/thin-provisioning-tools-0.2.1/work/thin-provisioning-tools-0.2.1'


Das Paket blockiert, da offenbar die installierte gcc Version nicht passt, was aber nicht der Fall ist.

Code:

*  sys-devel/gcc
      Latest version available: 4.7.3
      Latest version installed: 4.7.3
      Size of files: 81,022 kB
      Homepage:      http://gcc.gnu.org/
      Description:   The GNU Compiler Collection
      License:       GPL-3+ LGPL-3+ || ( GPL-3+ libgcc libstdc++ gcc-runtime-library-exception-3.1 ) FDL-1.3+


Kennt einer das Problem oder eine Lösung? Google hat mich hier nicht weitergebracht. Ich finde zwar die gleiche Fehlermeldung aber keine Lösung des Problems.


Last edited by Jefferson on Mon Sep 16, 2013 6:37 am; edited 1 time in total
Back to top
View user's profile Send private message
py-ro
Veteran
Veteran


Joined: 24 Sep 2002
Posts: 1374
Location: St. Wendel

PostPosted: Sun Sep 15, 2013 1:36 pm    Post subject: Reply with quote

Was sagt den

Code:
gcc-config -l


:?:
Back to top
View user's profile Send private message
Jefferson
n00b
n00b


Joined: 10 Nov 2005
Posts: 66

PostPosted: Sun Sep 15, 2013 3:14 pm    Post subject: Reply with quote

Code:

 gcc-config -l
 [1] x86_64-pc-linux-gnu-4.6.3 *
 [2] x86_64-pc-linux-gnu-4.7.3


Das wäre dann die Antwort, warum es NICHT geht.

Wenn du mir jetzt noch einen Tip geben kannst wie man es umstellt, dann wäre ich echt dankbar
Back to top
View user's profile Send private message
Christian99
l33t
l33t


Joined: 28 May 2009
Posts: 900

PostPosted: Sun Sep 15, 2013 3:51 pm    Post subject: Reply with quote

mit "gcc-config <profil name oder nummer>" in deinem fall "gcc-config 2"
Back to top
View user's profile Send private message
Jefferson
n00b
n00b


Joined: 10 Nov 2005
Posts: 66

PostPosted: Mon Sep 16, 2013 6:37 am    Post subject: Reply with quote

Vielen Dank an euch beide (Christian99 und py-ro).

Jetzt geht es und ich habe wieder etwas dazugelernt. :D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum