Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved]error bbswitch no such device no ACPI handle found
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
double_crane
Tux's lil' helper
Tux's lil' helper


Joined: 11 Dec 2011
Posts: 97
Location: JiangSu,China

PostPosted: Tue Sep 10, 2013 3:03 am    Post subject: [Solved]error bbswitch no such device no ACPI handle found Reply with quote

I notice those blogs about how to install bumblebee whith
Code:

~$:lspci:
00:02.0 VGA compatible controller: Intel Corporation Haswell Integrated Graphics Controller (rev 06)
00.XX.XX :VGA compatible controller: nvidia device XXX


but on my laptop: (install Gentoo,I have installed nvidia-drivers)
Code:

~$:lspci
00:02.0 VGA compatible controller: Intel Corporation Haswell Integrated Graphics Controller (rev 06)
01:00.0 3D controller: NVIDIA Corporation Device 11e2 (rev a1)


And I have tried Ubuntu lspci output is about the same: (driver using nvidia-304)
Code:

~$:lspci
00:02.0 VGA compatible controller: Intel Corporation Haswell Integrated Graphics Controller (rev 06)
01:00.0 3D controller: NVIDIA Corporation GK106 [GT765M] device (rev a1)


why is my nvidia card recognized as 3D controller but not VGA controller?

when modprobe bbswitch ,it says no device found !!!

I'm sure my laptop support optimus, there is a label on the keyboard. And optimus is OK in windows

and in Ubuntu dmesg , I found this:
Code:

~$: dmesg :
Sep 10 00:50:41 K650C kernel: [   23.759137] bbswitch: cannot find ACPI handle for VGA device 0000:01:00.0
Sep 10 00:50:41 K650C kernel: [   23.759138] bbswitch: No discrete VGA device found
Sep 10 00:50:41 K650C bumblebeed[1639]: Module bbswitch could not be loaded (timeout?)
Sep 10 00:50:41 witch: cannot find ACPI handle for VGA device 0000:01:00.0650C bumblebeed[1639]: No switching method available. The dedicated card will always be on.


and in Gentoo when emerge nvidia-drivers, I notice this
Code:

module license NVIDIA traints kernel


how to make the nvidia card recognized as VGA compatible controller ,but not 3D controller?


Last edited by double_crane on Sat Sep 14, 2013 3:42 pm; edited 2 times in total
Back to top
View user's profile Send private message
hadrons123
Tux's lil' helper
Tux's lil' helper


Joined: 08 Mar 2012
Posts: 90
Location: chennai

PostPosted: Tue Sep 10, 2013 5:25 pm    Post subject: Reply with quote

I guess this is a bug.

https://bugzilla.kernel.org/show_bug.cgi?id=60829

might help.
_________________
LENOVO Y580 FHD Intel® Core™ i7-3630QM CPU @ 2.40GHz × 8 |660M GTX NVIDIA | 16GB SanDisk SSD
Back to top
View user's profile Send private message
double_crane
Tux's lil' helper
Tux's lil' helper


Joined: 11 Dec 2011
Posts: 97
Location: JiangSu,China

PostPosted: Sat Sep 14, 2013 3:41 pm    Post subject: Reply with quote

Solved

it's the kernel ACPI bug

use 3.7and before version ,bbswitch can be insmod correctly

use 3.8 to 3.10, it print no such device error, and dmesg you'll get can't find ACPI handle for VGA device PCI bus 1:0:0 ...

I tried 3.11.0 gentoo-sources , the bug was fixed,however nvidia-drivers 319.49 was'nt Compatible with kernel 3.11.0...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum