Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
wine-9999 build fails due to libxml2 headers mismatch
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
ExecutorElassus
l33t
l33t


Joined: 11 Mar 2004
Posts: 731
Location: Stuttgart, Germany

PostPosted: Wed Aug 28, 2013 9:07 am    Post subject: wine-9999 build fails due to libxml2 headers mismatch Reply with quote

According to the wine dev, there is an error in the gentoo build of wine that stems from a mismatch between libxml2-headers and the library. When I try to emerge wine-9999, I get this:

Code:
x86_64-pc-linux-gnu-gcc -m32 -c -I/var/tmp/portage/app-emulation/wine-9999/work/wine-9999/dlls/ole32 -I. -I/var/tmp/portage/app-emulation/wine-9999/work/wine-9999/include -I../../include  -D__WINESRC__ -D_OLE32_ -DCOM_NO_WINDOWS_H -DENTRY_PREFIX=OLE32_ -DPROXY_CLSID=CLSID_PSFactoryBuffer -DWINE_REGISTER_DLL -D_REENTRANT -fPIC -Wall -pipe -fno-strict-aliasing -Wdeclaration-after-statement -Wempty-body -Wignored-qualifiers -Wstrict-prototypes -Wtype-limits -Wunused-but-set-parameter -Wwrite-strings -Wpointer-arith -Wlogical-op -fno-omit-frame-pointer  -march=athlon64 -O2 -pipe -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=0  -o marshal.o /var/tmp/portage/app-emulation/wine-9999/work/wine-9999/dlls/ole32/marshal.c
node.o: In function `node_transform_node':
node.c:(.text+0x3495): undefined reference to `xmlOutputBufferGetContent'
collect2: error: ld returned 1 exit status
winegcc: x86_64-pc-linux-gnu-gcc failed
make[1]: *** [msxml3.dll.so] Error 2
make[1]: Leaving directory `/var/tmp/portage/app-emulation/wine-9999/work/wine-9999-x86/dlls/msxml3'
make: *** [dlls/msxml3] Error 2
make: *** Waiting for unfinished jobs....
and then it fails.

How do I work around this?

Cheers,

EE
Back to top
View user's profile Send private message
Navar
Apprentice
Apprentice


Joined: 20 Aug 2012
Posts: 222

PostPosted: Thu Aug 29, 2013 8:42 pm    Post subject: Re: wine-9999 build fails due to libxml2 headers mismatch Reply with quote

ExecutorElassus wrote:
According to the wine dev, there is an error in the gentoo build of wine that stems from a mismatch between libxml2-headers and the library.

Who? Reference link?

Quote:
How do I work around this?

File a bug on the linker error.

According to upstream, dev-libs/libxml2-2.9.1-r1 is pretty current.
Back to top
View user's profile Send private message
Aquous
l33t
l33t


Joined: 08 Jan 2011
Posts: 642

PostPosted: Fri Aug 30, 2013 9:00 am    Post subject: Reply with quote

I guess the easiest thing to do would be to simply wait until the emul-linux libxml is updated to a version that is compatible with the current ~amd64 version.
Back to top
View user's profile Send private message
BobWya
n00b
n00b


Joined: 12 Aug 2012
Posts: 38
Location: Cambridge,UK

PostPosted: Wed Sep 11, 2013 2:01 pm    Post subject: Reply with quote

Aquous wrote:
I guess the easiest thing to do would be to simply wait until the emul-linux libxml is updated to a version that is compatible with the current ~amd64 version.


The FireBurn overlay has an updated version of the libxml2 library file... Wine git builds OK for me using this overlay. I wanted to try out the Direct3D patches - so needed 1.7.1...

Bob
Back to top
View user's profile Send private message
WuDDjA
n00b
n00b


Joined: 30 Aug 2005
Posts: 42

PostPosted: Fri Sep 13, 2013 5:43 pm    Post subject: Reply with quote

I already updated to libxm2 r2 and emul baselibs r54 both from FireBurn overlay but the error persists. Do you have an idea?
Will try MAKEOPTS=-j1" and see.
Back to top
View user's profile Send private message
BobWya
n00b
n00b


Joined: 12 Aug 2012
Posts: 38
Location: Cambridge,UK

PostPosted: Sat Sep 14, 2013 2:08 pm    Post subject: Reply with quote

WuDDjA wrote:
I already updated to libxm2 r2 and emul baselibs r54 both from FireBurn overlay but the error persists. Do you have an idea?
Will try MAKEOPTS=-j1" and see.


I don't think your make/link options will be a big deal - in fact they look pretty tame... Put it this way my copy of wine build with the following crazy flags!!
Code:
GRAPHITE="-floop-block -floop-interchange -floop-strip-mine -ftree-loop-distribution -fgraphite-identity"
CFLAGS="-O2 -fomit-frame-pointer ${GRAPHITE} -flto=2 -ftree-vectorize -march=native -pipe"
CXXFLAGS="${CFLAGS}"
LDFLAGS="${CFLAGS} -Wl,--as-needed -Wl,-O1 -fuse-linker-plugin"
MAKEOPTS="-j2 -s"


My Use options...
Code:
emerge -pv wine

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   *] app-emulation/wine-9999-r1::robs-local-ebuilds  USE="X alsa cups fontconfig gecko gphoto2 gsm jpeg lcms ldap mono mp3 ncurses nls openal opencl opengl osmesa perl png prelink run-exes samba scanner ssl threads truetype udisks xinerama xml -capi -custom-cflags -dos -gstreamer -nine -odbc -oss (-selinux) {-test} -v4l -xcomposite" ABI_X86="32 64 (-x32)" LINGUAS="en -ar -bg -ca -cs -da -de -el -en_US -eo -es -fa -fi -fr -he -hi -hr -hu -it -ja -ko -lt -ml -nb_NO -nl -or -pa -pl -pt_BR -pt_PT -rm -ro -ru -sk -sl -sr_RS@cyrillic -sr_RS@latin -sv -te -th -tr -uk -wa -zh_CN -zh_TW" 87,519 kB

(only using a local ports tree wine ebuild as the FireBurn Overlay ebuild of wine used an osmesa patch that is no longer required - the maintainer said he was going to remove this ASAP)

My dependency graph...
Code:
equery g =app-emulation/wine-9999-r1::robs-local-ebuilds
 * Searching robs-local-ebuilds for wine9999-r1 in app-emulation ...

 * dependency graph for app-emulation/wine-9999-r1
 `--  app-emulation/wine-9999-r1   
   `--  media-libs/freetype-2.4.12  (>=media-libs/freetype-2.0.0) ~amd64
   `--  net-dialup/capi4k-utils-20050718-r3  (net-dialup/capi4k-utils) amd64
   `--  sys-libs/ncurses-5.9-r3  (>=sys-libs/ncurses-5.2) ~amd64
   `--  sys-apps/dbus-1.6.12  (sys-apps/dbus) amd64
   `--  media-libs/fontconfig-2.10.93  (media-libs/fontconfig) ~amd64
   `--  media-libs/libgphoto2-2.5.2  (media-libs/libgphoto2) ~amd64
   `--  media-libs/openal-1.15.1-r1  (media-libs/openal) amd64
   `--  media-libs/gstreamer-0.10.36-r1  (media-libs/gstreamer) amd64
   `--  media-libs/gst-plugins-base-0.10.36-r1  (media-libs/gst-plugins-base) amd64
   `--  x11-libs/libXcursor-1.1.14  (x11-libs/libXcursor) ~amd64
   `--  x11-libs/libXext-1.3.2  (x11-libs/libXext) ~amd64
   `--  x11-libs/libXrandr-1.4.1  (x11-libs/libXrandr) ~amd64
   `--  x11-libs/libXi-1.7.2  (x11-libs/libXi) ~amd64
   `--  x11-libs/libXmu-1.1.1-r1  (x11-libs/libXmu) ~amd64
   `--  x11-libs/libXxf86vm-1.1.3  (x11-libs/libXxf86vm) ~amd64
   `--  x11-libs/libXinerama-1.1.3  (x11-libs/libXinerama) ~amd64
   `--  media-libs/alsa-lib-1.0.27.2  (media-libs/alsa-lib) ~amd64
   `--  net-print/cups-1.6.3-r2  (net-print/cups) ~amd64
   `--  virtual/opencl-0-r3  (virtual/opencl) ~amd64
   `--  virtual/glu-9.0-r1  (virtual/glu) amd64
   `--  virtual/opengl-7.0  (virtual/opengl) amd64  [nine? abi_x86_32(-)? abi_x86_64(-)? abi_x86_x32(-)? abi_x86_32(-)? abi_x86_64(-)? abi_mips_n32(-)? abi_mips_n64(-)? abi_mips_o32(-)?]
   `--  media-sound/gsm-1.0.13-r1  (media-sound/gsm) ~amd64
   `--  virtual/jpeg-0-r2  (virtual/jpeg) ~amd64
   `--  net-nds/openldap-2.4.35  (net-nds/openldap) amd64
   `--  media-libs/lcms-2.5-r1  (media-libs/lcms) ~amd64
   `--  media-sound/mpg123-1.15.4-r1  (>=media-sound/mpg123-1.5.0) ~amd64
   `--  sys-devel/gettext-0.18.3.1  (sys-devel/gettext) ~amd64
   `--  dev-db/unixODBC-2.3.1  (dev-db/unixODBC) amd64
   `--  media-libs/mesa-9999-r51  (media-libs/mesa) ~amd64  [osmesa]
   `--  dev-libs/libxml2-2.9.1-r2  (dev-libs/libxml2) amd64
   `--  dev-libs/libxslt-1.1.28-r2  (dev-libs/libxslt) amd64
   `--  media-gfx/sane-backends-1.0.23-r2  (media-gfx/sane-backends) ~amd64
   `--  net-libs/gnutls-3.2.4  (net-libs/gnutls) ~amd64
   `--  media-libs/libpng-1.6.3-r1  (media-libs/libpng) ~amd64
   `--  media-libs/libv4l-1.0.0  (media-libs/libv4l) ~amd64
   `--  x11-libs/libXcomposite-0.4.4-r1  (x11-libs/libXcomposite) ~amd64
   `--  app-emulation/emul-linux-x86-gstplugins-20130224-r1  (app-emulation/emul-linux-x86-gstplugins) amd64
   `--  app-emulation/emul-linux-x86-medialibs-20130224-r14  (app-emulation/emul-linux-x86-medialibs) ~amd64  [development]
   `--  app-emulation/emul-linux-x86-xlibs-20130224-r51  (>=app-emulation/emul-linux-x86-xlibs-2.1) ~amd64  [development]
   `--  app-emulation/emul-linux-x86-soundlibs-20130224-r11  (>=app-emulation/emul-linux-x86-soundlibs-2.1) ~amd64  [development]
   `--  app-emulation/emul-linux-x86-db-20130224  (app-emulation/emul-linux-x86-db) amd64  [development]
   `--  app-emulation/emul-linux-x86-sdl-20130224-r1  (app-emulation/emul-linux-x86-sdl) amd64  [development]
   `--  app-emulation/emul-linux-x86-opengl-20130224-r51  (app-emulation/emul-linux-x86-opengl) ~amd64  [development]
   `--  app-emulation/emul-linux-x86-baselibs-20130224-r51  (>=app-emulation/emul-linux-x86-baselibs-20130224) ~amd64  [development]
   `--  x11-proto/inputproto-2.3  (x11-proto/inputproto) ~amd64
   `--  x11-proto/xextproto-9999  (x11-proto/xextproto) ~amd64
   `--  x11-proto/xf86vidmodeproto-9999  (x11-proto/xf86vidmodeproto) ~amd64
   `--  x11-proto/xineramaproto-1.2.1-r1  (x11-proto/xineramaproto) ~amd64
   `--  sys-devel/prelink-20130503  (sys-devel/prelink) ~amd64
   `--  sys-kernel/linux-headers-3.11  (>=sys-kernel/linux-headers-2.6) ~amd64
   `--  virtual/pkgconfig-0  (virtual/pkgconfig) amd64
   `--  virtual/yacc-0  (virtual/yacc) amd64
   `--  sys-devel/flex-2.5.37  (sys-devel/flex) amd64
   `--  sys-devel/automake-1.12.6  (>=sys-devel/automake-1.12) amd64
   `--  sys-devel/automake-1.13.4  (>=sys-devel/automake-1.13) amd64
   `--  sys-devel/autoconf-2.69  (>=sys-devel/autoconf-2.68) amd64
   `--  sys-devel/libtool-2.4.2  (sys-devel/libtool) ~amd64
   `--  sys-apps/sed-4.2.2  (>=sys-apps/sed-4) ~amd64
   `--  x11-base/xorg-server-1.14.2.902  (x11-base/xorg-server) ~amd64  [xvfb]
   `--  x11-apps/xhost-1.0.5  (x11-apps/xhost) amd64
   `--  dev-vcs/git-1.8.3.2  (dev-vcs/git) ~amd64
   `--  dev-lang/perl-5.18.1  (dev-lang/perl) ~amd64
   `--  dev-perl/XML-Simple-2.200.0  (dev-perl/XML-Simple) amd64
   `--  net-fs/samba-3.6.18  (>=net-fs/samba-3.0.25) ~amd64
   `--  sec-policy/selinux-wine-9999  (sec-policy/selinux-wine) M[package.mask]
   `--  media-fonts/corefonts-1-r4  (media-fonts/corefonts) amd64
   `--  sys-fs/udisks-2.1.1  (sys-fs/udisks) ~amd64
[ app-emulation/wine-9999-r1 stats: packages (68), max depth (1) ]


Have you performed a revdep-rebuild operation?? - After emerging the new version of libxml2...
Personally I would also do a full world update as well - just as extra belt-n-braces... 8)

Bob
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum