Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Lost video with kernel 3.10.7 [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
marinheiro
Tux's lil' helper
Tux's lil' helper


Joined: 16 Jan 2004
Posts: 104

PostPosted: Sun Sep 08, 2013 6:21 pm    Post subject: Lost video with kernel 3.10.7 [SOLVED] Reply with quote

I have an oldish Dell Vostro running mainly stable but with gnome 3. As part of a struggle to get gnome 3.8.4 installed I ended up re-emerging a lot of packages, including (I can't even remember why now) a kernel upgrade to 3.10.7. I'm now getting the 'no devices detected' error from the Xorg-server. I've worked through everything I can think of and can't see why. I have no separate xorg.conf. I have re-emerged everything to do with X:

Code:
emerge --oneshot x11-libs/libdrm media-libs/mesa x11-apps/mesa-progs x11-base/xorg-server x11-base/xorg-drivers $(qlist -IC x11-drivers/)


Any suggestions for where to look?

Thanks
Graham

/var/log/dmesg:

Code:

[    0.000000] Linux version 3.10.7-gentoo (root@argos) (gcc version 4.7.3 (Gentoo 4.
7.3 p1.1, pie-0.5.5) ) #4 SMP Sat Sep 7 23:49:27 BST 2013
....
[    0.730246] agpgart-intel 0000:00:00.0: Intel GM45 Chipset
[    0.730405] agpgart-intel 0000:00:00.0: detected gtt size: 2097152K total, 262144K mappable
[    0.731403] agpgart-intel 0000:00:00.0: detected 32768K stolen memory
[    0.731719] agpgart-intel 0000:00:00.0: AGP aperture is 256M @ 0xd0000000
....
[    0.952358] [drm] Initialized drm 1.1.0 20060810
[    0.952867] [drm] Memory usable by graphics device = 2048M
[    0.952955] i915 0000:00:02.0: setting latency timer to 64
[    0.953261] i915 0000:00:02.0: irq 46 for MSI/MSI-X
[    0.953270] [drm] Supports vblank timestamp caching Rev 1 (10.10.2010).
[    0.953353] [drm] Driver supports precise vblank timestamp query.
[    0.953478] vgaarb: device changed decodes: PCI:0000:00:02.0,olddecodes=io+mem,decodes=io+mem:owns=io+mem
[    1.022440] fbcon: inteldrmfb (fb0) is primary device
[    1.023074] i915: fixme: max PWM is zero
[    1.440123] ACPI: Deprecated procfs I/F for battery is loaded, please retry with CONFIG_ACPI_PROCFS_POWER cleared
[    1.440129] ACPI: Battery Slot [BAT1] (battery present)
[    2.055301] Console: switching to colour frame buffer device 180x56
[    2.060634] i915 0000:00:02.0: fb0: inteldrmfb frame buffer device
[    2.060679] i915 0000:00:02.0: registered panic notifier
[    2.095201] ACPI: Video Device [GFX0] (multi-head: yes  rom: no  post: no)
[    2.095318] input: Video Bus as /devices/LNXSYSTM:00/device:00/PNP0A08:00/LNXVIDEO:01/input/input4
[    2.095429] [drm] Initialized i915 1.6.0 20080730 for 0000:00:02.0 on minor 0


Lspci -k:

Code:
00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 07)
        Subsystem: Dell Device 02bc
        Kernel driver in use: agpgart-intel
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
        Subsystem: Dell Device 02bc
        Kernel driver in use: i915
00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
        Subsystem: Dell Device 02bc


Xorg.0.log:

Code:

[   165.968]
X.Org X Server 1.13.4
Release Date: 2013-04-17
[   165.969] X Protocol Version 11, Revision 0
[   165.969] Build Operating System: Linux 3.10.7-gentoo i686 Gentoo
[   165.969] Current Operating System: Linux argos 3.10.7-gentoo #4 SMP Sat Sep 7 23:49:27 BST 2013 i686
[   165.969] Kernel command line: root=/dev/sda6
[   165.969] Build Date: 08 September 2013  06:52:49PM
[   165.969]
[   165.969] Current version of pixman: 0.28.0
[   165.969]    Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
[   165.969] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   165.969] (==) Log file: "/var/log/Xorg.0.log", Time: Sun Sep  8 19:17:27 2013
[   165.970] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[   165.970] (==) No Layout section.  Using the first Screen section.
[   165.970] (==) No screen section available. Using defaults.
[   165.970] (**) |-->Screen "Default Screen Section" (0)
[   165.970] (**) |   |-->Monitor "<default monitor>"
[   165.970] (==) No monitor specified for screen "Default Screen Section".
        Using a default monitor configuration.
[   165.970] (==) Automatically adding devices
[   165.970] (==) Automatically enabling devices
[   165.970] (==) Automatically adding GPU devices
[   165.970] (==) FontPath set to:
        /usr/share/fonts/misc/,
        /usr/share/fonts/TTF/,
        /usr/share/fonts/OTF/,
        /usr/share/fonts/Type1/,
        /usr/share/fonts/100dpi/,
        /usr/share/fonts/75dpi/
[   165.970] (==) ModulePath set to "/usr/lib/xorg/modules"
[   165.970] (II) The server relies on udev to provide the list of input devices.
        If no devices become available, reconfigure udev or disable AutoAddDevices.
[   165.970] (II) Loader magic: 0x825f620
[   165.970] (II) Module ABI versions:
[   165.970]    X.Org ANSI C Emulation: 0.4
[   165.970]    X.Org Video Driver: 13.1
[   165.970]    X.Org XInput driver : 18.0
[   165.970]    X.Org Server Extension : 7.0
[   165.970] (II) config/udev: Adding drm device (/dev/dri/card0)
[   165.973] (--) PCI:*(0:0:2:0) 8086:2a42:1028:02bc rev 7, Mem @ 0xf6800000/4194304, 0xd0000000/268435456, I/O @ 0x00001800/8
[   165.973] (--) PCI: (0:0:2:1) 8086:2a43:1028:02bc rev 7, Mem @ 0xf6100000/1048576
[   165.973] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[   165.973] Initializing built-in extension Generic Event Extension
[   165.973] Initializing built-in extension SHAPE
[   165.973] Initializing built-in extension MIT-SHM
[   165.973] Initializing built-in extension XInputExtension
[   165.973] Initializing built-in extension XTEST
[   165.973] Initializing built-in extension BIG-REQUESTS
[   165.973] Initializing built-in extension SYNC
[   165.973] Initializing built-in extension XKEYBOARD
[   165.973] Initializing built-in extension XC-MISC
[   165.973] Initializing built-in extension XINERAMA
[   165.973] Initializing built-in extension XFIXES
[   165.973] Initializing built-in extension RENDER
[   165.973] Initializing built-in extension RANDR
[   165.973] Initializing built-in extension COMPOSITE
[   165.973] Initializing built-in extension DAMAGE
[   165.973] Initializing built-in extension MIT-SCREEN-SAVER
[   165.973] Initializing built-in extension DOUBLE-BUFFER
[   165.973] Initializing built-in extension RECORD
[   165.973] Initializing built-in extension DPMS
[   165.973] Initializing built-in extension X-Resource
[   165.974] Initializing built-in extension XVideo
[   165.974] Initializing built-in extension XVideo-MotionCompensation
[   165.974] Initializing built-in extension XFree86-VidModeExtension
[   165.974] Initializing built-in extension XFree86-DGA
[   165.974] Initializing built-in extension XFree86-DRI
[   165.974] Initializing built-in extension DRI2
[   165.974] (II) LoadModule: "glx"
[   165.974] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[   165.974] (II) Module glx: vendor="X.Org Foundation"
[   165.974]    compiled for 1.13.4, module version = 1.0.0
[   165.974]    ABI class: X.Org Server Extension, version 7.0
[   165.974] (==) AIGLX enabled
[   165.974] Loading extension GLX
[   165.974] (==) Matched intel as autoconfigured driver 0
[   165.974] (==) Matched vesa as autoconfigured driver 1
[   165.974] (==) Matched modesetting as autoconfigured driver 2
[   165.974] (==) Matched fbdev as autoconfigured driver 3
[   165.974] (==) Assigned the driver to the xf86ConfigLayout
[   165.974] (II) LoadModule: "intel"
[   165.974] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[   165.974] (II) Module intel: vendor="X.Org Foundation"
[   165.975]    compiled for 1.13.4, module version = 2.20.13
[   165.975]    Module class: X.Org Video Driver
[   165.975]    ABI class: X.Org Video Driver, version 13.1
[   165.975] (II) LoadModule: "vesa"
[   165.975] (WW) Warning, couldn't open module vesa
[   165.975] (II) UnloadModule: "vesa"
[   165.975] (II) Unloading vesa
[   165.975] (EE) Failed to load module "vesa" (module does not exist, 0)
[   165.975] (II) LoadModule: "modesetting"
[   165.975] (WW) Warning, couldn't open module modesetting
[   165.975] (II) UnloadModule: "modesetting"
[   165.975] (II) Unloading modesetting
[   165.975] (EE) Failed to load module "modesetting" (module does not exist, 0)
[   165.975] (II) LoadModule: "fbdev"
[   165.975] (WW) Warning, couldn't open module fbdev
[   165.975] (II) UnloadModule: "fbdev"
[   165.975] (II) Unloading fbdev
[   165.975] (EE) Failed to load module "fbdev" (module does not exist, 0)
[   165.975] (II) intel: Driver for Intel Integrated Graphics Chipsets: i810,
        i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G, 915G,
        E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM, Pineview G,
        965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33, GM45,
        4 Series, G45/G43, Q45/Q43, G41, B43, B43, Clarkdale, Arrandale,
        Sandybridge Desktop (GT1), Sandybridge Desktop (GT2),
        Sandybridge Desktop (GT2+), Sandybridge Mobile (GT1),
        Sandybridge Mobile (GT2), Sandybridge Mobile (GT2+),
        Sandybridge Server, Ivybridge Mobile (GT1), Ivybridge Mobile (GT2),
        Ivybridge Desktop (GT1), Ivybridge Desktop (GT2), Ivybridge Server,
        Ivybridge Server (GT2), Haswell Desktop (GT1), Haswell Desktop (GT2),
        Haswell Desktop (GT2+), Haswell Mobile (GT1), Haswell Mobile (GT2),
        Haswell Mobile (GT2+), Haswell Server (GT1), Haswell Server (GT2),
        Haswell Server (GT2+), Haswell SDV Desktop (GT1),
        Haswell SDV Desktop (GT2), Haswell SDV Desktop (GT2+),
        Haswell SDV Mobile (GT1), Haswell SDV Mobile (GT2),
        Haswell SDV Mobile (GT2+), Haswell SDV Server (GT1),
        Haswell SDV Server (GT2), Haswell SDV Server (GT2+),
        Haswell ULT Desktop (GT1), Haswell ULT Desktop (GT2),
        Haswell ULT Desktop (GT2+), Haswell ULT Mobile (GT1),
        Haswell ULT Mobile (GT2), Haswell ULT Mobile (GT2+),
        Haswell ULT Server (GT1), Haswell ULT Server (GT2),
        Haswell ULT Server (GT2+), Haswell CRW Desktop (GT1),
        Haswell CRW Desktop (GT2), Haswell CRW Desktop (GT2+),
        Haswell CRW Mobile (GT1), Haswell CRW Mobile (GT2),
        Haswell CRW Mobile (GT2+), Haswell CRW Server (GT1),
[   165.976] (--) using VT number 7

[   166.064] (EE) No devices detected.
[   166.064]
Fatal server error:
[   166.064] no screens found
[   166.064] (EE)
Please consult the The X.Org Foundation support
         at http://wiki.x.org
 for help.
[   166.064] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[   166.064] (EE)
Back to top
View user's profile Send private message
marinheiro
Tux's lil' helper
Tux's lil' helper


Joined: 16 Jan 2004
Posts: 104

PostPosted: Thu Sep 12, 2013 9:38 pm    Post subject: Reply with quote

In all the mess of upgrading to gnome 3.8 I'd somehow messed up udev. I've now switched to systemd, and everything is fine (so far..)

Graham
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum