Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] No wifi working after switching to systemd
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
acidrums4
Tux's lil' helper
Tux's lil' helper


Joined: 05 Feb 2009
Posts: 115
Location: Al otro lado del monitor

PostPosted: Thu Aug 29, 2013 8:32 pm    Post subject: [SOLVED] No wifi working after switching to systemd Reply with quote

Hello there! Not sure if this is the place to post this question, but here it goes.

I've recently switched from openrc to systemd (204). Aside from being amazed for its speed, I've managed to get all working except wifi card. It doesn't even turn on.

I'm running Gentoo under a HP Pavilion DV2000 with a Broadcom BCM4311 wifi card. If I switch back to openrc, it works fine. But with systemd even iwconfig / ifconfig recognizes it (as if my kernel had not support for it).

I'm pretty noob to systemd, I would be glad if someone could throw me a clue about this. Thanks!


Last edited by acidrums4 on Wed Sep 11, 2013 9:50 pm; edited 1 time in total
Back to top
View user's profile Send private message
666threesixes666
Veteran
Veteran


Joined: 31 May 2011
Posts: 1223
Location: 42.68n 85.41w

PostPosted: Thu Aug 29, 2013 9:57 pm    Post subject: Reply with quote

i have a similar setup, similar wifi card... on my laptop that is. i had systemd and ran into your problem. i resolved your problem by using gdm rather than startx. im sure lightdm would do the trick also.

https://wiki.gentoo.org/wiki/LightDM

give it a try.... if it fixes it, shout back and ill append systemd wikis suggesting lightdm. i also ran into not being able to use menus to load programs, and it resolved that also.

edit to note that i was talking about networkmanager.
_________________
cat /etc/*-release
Funtoo Linux - baselayout 2.2.0
consider this warning no. 1
http://ecx.images-amazon.com/images/I/81Ku-vxIb3L._SL1500_.jpg
http://wiki.gentoo.org/wiki/Special:Contributions/666threesixes666


Last edited by 666threesixes666 on Thu Aug 29, 2013 10:36 pm; edited 1 time in total
Back to top
View user's profile Send private message
ulenrich
Veteran
Veteran


Joined: 10 Oct 2010
Posts: 1122

PostPosted: Thu Aug 29, 2013 10:23 pm    Post subject: Reply with quote

Code:
systemctl enable wpa_supplicant@.service

should into multi-user like :
Code:
vdir /etc/systemd/system/multi-user.target.wants
lrwxrwxrwx 1 root root 34  6. Aug 16:11 dhcpcd.service -> /etc/systemd/system/dhcpcd.service
lrwxrwxrwx 1 root root 41 24. Jul 00:15 local-d-start.service -> /etc/systemd/system/local-d-start.service
lrwxrwxrwx 1 root root 43 28. Aug 12:19 machine-idrenew.service -> /etc/systemd/system/machine-idrenew.service
lrwxrwxrwx 1 root root 40 12. Aug 11:58 remote-fs.target -> /usr/lib/systemd/system/remote-fs.target
lrwxrwxrwx 1 root root 44 24. Jul 00:23 vixie-cron.service -> /usr/lib64/systemd/system/vixie-cron.service
lrwxrwxrwx 1 root root 43  6. Aug 22:30 wpa_supplicant@wlan0.service -> /etc/systemd/system/wpa_supplicant@.service

_________________
fun2gen2
Back to top
View user's profile Send private message
acidrums4
Tux's lil' helper
Tux's lil' helper


Joined: 05 Feb 2009
Posts: 115
Location: Al otro lado del monitor

PostPosted: Thu Aug 29, 2013 11:10 pm    Post subject: Reply with quote

666threesixes666 wrote:
I resolved your problem by using gdm rather than startx. Im sure lightdm would do the trick also.


Actually I was using kdm. As there's no way I'm using gdm, I tried with lightdm. But got nowhere. Still the same thing.

ulenrich wrote:
Code:
systemctl enable wpa_supplicant@.service


I was thinking it will do the trick, as I hadn't enabled that service (I didn't saw it when listing /usr/lib/systemd/system). But still my wifi card didn't even turn on...

Thank you so much guys, I'm guessing it will need some act of God to work with systemd.
Back to top
View user's profile Send private message
acidrums4
Tux's lil' helper
Tux's lil' helper


Joined: 05 Feb 2009
Posts: 115
Location: Al otro lado del monitor

PostPosted: Fri Aug 30, 2013 12:45 am    Post subject: Reply with quote

With a little help of the journal I found this:

Code:

ago 29 09:29:24 localhost NetworkManager[192]: <warn> error requesting auth for org.freedesktop.NetworkManager.sleep-wake: (3) GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: Could not get UID of name ':1.14': no such name
ago 29 09:29:24 localhost NetworkManager[192]: <warn> error requesting auth for org.freedesktop.NetworkManager.enable-disable-wifi: (3) GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: Could not get UID of name ':1.14': no such name
ago 29 09:29:24 localhost NetworkManager[192]: <warn> error requesting auth for org.freedesktop.NetworkManager.enable-disable-wwan: (3) GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: Could not get UID of name ':1.14': no such name
ago 29 09:29:24 localhost NetworkManager[192]: <warn> error requesting auth for org.freedesktop.NetworkManager.enable-disable-wimax: (3) GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: Could not get UID of name ':1.14': no such name
ago 29 09:29:24 localhost NetworkManager[192]: <warn> error requesting auth for org.freedesktop.NetworkManager.network-control: (3) GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: Could not get UID of name ':1.14': no such name
ago 29 09:29:24 localhost NetworkManager[192]: <warn> error requesting auth for org.freedesktop.NetworkManager.wifi.share.protected: (3) GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: Could not get UID of name ':1.14': no such name
ago 29 09:29:24 localhost NetworkManager[192]: <warn> error requesting auth for org.freedesktop.NetworkManager.wifi.share.open: (3) GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: Could not get UID of name ':1.14': no such name
ago 29 09:29:24 localhost NetworkManager[192]: <warn> error requesting auth for org.freedesktop.NetworkManager.settings.modify.system: (3) GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: Could not get UID of name ':1.14': no such name
ago 29 09:29:24 localhost NetworkManager[192]: <warn> error requesting auth for org.freedesktop.NetworkManager.settings.modify.own: (3) GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: Could not get UID of name ':1.14': no such name
ago 29 09:29:24 localhost NetworkManager[192]: <warn> error requesting auth for org.freedesktop.NetworkManager.settings.modify.hostname: (3) GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: Could not get UID of name ':1.14': no such name


I googled about this but seems a very rare issue related to crashes, unexpected reboots, burning computers and children shouting loud. Anybody can help me with this?
Back to top
View user's profile Send private message
ulenrich
Veteran
Veteran


Joined: 10 Oct 2010
Posts: 1122

PostPosted: Fri Aug 30, 2013 7:11 am    Post subject: Reply with quote

@acidDrum, I don't travel around, but only connect to two alternating wifis at home, which I got working with only dhcpcd and wpa_supplicant. That's another story NetworkManager ....
_________________
fun2gen2
Back to top
View user's profile Send private message
Logicien
l33t
l33t


Joined: 16 Sep 2005
Posts: 741
Location: Montréal

PostPosted: Fri Aug 30, 2013 8:16 am    Post subject: Reply with quote

Hello,
with Fedora who use Systemd by default, NetworkManager was connecting me correctly to the Internet when I was using Gdm has display manager. Systemd use /dev/tty1 has the virtual terminal for display managers.

Than, I stop and disable the Gdm service with systemctl. I startx from /dev/tty6 after openning a session in that terminal. I had the experience of not being able to connect to Internet with NetworkManager because of insufficient privileges.

I logout and startx from /dev/tty1. I was able to connect to internet with NetworkManager. I read somewhere that Xorg must use the first virtual terminal /dev/tty1 with Systemd.

The Broadcom wireless cards are not too easy to support in Linux. Even if Systemd do not want to make your card work, you should be able to see it with lspci or lsusb depending on the port on which it is connected.

You can also load manually the appropriate Broadcom module and check with dmesg if the kernel complain about something, like firmware. If everething is ok, you should see your card with ifconfig -a and ip link show. Than wpa_supplicant and a dhcp client should be able to connect you to the Internet.

I always assure myself I can connect to Internet manually if something goes wrong with the network scripts. Than I can find more easily how to make the network support fo the distribution work.

You have several ways to connect automatically. The wpa_supplicant plus dhcpcd scripts, net.lo link to your network card and configure in /etc/conf.d/net, NetworkManager, Wicd, etc.
_________________
Paul
Back to top
View user's profile Send private message
rokj
n00b
n00b


Joined: 05 Sep 2005
Posts: 33

PostPosted: Fri Aug 30, 2013 10:30 am    Post subject: Reply with quote

Removing dhcpcd and uninstalling net-misc/dhcp from systemd sysvinit solved problems for me, but do not know if it is the same problem as yours.

Mine was just that it was "reseting IP" all the time when using DHCP on wifi or wired.
Back to top
View user's profile Send private message
acidrums4
Tux's lil' helper
Tux's lil' helper


Joined: 05 Feb 2009
Posts: 115
Location: Al otro lado del monitor

PostPosted: Wed Sep 11, 2013 9:49 pm    Post subject: Reply with quote

Thank you so much to all of you, gentlemen, for your kindly help. Turns out that, as @Logicien said, I hadn't had enabled the b43 kernel module. So I did, and wifi worked.

I trusted on @ulenrich about his command to activate wpa_supplicant at boot, but it didn't worked and my wifi spot was refusing to connect. I figured out after many hours googling that I had to do

Code:
sudo systemctl enable wpa_supplicant.service


in order to activate wpa_supplicant at boot (note that doesn't include the '@' character in the service name).

Now everything here is OK, marking this thread as SOLVED. Again, thank you so much!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum