Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] How to choose which version of firefox to install?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
folderman
n00b
n00b


Joined: 14 Dec 2012
Posts: 4

PostPosted: Mon Sep 09, 2013 3:05 am    Post subject: [SOLVED] How to choose which version of firefox to install? Reply with quote

Hi all,

Here is my eix information:

[U] www-client/firefox
Available versions: *10.0.11 17.0.5 17.0.6 17.0.7 17.0.8 (~)23.0 (~)23.0[1] (~)23.0-r100[1] {+alsa bindist custom-cflags custom-optimization +dbus debug egl gstreamer +ipc +jit libnotify +minimal pgo pulseaudio selinux startup-notification system-cairo system-jpeg system-sqlite +webm wifi LINGUAS="af ak ar as ast be bg bn_BD bn_IN br bs ca cs csb cy da de el en_GB en_ZA eo es_AR es_CL es_ES es_MX et eu fa fi fr fy_NL ga_IE gd gl gu_IN he hi_IN hr hu hy_AM id is it ja kk km kn ko ku lg lt lv mai mk ml mr nb_NO nl nn_NO nso or pa_IN pl pt_BR pt_PT rm ro ru si sk sl son sq sr sv_SE ta ta_LK te th tr uk vi zh_CN zh_TW zu"}
Installed versions: 23.0(15:56:29 08/30/13)(alsa bindist dbus jit libnotify minimal startup-notification -custom-cflags -custom-optimization -debug -gstreamer -pgo -pulseaudio -selinux -system-cairo -system-jpeg -system-sqlite -wifi LINGUAS="zh_TW -af -ak -ar -as -ast -be -bg -bn_BD -bn_IN -br -bs -ca -cs -csb -cy -da -de -el -en_GB -en_ZA -eo -es_AR -es_CL -es_ES -es_MX -et -eu -fa -fi -fr -fy_NL -ga_IE -gd -gl -gu_IN -he -hi_IN -hr -hu -hy_AM -id -is -it -ja -kk -km -kn -ko -ku -lg -lt -lv -mai -mk -ml -mr -nb_NO -nl -nn_NO -nso -or -pa_IN -pl -pt_BR -pt_PT -rm -ro -ru -si -sk -sl -son -sq -sr -sv_SE -ta -ta_LK -te -th -tr -uk -vi -zh_CN -zu")
Homepage: http://www.mozilla.com/firefox
Description: Firefox Web Browser


I have one version from gentoo while the other from one overlay ( as that version is tailered for my display chip), how can I choose to use "(~)23.0[1]"?

As for different versions, I can use emerge -av =www-client/firefox-23.0.

Thanks!

Rgds,
Kenneth


Last edited by folderman on Mon Sep 09, 2013 8:29 am; edited 1 time in total
Back to top
View user's profile Send private message
kurly
Apprentice
Apprentice


Joined: 02 Apr 2012
Posts: 164

PostPosted: Mon Sep 09, 2013 4:48 am    Post subject: Reply with quote

You can append an overlay name to a package like this: www-client/firefox::myoverlay

You didn't list enough information for us to know what overlay you are using, but I'm sure you know its name! Note that official Gentoo packages have an implicit overlay name of ::gentoo. I hope this is helpful.
Back to top
View user's profile Send private message
folderman
n00b
n00b


Joined: 14 Dec 2012
Posts: 4

PostPosted: Mon Sep 09, 2013 5:32 am    Post subject: Reply with quote

Hi Kurly,

Thanks very much for your information, the information you provided is enough for me.

Rgds,
Kenneth
Back to top
View user's profile Send private message
fturco
Apprentice
Apprentice


Joined: 08 Dec 2010
Posts: 240
Location: Italy

PostPosted: Mon Sep 09, 2013 7:43 am    Post subject: Reply with quote

@folderman: I'm glad you fixed your problem, but please mark the thread as SOLVED. And next time you could use the forum code tags for the output of commands, so they look better.
Back to top
View user's profile Send private message
folderman
n00b
n00b


Joined: 14 Dec 2012
Posts: 4

PostPosted: Mon Sep 09, 2013 8:30 am    Post subject: Reply with quote

Hi fturco,

Thanks, will use the tag for showing output next time.

Rgds,
Kenneth
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum