Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
failed to extract cpio via gzip (not actually an RPM?)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
curmudgeon
Veteran
Veteran


Joined: 08 Aug 2003
Posts: 1340

PostPosted: Sat Sep 07, 2013 3:56 pm    Post subject: failed to extract cpio via gzip (not actually an RPM?) Reply with quote

Downloaded an ordinary rpm file: http://downloads.lexmark.com/downloads/pssd/print-drivers-linux-glibc2-x86.rpm

Code:

$ rpm2targz print-drivers-linux-glibc2-x86.rpm
rpm2targz: print-drivers-linux-glibc2-x86.rpm: failed to extract cpio via gzip (not actually an RPM?)


I have no idea what is going on. I tried using cpio directly, and I couldn't get any output at all (definitely not one of the the more accessible programs on the system).

Any ideas?
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5268

PostPosted: Mon Sep 09, 2013 3:34 am    Post subject: Reply with quote

Well, this might be worth filing a bug, though for a completely different reason.

Walking through all the separate steps of rpm2tarxz, the unpacking works fine, but tar fails cause unpacked /usr/local/lexmark/unix_prt_drivers/bin/.scripts/setup.sh has stupid permissions (005).
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum