Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
dhcpcd: DHCP lease expired on static eth interface
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
Camp
Tux's lil' helper
Tux's lil' helper


Joined: 31 May 2004
Posts: 82
Location: Moscow

PostPosted: Fri Sep 06, 2013 4:33 pm    Post subject: dhcpcd: DHCP lease expired on static eth interface Reply with quote

Hi there, I 've just seen one interesting problem and cannot imagine how it could be happened.
Server running 3.2.1-gentoo-r2 on i686 AMD Athlon(tm) II X2 245 Processor AuthenticAMD GNU/Linux

interface eth1 have static address 192.168.1.50, ifconfig command with this address starting from script in /etc/local.d

Unexpectably after 7 days 3h12m of uptime my system lost routes to 192.168.1.0/24 net, ip address in ifconfig was normal 192.168.1.50, BUT:

In /var/log/messages/ I see:
Code:
Sep  6 19:43:14 localhost dhcpcd[1923]: eth1: DHCP lease expired
Sep  6 19:43:14 localhost dhcpcd[1923]: eth1: deleting host route to 192.168.1.90 via 127.0.0.1
Sep  6 19:43:14 localhost dhcpcd[1923]: eth1: deleting route to 192.168.1.0/24
Sep  6 19:43:14 localhost dhcpcd[1923]: eth1: soliciting an IPv6 router
Sep  6 19:43:14 localhost dhcpcd[1923]: eth1: soliciting a DHCP lease
Sep  6 19:43:26 localhost dhcpcd[1923]: eth1: no IPv6 Routers available
Sep  6 19:43:44 localhost dhcpcd[1923]: eth1: probing for an IPv4LL address
Sep  6 19:43:50 localhost dhcpcd[1923]: eth1: using IPv4LL address 169.254.11.240
Sep  6 19:43:50 localhost dhcpcd[1923]: eth1: adding host route to 169.254.11.240 via 127.0.0.1
Sep  6 19:43:50 localhost dhcpcd[1923]: eth1: adding route to 169.254.0.0/16
Sep  6 19:43:55 localhost dhcpcd[1923]: eth1: soliciting a DHCP lease


dhcpcd client started but starting with parameter to work ONLY at other interface (eth0)

Does anyone know what is this? And how this problem could be occurred on static eth1 interface?
_________________
registered Linux user #357267
GENTOO
Back to top
View user's profile Send private message
Logicien
l33t
l33t


Joined: 16 Sep 2005
Posts: 738
Location: Montréal

PostPosted: Fri Sep 06, 2013 8:44 pm    Post subject: Reply with quote

Hi,
if you have a symbolic link from net.lo to net.eth0 in /etc/init.d/, Gentoo network boot scripts by default will send a dhcp request on the eth0 interface. Remove the symlink if it exist and (try to) block any Gentoo configuration of eth0 in /etc/conf.d/net like
Code:
modules_eth0="!dhclient !dhcpcd !ifconfig !iproute2 !pump !udhcpc !wireless"

and continue to configure it manually. Else, you can use Gentoo to configure this interface, what I think is the best. In /etc/conf.d/net write
Code:

config_eth0="192.168.1.50 broadcast 192.168.1.255 netmask 255.255.255.0"
modules_eth0="!dhclient !dhcpcd !ifconfig iproute2 !pump !udhcpc !wireless"

Be sure you have the symlink net.lo to net.eth0, activate net.eth0 with rc-update and do not configure eth0 from /etc/local.d/ boot script.
_________________
Paul
Back to top
View user's profile Send private message
Camp
Tux's lil' helper
Tux's lil' helper


Joined: 31 May 2004
Posts: 82
Location: Moscow

PostPosted: Fri Sep 06, 2013 9:37 pm    Post subject: Reply with quote

Logicien, I don't have any links, and have this:
Code:
# rc-update show | grep net
               net.lo | boot                         
             netmount |      default   

all interfaces configuring from local scripts manually...
And it NEVER happened before...
_________________
registered Linux user #357267
GENTOO
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum