Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ownCloud: cannot create contacts via CardDAV
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
SirLD
Tux's lil' helper
Tux's lil' helper


Joined: 05 May 2007
Posts: 78

PostPosted: Mon Aug 05, 2013 10:18 pm    Post subject: ownCloud: cannot create contacts via CardDAV Reply with quote

Hey,

I've been looking around the internet but didn't find a solution to the following problem:

I installed apache and owncloud-5.0.9 with mysql. I can use the web interface, create contacts, edit them, delete them etc. But when I try to sync the contact list via Evolution or my android phone, I can only read but not write the contacts. Whenever I try to write a contact, it says: 400 (Bad request).

I made sure that mod_rewrite is not commented out, I looked at the 00_default_vhosts.conf file (like it is written in the ownCloud manual), the permissions in the /var/www/localhost/htdocs/owncloud directory are owned by apache:apache.

But now I am a little bit stuck. Can anyone give me a hint, where I can have a look still?

Thanks a lot in advance!
_________________
gentoo, IBM T41p, atheros wlan, firegl T2, konsolenfreak ;)
Back to top
View user's profile Send private message
SirLD
Tux's lil' helper
Tux's lil' helper


Joined: 05 May 2007
Posts: 78

PostPosted: Wed Aug 07, 2013 7:42 pm    Post subject: Reply with quote

So, I will post new details. I added the addressbook in evolution with the url http://<server>/owncloud/remote.php/contacts/addressbooks/<username>/contacts.

On the web frontend I can log into ownCloud and add contacts. These contacts also appear in evolution. When I then add contacts, I get the error

Code:
Cannot add contact: Create resource 'http://<username>@<server>/owncloud/remote.php/contacts/addressbooks/<username>/contacts/131F39D7-77829FEE-28CB5FAD.vcf' failed with HTTP status: 400 (Bad request)


And the access log on the server /var/log/apache2/access_log:
Code:
<client-ip> - <username> [07/Aug/2013:21:41:41 +0200] "PROPFIND /owncloud/remote.php/contacts/addressbooks/<username>/contacts/ HTTP/1.1" 207 359
<client-ip> - <username> [07/Aug/2013:21:41:41 +0200] "PUT /owncloud/remote.php/contacts/addressbooks/<username>/contacts/131F39D7-77829FEE-28CB5FAD.vcf HTTP/1.1" 400 272


The error log does not show anything.

Does anybody have an idea where I could look?
_________________
gentoo, IBM T41p, atheros wlan, firegl T2, konsolenfreak ;)
Back to top
View user's profile Send private message
SirLD
Tux's lil' helper
Tux's lil' helper


Joined: 05 May 2007
Posts: 78

PostPosted: Thu Sep 05, 2013 7:37 am    Post subject: Reply with quote

Ok, I had some time to play around again. I tried to use webdav.php and it works very nicely, I can see, modify and create files and folders. Also for the calendar it works!

However, I still get a "400 - BAD REQUEST" error when I try to use the CardDAV.

Does anyone have suggestions for me?
_________________
gentoo, IBM T41p, atheros wlan, firegl T2, konsolenfreak ;)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum