Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[unity] quale gcc
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4506
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Sun May 05, 2013 5:00 pm    Post subject: [unity] quale gcc Reply with quote

volevo provare a compilare unity, e quindi ho smascherato il corrispondente overlay con layman.
immediatamente, però, ho osservato che alcuni pacchetti pretendevano l'uso di >=sys-devel/gcc-4.7.3.

qui ho scoperto, con sorpresa, che in portage è disponible al massimo una versione 4.8.0, ma hard-masked.
da gcc.gnu.org, la versione 4.7.3 sarebbe stabile.

non ho gran voglia di passare a una versione mascherata di gcc, con il rischio di incontrare pacchetti non ancora maturi.
qualcuno ha idea di quali possono i tempi di attesa per un upgrade di gcc?
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1486
Location: Cosenza, Italy

PostPosted: Mon May 06, 2013 7:12 am    Post subject: Reply with quote

Diciamo che gcc-4.8 è una delle poche versioni negli ultimi tempi che ha creato meno danni/lavoro. I pacchetti che non compilano sono davvero pochi.
Se presti attenzione potresti compilare solo i pacchetti che ti interessano con gcc-4.8.0 e il resto resta compilato con quello che hai. Attenzione a un depclean che rimuove la vecchia versione.

Come alternativa, potresti creare un chroot e compilare il tuo $( qlist -IC ) con gcc-4.8.0 cosi vedi se la situazione è rosea o meno e nel sistema principale installi gcc-4.8.0 senza attivarlo da gcc-config. A quel punto installi i binari(che ti interessano) fatti con quickpkg.
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4506
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Sun May 12, 2013 7:10 pm    Post subject: Reply with quote

alla fine sono passato a gcc-4.8.0.

la compilazione ha avuto buon fine e, al momento, non osservo controindicazioni.
unity lavora piuttosto bene, anche se, personalmente, preferisco ancora kde.

secondo me, tuttavia, la versione in overlay utilizza delle impostazioni di default largamente opinabili.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1486
Location: Cosenza, Italy

PostPosted: Sun May 12, 2013 7:21 pm    Post subject: Reply with quote

cloc3 wrote:
secondo me, tuttavia, la versione in overlay utilizza delle impostazioni di default largamente opinabili.


A cosa ti riferisci?Quale overlay?
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4506
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Sun May 12, 2013 8:28 pm    Post subject: Reply with quote

ago wrote:
cloc3 wrote:
secondo me, tuttavia, la versione in overlay utilizza delle impostazioni di default largamente opinabili.


A cosa ti riferisci?Quale overlay?

unity.

quando l'utente esegue il suo primo login, i tap sul touchapd non rispondono, e bisogna diventare matti a cercare nelle impostazioni di sistema per sbloccare la situazione.
anche dopo esserci riusciti, tuttavia le opzioni offerte dalle interfaccie grafiche sono piuttosto insoddisfacenti.
non è possibile, infatti, ottenere certe configurazioni che synclient supporta e che, a me, risultano molto utili.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1486
Location: Cosenza, Italy

PostPosted: Sun May 12, 2013 8:57 pm    Post subject: Reply with quote

Pensavo ti riferissi a gcc..
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
pingoo
Guru
Guru


Joined: 11 Jul 2006
Posts: 322

PostPosted: Sat Aug 31, 2013 5:05 pm    Post subject: Reply with quote

Piccolo OT
@cloc3 (e per chi ha provato Unity): come va con Unity, ce l'hai ancora installata/aggiornata? In particolare mi interesserebbe capire se funziona la HUD che trovo piuttosto comoda. Sto cercando di capire se vale la pena provarla anche per valutarla come sostituta di gnome-shell/gnome (sarà difficile perché amo l'effetto "exposé"...)

PS: pollycokers?
Back to top
View user's profile Send private message
tano70
Tux's lil' helper
Tux's lil' helper


Joined: 26 Aug 2013
Posts: 79
Location: Torino

PostPosted: Sun Sep 01, 2013 11:30 pm    Post subject: Reply with quote

Ma come si aggiorna il gcc?? anche io vorrei mettere la nuova versione per alcuni errori che mi da il terminale, su questo ho gia' aperto un post dove nessuno mi ha finora dato una risposta:
https://forums.gentoo.org/viewtopic-t-968858.html
Comunque per risolvere alcuni di quei errori ho bisogno di compilare con uan versione gcc superiore al 4.7. Mi dite esattamente come procedere a mettere questa versione 4.8.0 o 4.8.1 (mi pare che adesso sia la versione ultima, visto che questo post e' piuttosto antecendente). Quali comandi dare?
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4506
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Mon Sep 02, 2013 3:08 pm    Post subject: Reply with quote

pingoo wrote:
Piccolo OT
@cloc3 (e per chi ha provato Unity): come va con Unity

attualmente è disinstallata.

il problema non è unity in sè, ma la compatiblità limitata dell'overlay con i pacchetti ufficiali di portage.
in parte la colpa mia, perché la mia installazione contiene troppo software, che aumenta esponenzialemte le probabilità di incontrare pasticci e i tempi necessari a risolverli.

conto di tornare all'attacco più avanti.
quanto a funzionalità, non era male, anche se, a volte, osservavo delle latenze un po' fastidiose.

pollycokers? occasionale.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum