Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Gnome-fallback with Gnome 3.8
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Zenkibou
n00b
n00b


Joined: 25 Jan 2013
Posts: 2

PostPosted: Fri Aug 30, 2013 7:56 am    Post subject: Gnome-fallback with Gnome 3.8 Reply with quote

Hello,

I'm using ~arch and I just upgraded to gnome 3.8 + systemd. I use gnome-panel (a.k.a gnome-fallback), but after this upgrade, I could not use gnome-fallback anymore, only gnome-shell was possible.
I just finished solving this issue so I figured I would put this somewhere so that other could spend less time figuring things out.

So the first thing to do is to tell gnome-session to start the "gnome-fallback" session instead of the "gnome":
Code:
gsettings set org.gnome.desktop.session session-name gnome-fallback

For those using .xinitrc, this is possible as well:
Code:
gnome-session --session=gnome-fallback

Then, this session must be written as a file gnome-fallback.desktop in one of those files:
  • ~/.config/gnome-session/sessions/gnome-fallback.session
  • /etc/xdg/gnome-session/sessions/gnome-fallback.session
  • /usr/local/share/gnome-session/sessions/gnome-fallback.session
  • /usr/share/gnome-session/sessions/gnome-fallback.session

The content of this file must be different than what was used before gnome-3.8 because of the following change:
"session: Remove RequiredProviders support"
https://git.gnome.org/browse/gnome-session/commit/gnome-session?id=098fad4ea1be6953f66fc457df1943a31247611a
So we can't use RequiredProviders anymore, they must be in RequiredComponents:
Code:
[GNOME Session]
Name=GNOME fallback
RequiredComponents=gnome-panel;gnome-settings-daemon;gnome-screensaver;metacity;
DesktopName=GNOME fallback


Note that the package gnome-fallback (with gnome-screensaver, gnome-panel, ...) must be installed as well (it is not in the default gnome install anymore). Those will still be in version 3.6 but will work anyway.
(I just needed to remove the weather applet from gnome-applets-3.6, but I guess that a proper port to gweather 3.8 would be better)

So now I'm back like before gnome 3.8 and everything is good again. I think I will try the gnome-flashback desktop but I'm not sure it will fit my need !
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum