Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Random gnome/cinnamon issues
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Incomplet
n00b
n00b


Joined: 12 Apr 2012
Posts: 42

PostPosted: Sun Jun 09, 2013 2:18 pm    Post subject: Random gnome/cinnamon issues Reply with quote

When I first emerged everything on this machine I had to emerge both cinnamon and xfce4 as a test, and neither of them would populate the desktop with files/symlinks, nor would they generate the usual "music, video, downloads" etc folders for any user. Wallpapers/backgrounds worked though, but then after trying to fix things THAT stopped working too, and now my desktop both has no icons AND is pitch black. Setting the bg color does nothing, and images won't load for it either under the gnome-control-panel setting nor under cinnamon settings. I tried to fix that by deleting relevant settings files both under ~/ for my user and for root, which did nothing. Now sound settings refuses to show any devices (although I get a message about there not being a user called 'pulse' at startup which may be related) and the sound item on the panel is gone. Additionally, synapse, which I had set to start up on login no longer does so, and toggling that setting does nothing to fix it. The logout function also stopped working, and I've had to use reboot just to get out of cinnamon..

I think this nonsense is coming from somewhere in gnome/gtk, since shifting things around in media-libs/ and media-plugins/ changed nothing, and the problems seem to keep piling up even though I basically wiped everything except my user directory and reinstalled. I really don't get it. :|
Back to top
View user's profile Send private message
NReale3370
n00b
n00b


Joined: 26 Jul 2013
Posts: 11

PostPosted: Thu Aug 22, 2013 9:25 pm    Post subject: Reply with quote

I vaguely recall having that issue around the gnome 3.8 update in Cinnamon. I had to mask a few packages to get Cinnamon to work right after the update, try masking these:

>dev-libs/gjs-1.34.0
>media-libs/clutter-1.12.2
>media-libs/clutter-gtk-1.4.2
=x11-wm/muffin-1.8.2-r1

and see if that helps. Clutter I know made the Cinnamon menu freeze on mouse clicks. I'm also running all ~amd64 so that might help as well.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum