Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Have no Idea what I screwed up
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
linuxUser1
n00b
n00b


Joined: 16 Aug 2013
Posts: 4
Location: Somewhere in Nevada

PostPosted: Wed Aug 21, 2013 8:01 pm    Post subject: Have no Idea what I screwed up Reply with quote

After successfully installing the basic genkernel and successfully booting into my new kernel I wanted to install a desktop environment, GNOME. I've tried now for about a week tinkering around with the kernel, xorg, etc.. to which I have no success. Sorry D:

Code:
 uname -r
3.8.13-gentoo


Code:

Portage 2.1.12.2 (default/linux/x86/13.0/desktop, gcc-4.6.3, glibc-2.15-r3, 3.8.13-gentoo i686)
=================================================================
System uname: Linux-3.8.13-gentoo-i686-Intel-R-_Pentium-R-_M_processor_1400MHz-with-gentoo-2.2
KiB Mem:     1033328 total,    839112 free
KiB Swap:    2097148 total,   2097148 free
Timestamp of tree: Tue, 20 Aug 2013 00:45:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
app-shells/bash:          4.2_p45
dev-lang/python:          2.7.5, 3.2.5-r1
dev-util/cmake:           2.8.10.2-r2
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.10.3, 1.12.6
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.6.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.7 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="* -@EULA"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=pentium-m -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=pentium-m -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -march=i686 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -march=i686 -pipe"
GENTOO_MIRRORS="http://lug.mtu.edu/gentoo/"
LANG="en_US_UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync3.us.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa berkdb bluetooth branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr emboss encode exif fam firefox flac fortran gdbm gif gnome gpm gtk iconv ipv6 jpeg lcms ldap libffi libkms libnotify mad mng modules mp3 mp4 mpeg mudflap ncurses nls nptl ogg opengl openmp pam pango pcre pdf png policykit ppds python* qt3support readline sdl session spell ssl startup-notification svg tcpd tiff truetype udev udisks unicode upower usb vorbis wxwidgets x264 x86 xa xcb xml xv xvid zlib" ABI_X86="32" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-4" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby19 ruby18" USERLAND="GNU" VIDEO_CARDS="radeon" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON


Code:
 ls /boot
3.8.13-gentoo
System.map-genkernel-x86-3.8.13-gentoo
boot
grub
initramfs-genkernel-x86-3.8.13-gentoo
kernel-3.8.13-gentoo
kernel-genkernel-x86-3.8.13-gentoo
lost+found


Code:
 ls
xorg.conf.new
xorg.conf.new1


Code:
 modprobe -c
http://bpaste.net/show/124917/


Code:
 nano /var/log/Xorg.0.log
[?7h[?25h[?0c  GNU nano 2.3.2           File: /var/log/Xorg.0.log                            [  3002.925]
X.Org X Server 1.13.4
Release Date: 2013-04-17
[  3002.925] X Protocol Version 11, Revision 0
[  3002.925] Build Operating System: Linux 3.8.13-gentoo i686 Gentoo
[  3002.925] Current Operating System: Linux ghostx 3.8.13-gentoo #1 SMP Thu Au$[  3002.925] Kernel command line: root=/dev/sda3
[  3002.925] Build Date: 20 August 2013  03:07:58PM
[  3002.925]
[  3002.925] Current version of pixman: 0.28.0
[  3002.926]    Before reporting problems, check http://wiki.x.orgto make sure that you have the latest version.
[  3002.926] Markers: (--) probed, (**) from config file, (==) default setting,(++) from command line, (!!) notice, (II) informational,(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  3002.926] (==) Log file: "/var/log/Xorg.0.log", Time: Wed Aug 21 12:43:29 20$[  3002.927] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[  3002.927] (==) No Layout section.  Using the first Screen section.
[  3002.927] (==) No screen section available. Using defaults.
[  3002.927] (**) |-->Screen "Default Screen Section" (0)[ Read 367 lines ]
^G Get Help  ^O WriteOut  ^W Where Is  ^V Next Page ^U UnCut Text^T To Spell
^X Exit^R Read File ^Y Prev Page ^K Cut Text  ^C Cur Pos   M-| First Line
[ line 1/368 (0%), col 1/14 (7%), char 0/19957 (0%) ]



Code:
 lsmod
http://bpaste.net/show/124915/


Code:
 lspci


00:00.0 Host bridge: Intel Corporation 82855PM Processor to I/O Controller (rev 03)
00:01.0 PCI bridge: Intel Corporation 82855PM Processor to AGP Controller (rev 03)
00:1d.0 USB controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #1 (rev 01)
00:1d.1 USB controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #2 (rev 01)
00:1d.2 USB controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #3 (rev 01)
00:1d.7 USB controller: Intel Corporation 82801DB/DBM (ICH4/ICH4-M) USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 81)
00:1f.0 ISA bridge: Intel Corporation 82801DBM (ICH4-M) LPC Interface Bridge (rev 01)
00:1f.1 IDE interface: Intel Corporation 82801DBM (ICH4-M) IDE Controller (rev 01)
00:1f.5 Multimedia audio controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 01)
00:1f.6 Modem: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Modem Controller (rev 01)
01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI RV250/M9 GL [Mobility FireGL 9000/Radeon 9000] (rev 02)
02:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5705M Gigabit Ethernet (rev 01)
02:01.0 CardBus bridge: O2 Micro, Inc. OZ711EC1 SmartCardBus Controller (rev 20)
02:01.1 CardBus bridge: O2 Micro, Inc. OZ711EC1 SmartCardBus Controller (rev 20)
02:03.0 Network controller: Broadcom Corporation BCM4309 802.11abg Wireless Network Controller (rev 02)


It's kind of sad because I don't know how to update the kernel to use the new Xorg conf, neither do I know how to correctly configure the Xorg configuration file, but I know I correctly configured my make menuconfig to some extent >.<
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 33621
Location: 56N 3W

PostPosted: Wed Aug 21, 2013 8:50 pm    Post subject: Reply with quote

linuxUser1,

I suspect Gnome may be painfully slow on your hardware but the first step is to get Xorg working.

Your Xorg.0.log is corrupt, which is a bad sign. Can you reproduce this corruption and if you do, is there any problems logged in dmesg?

Install the following packages
Code:
emerge -1 xf86-video-vesa twm xterm xclock
then run startx as a normal user.

If the radeon driver fails to load, Xorg should fall back to the vesa driver and you should get three xterms, an analogue clock all supported by twm.

Whatever the result, post your /var/log/Xorg.0.log on a pastebin site. wgetpaste is your friend here.
That will show what happened when Xorg (tried to) start(ed).

If there are errors in dmesg, pastebin that too.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
linuxUser1
n00b
n00b


Joined: 16 Aug 2013
Posts: 4
Location: Somewhere in Nevada

PostPosted: Thu Aug 22, 2013 6:11 pm    Post subject: Desktop Issues Reply with quote

Hello, I finally got to the point of when I login as a regular user and ^C almost immediately after issuing the startx command do I get the three xterm prompts and one analog clock. It doesn't always work though D:

http://bpaste.net/show/125227/ Xorg Log
http://bpaste.net/show/125220/ dmesg

This is actually after I issued these (VV) commands, only because after loading the initial failback drivers the first time startx didn't even load anything.

Code:


>emerge -1 xf86-video-vesa twm xterm xclock
>emerge --ask @x11-modules-rebuild
>emerge --ask @world
>emerge --sync
>emerge -1 xf86-video-vesa twm xterm xclock


_________________
ghostx1
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 33621
Location: 56N 3W

PostPosted: Thu Aug 22, 2013 6:46 pm    Post subject: Reply with quote

linuxUser1,

Xorg.0.log:
[   135.156] (II) [KMS] drm report modesetting isn't supported.
[   135.156] (EE) Screen 0 deleted because of no matching config section.

Shows that when the radeon driver loads, it finds a piece of the kernel missing. In the example log you posted, Xorg went on to start normally with the vesa driver, which was what I was expecting to happen.

Your dmesg is missing the first few seconds as your kernel ring buffer is a little on the small side.
dmesg:
[   12.471703] video: Unknown symbol backlight_device_unregister (err 0)
[   12.471736] video: Unknown symbol backlight_force_update (err 0)
[   12.471877] video: Unknown symbol backlight_device_register (err 0)
is another pointer to kernel problems.

Have a look at the Gentoo Wiki, in particular, the kernel setup.
You need to fix your kernel configuration, rebuilt the kernel, install the new kernel and reboot to use it.
When its right, the radeon driver will start.

If you still have problems pastebin your kernel .config file.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum