Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
please help me understand portage
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
chrosa
n00b
n00b


Joined: 27 Jul 2013
Posts: 16
Location: Norway

PostPosted: Mon Aug 19, 2013 6:01 pm    Post subject: please help me understand portage Reply with quote

so trying to emerge gnome 3.8, just install'd gentoo again and keep getting the same output.
i know i have to put the use flags and unmerge some, but cant say that i understand much of it, so can antone please help me out understand how to do this :)


localhost portage # emerge gnome

* IMPORTANT: 4 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.

Calculating dependencies... done!

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/glib:2

(dev-libs/glib-2.36.4::gentoo, ebuild scheduled for merge) pulled in by
>=dev-libs/glib-2.36.4:2 required by (dev-util/gdbus-codegen-2.36.4::gentoo, ebuild scheduled for merge)
(and 5 more with the same problem)

(dev-libs/glib-2.32.4-r1::gentoo, installed) pulled in by
(no parents that aren't satisfied by other packages in this slot)

sys-auth/pambase:0

(sys-auth/pambase-20120417-r2::gentoo, installed) pulled in by
(no parents that aren't satisfied by other packages in this slot)

(sys-auth/pambase-20120417-r2::gentoo, ebuild scheduled for merge) pulled in by
sys-auth/pambase[consolekit] required by (sys-auth/polkit-0.111-r1::gentoo, ebuild scheduled for merge)

sys-libs/zlib:0

(sys-libs/zlib-1.2.8-r1::gentoo, ebuild scheduled for merge) pulled in by
>=sys-libs/zlib-1.2.8-r1:=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_x86_32(-)?,abi_x86_64(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (media-libs/libpng-1.6.3-r1::gentoo, ebuild scheduled for merge)

(sys-libs/zlib-1.2.7::gentoo, installed) pulled in by
(no parents that aren't satisfied by other packages in this slot)

dev-util/gtk-doc-am:0

(dev-util/gtk-doc-am-1.18::gentoo, installed) pulled in by
(no parents that aren't satisfied by other packages in this slot)

(dev-util/gtk-doc-am-1.19::gentoo, ebuild scheduled for merge) pulled in by
~dev-util/gtk-doc-am-1.19 required by (dev-util/gtk-doc-1.19::gentoo, ebuild scheduled for merge)

dev-libs/libxml2:2

(dev-libs/libxml2-2.9.1-r1::gentoo, ebuild scheduled for merge) pulled in by
dev-libs/libxml2[python] required by (dev-util/itstool-1.2.0::gentoo, ebuild scheduled for merge)

(dev-libs/libxml2-2.9.1-r1::gentoo, installed) pulled in by
(no parents that aren't satisfied by other packages in this slot)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.
localhost portage # emerge -av layman

* IMPORTANT: 4 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/glib:2

(dev-libs/glib-2.36.4::gentoo, ebuild scheduled for merge) pulled in by
>=dev-libs/glib-2.36.4:2 required by (dev-util/gdbus-codegen-2.36.4::gentoo, ebuild scheduled for merge)
(and 7 more with the same problem)

(dev-libs/glib-2.32.4-r1::gentoo, installed) pulled in by
(no parents that aren't satisfied by other packages in this slot)

sys-libs/zlib:0

(sys-libs/zlib-1.2.8-r1::gentoo, ebuild scheduled for merge) pulled in by
>=sys-libs/zlib-1.2.5.1-r2:0[minizip] required by (dev-db/virtuoso-server-6.1.6::gentoo, ebuild scheduled for merge)
>=sys-libs/zlib-1.2.8-r1:=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_x86_32(-)?,abi_x86_64(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (media-libs/libpng-1.6.3-r1::gentoo, ebuild scheduled for merge)

(sys-libs/zlib-1.2.7::gentoo, installed) pulled in by
(no parents that aren't satisfied by other packages in this slot)

sys-auth/pambase:0

(sys-auth/pambase-20120417-r2::gentoo, installed) pulled in by
(no parents that aren't satisfied by other packages in this slot)

(sys-auth/pambase-20120417-r2::gentoo, ebuild scheduled for merge) pulled in by
sys-auth/pambase[consolekit] required by (sys-auth/polkit-0.111-r1::gentoo, ebuild scheduled for merge)

dev-util/gtk-doc-am:0

(dev-util/gtk-doc-am-1.18::gentoo, installed) pulled in by
(no parents that aren't satisfied by other packages in this slot)

(dev-util/gtk-doc-am-1.19::gentoo, ebuild scheduled for merge) pulled in by
~dev-util/gtk-doc-am-1.19 required by (dev-util/gtk-doc-1.19::gentoo, ebuild scheduled for merge)

dev-libs/libxml2:2

(dev-libs/libxml2-2.9.1-r1::gentoo, ebuild scheduled for merge) pulled in by
dev-libs/libxml2[python] required by (dev-util/itstool-1.2.0::gentoo, ebuild scheduled for merge)

(dev-libs/libxml2-2.9.1-r1::gentoo, installed) pulled in by
(no parents that aren't satisfied by other packages in this slot)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


The following USE changes are necessary to proceed:
(see "package.use" in the portage(5) man page for more details)
# required by dev-db/virtuoso-server-6.1.6
# required by dev-libs/soprano-2.9.3[virtuoso]
# required by kde-base/nepomuk-widgets-4.11.0
# required by kde-base/kdelibs-4.11.0
# required by net-libs/libproxy-0.4.11-r1[kde]
# required by net-libs/glib-networking-2.36.2[libproxy]
# required by net-libs/libsoup-2.42.2
# required by media-plugins/gst-plugins-soup-0.10.31
# required by media-libs/phonon-gstreamer-4.6.3[network]
# required by media-libs/phonon-4.6.0-r1[gstreamer]
>=sys-libs/zlib-1.2.8-r1 minizip

Use --autounmask-write to write changes to config files (honoring
CONFIG_PROTECT). Carefully examine the list of proposed changes,
paying special attention to mask or keyword changes that may expose
experimental or unstable packages.

!!! The ebuild selected to satisfy "net-fs/cifs-utils" has unmet requirements.
- net-fs/cifs-utils-6.1::gentoo USE="acl caps caps-ng -ads -creds -upcall"

The following REQUIRED_USE flag constraints are unsatisfied:
acl? ( upcall )

(dependency required by "net-fs/samba-3.6.18[client]" [ebuild])
(dependency required by "net-libs/libsoup-2.42.2[samba]" [ebuild])
(dependency required by "media-plugins/gst-plugins-soup-0.10.31" [ebuild])
(dependency required by "media-libs/phonon-gstreamer-4.6.3[network]" [ebuild])
(dependency required by "media-libs/phonon-4.6.0-r1[gstreamer]" [ebuild])
(dependency required by "kde-base/kdelibs-4.11.0" [ebuild])
(dependency required by "net-libs/libproxy-0.4.11-r1[kde]" [ebuild])
(dependency required by "net-libs/glib-networking-2.36.2[libproxy]" [ebuild])


!!! The ebuild selected to satisfy "net-fs/cifs-utils" has unmet requirements.
- net-fs/cifs-utils-6.1::gentoo USE="acl caps caps-ng -ads -creds -upcall"

The following REQUIRED_USE flag constraints are unsatisfied:
acl? ( upcall )

(dependency required by "net-fs/samba-3.6.18[client]" [ebuild])
(dependency required by "net-libs/libsoup-2.42.2[samba]" [ebuild])
(dependency required by "media-plugins/gst-plugins-soup-0.10.31" [ebuild])
(dependency required by "media-libs/phonon-gstreamer-4.6.3[network]" [ebuild])
(dependency required by "media-libs/phonon-4.6.0-r1[gstreamer]" [ebuild])
(dependency required by "kde-base/kdelibs-4.11.0" [ebuild])
(dependency required by "net-libs/libproxy-0.4.11-r1[kde]" [ebuild])
(dependency required by "net-libs/glib-networking-2.36.2[libproxy]" [ebuild])
_________________
Yeah, Windows is great... I used it to download Linux!
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 6251
Location: Goose Creek SC

PostPosted: Mon Aug 19, 2013 6:53 pm    Post subject: Reply with quote

A reading assignment:
http://www.gentoo.org/doc/en/handbook/handbook-amd64.xml?style=printable&full=1#book_part2
http://www.gentoo.org/doc/en/handbook/handbook-amd64.xml?style=printable&full=1#book_part3

If you do not have the gnome profile set, you should set it. The gnome profile contains the expert's choices of use flags.

To check:
Code:
 eselect profile list
should produce:
Quote:
Available profile symlink targets:
[1] default/linux/amd64/13.0
[2] default/linux/amd64/13.0/selinux
[3] default/linux/amd64/13.0/desktop
[4] default/linux/amd64/13.0/desktop/gnome *
[5] default/linux/amd64/13.0/desktop/kde
[6] default/linux/amd64/13.0/developer
[7] default/linux/amd64/13.0/no-multilib
[8] default/linux/amd64/13.0/x32
[9] hardened/linux/amd64
[10] hardened/linux/amd64/selinux
[11] hardened/linux/amd64/no-multilib
[12] hardened/linux/amd64/no-multilib/selinux
[13] hardened/linux/amd64/x32
[14] hardened/linux/uclibc/amd64

If another profile is selected, reset it by:
Code:
eselect profile set 4

If you have a USE=" line in /etc/portage/make.conf suggest you comment it out as in #USE=" . If you don't have the USE= line leave it out. You can play with global USE flags later.

Run
Code:
emerge wgetpaste
emerge -pv gnome | tee out.txt
wgetpaste out.txt
rm out.txt


post the url returned, we can then attack specific problems from a common established base.
_________________
Defund the FCC.
Back to top
View user's profile Send private message
chrosa
n00b
n00b


Joined: 27 Jul 2013
Posts: 16
Location: Norway

PostPosted: Mon Aug 19, 2013 7:20 pm    Post subject: Reply with quote

thnx for the fast reply m8, so i # the use=" entry in make.conf, and things look better already. think i used to many use flags that didn't apply.
_________________
Yeah, Windows is great... I used it to download Linux!
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 6251
Location: Goose Creek SC

PostPosted: Mon Aug 19, 2013 7:28 pm    Post subject: Reply with quote

may be good to
Code:
emerge -uND world
to reset the non gnome world packages that may have been built with random USE flags.
_________________
Defund the FCC.
Back to top
View user's profile Send private message
chrosa
n00b
n00b


Joined: 27 Jul 2013
Posts: 16
Location: Norway

PostPosted: Mon Aug 19, 2013 8:17 pm    Post subject: Reply with quote

thanks again, think i'm gonna think things more thru before i add them to use=" from now on :)
_________________
Yeah, Windows is great... I used it to download Linux!
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 6251
Location: Goose Creek SC

PostPosted: Mon Aug 19, 2013 8:23 pm    Post subject: Reply with quote

most of us go USE happy on first install ...
_________________
Defund the FCC.
Back to top
View user's profile Send private message
chrosa
n00b
n00b


Joined: 27 Jul 2013
Posts: 16
Location: Norway

PostPosted: Wed Aug 21, 2013 8:48 am    Post subject: Use="? Reply with quote

so if i want to run gnome 3, then my USE will look something like this
USE="gnome gtk X" ??
are there more i should put in there ?
_________________
Yeah, Windows is great... I used it to download Linux!
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 6251
Location: Goose Creek SC

PostPosted: Wed Aug 21, 2013 9:00 am    Post subject: Reply with quote

run
Code:
emerge --info
and have a look at all the free USE flags you already have coutesy of the profile. Should see X gnome and gtk already enabled. Being redundant is neither harmful nor helpful. BTW another handy tool for viewing and managing is ufed.
_________________
Defund the FCC.
Back to top
View user's profile Send private message
chrosa
n00b
n00b


Joined: 27 Jul 2013
Posts: 16
Location: Norway

PostPosted: Wed Aug 21, 2013 12:58 pm    Post subject: Reply with quote

thanks again m8, gonna have a look at it when i get home from work :)
_________________
Yeah, Windows is great... I used it to download Linux!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum