Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Xen: can't migrate Gentoo domUs between hosts
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message

Joined: 18 Aug 2013
Posts: 1

PostPosted: Mon Aug 19, 2013 4:53 pm    Post subject: Xen: can't migrate Gentoo domUs between hosts Reply with quote

We have two twin systems (Dell Xeon servers) which have been happily running Gentoo and Xen in the last years, we also recently added an iSCSI SAN (Dell MD3220i) and moved Xen VMs on that. This has been happily running for some months now.

I can live migrate Ubuntu 64bit PV domU (both 10.04 and 12.04) just fine between the two nodes, but I have problems when trying to migrate Gentoo 64bit PV domU: they seem to migrate and "run" on the destination node, but any interaction with the external world (block devices, network, console) seems to be frozen...
- xm migrate $DOMAIN $OTHER_NODE_IP, with or without "-l" (live migration), will always "succeed"
- after migration, I can see the domU on the destination node, in running state, and consuming CPU resources (eg. "Time" in xm list or xm top will move on)
- but I cannot access the domU via network (nor does it sends out anything on its vif as seen from dom0), and while "xm console $DOMAIN" does "connect" to the domU console, I can't get any output from it
- xm shutdown won't shutdown the migrated domU
- it seems, but I don't have scientific evidence for it yet, that the domU does not do any I/O on the SAN from the destination node (not a single IOP, that is)
- /var/log/xen/xend.log does not have any WARNING/ERROR about the migration, just a bunch of INFO and DEBUG lines

Some configuration details:
- both systems are up-to-date Gentoo hardened/linux/amd64 profile
- both systems run app-emulation/xen-4.3.0 with Domain-0 kernel gentoo-sources-3.7.7
- the domU are PV domains Gentoo hardened/linux/amd64 with kernel gentoo-sources-3.10.7
- xen configuration files for all DomUs (both Gentoo & Ubuntu) are identical, except for different amount of allocated memory

I suspect that there is something about my domU kernels that is causing this issue, but I have no idea where to start looking around: I have no console output and no logging on the filesystem after the migration event :|

Has anyone compiled a kernel (on gentoo or anything else) capable of being migrated between Xen hosts? Any other suggestion?

Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum