Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Unable to add gnome overlay
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
rain_physics
n00b
n00b


Joined: 24 Mar 2013
Posts: 10

PostPosted: Sat Aug 17, 2013 1:19 pm    Post subject: Unable to add gnome overlay Reply with quote

Hi,
I am trying to install Gnome 3 on my Gentoo 3.8.13 x86_64. For this reason I emerge layman. But I am unable to add gnome overlay.


Code:
sudo layman -a gnome

 * Adding overlay,...
 * Warning: an installed db file was not found at: ['/var/lib/layman/installed.xml']
 * Warning: an installed db file was not found at: ['/var/lib/layman/cache_ac494f50f5736be7871962c0dec7b3bb.xml']
 * Exception: Overlay "gnome" does not exist.
 * CLI: Errors occurred processing action add
 * Exception: Overlay "gnome" does not exist.



Thanks in advance.
Back to top
View user's profile Send private message
dol-sen
Developer
Developer


Joined: 30 Jun 2002
Posts: 2503
Location: Richmond, BC, Canada

PostPosted: Sun Aug 18, 2013 6:30 am    Post subject: Reply with quote

hmm, did you add the "source /var/lib/layman/make.conf" line to your /etc/portage/make.conf file?

Did you run
Code:
layman -f
# or
layman -L


I believe that you did not, so it didn't have the repositories.xml file downloaded from the gentoo server which would have caused the
Code:
  * Warning: an installed db file was not found at: ['/var/lib/layman/cache_ac494f50f5736be7871962c0dec7b3bb.xml']
 * Exception: Overlay "gnome" does not exist.


So run one of the above commands, then
Code:
layman -i gnome
layman -a gnome



if you haven't added any overlays, then it won't have an installed.xml file, so don't worry about that one
_________________
Brian
Porthole, the Portage GUI frontend irc@freenode: #gentoo-guis, #porthole, Blog
layman, gentoolkit, CoreBuilder, esearch...
Back to top
View user's profile Send private message
rain_physics
n00b
n00b


Joined: 24 Mar 2013
Posts: 10

PostPosted: Sun Aug 18, 2013 2:06 pm    Post subject: Reply with quote

Thanks for your kind reply
My make.conf is like this

Code:

CFLAGS="-march=core2 -O2 -pipe"
CXXFLAGS="${CFLAGS}"
CHOST="x86_64-pc-linux-gnu"
USE="bindist mmx sse sse2 -kde X dbus gtk gnome alsa cdr dvd acpi samba smbsharemodes kerberos pam readline python winbind"
MAKEOPTS="-j5"
ACCEPT_LICENSE="* -@EULA"
VIDEO_CARDS="radeon"
INPUT_DEVICES="evdev synaptics"
source /var/lib/layman/make.conf


Then I run the following command

Code:

layman -f
 * Fetching remote list,...
 * Remote list already up to date: http://www.gentoo.org/proj/en/overlays/repositories.xml
 * Last-modified: Sun, 28 Jul 2013 14:14:43 GMT
 * Fetch Ok


Then I run the following command

Code:

layman -i gnome

 * gnome
 * ~~~~~
 * Sources:
 *   1. git://git.overlays.gentoo.org/proj/gnome.git
 *   2. http://git.overlays.gentoo.org/gitroot/proj/gnome.git
 *   3. git+ssh://git@git.overlays.gentoo.org/proj/gnome.git
 *
 * Contact : GNOME team <gnome@gentoo.org>
 * Type    : Git; Priority: 50
 * Quality : experimental
 *
 * Description:
 *   experimental gnome ebuilds
 *
 * Link:
 *   http://git.overlays.gentoo.org/gitweb/?p=proj/gnome.git;a=summary
 *
 * Feeds:
 *   http://git.overlays.gentoo.org/gitweb/?p=proj/gnome.git;a=atom
 *   http://git.overlays.gentoo.org/gitweb/?p=proj/gnome.git;a=rss
 *



Then I run the following command

Code:

layman -a gnome

 * Adding overlay,...
 * Warning: an installed db file was not found at: ['/var/lib/layman/installed.xml']
 * Running Git... # ( cd /var/lib/layman  && /usr/bin/git clone git://git.overlays.gentoo.org/proj/gnome.git /var/lib/layman/gnome )
Cloning into '/var/lib/layman/gnome'...
fatal: unable to connect to git.overlays.gentoo.org:
git.overlays.gentoo.org[0: 94.100.119.163]: errno=Connection timed out

 * Failure result returned from Git
 * Running Git... # ( cd /var/lib/layman/gnome  && /usr/bin/git config user.name "layman" )
 * [Errno 2] No such file or directory: '/var/lib/layman/gnome'
 *
 * Trying next source of listed sources...
 * Running Git... # ( cd /var/lib/layman  && /usr/bin/git clone http://git.overlays.gentoo.org/gitroot/proj/gnome.git/ /var/lib/layman/gnome )
Cloning into '/var/lib/layman/gnome'...
error: Failed connect to git.overlays.gentoo.org:80; Connection timed out while accessing http://git.overlays.gentoo.org/gitroot/proj/gnome.git/info/refs?service=git-upload-pack
fatal: HTTP request failed
 * Failure result returned from Git
 * Running Git... # ( cd /var/lib/layman/gnome  && /usr/bin/git config user.name "layman" )
 * [Errno 2] No such file or directory: '/var/lib/layman/gnome'
 *
 * Trying next source of listed sources...
 * Running Git... # ( cd /var/lib/layman  && /usr/bin/git clone git+ssh://git@git.overlays.gentoo.org/proj/gnome.git /var/lib/layman/gnome )
Cloning into '/var/lib/layman/gnome'...
ssh: connect to host git.overlays.gentoo.org port 22: Connection timed out
fatal: Could not read from remote repository.

Please make sure you have the correct access rights
and the repository exists.
 * Failure result returned from Git
 * Running Git... # ( cd /var/lib/layman/gnome  && /usr/bin/git config user.name "layman" )
 * [Errno 2] No such file or directory: '/var/lib/layman/gnome'
 * Adding repository "gnome" failed!
 * Warning: an installed db file was not found at: ['/var/lib/layman/installed.xml']

 * CLI: Errors occurred processing action add
 * Adding repository "gnome" failed!



still I am unable to add gnome overlay :(
Back to top
View user's profile Send private message
dol-sen
Developer
Developer


Joined: 30 Jun 2002
Posts: 2503
Location: Richmond, BC, Canada

PostPosted: Sun Aug 18, 2013 3:26 pm    Post subject: Reply with quote

OK, your almost there, it's just that your connection timed out before it could clone the overlay.
Code:
fatal: unable to connect to git.overlays.gentoo.org:
git.overlays.gentoo.org[0: 94.100.119.163]: errno=Connection timed out
a few other errors occurred due to that
It happens from time to time depending on the server load, etc. It happens for sync's at times too.

Try adding it again, it should successfully add it.
_________________
Brian
Porthole, the Portage GUI frontend irc@freenode: #gentoo-guis, #porthole, Blog
layman, gentoolkit, CoreBuilder, esearch...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum