Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Portage wants to downgrade Vuze (Torrent client) [solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
jonfr
l33t
l33t


Joined: 20 Jul 2003
Posts: 908
Location: Denmark

PostPosted: Sun Aug 18, 2013 12:46 am    Post subject: Portage wants to downgrade Vuze (Torrent client) [solved] Reply with quote

For some reasons portage wants to downgrade Vuze from version 4.8.1.2-r1 and down to 4.5.1.0. A lot older version that is not nearly as good as the newer one.

I get this message when I run 'emerge world -uDNpv'.

Code:
(net-p2p/vuze-4.8.1.2-r1::gentoo, ebuild scheduled for merge) conflicts with
    ~net-p2p/vuze-4.5.1.0 required by (net-p2p/vuze-coreplugins-4.5.1.0::gentoo, ebuild scheduled for merge)


I do not have Vuze-4.5.1.0 installed on my system. So why I am getting downgraded to a lot older version? Version 4.8.1.2 is also outdated by several new releases by now according to latest information on this program.


Last edited by jonfr on Sun Aug 18, 2013 10:44 am; edited 1 time in total
Back to top
View user's profile Send private message
666threesixes666
Veteran
Veteran


Joined: 31 May 2011
Posts: 1223
Location: 42.68n 85.41w

PostPosted: Sun Aug 18, 2013 12:53 am    Post subject: Reply with quote

you need to unmask its core plugs....

Code:

echo "net-p2p/vuze-coreplugins" >> /etc/portage/package.accept_keywords


then it should upgrade the other rather than downgrade the vuze.

the old version is stabilized, the new versions not. id not worry about running "unstable" software.
_________________
cat /etc/*-release
Funtoo Linux - baselayout 2.2.0
consider this warning no. 1
http://ecx.images-amazon.com/images/I/81Ku-vxIb3L._SL1500_.jpg
http://wiki.gentoo.org/wiki/Special:Contributions/666threesixes666
Back to top
View user's profile Send private message
kurly
Apprentice
Apprentice


Joined: 02 Apr 2012
Posts: 164

PostPosted: Sun Aug 18, 2013 2:32 am    Post subject: Reply with quote

666threesixes666 wrote:

the old version is stabilized, the new versions not. id not worry about running "unstable" software.


You have a bad habit of blindly suggesting that people mix unstable software with stable, without knowing anything about their system or situation. I have encouraged you in the past to stop this, but I guess I'll try again.

Stop giving out potentially dangerous advice. It may not be dangerous in this EXACT situation, and nobody may be bitten THIS time, but it is simply NOT good advice to offer in general without knowing more about peoples' setups. Think more; speak less. If you are not certain of a solution, at least admit so. The regulars around here know to take your guessing/advice with a grain of salt, but newcomers in general do not. I know you are trying to be genuinely helpful, and that is awesome and highly appreciated. But try to limit your assistance to things that are part of your core knowledge set. Sooner or later, you're going to cause serious harm to someone's system (again, meaning the best), and it's going to be very unfortunate.
Back to top
View user's profile Send private message
TomWij
Developer
Developer


Joined: 04 Jul 2012
Posts: 1347

PostPosted: Sun Aug 18, 2013 8:25 am    Post subject: Reply with quote

Code:
 $ eshowkw net-p2p/vuze
Keywords for net-p2p/vuze:
           |                           | u   | 
           | a a             p     s   | n   | 
           | l m   h i m m   p s   p   | u s | r
           | p d a p a 6 i p c 3   a x | s l | e
           | h 6 r p 6 8 p p 6 9 s r 8 | e o | p
           | a 4 m a 4 k s c 4 0 h c 6 | d t | o
-----------+---------------------------+-----+-------
4.5.1.0-r1 | o + o o o o o + + o o o + | o 0 | gentoo
4.7.1.2-r1 | o ~ o o o o o ~ ~ o o o ~ | #   | gentoo
4.8.1.2-r1 | o ~ o o o o o ~ ~ o o o ~ | o   | gentoo
 $ eshowkw net-p2p/vuze-coreplugins
Keywords for net-p2p/vuze-coreplugins:
        |                           | u   | 
        | a a             p     s   | n   | 
        | l m   h i m m   p s   p   | u s | r
        | p d a p a 6 i p c 3   a x | s l | e
        | h 6 r p 6 8 p p 6 9 s r 8 | e o | p
        | a 4 m a 4 k s c 4 0 h c 6 | d t | o
--------+---------------------------+-----+-------
4.5.1.0 | o + o o o o o + + o o o + | o 0 | gentoo
4.7.1.2 | o ~ o o o o o ~ ~ o o o ~ | #   | gentoo
4.8.1.2 | o ~ o o o o o ~ ~ o o o ~ | o   | gentoo


If you accept keyword for one then you need to also accept keywords on its dependencies.

You likely have unmasked the specific version but not its revisions; therefore, because I did a revision bump to fix up that package it downgrades it because you don't accept the revision.

Use ~ instead of = next time in package.accept_keywords and it will accept revisions.
Back to top
View user's profile Send private message
jonfr
l33t
l33t


Joined: 20 Jul 2003
Posts: 908
Location: Denmark

PostPosted: Sun Aug 18, 2013 10:43 am    Post subject: Reply with quote

I have fixed my 'package.keywords' file. I changed this lines.

Code:
=net-p2p/vuze-coreplugins-4.8.1.2
=net-p2p/vuze-4.8.1.2-r1


Then it started to work properly. Now I get this when I run 'emerge vuze vuze-coreplugins -pv'.

Code:
emerge vuze vuze-coreplugins -pv

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  NS    ] dev-java/bcprov-1.40-r1:1.40 [1.40:1.3] USE="-doc -source" 3,413 kB
[ebuild     U ~] net-p2p/vuze-4.8.1.2-r1 [4.8.1.2] USE="-source" 0 kB
[ebuild   R   ~] net-p2p/vuze-coreplugins-4.8.1.2  0 kB
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum