Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Glibc 2.17
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
rokj
n00b
n00b


Joined: 05 Sep 2005
Posts: 33

PostPosted: Fri Mar 29, 2013 2:05 pm    Post subject: Glibc 2.17 Reply with quote

Hi,

any idea why I get following error when compiling glibc 2.17? I have core i7.

Code:

/bin/sh: /var/tmp/portage/sys-libs/glibc-2.17/work/build-x86-x86_64-pc-linux-gnu-nptl/sunrpc/cross-rpcgen: No such file or directory
mkdir /var/tmp/portage/sys-libs/glibc-2.17/work/build-x86-x86_64-pc-linux-gnu-nptl/sunrpc/rpcsvc
make[2]: *** [/var/tmp/portage/sys-libs/glibc-2.17/work/build-x86-x86_64-pc-linux-gnu-nptl/sunrpc/xnlm_prot.stmp] Error 127
make[2]: *** Waiting for unfinished jobs....
mkdir /var/tmp/portage/sys-libs/glibc-2.17/work/build-x86-x86_64-pc-linux-gnu-nptl/sunrpc/rpcsvc
/bin/sh: /var/tmp/portage/sys-libs/glibc-2.17/work/build-x86-x86_64-pc-linux-gnu-nptl/sunrpc/cross-rpcgen: No such file or directory
make[2]: *** [/var/tmp/portage/sys-libs/glibc-2.17/work/build-x86-x86_64-pc-linux-gnu-nptl/sunrpc/xbootparam_prot.stmp] Error 127
mkdir: cannot create directory ‘/var/tmp/portage/sys-libs/glibc-2.17/work/build-x86-x86_64-pc-linux-gnu-nptl/sunrpc/rpcsvc’: File exists
CPP='x86_64-pc-linux-gnu-gcc -m32 -E -x c-header' /var/tmp/portage/sys-libs/glibc-2.17/work/build-x86-x86_64-pc-linux-gnu-nptl/sunrpc/cross-rpcgen -Y ../scripts -h rpcsvc/bootparam_prot.x -o /var/tmp/portage/sys-libs/glibc-2.17/work/build-x86-x86_64-pc-linux-gnu-nptl/sunrpc/rpcsvc/bootparam_prot.T
CPP='x86_64-pc-linux-gnu-gcc -m32 -E -x c-header' /var/tmp/portage/sys-libs/glibc-2.17/work/build-x86-x86_64-pc-linux-gnu-nptl/sunrpc/cross-rpcgen -Y ../scripts -h rpcsvc/nlm_prot.x -o /var/tmp/portage/sys-libs/glibc-2.17/work/build-x86-x86_64-pc-linux-gnu-nptl/sunrpc/rpcsvc/nlm_prot.T
/bin/sh: /var/tmp/portage/sys-libs/glibc-2.17/work/build-x86-x86_64-pc-linux-gnu-nptl/sunrpc/cross-rpcgen: No such file or directory
make[2]: *** [/var/tmp/portage/sys-libs/glibc-2.17/work/build-x86-x86_64-pc-linux-gnu-nptl/sunrpc/rpcsvc/bootparam_prot.stmp] Error 127
/bin/sh: /var/tmp/portage/sys-libs/glibc-2.17/work/build-x86-x86_64-pc-linux-gnu-nptl/sunrpc/cross-rpcgen: No such file or directory
make[2]: *** [/var/tmp/portage/sys-libs/glibc-2.17/work/build-x86-x86_64-pc-linux-gnu-nptl/sunrpc/rpcsvc/nlm_prot.stmp] Error 127
make[2]: Leaving directory `/var/tmp/portage/sys-libs/glibc-2.17/work/glibc-2.17/sunrpc'
make[1]: *** [sunrpc/others] Error 2
make[1]: Leaving directory `/var/tmp/portage/sys-libs/glibc-2.17/work/glibc-2.17'
make: *** [all] Error 2
emake failed
 * ERROR: sys-libs/glibc-2.17 failed (compile phase):
 *   make for x86 failed
 *
 * Call stack:
 *           ebuild.sh, line   93:  Called src_compile
 *         environment, line 3249:  Called eblit-run 'src_compile'
 *         environment, line  871:  Called eblit-glibc-src_compile
 *   src_compile.eblit, line  230:  Called src_compile
 *         environment, line 3249:  Called eblit-run 'src_compile'
 *         environment, line  871:  Called eblit-glibc-src_compile
 *   src_compile.eblit, line  238:  Called toolchain-glibc_src_compile
 *   src_compile.eblit, line  145:  Called die
 * The specific snippet of code:
 *         emake || die "make for ${ABI} failed"
 *
 * If you need support, post the output of `emerge --info '=sys-libs/glibc-2.17'`,
 * the complete build log and the output of `emerge -pqv '=sys-libs/glibc-2.17'`.
 * The complete build log is located at '/var/tmp/portage/sys-libs/glibc-2.17/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-libs/glibc-2.17/temp/environment'.
 * Working directory: '/var/tmp/portage/sys-libs/glibc-2.17/work/build-x86-x86_64-pc-linux-gnu-nptl'
 * S: '/var/tmp/portage/sys-libs/glibc-2.17/work/glibc-2.17'

>>> Failed to emerge sys-libs/glibc-2.17, Log file:

>>>  '/var/tmp/portage/sys-libs/glibc-2.17/temp/build.log'

 * Messages for package sys-libs/glibc-2.17:

 * ERROR: sys-libs/glibc-2.17 failed (compile phase):
 *   make for x86 failed
 *
 * Call stack:
 *           ebuild.sh, line   93:  Called src_compile
 *         environment, line 3249:  Called eblit-run 'src_compile'
 *         environment, line  871:  Called eblit-glibc-src_compile
 *   src_compile.eblit, line  230:  Called src_compile
 *         environment, line 3249:  Called eblit-run 'src_compile'
 *         environment, line  871:  Called eblit-glibc-src_compile
 *   src_compile.eblit, line  238:  Called toolchain-glibc_src_compile
 *   src_compile.eblit, line  145:  Called die
 * The specific snippet of code:
 *         emake || die "make for ${ABI} failed"
 *
 * If you need support, post the output of `emerge --info '=sys-libs/glibc-2.17'`,
 * the complete build log and the output of `emerge -pqv '=sys-libs/glibc-2.17'`.
 * The complete build log is located at '/var/tmp/portage/sys-libs/glibc-2.17/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-libs/glibc-2.17/temp/environment'.
 * Working directory: '/var/tmp/portage/sys-libs/glibc-2.17/work/build-x86-x86_64-pc-linux-gnu-nptl'
 * S: '/var/tmp/portage/sys-libs/glibc-2.17/work/glibc-2.17'



Kind regards,

Rok
Back to top
View user's profile Send private message
Maitreya
Apprentice
Apprentice


Joined: 11 Jan 2006
Posts: 190

PostPosted: Tue Apr 02, 2013 8:33 am    Post subject: Reply with quote

Which version of binutils and gcc are you using?
Back to top
View user's profile Send private message
rokj
n00b
n00b


Joined: 05 Sep 2005
Posts: 33

PostPosted: Fri Aug 16, 2013 1:11 pm    Post subject: Reply with quote

binutils-2.23.2
gcc-4.6.3
Back to top
View user's profile Send private message
lagalopex
Guru
Guru


Joined: 16 Oct 2004
Posts: 452

PostPosted: Fri Aug 16, 2013 1:30 pm    Post subject: Reply with quote

Ever tried it with -j 1? (Just to get the linear output...)

Bug 474900 - =sys-libs/glibc-2.17 […]cross-rpcgen: No such file or directory
_________________
System: AMD Phenom II X4 840, 16GB RAM, NVidia GeForce GT 520, ASUS M4A87TD/USB3, Raid, Seagate Constellation ES
AMD64 system slow/unresponsive during disk access...
Back to top
View user's profile Send private message
rokj
n00b
n00b


Joined: 05 Sep 2005
Posts: 33

PostPosted: Sat Aug 17, 2013 6:24 am    Post subject: Reply with quote

I get same error.
lagalopex wrote:
Ever tried it with -j 1? (Just to get the linear output...)

Bug 474900 - =sys-libs/glibc-2.17 [...]cross-rpcgen: No such file or directory
Back to top
View user's profile Send private message
TomWij
Developer
Developer


Joined: 04 Jul 2012
Posts: 1352

PostPosted: Sat Aug 17, 2013 7:34 am    Post subject: Reply with quote

Attach your information (`emerge --info` and build.log) to the bug such that it gets bumped.
Back to top
View user's profile Send private message
lagalopex
Guru
Guru


Joined: 16 Oct 2004
Posts: 452

PostPosted: Sat Aug 17, 2013 1:38 pm    Post subject: Reply with quote

rokj wrote:
I get same error.
lagalopex wrote:
Ever tried it with -j 1? (Just to get the linear output...)

Changing MAKEOPTS to only use one job should produce a slightly different build log.
The full build log and emerge-info would help (as TomWij already noted).

So long I take another guess: ;)

Tried safe flags? Like:
Code:

CFLAGS="-march=native -O2 -pipe"
CXXFLAGS="${CFLAGS}"
MAKEOPTS="-j1"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"

_________________
System: AMD Phenom II X4 840, 16GB RAM, NVidia GeForce GT 520, ASUS M4A87TD/USB3, Raid, Seagate Constellation ES
AMD64 system slow/unresponsive during disk access...
Back to top
View user's profile Send private message
rokj
n00b
n00b


Joined: 05 Sep 2005
Posts: 33

PostPosted: Sat Aug 17, 2013 4:11 pm    Post subject: Reply with quote

Did try also that, but same error.

However, changing profile to no-multilib solved problems; probably until I do not need 32bit programs.

lagalopex wrote:
rokj wrote:
I get same error.
lagalopex wrote:
Ever tried it with -j 1? (Just to get the linear output...)

Changing MAKEOPTS to only use one job should produce a slightly different build log.
The full build log and emerge-info would help (as TomWij already noted).

So long I take another guess: ;)

Tried safe flags? Like:
Code:

CFLAGS="-march=native -O2 -pipe"
CXXFLAGS="${CFLAGS}"
MAKEOPTS="-j1"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum