Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved]Unable to "emerge --oneshot portage"
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
roarkh
n00b
n00b


Joined: 24 May 2003
Posts: 70
Location: Bellingham, Washington

PostPosted: Thu Aug 15, 2013 6:55 pm    Post subject: [Solved]Unable to "emerge --oneshot portage" Reply with quote

I'm hoping someone may be able to give me a little help here as I am stuck. I did an emerge sync a bit ago and was advised to run "emerge --oneshot portage" which is something that I have done many times. This time I am getting blocked and am having a difficult time figuring out how to get around the problem. Here is the output...
Code:
emerge --oneshot portage
Calculating dependencies... done!
[ebuild   R    ] virtual/libiconv-0
[ebuild   R    ] virtual/libffi-3.0.11
[ebuild     U  ] sys-apps/portage-2.2.0 [2.1.12.13]
[ebuild     U  ] dev-libs/glib-2.36.3-r2 [2.34.3] ABI_X86="(64%*) -32% (-x32)" PYTHON_TARGETS="python2_7%* (-python2_5) -python2_6%"
[ebuild     U  ] net-libs/libsoup-2.42.2 [2.40.3]
[ebuild     U  ] net-libs/gnome-online-accounts-3.8.2 [3.6.3]
[ebuild     U  ] gnome-extra/evolution-data-server-3.8.4-r1 [3.6.4] USE="gtk%*"
[ebuild     U  ] dev-libs/folks-0.9.3 [0.8.0] USE="-zeitgeist%"
[ebuild  r  U  ] net-im/empathy-3.8.3 [3.6.4]

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

net-libs/gnome-online-accounts:0

  (net-libs/gnome-online-accounts-3.6.3::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (net-libs/gnome-online-accounts-3.8.2::gentoo, ebuild scheduled for merge) pulled in by
    >=net-libs/gnome-online-accounts-3.7.90 required by (gnome-extra/evolution-data-server-3.8.4-r1::gentoo, ebuild scheduled for merge)

net-libs/libsoup:2.4

  (net-libs/libsoup-2.42.2::gentoo, ebuild scheduled for merge) pulled in by
    >=net-libs/libsoup-2.42:2.4 required by (net-libs/gnome-online-accounts-3.8.2::gentoo, ebuild scheduled for merge)

  (net-libs/libsoup-2.40.3::gentoo, installed) pulled in by
    ~net-libs/libsoup-2.40.3[introspection?] required by (net-libs/libsoup-gnome-2.40.3::gentoo, installed)

dev-libs/glib:2

  (dev-libs/glib-2.34.3::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/glib-2.36.3-r2::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/glib-2.36.0:2 required by (net-libs/libsoup-2.42.2::gentoo, ebuild scheduled for merge)
    (and 1 more with the same problem)

gnome-extra/evolution-data-server:0

  (gnome-extra/evolution-data-server-3.6.4::gentoo, installed) pulled in by
    =gnome-extra/evolution-data-server-3.6* required by (mail-client/evolution-3.6.4::gentoo, installed)

  (gnome-extra/evolution-data-server-3.8.4-r1::gentoo, ebuild scheduled for merge) pulled in by
    >=gnome-extra/evolution-data-server-3.8.1:=[vala] required by (dev-libs/folks-0.9.3::gentoo, ebuild scheduled for merge)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.

I would appreciate any advice anyone can provide in getting my system updated.


Last edited by roarkh on Thu Aug 15, 2013 11:55 pm; edited 1 time in total
Back to top
View user's profile Send private message
Oniryczny
Tux's lil' helper
Tux's lil' helper


Joined: 01 Dec 2011
Posts: 128
Location: Poznań

PostPosted: Thu Aug 15, 2013 7:20 pm    Post subject: Reply with quote

I'd try to install all packages instead one blocking then try update the one left and see if it's still giving the same errors...
_________________
cogito ergo sum
Back to top
View user's profile Send private message
roarkh
n00b
n00b


Joined: 24 May 2003
Posts: 70
Location: Bellingham, Washington

PostPosted: Thu Aug 15, 2013 7:35 pm    Post subject: Reply with quote

Oniryczny wrote:
I'd try to install all packages instead one blocking then try update the one left and see if it's still giving the same errors...

I did try updating the individual files that portage wants to pull in and either get the same block messages or in some cases (like glib and libsoup) I get many many block messages...
Code:
emerge -uav libsoup

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] virtual/libiconv-0-r1 [0] ABI_X86="(64%*) -32% (-x32)" 0 kB
[ebuild     U  ] dev-libs/libffi-3.0.13-r1 [3.0.13] USE="-debug -pax_kernel -static-libs {-test}" ABI_X86="(64%*) -32% (-x32)" 0 kB
[ebuild     U  ] virtual/libffi-3.0.13-r1 [3.0.11] ABI_X86="(64%*) -32% (-x32)" 0 kB
[ebuild     U  ] dev-libs/glib-2.36.3-r2:2 [2.34.3:2] USE="-debug (-fam) (-selinux) -static-libs -systemtap {-test} -utils -xattr" ABI_X86="(64%*) -32% (-x32)" PYTHON_TARGETS="python2_7%* (-python2_5) -python2_6%" 6,472 kB
[ebuild     U  ] net-libs/libsoup-2.42.2:2.4 [2.40.3:2.4] USE="introspection ssl -debug -samba {-test}" 716 kB
[ebuild     U  ] net-libs/gnome-online-accounts-3.8.2 [3.6.3] USE="gnome introspection -debug -kerberos" 631 kB
[ebuild     U  ] gnome-extra/evolution-data-server-3.8.4-r1:0/40 [3.6.4:0/40] USE="gnome-online-accounts gtk%* introspection ipv6 ldap vala weather -api-doc-extras -kerberos {-test}" 3,841 kB
[ebuild     U  ] dev-libs/folks-0.9.3:0/25 [0.8.0:0/25] USE="eds socialweb telepathy -debug {-test} -tracker -utils -zeitgeist% (-vala%*)" 1,613 kB
[ebuild  r  U  ] net-im/empathy-3.8.3 [3.6.4] USE="geoloc gnome gnome-online-accounts map spell v4l -debug {-test} (-geocode%*) (-sendto%)" 4,606 kB
[blocks B      ] net-libs/libsoup-gnome ("net-libs/libsoup-gnome" is blocking net-libs/libsoup-2.42.2)
[blocks B      ] <dev-libs/gobject-introspection-1.36 ("<dev-libs/gobject-introspection-1.36" is blocking dev-libs/glib-2.36.3-r2)
[blocks B      ] >=net-libs/libsoup-2.42 (">=net-libs/libsoup-2.42" is blocking net-libs/libsoup-gnome-2.40.3)

Total: 9 packages (9 upgrades), Size of downloads: 17,875 kB
Conflict: 3 blocks (3 unsatisfied)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

gnome-extra/evolution-data-server:0

  (gnome-extra/evolution-data-server-3.6.4::gentoo, installed) pulled in by
    =gnome-extra/evolution-data-server-3.6* required by (mail-client/evolution-3.6.4::gentoo, installed)

  (gnome-extra/evolution-data-server-3.8.4-r1::gentoo, ebuild scheduled for merge) pulled in by
    >=gnome-extra/evolution-data-server-3.8.1:=[vala] required by (dev-libs/folks-0.9.3::gentoo, ebuild scheduled for merge)

net-libs/libsoup:2.4

  (net-libs/libsoup-2.42.2::gentoo, ebuild scheduled for merge) pulled in by
    >=net-libs/libsoup-2.42 required by (dev-libs/libgdata-0.13.3::gentoo, installed)
    (and 7 more with the same problem)

  (net-libs/libsoup-2.40.3::gentoo, installed) pulled in by
    ~net-libs/libsoup-2.40.3[introspection?] required by (net-libs/libsoup-gnome-2.40.3::gentoo, installed)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (net-libs/libsoup-gnome-2.40.3::gentoo, installed) pulled in by
    >=net-libs/libsoup-gnome-2.26.0 required by (gnome-base/gvfs-1.14.2::gentoo, installed)
    net-libs/libsoup-gnome required by @selected
    >=net-libs/libsoup-gnome-2.39.6:2.4 required by (www-client/epiphany-3.6.1::gentoo, installed)
    >=net-libs/libsoup-gnome-2.25.1:2.4 required by (dev-libs/libgweather-3.6.2::gentoo, installed)
    >=net-libs/libsoup-gnome-2.30:2.4 required by (dev-libs/totem-pl-parser-3.4.3-r1::gentoo, installed)

  (dev-libs/glib-2.36.3-r2::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/glib-2.6:2 required by (media-libs/gst-plugins-ugly-1.0.6::gentoo, installed)
    dev-libs/glib:2 required by (media-libs/harfbuzz-0.9.18-r1::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-dts-0.10.23::gentoo, installed)
    >=dev-libs/glib-2.33.1:2 required by (net-libs/libsoup-2.40.3::gentoo, installed)
    >=dev-libs/glib-2.32 required by (sys-auth/polkit-0.111::gentoo, installed)
    >=dev-libs/glib-2.32.0:2 required by (gnome-base/gnome-keyring-3.6.3::gentoo, installed)
    >=dev-libs/glib-2.33.3:2 required by (gnome-base/dconf-0.14.1::gentoo, installed)
    >=dev-libs/glib-2.31:2 required by (media-gfx/eog-3.6.2::gentoo, installed)
    >=dev-libs/glib-2.33.2:2 required by (gnome-base/gdm-3.6.2-r1::gentoo, installed)
    >=dev-libs/glib-2.31.19:2 required by (media-libs/clutter-1.12.2-r1::gentoo, installed)
    >=dev-libs/glib-2.32:2 required by (media-libs/gst-plugins-base-1.0.7::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-resindvd-1.0.7::gentoo, installed)
    >=dev-libs/glib-2.30:2 required by (gnome-extra/gnome-search-tool-3.6.0::gentoo, installed)
    >=dev-libs/glib-2.32:2 required by (dev-libs/folks-0.9.3::gentoo, ebuild scheduled for merge)
    dev-libs/glib:2 required by (app-text/poppler-0.22.5::gentoo, installed)
    dev-libs/glib:2 required by (media-libs/gexiv2-0.6.0::gentoo, installed)
    dev-libs/glib:2 required by (dev-dotnet/glib-sharp-2.12.10::gentoo, installed)
    >=dev-libs/glib-2.18:2 required by (dev-lang/vala-0.20.1::gentoo, installed)
    >=dev-libs/glib-2.28:2 required by (app-editors/gedit-3.6.2-r1::gentoo, installed)
    >=dev-libs/glib-2.16:2 required by (gnome-base/libgnomeui-2.24.5::gentoo, installed)
    >=dev-libs/glib-2.31.10:2 required by (gnome-extra/gnome-color-manager-3.6.1::gentoo, installed)
    >=dev-libs/glib-2.32.0:2 required by (net-libs/telepathy-glib-0.20.3::gentoo, installed)
    >=dev-libs/glib-2.28:2 required by (app-mobilephone/obexd-0.46::gentoo, installed)
    >=dev-libs/glib-2.32 required by (gnome-extra/gucharmap-3.6.1::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-v4l2-1.0.7::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-flac-0.10.31::gentoo, installed)
    >=dev-libs/glib-2.30 required by (dev-util/pkgconfig-0.28::gentoo, installed)
    >=dev-libs/glib-2.22:2= required by (sys-auth/consolekit-0.4.5_p20120320-r2::gentoo, installed)
    >=dev-libs/glib-2.26:2 required by (net-libs/gupnp-0.20.3::gentoo, installed)
    >=dev-libs/glib-2.16 required by (x11-libs/libxklavier-5.3::gentoo, installed)
    >=dev-libs/glib-2.28:2 required by (app-accessibility/at-spi2-core-2.6.3::gentoo, installed)
    >=dev-libs/glib-2.30 required by (gnome-extra/polkit-gnome-0.105::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-libs/gst-plugins-ugly-0.10.19::gentoo, installed)
    >=dev-libs/glib-2.12:2 required by (dev-libs/libgee-0.6.8::gentoo, installed)
    >=dev-libs/glib-2 required by (app-misc/geoclue-0.12.99::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-taglib-1.0.7::gentoo, installed)
    >=dev-libs/glib-2.28:2 required by (media-libs/gegl-0.2.0-r2::gentoo, installed)
    >=dev-libs/glib-2.30.0:2 required by (media-gfx/shotwell-0.14.1::gentoo, installed)
    dev-libs/glib required by (media-libs/qt-gstreamer-0.10.2::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-dvdread-1.0.6::gentoo, installed)
    >=dev-libs/glib-2.14:2 required by (x11-libs/gtksourceview-2.10.5-r2::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-vorbis-0.10.36::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-x264-0.10.19::gentoo, installed)
    >=dev-libs/glib-2.31:2 required by (gnome-extra/gcalctool-6.6.2::gentoo, installed)
     .
     .
     . (these messages continue for a long time, there are a bunch about gobject-introspection as well here)

Thanks for your feedback.
Back to top
View user's profile Send private message
Oniryczny
Tux's lil' helper
Tux's lil' helper


Joined: 01 Dec 2011
Posts: 128
Location: Poznań

PostPosted: Thu Aug 15, 2013 7:48 pm    Post subject: Reply with quote

Code:
emerge -av libsoup
??
_________________
cogito ergo sum
Back to top
View user's profile Send private message
roarkh
n00b
n00b


Joined: 24 May 2003
Posts: 70
Location: Bellingham, Washington

PostPosted: Thu Aug 15, 2013 8:38 pm    Post subject: Reply with quote

I think the main source of my problem was gobject-introspection, updating that seemed to help, now unto to trying to get my system updated.
Back to top
View user's profile Send private message
paul138
Guru
Guru


Joined: 09 Aug 2002
Posts: 370
Location: Ottawa, ON

PostPosted: Mon Aug 26, 2013 5:32 pm    Post subject: Reply with quote

I'm having the same problem. Can you please follow-up with what you did to fix it?
_________________
Talk is cheap because supply always exceeds demand.
Back to top
View user's profile Send private message
roarkh
n00b
n00b


Joined: 24 May 2003
Posts: 70
Location: Bellingham, Washington

PostPosted: Mon Aug 26, 2013 6:41 pm    Post subject: Reply with quote

paul138 wrote:
I'm having the same problem. Can you please follow-up with what you did to fix it?

It has been a little while now but the root of my problem was the fact that portage was pulling in an upgrade to Gnome 3.8. There were a lot of blocks and I don't remember exactly how I determined that gobject-introspection was causing issues for me but I was able to slowly narrow it down to that on my system. If this is being caused by a Gnome 3.8 update then I recommend digging around for some of the Gnome 3.8 update threads, there is a lot of helpful information in some of those, you will probably find, as I did, that removing certain Gnome 3.6 packages is the best way to get around the blocks. Also I would pay special attention to systemd which Gnome 3.8 wants to pull in, migrating to systemd probably was the most time consuming part of the entire update process for me.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum