Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Why is sys-devel/automake-1.13.4 repeatedly (un)merged?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
Helena
Veteran
Veteran


Joined: 02 Apr 2003
Posts: 1027
Location: De Meern, The Netherlands

PostPosted: Sun Aug 11, 2013 8:52 am    Post subject: Why is sys-devel/automake-1.13.4 repeatedly (un)merged? Reply with quote

Probably the following is due to me not understanding Portage completely. I have noticed over the past few days that sys-devel/automake-1.13.4 is repeatedly pulled in (as a dependency) and removed again (by depclean), why I do not understand. Case in point from /var/log/emerge.log:
Code:
1376209397:  *** emerge --autounmask-write --deep --keep-going --update @world
1376209493:  >>> emerge (1 of 7) media-libs/lcms-2.5-r1 to /
1376209495:  === (1 of 7) Cleaning (media-libs/lcms-2.5-r1::/usr/portage/media-libs/lcms/lcms-2.5-r1.ebuild)
1376209495:  === (1 of 7) Compiling/Merging (media-libs/lcms-2.5-r1::/usr/portage/media-libs/lcms/lcms-2.5-r1.ebuild)
1376209523:  === (1 of 7) Merging (media-libs/lcms-2.5-r1::/usr/portage/media-libs/lcms/lcms-2.5-r1.ebuild)
1376209532:  >>> AUTOCLEAN: media-libs/lcms:2
1376209532:  === Unmerging... (media-libs/lcms-2.5)
1376209536:  >>> unmerge success: media-libs/lcms-2.5
1376209538:  === (1 of 7) Post-Build Cleaning (media-libs/lcms-2.5-r1::/usr/portage/media-libs/lcms/lcms-2.5-r1.ebuild)
1376209538:  ::: completed emerge (1 of 7) media-libs/lcms-2.5-r1 to /
1376209538:  >>> emerge (2 of 7) dev-libs/libcdio-0.90-r1 to /
1376209538:  === (2 of 7) Cleaning (dev-libs/libcdio-0.90-r1::/usr/portage/dev-libs/libcdio/libcdio-0.90-r1.ebuild)
1376209538:  === (2 of 7) Compiling/Merging (dev-libs/libcdio-0.90-r1::/usr/portage/dev-libs/libcdio/libcdio-0.90-r1.ebuild)                                                                                                                           
1376209573:  === (2 of 7) Merging (dev-libs/libcdio-0.90-r1::/usr/portage/dev-libs/libcdio/libcdio-0.90-r1.ebuild)                                                                                                                                     
1376209575:  >>> AUTOCLEAN: dev-libs/libcdio:0                                                                                                                                                                                                         
1376209575:  === Unmerging... (dev-libs/libcdio-0.90)                                                                                                                                                                                                   
1376209577:  >>> unmerge success: dev-libs/libcdio-0.90                                                                                                                                                                                                 
1376209580:  === (2 of 7) Post-Build Cleaning (dev-libs/libcdio-0.90-r1::/usr/portage/dev-libs/libcdio/libcdio-0.90-r1.ebuild)                                                                                                                         
1376209580:  ::: completed emerge (2 of 7) dev-libs/libcdio-0.90-r1 to /                                                                                                                                                                               
1376209580:  >>> emerge (3 of 7) sys-devel/automake-1.13.4 to /                                                                                                                                                                                         
1376209580:  === (3 of 7) Cleaning (sys-devel/automake-1.13.4::/usr/portage/sys-devel/automake/automake-1.13.4.ebuild)                                                                                                                                 
1376209580:  === (3 of 7) Compiling/Merging (sys-devel/automake-1.13.4::/usr/portage/sys-devel/automake/automake-1.13.4.ebuild)                                                                                                                         
1376209591:  === (3 of 7) Merging (sys-devel/automake-1.13.4::/usr/portage/sys-devel/automake/automake-1.13.4.ebuild)                                                                                                                                   
1376209592:  >>> AUTOCLEAN: sys-devel/automake:1.13                                                                                                                                                                                                     
1376209598:  === (3 of 7) Post-Build Cleaning (sys-devel/automake-1.13.4::/usr/portage/sys-devel/automake/automake-1.13.4.ebuild)                                                                                                                       
1376209598:  ::: completed emerge (3 of 7) sys-devel/automake-1.13.4 to /                                                                                                                                                                               
1376209598:  >>> emerge (4 of 7) app-text/libpaper-1.1.24-r2 to /                                                                                                                                                                                       
1376209598:  === (4 of 7) Cleaning (app-text/libpaper-1.1.24-r2::/usr/portage/app-text/libpaper/libpaper-1.1.24-r2.ebuild)                                                                                                                             
1376209598:  === (4 of 7) Compiling/Merging (app-text/libpaper-1.1.24-r2::/usr/portage/app-text/libpaper/libpaper-1.1.24-r2.ebuild)                                                                                                                     
1376209620:  === (4 of 7) Merging (app-text/libpaper-1.1.24-r2::/usr/portage/app-text/libpaper/libpaper-1.1.24-r2.ebuild)                                                                                                                               
1376209621:  >>> AUTOCLEAN: app-text/libpaper:0                                                                                                                                                                                                         
1376209621:  === Unmerging... (app-text/libpaper-1.1.24-r1)                                                                                                                                                                                             
1376209623:  >>> unmerge success: app-text/libpaper-1.1.24-r1                                                                                                                                                                                           
1376209626:  === (4 of 7) Post-Build Cleaning (app-text/libpaper-1.1.24-r2::/usr/portage/app-text/libpaper/libpaper-1.1.24-r2.ebuild)                                                                                                                   
1376209626:  ::: completed emerge (4 of 7) app-text/libpaper-1.1.24-r2 to /                                                                                                                                                                             
1376209626:  >>> emerge (5 of 7) dev-libs/libcdio-paranoia-0.90_p1-r1 to /                                                                                                                                                                             
1376209626:  === (5 of 7) Cleaning (dev-libs/libcdio-paranoia-0.90_p1-r1::/usr/portage/dev-libs/libcdio-paranoia/libcdio-paranoia-0.90_p1-r1.ebuild)                                                                                                   
1376209626:  === (5 of 7) Compiling/Merging (dev-libs/libcdio-paranoia-0.90_p1-r1::/usr/portage/dev-libs/libcdio-paranoia/libcdio-paranoia-0.90_p1-r1.ebuild)                                                                                           
1376209663:  === (5 of 7) Merging (dev-libs/libcdio-paranoia-0.90_p1-r1::/usr/portage/dev-libs/libcdio-paranoia/libcdio-paranoia-0.90_p1-r1.ebuild)
1376209665:  >>> AUTOCLEAN: dev-libs/libcdio-paranoia:0
1376209665:  === Unmerging... (dev-libs/libcdio-paranoia-0.90_p1)
1376209666:  >>> unmerge success: dev-libs/libcdio-paranoia-0.90_p1
1376209669:  === (5 of 7) Post-Build Cleaning (dev-libs/libcdio-paranoia-0.90_p1-r1::/usr/portage/dev-libs/libcdio-paranoia/libcdio-paranoia-0.90_p1-r1.ebuild)
1376209669:  ::: completed emerge (5 of 7) dev-libs/libcdio-paranoia-0.90_p1-r1 to /
1376209669:  >>> emerge (6 of 7) media-libs/libmpeg2-0.5.1-r2 to /
1376209669:  === (6 of 7) Cleaning (media-libs/libmpeg2-0.5.1-r2::/usr/portage/media-libs/libmpeg2/libmpeg2-0.5.1-r2.ebuild)
1376209670:  === (6 of 7) Compiling/Merging (media-libs/libmpeg2-0.5.1-r2::/usr/portage/media-libs/libmpeg2/libmpeg2-0.5.1-r2.ebuild)
1376209694:  === (6 of 7) Merging (media-libs/libmpeg2-0.5.1-r2::/usr/portage/media-libs/libmpeg2/libmpeg2-0.5.1-r2.ebuild)
1376209697:  >>> AUTOCLEAN: media-libs/libmpeg2:0
1376209697:  === Unmerging... (media-libs/libmpeg2-0.5.1-r1)
1376209698:  >>> unmerge success: media-libs/libmpeg2-0.5.1-r1
1376209701:  === (6 of 7) Post-Build Cleaning (media-libs/libmpeg2-0.5.1-r2::/usr/portage/media-libs/libmpeg2/libmpeg2-0.5.1-r2.ebuild)
1376209701:  ::: completed emerge (6 of 7) media-libs/libmpeg2-0.5.1-r2 to /
1376209701:  >>> emerge (7 of 7) dev-libs/fribidi-0.19.5-r2 to /
1376209701:  === (7 of 7) Cleaning (dev-libs/fribidi-0.19.5-r2::/usr/portage/dev-libs/fribidi/fribidi-0.19.5-r2.ebuild)
1376209702:  === (7 of 7) Compiling/Merging (dev-libs/fribidi-0.19.5-r2::/usr/portage/dev-libs/fribidi/fribidi-0.19.5-r2.ebuild)
1376209726:  === (7 of 7) Merging (dev-libs/fribidi-0.19.5-r2::/usr/portage/dev-libs/fribidi/fribidi-0.19.5-r2.ebuild)
1376209728:  >>> AUTOCLEAN: dev-libs/fribidi:0
1376209728:  === Unmerging... (dev-libs/fribidi-0.19.5-r1)
1376209729:  >>> unmerge success: dev-libs/fribidi-0.19.5-r1
1376209733:  === (7 of 7) Post-Build Cleaning (dev-libs/fribidi-0.19.5-r2::/usr/portage/dev-libs/fribidi/fribidi-0.19.5-r2.ebuild)
1376209733:  ::: completed emerge (7 of 7) dev-libs/fribidi-0.19.5-r2 to /
1376209733:  *** Finished. Cleaning up...
1376209735:  *** exiting successfully.
1376209748:  *** terminating.
1376209748: Started emerge on: Aug 11, 2013 10:29:08
1376209748:  *** emerge  --depclean
1376209748:  >>> depclean
1376209772: === Unmerging... (sys-devel/automake-1.13.4)
1376209775:  >>> unmerge success: sys-devel/automake-1.13.4
1376209775:  *** exiting successfully.
1376209783:  *** terminating.
Now automake apparently needs multiple versions to be installed at the same time (I am unsure whether the portage term SLOT applies however). In my case it appears that versions 1.11, 1.12 and 1.14 exist:
Code:
itanGentoo2 ~ # equery l -p automake
 * Searching for automake ...
[-P-] [  ] sys-devel/automake-1.4_p6-r1:1.4
[-P-] [  ] sys-devel/automake-1.5-r1:1.5
[-P-] [  ] sys-devel/automake-1.6.3-r1:1.6
[-P-] [  ] sys-devel/automake-1.7.9-r2:1.7
[-P-] [  ] sys-devel/automake-1.8.5-r4:1.8
[-P-] [  ] sys-devel/automake-1.9.6-r3:1.9
[-P-] [  ] sys-devel/automake-1.10.3:1.10
[IP-] [  ] sys-devel/automake-1.11.6:1.11
[IP-] [  ] sys-devel/automake-1.12.6:1.12
[-P-] [  ] sys-devel/automake-1.13.1:1.13
[-P-] [  ] sys-devel/automake-1.13.2:1.13
[-P-] [  ] sys-devel/automake-1.13.3:1.13
[-P-] [  ] sys-devel/automake-1.13.4:1.13
[IP-] [  ] sys-devel/automake-1.14:1.14
[-P-] [ -] sys-devel/automake-9999:9999
Now if a package would require a version > 1.12 I would think that 1.14 satisfies the claim. As someone not very experienced in bash and portage I tried to prove that the following way:
Code:
TitanGentoo2 ~ # equery d sys-devel/automake-1.13 > 13.txt
TitanGentoo2 ~ # equery d sys-devel/automake-1.14 > 14.txt
TitanGentoo2 ~ # diff 13.txt 14.txt
TitanGentoo2 ~ #
resulting in an empty output.

So what am I missing here?
Back to top
View user's profile Send private message
TomWij
Developer
Developer


Joined: 04 Jul 2012
Posts: 1364

PostPosted: Sun Aug 11, 2013 1:55 pm    Post subject: Reply with quote

Because it is a build time dependency and not a run time dependency and that you have --with-bdeps=n specified when doing a dependency clean; see `man emerge`, which explains this flag:

Quote:
--with-bdeps < y | n >
In dependency calculations, pull in build time dependencies that are not strictly required. This defaults to ´n´ for installation actions, meaning they will not be installed,
and ´y´ for the --depclean action, meaning they will not be removed. This setting can be added to EMERGE_DEFAULT_OPTS (see make.conf(5)) and later overridden via the command
line.
Back to top
View user's profile Send private message
Helena
Veteran
Veteran


Joined: 02 Apr 2003
Posts: 1027
Location: De Meern, The Netherlands

PostPosted: Mon Aug 12, 2013 9:43 am    Post subject: Reply with quote

TomWij wrote:
Because it is a build time dependency and not a run time dependency and that you have --with-bdeps=n specified when doing a dependency clean; see `man emerge`, which explains this flag:

...
This is confusing. As stated sys-devel/automake-1.13.4 is first installed without specifying the --with-bdeps option. As far as I understand, it is not strictly required. According to the emerge manual this would imply it should not be installed therefore. Contradiction 1.

Second, sys-devel/automake-1.13.4 is removed again by emerge --depclean although again is not strictly required. According to the emerge manual it should not have been removed. Contradiction #2.

I have not set EMERGE_DEFAULT_OPTS.
Back to top
View user's profile Send private message
TomWij
Developer
Developer


Joined: 04 Jul 2012
Posts: 1364

PostPosted: Mon Aug 12, 2013 10:12 am    Post subject: Reply with quote

Helena wrote:
As far as I understand, it is not strictly required.


It needs it to build; so, it is strictly required for building.

I'm not so sure about your second contradiction; well, it might be caused by a change in dependencies in a package. Odd...
Back to top
View user's profile Send private message
Helena
Veteran
Veteran


Joined: 02 Apr 2003
Posts: 1027
Location: De Meern, The Netherlands

PostPosted: Wed Aug 14, 2013 10:44 am    Post subject: Reply with quote

TomWij wrote:
Helena wrote:
As far as I understand, it is not strictly required.


It needs it to build; so, it is strictly required for building. ...
Why is not automake-1.14 (already installed) sufficient as suggested in my OP?
Back to top
View user's profile Send private message
TomWij
Developer
Developer


Joined: 04 Jul 2012
Posts: 1364

PostPosted: Wed Aug 14, 2013 10:47 am    Post subject: Reply with quote

Helena wrote:
TomWij wrote:
Helena wrote:
As far as I understand, it is not strictly required.


It needs it to build; so, it is strictly required for building. ...
Why is not automake-1.14 (already installed) sufficient as suggested in my OP?


That's hard to tell if we don't know what is pulling it in; next time, add --tree --unordered-display to an emerge and see which package pulls it in.
Back to top
View user's profile Send private message
Helena
Veteran
Veteran


Joined: 02 Apr 2003
Posts: 1027
Location: De Meern, The Netherlands

PostPosted: Fri Aug 16, 2013 5:58 am    Post subject: Reply with quote

Here is an example:
Code:
==> Command executed: emerge  --ask --deep --tree --unordered-display --update --keep-going --autounmask-write @world

These are the packages that would be merged:

Calculating dependencies... done!
[nomerge       ] sys-apps/systemd-ui-2
[ebuild     U  ]  dev-libs/glib-2.36.4 [2.36.3-r2]
[ebuild  NS    ]   sys-devel/automake-1.13.4 [1.11.6, 1.12.6, 1.14]
[ebuild     U  ] sys-boot/grub-2.00_p5107 [2.00_p5086]
[ebuild  NS    ] sys-kernel/gentoo-sources-3.10.7 [3.10.6] USE="-build -deblob -symlink"

Would you like to merge these packages? [Yes/No]
Back to top
View user's profile Send private message
dmpogo
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2276
Location: Canada

PostPosted: Fri Aug 16, 2013 6:12 am    Post subject: Reply with quote

Helena wrote:
TomWij wrote:
Helena wrote:
As far as I understand, it is not strictly required.


It needs it to build; so, it is strictly required for building. ...
Why is not automake-1.14 (already installed) sufficient as suggested in my OP?


Not all the packages are necessarily upgraded to be buildable with the latest automake. Do

equery depends automake

and see if anything requires a specific version (= rather than >=). For example apache requires automake-1.11, I have couple of packages that require
automake-1.9

However I also experience appearence and disappearence of automake-1.13 (it looks like 1.12 is sufficient for everything I have)
Back to top
View user's profile Send private message
Helena
Veteran
Veteran


Joined: 02 Apr 2003
Posts: 1027
Location: De Meern, The Netherlands

PostPosted: Fri Aug 16, 2013 12:09 pm    Post subject: Re: Why is sys-devel/automake-1.13.4 repeatedly (un)merged? Reply with quote

See my OP where I already did this:
Helena wrote:
...Now if a package would require a version > 1.12 I would think that 1.14 satisfies the claim. As someone not very experienced in bash and portage I tried to prove that the following way:
Code:
TitanGentoo2 ~ # equery d sys-devel/automake-1.13 > 13.txt
TitanGentoo2 ~ # equery d sys-devel/automake-1.14 > 14.txt
TitanGentoo2 ~ # diff 13.txt 14.txt
TitanGentoo2 ~ #
resulting in an empty output....
but I'll list the output here for completeness:
Code:
TitanGentoo2 ~ # equery depends automake
 * These packages depend on automake:
app-admin/chrpath-0.13-r2 (>=sys-devel/automake-1.12:1.12)
                          (>=sys-devel/automake-1.13:1.13)
app-admin/syslog-ng-3.4.3 (>=sys-devel/automake-1.12:1.12)
                          (>=sys-devel/automake-1.13:1.13)
app-admin/system-config-printer-common-1.4.1 (>=sys-devel/automake-1.12:1.12)
                                             (>=sys-devel/automake-1.13:1.13)
app-admin/system-config-printer-gnome-1.4.1 (>=sys-devel/automake-1.12:1.12)
                                            (>=sys-devel/automake-1.13:1.13)
app-arch/snappy-1.1.0 (>=sys-devel/automake-1.12:1.12)
                      (>=sys-devel/automake-1.13:1.13)
app-arch/tar-1.26-r1 (>=sys-devel/automake-1.12:1.12)
                     (>=sys-devel/automake-1.13:1.13)
app-cdr/brasero-3.8.0 (>=sys-devel/automake-1.12:1.12)
                      (>=sys-devel/automake-1.13:1.13)
app-crypt/p11-kit-0.19.3 (>=sys-devel/automake-1.12:1.12)
                         (>=sys-devel/automake-1.13:1.13)
app-crypt/pinentry-0.8.2 (>=sys-devel/automake-1.12:1.12)
                         (>=sys-devel/automake-1.13:1.13)
app-editors/nano-2.3.2 (>=sys-devel/automake-1.12:1.12)
                       (>=sys-devel/automake-1.13:1.13)
app-misc/geoclue-0.12.99 (>=sys-devel/automake-1.12:1.12)
                         (>=sys-devel/automake-1.13:1.13)
app-misc/lirc-0.9.0-r2 (>=sys-devel/automake-1.12:1.12)
                       (>=sys-devel/automake-1.13:1.13)
app-misc/tracker-0.16.2 (>=sys-devel/automake-1.12:1.12)
                        (>=sys-devel/automake-1.13:1.13)
app-portage/ufed-0.90_rc2 (>=sys-devel/automake-1.12:1.12)
                          (>=sys-devel/automake-1.13:1.13)
app-text/docbook-sgml-utils-0.6.14-r1 (>=sys-devel/automake-1.12:1.12)
                                      (>=sys-devel/automake-1.13:1.13)
app-text/enchant-1.6.0 (>=sys-devel/automake-1.12:1.12)
                       (>=sys-devel/automake-1.13:1.13)
app-text/ghostscript-gpl-9.07 (>=sys-devel/automake-1.12:1.12)
                              (>=sys-devel/automake-1.13:1.13)
app-text/hunspell-1.3.2-r3 (>=sys-devel/automake-1.12:1.12)
                           (>=sys-devel/automake-1.13:1.13)
app-text/libpaper-1.1.24-r2 (>=sys-devel/automake-1.12:1.12)
                            (>=sys-devel/automake-1.13:1.13)
app-text/libspectre-0.2.7 (>=sys-devel/automake-1.12:1.12)                             
                          (>=sys-devel/automake-1.13:1.13)                             
app-text/openjade-1.3.2-r5 (>=sys-devel/automake-1.12:1.12)                           
                           (>=sys-devel/automake-1.13:1.13)                           
app-text/recode-3.6_p20 (=sys-devel/automake-1.11*)                                   
dev-db/libiodbc-3.52.8-r1 (>=sys-devel/automake-1.12:1.12)                             
                          (>=sys-devel/automake-1.13:1.13)                             
dev-db/sqlite-3.7.17 (>=sys-devel/automake-1.12:1.12)                                 
                     (>=sys-devel/automake-1.13:1.13)                                 
dev-db/virtuoso-odbc-6.1.6 (>=sys-devel/automake-1.12:1.12)                           
                           (>=sys-devel/automake-1.13:1.13)                           
dev-db/virtuoso-server-6.1.6 (>=sys-devel/automake-1.12:1.12)                         
                             (>=sys-devel/automake-1.13:1.13)                         
dev-java/icedtea-web-1.3.2-r7 (>=sys-devel/automake-1.12:1.12)                         
                              (>=sys-devel/automake-1.13:1.13)                         
dev-lang/R-3.0.1 (>=sys-devel/automake-1.12:1.12)                                     
                 (>=sys-devel/automake-1.13:1.13)                                     
dev-lang/orc-0.4.17-r1 (>=sys-devel/automake-1.12:1.12)                               
                       (>=sys-devel/automake-1.13:1.13)                               
dev-lang/python-2.7.5-r1 (sys-devel/automake)                                         
dev-lang/python-3.2.5-r1 (sys-devel/automake)                                         
dev-lang/python-3.3.2-r1 (sys-devel/automake)                                         
dev-lang/ruby-1.8.7_p374-r1 (>=sys-devel/automake-1.12:1.12)
                            (>=sys-devel/automake-1.13:1.13)
dev-lang/ruby-1.9.3_p448-r1 (>=sys-devel/automake-1.12:1.12)
                            (>=sys-devel/automake-1.13:1.13)
dev-lang/ruby-2.0.0_p247-r1 (>=sys-devel/automake-1.12:1.12)
                            (>=sys-devel/automake-1.13:1.13)
dev-lang/spidermonkey-1.8.5-r4 (>=sys-devel/automake-1.12:1.12)
                               (>=sys-devel/automake-1.13:1.13)
dev-lang/yasm-1.2.0-r1 (>=sys-devel/automake-1.12:1.12)
                       (>=sys-devel/automake-1.13:1.13)
dev-libs/apr-1.4.8-r1 (>=sys-devel/automake-1.12:1.12)
                      (>=sys-devel/automake-1.13:1.13)
dev-libs/cloog-ppl-0.15.10 (>=sys-devel/automake-1.12:1.12)
                           (>=sys-devel/automake-1.13:1.13)
dev-libs/cyrus-sasl-2.1.26-r3 (=sys-devel/automake-1.12*)
dev-libs/fribidi-0.19.5-r2 (>=sys-devel/automake-1.12:1.12)
                           (>=sys-devel/automake-1.13:1.13)
dev-libs/glib-2.36.4 (>=sys-devel/automake-1.12:1.12)
                     (>=sys-devel/automake-1.13:1.13)
dev-libs/icu-51.2 (>=sys-devel/automake-1.12:1.12)
                  (>=sys-devel/automake-1.13:1.13)
dev-libs/iniparser-3.1 (>=sys-devel/automake-1.12:1.12)
                       (>=sys-devel/automake-1.13:1.13)
dev-libs/json-c-0.11 (>=sys-devel/automake-1.12:1.12)
                     (>=sys-devel/automake-1.13:1.13)
dev-libs/json-glib-0.16.0-r1 (>=sys-devel/automake-1.12:1.12)
                             (>=sys-devel/automake-1.13:1.13)
dev-libs/libcdio-paranoia-0.90_p1-r1 (>=sys-devel/automake-1.12:1.12)
                                     (>=sys-devel/automake-1.13:1.13)
dev-libs/libev-4.15 (>=sys-devel/automake-1.12:1.12)
                    (>=sys-devel/automake-1.13:1.13)
dev-libs/libgcrypt-1.5.3 (>=sys-devel/automake-1.12:1.12)
                         (>=sys-devel/automake-1.13:1.13)
dev-libs/libpthread-stubs-0.3-r1 (>=sys-devel/automake-1.12:1.12)
                                 (>=sys-devel/automake-1.13:1.13)
dev-libs/libxml2-2.9.1-r1 (>=sys-devel/automake-1.12:1.12)
                          (>=sys-devel/automake-1.13:1.13)
dev-libs/libxslt-1.1.28-r1 (>=sys-devel/automake-1.12:1.12)
                           (>=sys-devel/automake-1.13:1.13)
dev-libs/nettle-2.7.1 (>=sys-devel/automake-1.12:1.12)
                      (>=sys-devel/automake-1.13:1.13)
dev-libs/nspr-4.10 (>=sys-devel/automake-1.12:1.12)
                   (>=sys-devel/automake-1.13:1.13)
dev-libs/openobex-1.5 (>=sys-devel/automake-1.12:1.12)
                      (>=sys-devel/automake-1.13:1.13)
dev-libs/protobuf-2.5.0 (>=sys-devel/automake-1.12:1.12)
                        (>=sys-devel/automake-1.13:1.13)
dev-python/pygobject-2.28.6-r53 (>=sys-devel/automake-1.12:1.12)
                                (>=sys-devel/automake-1.13:1.13)
dev-python/pygobject-3.8.3 (>=sys-devel/automake-1.12:1.12)
                           (>=sys-devel/automake-1.13:1.13)
dev-python/pygtk-2.24.0-r3 (>=sys-devel/automake-1.12:1.12)
                           (>=sys-devel/automake-1.13:1.13)
dev-scheme/guile-1.8.8-r1 (>=sys-devel/automake-1.12:1.12)
                          (>=sys-devel/automake-1.13:1.13)
dev-util/ragel-6.8 (>=sys-devel/automake-1.12:1.12)
                   (>=sys-devel/automake-1.13:1.13)
games-arcade/gnome-nibbles-3.8.0 (>=sys-devel/automake-1.12:1.12)
                                 (>=sys-devel/automake-1.13:1.13)
games-arcade/gnome-robots-3.8.1 (>=sys-devel/automake-1.12:1.12)
                                (>=sys-devel/automake-1.13:1.13)
games-board/four-in-a-row-3.8.1 (>=sys-devel/automake-1.12:1.12)
                                (>=sys-devel/automake-1.13:1.13)
games-board/gnome-chess-3.8.3 (>=sys-devel/automake-1.12:1.12)
                              (>=sys-devel/automake-1.13:1.13)
games-board/gnome-mahjongg-3.8.0 (>=sys-devel/automake-1.12:1.12)
                                 (>=sys-devel/automake-1.13:1.13)
games-board/gnome-mines-3.8.1 (>=sys-devel/automake-1.12:1.12)
                              (>=sys-devel/automake-1.13:1.13)
games-board/iagno-3.8.1 (>=sys-devel/automake-1.12:1.12)
                        (>=sys-devel/automake-1.13:1.13)
games-board/tali-3.8.0 (>=sys-devel/automake-1.12:1.12)
                       (>=sys-devel/automake-1.13:1.13)
games-puzzle/five-or-more-3.8.2 (>=sys-devel/automake-1.12:1.12)
                                (>=sys-devel/automake-1.13:1.13)
games-puzzle/gnome-klotski-3.8.2 (>=sys-devel/automake-1.12:1.12)
                                 (>=sys-devel/automake-1.13:1.13)
games-puzzle/gnome-sudoku-3.8.1 (>=sys-devel/automake-1.12:1.12)
                                (>=sys-devel/automake-1.13:1.13)
games-puzzle/gnome-tetravex-3.8.1 (>=sys-devel/automake-1.12:1.12)
                                  (>=sys-devel/automake-1.13:1.13)
games-puzzle/lightsoff-3.8.0 (>=sys-devel/automake-1.12:1.12)
                             (>=sys-devel/automake-1.13:1.13)
games-puzzle/quadrapassel-3.8.2 (>=sys-devel/automake-1.12:1.12)
                                (>=sys-devel/automake-1.13:1.13)
games-puzzle/swell-foop-3.8.1 (>=sys-devel/automake-1.12:1.12)
                              (>=sys-devel/automake-1.13:1.13)
gnome-base/gdm-3.8.4 (>=sys-devel/automake-1.12:1.12)
                     (>=sys-devel/automake-1.13:1.13)
gnome-base/gnome-control-center-3.8.4.1-r1 (>=sys-devel/automake-1.12:1.12)
                                           (>=sys-devel/automake-1.13:1.13)
gnome-base/gnome-settings-daemon-3.8.4 (>=sys-devel/automake-1.12:1.12)
                                       (>=sys-devel/automake-1.13:1.13)
gnome-base/gnome-shell-3.8.4 (>=sys-devel/automake-1.12:1.12)
                             (>=sys-devel/automake-1.13:1.13)
gnome-base/gvfs-1.16.3 (>=sys-devel/automake-1.12:1.12)
                       (>=sys-devel/automake-1.13:1.13)
gnome-base/libglade-2.6.4 (>=sys-devel/automake-1.12:1.12)
                          (>=sys-devel/automake-1.13:1.13)
gnome-base/librsvg-2.37.0 (>=sys-devel/automake-1.12:1.12)
                          (>=sys-devel/automake-1.13:1.13)
gnome-extra/yelp-3.8.1 (>=sys-devel/automake-1.12:1.12)
                       (>=sys-devel/automake-1.13:1.13)
mail-mta/ssmtp-2.64-r2 (sys-devel/automake)
media-fonts/encodings-1.0.4 (>=sys-devel/automake-1.12:1.12)
                            (>=sys-devel/automake-1.13:1.13)
media-fonts/font-adobe-100dpi-1.0.3 (>=sys-devel/automake-1.12:1.12)
                                    (>=sys-devel/automake-1.13:1.13)
media-fonts/font-adobe-75dpi-1.0.3 (>=sys-devel/automake-1.12:1.12)
                                   (>=sys-devel/automake-1.13:1.13)
media-fonts/font-adobe-utopia-100dpi-1.0.4 (>=sys-devel/automake-1.12:1.12)
                                           (>=sys-devel/automake-1.13:1.13)
media-fonts/font-adobe-utopia-75dpi-1.0.4 (>=sys-devel/automake-1.12:1.12)
                                          (>=sys-devel/automake-1.13:1.13)
media-fonts/font-adobe-utopia-type1-1.0.4 (>=sys-devel/automake-1.12:1.12)
                                          (>=sys-devel/automake-1.13:1.13)
media-fonts/font-alias-1.0.3 (>=sys-devel/automake-1.12:1.12)
                             (>=sys-devel/automake-1.13:1.13)
media-fonts/font-arabic-misc-1.0.3 (>=sys-devel/automake-1.12:1.12)
                                   (>=sys-devel/automake-1.13:1.13)
media-fonts/font-bh-100dpi-1.0.3 (>=sys-devel/automake-1.12:1.12)
                                 (>=sys-devel/automake-1.13:1.13)
media-fonts/font-bh-75dpi-1.0.3 (>=sys-devel/automake-1.12:1.12)
                                (>=sys-devel/automake-1.13:1.13)
media-fonts/font-bh-lucidatypewriter-100dpi-1.0.3 (>=sys-devel/automake-1.12:1.12)
                                                  (>=sys-devel/automake-1.13:1.13)
media-fonts/font-bh-lucidatypewriter-75dpi-1.0.3 (>=sys-devel/automake-1.12:1.12)
                                                 (>=sys-devel/automake-1.13:1.13)
media-fonts/font-bh-ttf-1.0.3 (>=sys-devel/automake-1.12:1.12)
                              (>=sys-devel/automake-1.13:1.13)
media-fonts/font-bh-type1-1.0.3 (>=sys-devel/automake-1.12:1.12)
                                (>=sys-devel/automake-1.13:1.13)
media-fonts/font-bitstream-100dpi-1.0.3 (>=sys-devel/automake-1.12:1.12)
                                        (>=sys-devel/automake-1.13:1.13)
media-fonts/font-bitstream-75dpi-1.0.3 (>=sys-devel/automake-1.12:1.12)
                                       (>=sys-devel/automake-1.13:1.13)
media-fonts/font-bitstream-speedo-1.0.2 (>=sys-devel/automake-1.12:1.12)
                                        (>=sys-devel/automake-1.13:1.13)
media-fonts/font-bitstream-type1-1.0.3 (>=sys-devel/automake-1.12:1.12)
                                       (>=sys-devel/automake-1.13:1.13)
media-fonts/font-cronyx-cyrillic-1.0.3 (>=sys-devel/automake-1.12:1.12)
                                       (>=sys-devel/automake-1.13:1.13)
media-fonts/font-cursor-misc-1.0.3 (>=sys-devel/automake-1.12:1.12)
                                   (>=sys-devel/automake-1.13:1.13)
media-fonts/font-daewoo-misc-1.0.3 (>=sys-devel/automake-1.12:1.12)
                                   (>=sys-devel/automake-1.13:1.13)
media-fonts/font-dec-misc-1.0.3 (>=sys-devel/automake-1.12:1.12)
                                (>=sys-devel/automake-1.13:1.13)
media-fonts/font-ibm-type1-1.0.3 (>=sys-devel/automake-1.12:1.12)
                                 (>=sys-devel/automake-1.13:1.13)
media-fonts/font-isas-misc-1.0.3 (>=sys-devel/automake-1.12:1.12)
                                 (>=sys-devel/automake-1.13:1.13)
media-fonts/font-jis-misc-1.0.3 (>=sys-devel/automake-1.12:1.12)
                                (>=sys-devel/automake-1.13:1.13)
media-fonts/font-micro-misc-1.0.3 (>=sys-devel/automake-1.12:1.12)
                                  (>=sys-devel/automake-1.13:1.13)
media-fonts/font-misc-cyrillic-1.0.3 (>=sys-devel/automake-1.12:1.12)
                                     (>=sys-devel/automake-1.13:1.13)
media-fonts/font-misc-ethiopic-1.0.3 (>=sys-devel/automake-1.12:1.12)
                                     (>=sys-devel/automake-1.13:1.13)
media-fonts/font-misc-meltho-1.0.3 (>=sys-devel/automake-1.12:1.12)
                                   (>=sys-devel/automake-1.13:1.13)
media-fonts/font-misc-misc-1.1.2 (>=sys-devel/automake-1.12:1.12)
                                 (>=sys-devel/automake-1.13:1.13)
media-fonts/font-mutt-misc-1.0.3 (>=sys-devel/automake-1.12:1.12)
                                 (>=sys-devel/automake-1.13:1.13)
media-fonts/font-schumacher-misc-1.1.2 (>=sys-devel/automake-1.12:1.12)
                                       (>=sys-devel/automake-1.13:1.13)
media-fonts/font-screen-cyrillic-1.0.4 (>=sys-devel/automake-1.12:1.12)
                                       (>=sys-devel/automake-1.13:1.13)
media-fonts/font-sony-misc-1.0.3 (>=sys-devel/automake-1.12:1.12)
                                 (>=sys-devel/automake-1.13:1.13)
media-fonts/font-sun-misc-1.0.3 (>=sys-devel/automake-1.12:1.12)
                                (>=sys-devel/automake-1.13:1.13)
media-fonts/font-util-1.3.0 (>=sys-devel/automake-1.12:1.12)
                            (>=sys-devel/automake-1.13:1.13)
media-fonts/font-winitzki-cyrillic-1.0.3 (>=sys-devel/automake-1.12:1.12)
                                         (>=sys-devel/automake-1.13:1.13)
media-fonts/font-xfree86-type1-1.0.4 (>=sys-devel/automake-1.12:1.12)
                                     (>=sys-devel/automake-1.13:1.13)
media-libs/alsa-lib-1.0.27.2 (>=sys-devel/automake-1.12:1.12)
                             (>=sys-devel/automake-1.13:1.13)
media-libs/audiofile-0.3.6-r1 (>=sys-devel/automake-1.12:1.12)
                              (>=sys-devel/automake-1.13:1.13)
media-libs/clutter-1.14.4-r1 (>=sys-devel/automake-1.12:1.12)
                             (>=sys-devel/automake-1.13:1.13)
media-libs/flac-1.2.1-r5 (>=sys-devel/automake-1.12:1.12)
                         (>=sys-devel/automake-1.13:1.13)
media-libs/fontconfig-2.10.92 (>=sys-devel/automake-1.12:1.12)
                              (>=sys-devel/automake-1.13:1.13)
media-libs/ftgl-2.1.3_rc5 (>=sys-devel/automake-1.12:1.12)
                          (>=sys-devel/automake-1.13:1.13)
media-libs/harfbuzz-0.9.18-r1 (>=sys-devel/automake-1.12:1.12)
                              (>=sys-devel/automake-1.13:1.13)
media-libs/jbig2dec-0.11-r1 (>=sys-devel/automake-1.12:1.12)
                            (>=sys-devel/automake-1.13:1.13)
media-libs/libart_lgpl-2.3.21-r1 (>=sys-devel/automake-1.12:1.12)
                                 (>=sys-devel/automake-1.13:1.13)
media-libs/libbluray-0.3.0-r1 (>=sys-devel/automake-1.12:1.12)
                              (>=sys-devel/automake-1.13:1.13)
media-libs/libgphoto2-2.5.2 (>=sys-devel/automake-1.12:1.12)
                            (>=sys-devel/automake-1.13:1.13)
media-libs/libjpeg-turbo-1.3.0-r2 (>=sys-devel/automake-1.12:1.12)
                                  (>=sys-devel/automake-1.13:1.13)
media-libs/libmad-0.15.1b-r8 (>=sys-devel/automake-1.12:1.12)
                             (>=sys-devel/automake-1.13:1.13)
media-libs/libmng-1.0.10-r1 (>=sys-devel/automake-1.12:1.12)
                            (>=sys-devel/automake-1.13:1.13)
media-libs/libmodplug-0.8.8.4-r1 (>=sys-devel/automake-1.12:1.12)
                                 (>=sys-devel/automake-1.13:1.13)
media-libs/libmpeg2-0.5.1-r2 (>=sys-devel/automake-1.12:1.12)
                             (>=sys-devel/automake-1.13:1.13)
media-libs/libraw-0.15.3 (>=sys-devel/automake-1.12:1.12)
                         (>=sys-devel/automake-1.13:1.13)
media-libs/libsamplerate-0.1.8-r1 (>=sys-devel/automake-1.12:1.12)
                                  (>=sys-devel/automake-1.13:1.13)
media-libs/libsdl-1.2.15-r4 (>=sys-devel/automake-1.12:1.12)
                            (>=sys-devel/automake-1.13:1.13)
media-libs/libsndfile-1.0.25-r1 (>=sys-devel/automake-1.12:1.12)
                                (>=sys-devel/automake-1.13:1.13)
media-libs/libtheora-1.1.1-r1 (>=sys-devel/automake-1.12:1.12)
                              (>=sys-devel/automake-1.13:1.13)
media-libs/libvorbis-1.3.3-r1 (>=sys-devel/automake-1.12:1.12)
                              (>=sys-devel/automake-1.13:1.13)
media-libs/libwmf-0.2.8.4-r5 (>=sys-devel/automake-1.12:1.12)
                             (>=sys-devel/automake-1.13:1.13)
media-libs/memphis-0.2.3 (=sys-devel/automake-1.11*)
media-libs/mesa-9.1.6 (>=sys-devel/automake-1.12:1.12)
                      (>=sys-devel/automake-1.13:1.13)
media-libs/sdl-gfx-2.0.24 (>=sys-devel/automake-1.12:1.12)
                          (>=sys-devel/automake-1.13:1.13)
media-libs/sdl-sound-1.0.3 (>=sys-devel/automake-1.12:1.12)
                           (>=sys-devel/automake-1.13:1.13)
media-libs/speex-1.2_rc1-r2 (>=sys-devel/automake-1.12:1.12)
                            (>=sys-devel/automake-1.13:1.13)
media-plugins/alsa-plugins-1.0.27 (>=sys-devel/automake-1.12:1.12)
                                  (>=sys-devel/automake-1.13:1.13)
media-sound/cdparanoia-3.10.2-r6 (>=sys-devel/automake-1.12:1.12)
                                 (>=sys-devel/automake-1.13:1.13)
media-sound/lame-3.99.5-r1 (>=sys-devel/automake-1.12:1.12)
                           (>=sys-devel/automake-1.13:1.13)
media-sound/sox-14.4.1 (>=sys-devel/automake-1.12:1.12)
                       (>=sys-devel/automake-1.13:1.13)
media-tv/xbmc-12.2-r1 (>=sys-devel/automake-1.12:1.12)
                      (>=sys-devel/automake-1.13:1.13)
media-video/totem-3.8.2-r1 (>=sys-devel/automake-1.12:1.12)
                           (>=sys-devel/automake-1.13:1.13)
net-dns/avahi-0.6.31-r2 (=sys-devel/automake-1.11*)
net-dns/bind-tools-9.9.3_p2 (>=sys-devel/automake-1.12:1.12)
                            (>=sys-devel/automake-1.13:1.13)
net-ftp/lftp-4.4.8 (>=sys-devel/automake-1.12:1.12)
                   (>=sys-devel/automake-1.13:1.13)
net-libs/gnutls-3.2.3 (>=sys-devel/automake-1.11.6)
                      (>=sys-devel/automake-1.12:1.12)
                      (>=sys-devel/automake-1.13:1.13)
net-libs/gupnp-igd-0.2.2-r1 (>=sys-devel/automake-1.12:1.12)
                            (>=sys-devel/automake-1.13:1.13)
net-libs/libpcap-1.4.0 (>=sys-devel/automake-1.12:1.12)
                       (>=sys-devel/automake-1.13:1.13)
net-libs/libsocialweb-0.25.21 (>=sys-devel/automake-1.12:1.12)
                              (>=sys-devel/automake-1.13:1.13)
net-libs/neon-0.30.0 (>=sys-devel/automake-1.12:1.12)
                     (>=sys-devel/automake-1.13:1.13)
net-libs/webkit-gtk-2.0.4 (>=sys-devel/automake-1.12:1.12)
                          (>=sys-devel/automake-1.13:1.13)
net-misc/curl-7.32.0 (>=sys-devel/automake-1.12:1.12)
                     (>=sys-devel/automake-1.13:1.13)
net-misc/networkmanager-0.9.8.2-r3 (>=sys-devel/automake-1.12:1.12)
                                   (>=sys-devel/automake-1.13:1.13)
net-misc/openssh-6.2_p2-r4 (>=sys-devel/automake-1.12:1.12)
                           (>=sys-devel/automake-1.13:1.13)
net-misc/wget-1.14 (>=sys-devel/automake-1.12:1.12)
                   (>=sys-devel/automake-1.13:1.13)
net-print/cups-1.6.3-r2 (>=sys-devel/automake-1.12:1.12)
                        (>=sys-devel/automake-1.13:1.13)
net-print/cups-filters-1.0.36-r1 (>=sys-devel/automake-1.12:1.12)
                                 (>=sys-devel/automake-1.13:1.13)
net-print/foomatic-filters-4.0.17-r1 (>=sys-devel/automake-1.12:1.12)
                                     (>=sys-devel/automake-1.13:1.13)
sci-libs/blas-reference-20070226-r2 (>=sys-devel/automake-1.12:1.12)
                                    (>=sys-devel/automake-1.13:1.13)
sci-libs/gsl-1.15 (>=sys-devel/automake-1.12:1.12)
                  (>=sys-devel/automake-1.13:1.13)
sys-apps/dbus-1.6.12 (>=sys-devel/automake-1.12:1.12)
                     (>=sys-devel/automake-1.13:1.13)
sys-apps/groff-1.22.2 (>=sys-devel/automake-1.12:1.12)
                      (>=sys-devel/automake-1.13:1.13)
sys-apps/kmod-14-r1 (>=sys-devel/automake-1.12:1.12)
                    (>=sys-devel/automake-1.13:1.13)
sys-apps/vbetool-1.1 (>=sys-devel/automake-1.12:1.12)
                     (>=sys-devel/automake-1.13:1.13)
sys-block/parted-3.1-r1 (>=sys-devel/automake-1.12:1.12)
                        (>=sys-devel/automake-1.13:1.13)
sys-block/thin-provisioning-tools-0.2.1 (>=sys-devel/automake-1.12:1.12)
                                        (>=sys-devel/automake-1.13:1.13)
sys-devel/libtool-2.4.2 (>=sys-devel/automake-1.12:1.12)
                        (>=sys-devel/automake-1.13:1.13)
sys-devel/patch-2.7.1-r2 (>=sys-devel/automake-1.12:1.12)
                         (>=sys-devel/automake-1.13:1.13)
sys-fs/lvm2-2.02.99-r2 (>=sys-devel/automake-1.12:1.12)
                       (>=sys-devel/automake-1.13:1.13)
sys-libs/db-4.8.30 (>=sys-devel/automake-1.12)
                   (>=sys-devel/automake-1.13)
sys-libs/libcap-ng-0.7.3 (>=sys-devel/automake-1.12:1.12)
                         (>=sys-devel/automake-1.13:1.13)
sys-libs/pam-1.1.6-r4 (>=sys-devel/automake-1.12:1.12)
                      (>=sys-devel/automake-1.13:1.13)
sys-libs/zlib-1.2.8-r1 (minizip ? >=sys-devel/automake-1.12:1.12)
                       (minizip ? >=sys-devel/automake-1.13:1.13)
www-client/firefox-23.0 (>=sys-devel/automake-1.12:1.12)
                        (>=sys-devel/automake-1.13:1.13)
www-misc/htdig-3.2.0_beta6-r3 (>=sys-devel/automake-1.12)
                              (>=sys-devel/automake-1.13)
x11-apps/appres-1.0.4 (>=sys-devel/automake-1.12:1.12)
                      (>=sys-devel/automake-1.13:1.13)
x11-apps/bdftopcf-1.0.4 (>=sys-devel/automake-1.12:1.12)
                        (>=sys-devel/automake-1.13:1.13)
x11-apps/bitmap-1.0.7 (>=sys-devel/automake-1.12:1.12)
                      (>=sys-devel/automake-1.13:1.13)
x11-apps/iceauth-1.0.6 (>=sys-devel/automake-1.12:1.12)
                       (>=sys-devel/automake-1.13:1.13)
x11-apps/luit-1.1.1 (>=sys-devel/automake-1.12:1.12)
                    (>=sys-devel/automake-1.13:1.13)
x11-apps/mesa-progs-8.1.0 (>=sys-devel/automake-1.12:1.12)
                          (>=sys-devel/automake-1.13:1.13)
x11-apps/mkfontdir-1.0.7 (>=sys-devel/automake-1.12:1.12)
                         (>=sys-devel/automake-1.13:1.13)
x11-apps/mkfontscale-1.1.1 (>=sys-devel/automake-1.12:1.12)
                           (>=sys-devel/automake-1.13:1.13)
x11-apps/rgb-1.0.5 (>=sys-devel/automake-1.12:1.12)
                   (>=sys-devel/automake-1.13:1.13)
x11-apps/scripts-1.0.1-r1 (>=sys-devel/automake-1.12:1.12)
                          (>=sys-devel/automake-1.13:1.13)
x11-apps/sessreg-1.0.8 (>=sys-devel/automake-1.12:1.12)
                       (>=sys-devel/automake-1.13:1.13)
x11-apps/setxkbmap-1.3.0 (>=sys-devel/automake-1.12:1.12)
                         (>=sys-devel/automake-1.13:1.13)
x11-apps/smproxy-1.0.5 (>=sys-devel/automake-1.12:1.12)
                       (>=sys-devel/automake-1.13:1.13)
x11-apps/x11perf-1.5.4 (>=sys-devel/automake-1.12:1.12)
                       (>=sys-devel/automake-1.13:1.13)
x11-apps/xauth-1.0.7 (>=sys-devel/automake-1.12:1.12)
                     (>=sys-devel/automake-1.13:1.13)
x11-apps/xbacklight-1.2.0 (>=sys-devel/automake-1.12:1.12)
                          (>=sys-devel/automake-1.13:1.13)
x11-apps/xcmsdb-1.0.4 (>=sys-devel/automake-1.12:1.12)
                      (>=sys-devel/automake-1.13:1.13)
x11-apps/xcursorgen-1.0.5 (>=sys-devel/automake-1.12:1.12)
                          (>=sys-devel/automake-1.13:1.13)
x11-apps/xdpyinfo-1.3.1 (>=sys-devel/automake-1.12:1.12)
                        (>=sys-devel/automake-1.13:1.13)
x11-apps/xdriinfo-1.0.4 (>=sys-devel/automake-1.12:1.12)
                        (>=sys-devel/automake-1.13:1.13)
x11-apps/xev-1.2.1 (>=sys-devel/automake-1.12:1.12)
                   (>=sys-devel/automake-1.13:1.13)
x11-apps/xf86dga-1.0.3 (>=sys-devel/automake-1.12:1.12)
                       (>=sys-devel/automake-1.13:1.13)
x11-apps/xgamma-1.0.5 (>=sys-devel/automake-1.12:1.12)
                      (>=sys-devel/automake-1.13:1.13)
x11-apps/xhost-1.0.6 (>=sys-devel/automake-1.12:1.12)
                     (>=sys-devel/automake-1.13:1.13)
x11-apps/xinit-1.3.2 (>=sys-devel/automake-1.12:1.12)
                     (>=sys-devel/automake-1.13:1.13)
x11-apps/xinput-1.6.0 (>=sys-devel/automake-1.12:1.12)
                      (>=sys-devel/automake-1.13:1.13)
x11-apps/xkbcomp-1.2.4 (>=sys-devel/automake-1.12:1.12)
                       (>=sys-devel/automake-1.13:1.13)
x11-apps/xkbevd-1.1.3 (>=sys-devel/automake-1.12:1.12)
                      (>=sys-devel/automake-1.13:1.13)
x11-apps/xkbutils-1.0.4 (>=sys-devel/automake-1.12:1.12)
                        (>=sys-devel/automake-1.13:1.13)
x11-apps/xkill-1.0.3 (>=sys-devel/automake-1.12:1.12)
                     (>=sys-devel/automake-1.13:1.13)
x11-apps/xlsatoms-1.1.1 (>=sys-devel/automake-1.12:1.12)
                        (>=sys-devel/automake-1.13:1.13)
x11-apps/xlsclients-1.1.2 (>=sys-devel/automake-1.12:1.12)
                          (>=sys-devel/automake-1.13:1.13)
x11-apps/xmessage-1.0.4 (>=sys-devel/automake-1.12:1.12)
                        (>=sys-devel/automake-1.13:1.13)
x11-apps/xmodmap-1.0.7 (>=sys-devel/automake-1.12:1.12)
                       (>=sys-devel/automake-1.13:1.13)
x11-apps/xpr-1.0.4 (>=sys-devel/automake-1.12:1.12)
                   (>=sys-devel/automake-1.13:1.13)
x11-apps/xprop-1.2.2 (>=sys-devel/automake-1.12:1.12)
                     (>=sys-devel/automake-1.13:1.13)
x11-apps/xrandr-1.4.1 (>=sys-devel/automake-1.12:1.12)
                      (>=sys-devel/automake-1.13:1.13)
x11-apps/xrdb-1.0.9 (>=sys-devel/automake-1.12:1.12)
                    (>=sys-devel/automake-1.13:1.13)
x11-apps/xrefresh-1.0.5 (>=sys-devel/automake-1.12:1.12)
                        (>=sys-devel/automake-1.13:1.13)
x11-apps/xset-1.2.3 (>=sys-devel/automake-1.12:1.12)
                    (>=sys-devel/automake-1.13:1.13)
x11-apps/xsetroot-1.1.1 (>=sys-devel/automake-1.12:1.12)
                        (>=sys-devel/automake-1.13:1.13)
x11-apps/xvinfo-1.1.2 (>=sys-devel/automake-1.12:1.12)
                      (>=sys-devel/automake-1.13:1.13)
x11-apps/xwd-1.0.6 (>=sys-devel/automake-1.12:1.12)
                   (>=sys-devel/automake-1.13:1.13)
x11-apps/xwininfo-1.1.3 (>=sys-devel/automake-1.12:1.12)
                        (>=sys-devel/automake-1.13:1.13)
x11-apps/xwud-1.0.4 (>=sys-devel/automake-1.12:1.12)
                    (>=sys-devel/automake-1.13:1.13)
x11-base/xorg-server-1.14.2.901 (>=sys-devel/automake-1.12:1.12)
                                (>=sys-devel/automake-1.13:1.13)
x11-drivers/xf86-input-evdev-2.8.1 (>=sys-devel/automake-1.12:1.12)
                                   (>=sys-devel/automake-1.13:1.13)
x11-drivers/xf86-video-nouveau-1.0.9 (>=sys-devel/automake-1.12:1.12)
                                     (>=sys-devel/automake-1.13:1.13)
x11-drivers/xf86-video-vesa-2.3.2-r1 (>=sys-devel/automake-1.12:1.12)
                                     (>=sys-devel/automake-1.13:1.13)
x11-libs/cairo-1.12.14-r4 (>=sys-devel/automake-1.12:1.12)
                          (>=sys-devel/automake-1.13:1.13)
x11-libs/gtk+-2.24.20 (>=sys-devel/automake-1.12:1.12)
                      (>=sys-devel/automake-1.13:1.13)
x11-libs/libICE-1.0.8-r1 (>=sys-devel/automake-1.12:1.12)
                         (>=sys-devel/automake-1.13:1.13)
x11-libs/libSM-1.2.1-r1 (>=sys-devel/automake-1.12:1.12)
                        (>=sys-devel/automake-1.13:1.13)
x11-libs/libX11-1.6.1 (>=sys-devel/automake-1.12:1.12)
                      (>=sys-devel/automake-1.13:1.13)
x11-libs/libXScrnSaver-1.2.2-r1 (>=sys-devel/automake-1.12:1.12)
                                (>=sys-devel/automake-1.13:1.13)
x11-libs/libXau-1.0.8 (>=sys-devel/automake-1.12:1.12)
                      (>=sys-devel/automake-1.13:1.13)
x11-libs/libXaw-1.0.11-r2 (>=sys-devel/automake-1.12:1.12)
                          (>=sys-devel/automake-1.13:1.13)
x11-libs/libXcomposite-0.4.4-r1 (>=sys-devel/automake-1.12:1.12)
                                (>=sys-devel/automake-1.13:1.13)
x11-libs/libXcursor-1.1.14 (>=sys-devel/automake-1.12:1.12)
                           (>=sys-devel/automake-1.13:1.13)
x11-libs/libXdamage-1.1.4-r1 (>=sys-devel/automake-1.12:1.12)
                             (>=sys-devel/automake-1.13:1.13)
x11-libs/libXdmcp-1.1.1-r1 (>=sys-devel/automake-1.12:1.12)
                           (>=sys-devel/automake-1.13:1.13)
x11-libs/libXext-1.3.2 (>=sys-devel/automake-1.12:1.12)
                       (>=sys-devel/automake-1.13:1.13)
x11-libs/libXfixes-5.0.1 (>=sys-devel/automake-1.12:1.12)
                         (>=sys-devel/automake-1.13:1.13)
x11-libs/libXfont-1.4.6 (>=sys-devel/automake-1.12:1.12)
                        (>=sys-devel/automake-1.13:1.13)
x11-libs/libXft-2.3.1-r1 (>=sys-devel/automake-1.12:1.12)
                         (>=sys-devel/automake-1.13:1.13)
x11-libs/libXi-1.7.2 (>=sys-devel/automake-1.12:1.12)
                     (>=sys-devel/automake-1.13:1.13)
x11-libs/libXinerama-1.1.3 (>=sys-devel/automake-1.12:1.12)
                           (>=sys-devel/automake-1.13:1.13)
x11-libs/libXmu-1.1.1-r1 (>=sys-devel/automake-1.12:1.12)
                         (>=sys-devel/automake-1.13:1.13)
x11-libs/libXpm-3.5.10-r1 (>=sys-devel/automake-1.12:1.12)
                          (>=sys-devel/automake-1.13:1.13)
x11-libs/libXrandr-1.4.1 (>=sys-devel/automake-1.12:1.12)
                         (>=sys-devel/automake-1.13:1.13)
x11-libs/libXrender-0.9.8 (>=sys-devel/automake-1.12:1.12)
                          (>=sys-devel/automake-1.13:1.13)
x11-libs/libXres-1.0.7 (>=sys-devel/automake-1.12:1.12)
                       (>=sys-devel/automake-1.13:1.13)
x11-libs/libXt-1.1.4 (>=sys-devel/automake-1.12:1.12)
                     (>=sys-devel/automake-1.13:1.13)
x11-libs/libXtst-1.2.2 (>=sys-devel/automake-1.12:1.12)
                       (>=sys-devel/automake-1.13:1.13)
x11-libs/libXv-1.0.9 (>=sys-devel/automake-1.12:1.12)
                     (>=sys-devel/automake-1.13:1.13)
x11-libs/libXxf86dga-1.1.4 (>=sys-devel/automake-1.12:1.12)
                           (>=sys-devel/automake-1.13:1.13)
x11-libs/libXxf86misc-1.0.3 (>=sys-devel/automake-1.12:1.12)
                            (>=sys-devel/automake-1.13:1.13)
x11-libs/libXxf86vm-1.1.3 (>=sys-devel/automake-1.12:1.12)
                          (>=sys-devel/automake-1.13:1.13)
x11-libs/libdrm-2.4.46 (>=sys-devel/automake-1.12:1.12)
                       (>=sys-devel/automake-1.13:1.13)
x11-libs/libfontenc-1.1.2 (>=sys-devel/automake-1.12:1.12)
                          (>=sys-devel/automake-1.13:1.13)
x11-libs/libnotify-0.7.5-r1 (>=sys-devel/automake-1.12:1.12)
                            (>=sys-devel/automake-1.13:1.13)
x11-libs/libpciaccess-0.13.2 (>=sys-devel/automake-1.12:1.12)
                             (>=sys-devel/automake-1.13:1.13)
x11-libs/libva-1.1.1 (>=sys-devel/automake-1.12:1.12)
                     (>=sys-devel/automake-1.13:1.13)
x11-libs/libva-vdpau-driver-0.7.4 (>=sys-devel/automake-1.12:1.12)
                                  (>=sys-devel/automake-1.13:1.13)
x11-libs/libxcb-1.9.1 (>=sys-devel/automake-1.12:1.12)
                      (>=sys-devel/automake-1.13:1.13)
x11-libs/libxkbfile-1.0.8 (>=sys-devel/automake-1.12:1.12)
                          (>=sys-devel/automake-1.13:1.13)
x11-libs/pango-1.34.1 (>=sys-devel/automake-1.12:1.12)
                      (>=sys-devel/automake-1.13:1.13)
x11-libs/pixman-0.30.2 (>=sys-devel/automake-1.12:1.12)
                       (>=sys-devel/automake-1.13:1.13)
x11-libs/startup-notification-0.12 (>=sys-devel/automake-1.12:1.12)
                                   (>=sys-devel/automake-1.13:1.13)
x11-libs/xcb-util-0.3.9 (>=sys-devel/automake-1.12:1.12)
                        (>=sys-devel/automake-1.13:1.13)
x11-libs/xcb-util-image-0.3.9 (>=sys-devel/automake-1.12:1.12)
                              (>=sys-devel/automake-1.13:1.13)
x11-libs/xcb-util-keysyms-0.3.9 (>=sys-devel/automake-1.12:1.12)
                                (>=sys-devel/automake-1.13:1.13)
x11-libs/xcb-util-renderutil-0.3.8 (>=sys-devel/automake-1.12:1.12)
                                   (>=sys-devel/automake-1.13:1.13)
x11-libs/xcb-util-wm-0.3.9 (>=sys-devel/automake-1.12:1.12)
                           (>=sys-devel/automake-1.13:1.13)
x11-libs/xtrans-1.2.7 (>=sys-devel/automake-1.12:1.12)
                      (>=sys-devel/automake-1.13:1.13)
x11-misc/makedepend-1.0.5 (>=sys-devel/automake-1.12:1.12)
                          (>=sys-devel/automake-1.13:1.13)
x11-misc/util-macros-1.17 (>=sys-devel/automake-1.12:1.12)
                          (>=sys-devel/automake-1.13:1.13)
x11-misc/xbitmaps-1.1.1 (>=sys-devel/automake-1.12:1.12)
                        (>=sys-devel/automake-1.13:1.13)
x11-misc/xkeyboard-config-2.9 (>=sys-devel/automake-1.12:1.12)
                              (>=sys-devel/automake-1.13:1.13)
x11-proto/bigreqsproto-1.1.2 (>=sys-devel/automake-1.12:1.12)
                             (>=sys-devel/automake-1.13:1.13)
x11-proto/compositeproto-0.4.2-r1 (>=sys-devel/automake-1.12:1.12)
                                  (>=sys-devel/automake-1.13:1.13)
x11-proto/damageproto-1.2.1-r1 (>=sys-devel/automake-1.12:1.12)
                               (>=sys-devel/automake-1.13:1.13)
x11-proto/dri2proto-2.8 (>=sys-devel/automake-1.12:1.12)
                        (>=sys-devel/automake-1.13:1.13)
x11-proto/fixesproto-5.0-r1 (>=sys-devel/automake-1.12:1.12)
                            (>=sys-devel/automake-1.13:1.13)
x11-proto/fontsproto-2.1.2 (>=sys-devel/automake-1.12:1.12)
                           (>=sys-devel/automake-1.13:1.13)
x11-proto/glproto-1.4.16 (>=sys-devel/automake-1.12:1.12)
                         (>=sys-devel/automake-1.13:1.13)
x11-proto/inputproto-2.3 (>=sys-devel/automake-1.12:1.12)
                         (>=sys-devel/automake-1.13:1.13)
x11-proto/kbproto-1.0.6-r1 (>=sys-devel/automake-1.12:1.12)
                           (>=sys-devel/automake-1.13:1.13)
x11-proto/randrproto-1.4.0-r1 (>=sys-devel/automake-1.12:1.12)
                              (>=sys-devel/automake-1.13:1.13)
x11-proto/recordproto-1.14.2-r1 (>=sys-devel/automake-1.12:1.12)
                                (>=sys-devel/automake-1.13:1.13)
x11-proto/renderproto-0.11.1-r1 (>=sys-devel/automake-1.12:1.12)
                                (>=sys-devel/automake-1.13:1.13)
x11-proto/resourceproto-1.2.0 (>=sys-devel/automake-1.12:1.12)
                              (>=sys-devel/automake-1.13:1.13)
x11-proto/scrnsaverproto-1.2.2-r1 (>=sys-devel/automake-1.12:1.12)
                                  (>=sys-devel/automake-1.13:1.13)
x11-proto/trapproto-3.4.3 (>=sys-devel/automake-1.12:1.12)
                          (>=sys-devel/automake-1.13:1.13)
x11-proto/videoproto-2.3.2 (>=sys-devel/automake-1.12:1.12)
                           (>=sys-devel/automake-1.13:1.13)
x11-proto/xcb-proto-1.8-r3 (>=sys-devel/automake-1.12:1.12)
                           (>=sys-devel/automake-1.13:1.13)
x11-proto/xcmiscproto-1.2.2 (>=sys-devel/automake-1.12:1.12)
                            (>=sys-devel/automake-1.13:1.13)
x11-proto/xextproto-7.2.1-r1 (>=sys-devel/automake-1.12:1.12)
                             (>=sys-devel/automake-1.13:1.13)
x11-proto/xf86bigfontproto-1.2.0-r1 (>=sys-devel/automake-1.12:1.12)
                                    (>=sys-devel/automake-1.13:1.13)
x11-proto/xf86dgaproto-2.1-r2 (>=sys-devel/automake-1.12:1.12)
                              (>=sys-devel/automake-1.13:1.13)
x11-proto/xf86driproto-2.1.1 (>=sys-devel/automake-1.12:1.12)
                             (>=sys-devel/automake-1.13:1.13)
x11-proto/xf86miscproto-0.9.3 (>=sys-devel/automake-1.12:1.12)
                              (>=sys-devel/automake-1.13:1.13)
x11-proto/xf86rushproto-1.1.2-r1 (>=sys-devel/automake-1.12:1.12)
                                 (>=sys-devel/automake-1.13:1.13)
x11-proto/xf86vidmodeproto-2.3.1-r1 (>=sys-devel/automake-1.12:1.12)
                                    (>=sys-devel/automake-1.13:1.13)
x11-proto/xineramaproto-1.2.1-r1 (>=sys-devel/automake-1.12:1.12)
                                 (>=sys-devel/automake-1.13:1.13)
x11-proto/xproto-7.0.24 (>=sys-devel/automake-1.12:1.12)
                        (>=sys-devel/automake-1.13:1.13)
x11-themes/xcursor-themes-1.0.4 (>=sys-devel/automake-1.12:1.12)
                                (>=sys-devel/automake-1.13:1.13)
Maybe it's a SLOT problem but it needs more portage expertise than I have.
Back to top
View user's profile Send private message
gcasillo
l33t
l33t


Joined: 23 Sep 2003
Posts: 736
Location: Cincinnati, Ohio, USA

PostPosted: Fri Oct 18, 2013 5:37 pm    Post subject: Reply with quote

OMG, thanks for posting this. I have noticed automake-1.13.4 coming and going now for a couple of weeks and meant to browse the forums and bug reports to see if anyone else had seen this. I don't know why this is happening, but I'll be happy when it's sorted out!
Back to top
View user's profile Send private message
mv
Advocate
Advocate


Joined: 20 Apr 2005
Posts: 3802

PostPosted: Fri Oct 18, 2013 6:21 pm    Post subject: Reply with quote

Helena wrote:
[This is confusing. As stated sys-devel/automake-1.13.4 is first installed without specifying the --with-bdeps option.

build-time dependencies are confusing from the user's perspective: When you emerge something, its buildtime dependencies automatically become mandatory, even in the default case --with-bdeps=n. It is different with -u for only deep implicit dependencies.
Quote:
Second, sys-devel/automake-1.13.4 is removed again by emerge --depclean although again is not strictly required.

Not sure how --depclean works, but I would expect that it accepts --with-bdeps=y as well to decide whether build dependencies should be kept.
Unless you run a "slave" system which pulls the binaries from somewhere else, I suggest to put EMERGE_DEFAULT_OPTS=--with-bdeps=y into your make.conf.
I think most users would be less confused if this were the default, since the opposite is useful for only rather special setups if you know rather well what you are doing.
Back to top
View user's profile Send private message
l33tmmx
Tux's lil' helper
Tux's lil' helper


Joined: 12 Mar 2005
Posts: 80
Location: Tampere, Finland

PostPosted: Fri Oct 25, 2013 4:23 pm    Post subject: Reply with quote

mv wrote:
Unless you run a "slave" system which pulls the binaries from somewhere else, I suggest to put EMERGE_DEFAULT_OPTS=--with-bdeps=y into your make.conf.
I think most users would be less confused if this were the default, since the opposite is useful for only rather special setups if you know rather well what you are doing.


I agree that the default should be "--with-bdeps=y". This continuous emerging/unmerging of automake-1.13.4 has been annoying :? me for quite a long time. After finding this thread I added --with-bdeps=y to the EMERGE_DEFAULT_OPTS, let's see whether it works...
_________________
"Trust me, I know what I'm doing!"
- Sledge Hammer

Follow me on Twitter
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum