Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
No sound through laptop speakers
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
PsyGhost
n00b
n00b


Joined: 18 May 2005
Posts: 25

PostPosted: Fri Aug 02, 2013 11:00 am    Post subject: No sound through laptop speakers Reply with quote

I have a Dell Inspiron 1525 laptop running KDE. I'm not using pulse audio. While headphones are connected to the laptop I can hear sound through them, but when I disconnect them there's no sound at all.
I searched the Internet and found out that if I do
Code:
rmmod snd-hda-intel
and the reload it with the option model=laptop I can hear sound from the speakers.
In order to make that option persistent I added
Code:
options snd-hda-intel model=laptop

to /etc/modprobe.d/sound.conf and rebooted. I checked that the module was loaded with the correct option by issuing:
Code:
cat /sys/module/snd_hda_intel/parameters/model

and it was indeed loaded with the "laptop" option. However, after rebooting I still can't hear sound from the laptop speaker unless I do the same manual process I described above.

Using kernel 3.10.0.

Code:
cat /proc/asound/Intel/codec\#* | grep Codec
Codec: Conexant ID 2c06
Codec: Silicon Image SiI1392 HDMI
Codec: SigmaTel STAC9228

Code:
cat /sys/module/snd_hda_intel/parameters/model
laptop,(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null)

Code:
CONFIG_SND_HDA_INTEL=m
CONFIG_SND_HDA_PREALLOC_SIZE=64
CONFIG_SND_HDA_HWDEP=y
CONFIG_SND_HDA_RECONFIG=y
CONFIG_SND_HDA_INPUT_BEEP=y
CONFIG_SND_HDA_INPUT_BEEP_MODE=1
CONFIG_SND_HDA_INPUT_JACK=y
CONFIG_SND_HDA_PATCH_LOADER=y
CONFIG_SND_HDA_CODEC_REALTEK=y
CONFIG_SND_HDA_CODEC_ANALOG=y
CONFIG_SND_HDA_CODEC_SIGMATEL=y
CONFIG_SND_HDA_CODEC_VIA=y
CONFIG_SND_HDA_CODEC_HDMI=y
CONFIG_SND_HDA_CODEC_CIRRUS=y
CONFIG_SND_HDA_CODEC_CONEXANT=y
CONFIG_SND_HDA_CODEC_CA0110=y
CONFIG_SND_HDA_CODEC_CA0132=y
# CONFIG_SND_HDA_CODEC_CA0132_DSP is not set
CONFIG_SND_HDA_CODEC_CMEDIA=y
CONFIG_SND_HDA_CODEC_SI3054=y
CONFIG_SND_HDA_GENERIC=y
CONFIG_SND_HDA_POWER_SAVE_DEFAULT=0
# CONFIG_SND_HDSP is not set
Back to top
View user's profile Send private message
Drasica
Apprentice
Apprentice


Joined: 16 Apr 2006
Posts: 156

PostPosted: Tue Aug 13, 2013 6:35 pm    Post subject: Reply with quote

Are you using ALSA? You are you sure that the ALSA mixer isn't just muting the speakers by default?
(I'm thinking that maybe that option somehow unmutes the speaker and might not be necessary).
Back to top
View user's profile Send private message
PaulBredbury
Watchman
Watchman


Joined: 14 Jul 2005
Posts: 7310

PostPosted: Tue Aug 13, 2013 7:10 pm    Post subject: Reply with quote

Probably need the auto-toggle (between headphones and speakers) turned on. Easy method:

Code:
amixer set "Auto-Mute Mode" Enabled
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum