Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Emerge Updates Targeted only for packages with bugs
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
TeoBì
Tux's lil' helper
Tux's lil' helper


Joined: 31 May 2004
Posts: 147

PostPosted: Mon Aug 12, 2013 9:33 am    Post subject: Emerge Updates Targeted only for packages with bugs Reply with quote

Code:

Hello,
  searching through the documentation I have seen that it is possbile to update packages with vulnerabilities, but instead wanted to know if you can upgrade the packages just in case we bug, I'll explain:
For example i have mysql v5.0.0.0 installed which has a bug, there is the 5.0.0.1 version that does not have this bug, however, there is also the 5.2.0.0 version that has the bug but it also has new features, I I would like the system automatically instal me the only 5.0.0.1 solving the bug.


Thanks
Matteo
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 6254
Location: Goose Creek SC

PostPosted: Mon Aug 12, 2013 1:13 pm    Post subject: Reply with quote

Is mysql on your system really that far out of date? versions 5.0.0 -5..0.2 are no longer in portage; latest stable is dev-db/mysql-s-1.7.0; testing is at dev-db/mysql-5.5.32; http://packages.gentoo.org/package/dev-db/mysql
put buggy version that is newer than the good version in /etc/portage/package.mask; for example as =dev-db/mysql-5.0.2
_________________
Defund the FCC.
Back to top
View user's profile Send private message
TeoBì
Tux's lil' helper
Tux's lil' helper


Joined: 31 May 2004
Posts: 147

PostPosted: Mon Aug 12, 2013 11:39 pm    Post subject: Reply with quote

DONAHUE wrote:
Is mysql on your system really that far out of date? versions 5.0.0 -5..0.2 are no longer in portage; latest stable is dev-db/mysql-s-1.7.0; testing is at dev-db/mysql-5.5.32; http://packages.gentoo.org/package/dev-db/mysql
put buggy version that is newer than the good version in /etc/portage/package.mask; for example as =dev-db/mysql-5.0.2


Not, isn't an example, it possible with the option of emerge upgrade all system , but only upgrade program version with a bug, not with news fecture.
Is for do a ambient server, whre is very important a stability.

(in Gentoo already exist upgrade only for secutiry for example)


Thanks.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum