Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Need advise on what to use for raid
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
nobody13
Tux's lil' helper
Tux's lil' helper


Joined: 21 Jan 2006
Posts: 145

PostPosted: Sun Aug 11, 2013 12:05 am    Post subject: Need advise on what to use for raid Reply with quote

I been trying to mount my raid 1 drives for about a week now and don't know what way to turn. I have 2 - 2TB dives with 3 partitions for mirrored storage that I want to access from windows or linux. Can someone tell me what's the best way to do this and which packages to use. In the past I just made the partitions in windows the ran dmsetup -ay added devices to dmtab and fstab and i was done. Now dmsetup has changed and i can't get linux to make the devices to mount them. I've tried lvm2 dmraid and mdraid - nothing works. The system is set to boot uefi only and gpt seems to be part of my headache.

what i'm trying to get :
sdb1, sdc1 > raid1
sdb2, sdc2 > raid2
sdb3, sdc3 > raid3

my setup:

Code:
Number  Start   End    Size    File system     Name                          Flags
 1      1049kB  316MB  315MB   ntfs            Basic data partition          hidden, diag
 2      316MB   420MB  105MB   fat32           EFI system partition          boot
 3      420MB   555MB  134MB                   Microsoft reserved partition  msftres
 4      555MB   158GB  157GB   ntfs            Basic data partition
 5      158GB   158GB  134MB   ext2            Basic data partition          boot
 6      158GB   159GB  1049MB  linux-swap(v1)  Basic data partition
 7      159GB   316GB  157GB   ext4            Basic data partition
 8      316GB   395GB  78.6GB                  Basic data partition
 9      395GB   474GB  78.6GB                  Basic data partition
10      474GB   945GB  472GB   ntfs            Basic data partition
11      945GB   972GB  26.2GB  ntfs            Basic data partition          hidden, diag


Model: ATA WDC WD20EZRX-00D (scsi)
Disk /dev/sdb: 2000GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags:

Number  Start   End     Size   File system  Name  Flags
 1      1049kB  524GB   524GB  ntfs               raid
 2      524GB   1049GB  524GB  ntfs               raid
 3      1049GB  2000GB  952GB  ntfs               raid


Model: ATA WDC WD20EZRX-00D (scsi)
Disk /dev/sdc: 2000GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags:

Number  Start   End     Size   File system  Name  Flags
 1      1049kB  524GB   524GB                     raid
 2      524GB   1049GB  524GB                     raid
 3      1049GB  2000GB  952GB                     raid


Code:

00:1f.2 SATA controller: Intel Corporation Lynx Point 6-port SATA Controller 1 [AHCI mode] (rev 04)
06:00.0 SATA controller: Marvell Technology Group Ltd. 88SE9172 SATA 6Gb/s Controller (rev 11)


my OS drive is connected to the intel sata controller and the raid drives are connected to the marvel sata controller. I don't know if where it connected matters or not and i'm confused if this is software or fake raid.
Back to top
View user's profile Send private message
eccerr0r
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3598
Location: USA

PostPosted: Sun Aug 11, 2013 1:14 am    Post subject: Reply with quote

Likely you are using fakeraid if you set it up using the card's BIOS. Linux can detect many of these fakeraid and set them up for you.

You don't need to use fakeraid at all (which is handled by device mapper). You can just use software MDRAID instead of fakeraid in which you would use mdadm to administrate them instead of dmsetup. You should disable RAID in BIOS to use MD software RAID.

Now I don't know why it stopped working. I have not had much experience working with dmraid unfortunately, but I would venture to guess that if the BIOS firmware on the fakeraid board doesn't detect the raid, then dmraid won't play with it either.
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed to be advocating?
Back to top
View user's profile Send private message
nobody13
Tux's lil' helper
Tux's lil' helper


Joined: 21 Jan 2006
Posts: 145

PostPosted: Sun Aug 11, 2013 2:18 am    Post subject: Reply with quote

Thanks for the reply, I forgot to mention this is a new computer. Device mapper is still working on my older computer just the commands have changed and that one is allready setup. The older comp is also setup as mbr instead if gpt
.
Back to top
View user's profile Send private message
nobody13
Tux's lil' helper
Tux's lil' helper


Joined: 21 Jan 2006
Posts: 145

PostPosted: Mon Aug 12, 2013 11:02 pm    Post subject: Reply with quote

I believe i have a bad controller. when you mentioned the bios settings i realised i never changed them from default. When I changed the setting from ahci to raid it hangs at the post screen for like 5 minutes and ctl+m doesn't give me the raid setup utility. So now I'm waiting for gigabyte tech support to respond (ill be back )
Back to top
View user's profile Send private message
DaggyStyle
Advocate
Advocate


Joined: 22 Mar 2006
Posts: 4883

PostPosted: Tue Aug 13, 2013 6:25 am    Post subject: Reply with quote

nobody13 wrote:
I believe i have a bad controller. when you mentioned the bios settings i realised i never changed them from default. When I changed the setting from ahci to raid it hangs at the post screen for like 5 minutes and ctl+m doesn't give me the raid setup utility. So now I'm waiting for gigabyte tech support to respond (ill be back )


maybe you need to blank the drives before running the util
_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
ProjectFootball
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum