Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
sys-boot/raspberrypi-firmware: gpu_mem=16 hangs [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on Alternative Architectures
View previous topic :: View next topic  
Author Message
XavierMiller
Moderator
Moderator


Joined: 23 Jul 2004
Posts: 5269
Location: ~Brussels - Belgique

PostPosted: Wed Jul 24, 2013 8:09 pm    Post subject: sys-boot/raspberrypi-firmware: gpu_mem=16 hangs [SOLVED] Reply with quote

Hello,

I use sys-boot/raspberrypi-firmware and sys-kernel/raspberrypi-image, and I would like to use gpu_mem=16 parameter in /boot/config.txt
But if I set it, my Raspberry Pi (256 Mb version) hangs at boot, with a wonderful red/yellow/orange gradient.

I didn't have that problem with the stage3 I loaded and the firmware files proposed by the wiki.

How can I reduce the video memory, so that I can maximize the little RAM?
_________________
Xavier Miller
(FR) Merci de respecter les règles du forum.
http://www.xaviermiller.be


Last edited by XavierMiller on Wed Aug 14, 2013 6:28 pm; edited 1 time in total
Back to top
View user's profile Send private message
XavierMiller
Moderator
Moderator


Joined: 23 Jul 2004
Posts: 5269
Location: ~Brussels - Belgique

PostPosted: Sat Aug 10, 2013 5:39 pm    Post subject: Reply with quote

no idea?
_________________
Xavier Miller
(FR) Merci de respecter les règles du forum.
http://www.xaviermiller.be
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 31342
Location: 56N 3W

PostPosted: Sat Aug 10, 2013 5:48 pm    Post subject: Reply with quote

XavierMiller,

I use the rpi-update script to keep my kernel and firmware up to date and the gpu_mem=16 works for me in a 256M Pi.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
XavierMiller
Moderator
Moderator


Joined: 23 Jul 2004
Posts: 5269
Location: ~Brussels - Belgique

PostPosted: Sun Aug 11, 2013 5:01 pm    Post subject: Reply with quote

Hello,

Where can I find that script?

EDIT: https://github.com/Hexxeh/rpi-update
_________________
Xavier Miller
(FR) Merci de respecter les règles du forum.
http://www.xaviermiller.be
Back to top
View user's profile Send private message
XavierMiller
Moderator
Moderator


Joined: 23 Jul 2004
Posts: 5269
Location: ~Brussels - Belgique

PostPosted: Wed Aug 14, 2013 6:28 pm    Post subject: Reply with quote

Solved: the problem was the presence of CMA parameters. I commented them out, and both rpi-update and Portage versions work. I switched to Gentoo version.
_________________
Xavier Miller
(FR) Merci de respecter les règles du forum.
http://www.xaviermiller.be
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Alternative Architectures All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum