Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[emerge] dev-libs/libxml2-2.9.0-r2 ne compile pas (résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Thoma HAUC
n00b
n00b


Joined: 30 May 2011
Posts: 32

PostPosted: Wed Aug 07, 2013 1:42 pm    Post subject: [emerge] dev-libs/libxml2-2.9.0-r2 ne compile pas (résolu) Reply with quote

Bonjour,

Je n'arrive pas à compiler dev-libs/libxml2-2.9.0-r2.

Je joins un extrait du fichier log :
Code:

libtool: compile:  i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I.. -I../include -I../include -I/usr/include/python2.7 -O2 -march=core2 -pipe -pedantic -W -Wformat -Wunused -Wimplicit -Wreturn-type -Wswitch -Wcomment -Wtrigraphs -Wformat $
libtool: compile:  i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I.. -I../include -I../include -I/usr/include/python2.7 -O2 -march=core2 -pipe -pedantic -W -Wformat -Wunused -Wimplicit -Wreturn-type -Wswitch -Wcomment -Wtrigraphs -Wformat $
libxml.c:2677:1: warning: no previous prototype for ‘libxml_xmlNodeRemoveNsDef’ [-Wmissing-prototypes]
/bin/sh ../libtool  --tag=CC   --mode=compile i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I..  -I../include -I../include -I/usr/include/python2.7 -shared   -O2 -march=core2 -pipe -pedantic -W -Wformat -Wunused -Wimplicit -Wreturn-type -W$
libtool: compile:  i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I.. -I../include -I../include -I/usr/include/python2.7 -O2 -march=core2 -pipe -pedantic -W -Wformat -Wunused -Wimplicit -Wreturn-type -Wswitch -Wcomment -Wtrigraphs -Wformat $
/bin/sh ../libtool  --tag=CC   --mode=link i686-pc-linux-gnu-gcc  -O2 -march=core2 -pipe -pedantic -W -Wformat -Wunused -Wimplicit -Wreturn-type -Wswitch -Wcomment -Wtrigraphs -Wformat -Wchar-subscripts -Wuninitialized -Wparentheses -Ws$
libtool: link: i686-pc-linux-gnu-gcc -shared  -fPIC -DPIC  .libs/libxml.o .libs/libxml2-py.o .libs/types.o   -Wl,-rpath -Wl,/var/tmp/portage/dev-libs/libxml2-2.9.0-r2/work/libxml2-2.9.0-python2_7/.libs -Wl,--as-needed ../.libs/libxml2.s$
libtool: link: ( cd ".libs" && rm -f "libxml2mod.la" && ln -s "../libxml2mod.la" "libxml2mod.la" )
/usr/bin/Modules/Setup.local
make[2]: /usr/bin/Modules/Setup.local: Command not found
make[2]: *** [libxml2mod.la] Error 127
make[2]: Leaving directory `/var/tmp/portage/dev-libs/libxml2-2.9.0-r2/work/libxml2-2.9.0-python2_7/python'
Making all in tests
make[2]: Entering directory `/var/tmp/portage/dev-libs/libxml2-2.9.0-r2/work/libxml2-2.9.0-python2_7/python/tests'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/var/tmp/portage/dev-libs/libxml2-2.9.0-r2/work/libxml2-2.9.0-python2_7/python/tests'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/dev-libs/libxml2-2.9.0-r2/work/libxml2-2.9.0-python2_7/python'
make: *** [all] Error 2


J'ai repère deux erreurs (Error 2 & Error 127) mais cela ne m'avance pas. Je pense que le message "Command not found" est à l'origine de mon problème mais je ne trouve pas la commande "/usr/bin/Modules/Setup.local". D'ailleurs, je ne pense pas que c'est une commande et le chemin "/usr/bin/Modules/" n'existe pas.

J'ai aussi remarqué des "/usr/bin/Modules/Setup.local" ainsi que des "/usr/bin/Modules/Setup.dist" qui s'affichent régulièrement.
De quoi, cela provient-il ? Est-ce l'origine de mon problème ?

D'avance merci.

Thoma


Last edited by Thoma HAUC on Tue Aug 13, 2013 7:29 pm; edited 1 time in total
Back to top
View user's profile Send private message
boozo
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3136

PostPosted: Thu Aug 08, 2013 3:27 pm    Post subject: Reply with quote

'alute

une version de python installé en local hors portage sans doute non ? (car le /usr/local/Module/Setup ça vient de là)

Sinon il faudra donner plus d'infos p.e. le #emerge --info ; le contexte de recompilation de libxml2, etc et qui est susceptible de pointer un problèmes sinon d'orienter des recherches :wink:
_________________
" Un psychotique, c'est quelqu'un qui croit dur comme fer que 2 et 2 font 5, et qui en est pleinement satisfait.
Un névrosé, c'est quelqu'un qui sait pertinemment que 2 et 2 font 4, et ça le rend malade ! "
Back to top
View user's profile Send private message
Thoma HAUC
n00b
n00b


Joined: 30 May 2011
Posts: 32

PostPosted: Thu Aug 08, 2013 4:45 pm    Post subject: Reply with quote

B'soir Boozo,

Je n'ai jamais installé de Python hors portage (du moins, pas de manière volontaire).

Du coup, je vais essayer de réinstaller les différents interpréteurs Python.
Est-ce que cela peut corriger mon problème ?

En ce qui concerne le résultat de emerge --info, le voici :

Code:

Portage 2.1.12.2 (default/linux/x86/13.0, gcc-4.6.3, glibc-2.15-r3, 3.7.10-gentoo i686)
=================================================================
System uname: Linux-3.7.10-gentoo-i686-Intel-R-_Core-TM-2_Quad_CPU_Q6600_@_2.40GHz-with-gentoo-2.2
KiB Mem:     6227424 total,   4670628 free
KiB Swap:    4194300 total,   4194300 free
Timestamp of tree: Mon, 05 Aug 2013 08:00:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
ccache version 3.1.9 [disabled]
app-shells/bash:          4.2_p45
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.4.6, 2.5.4-r5, 2.6.8-r1, 2.7.3-r3, 3.2.5-r1
dev-util/ccache:          3.1.9
dev-util/cmake:           2.8.10.2-r2
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.10.3, 1.11.6, 1.12.6
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.6.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.7 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo java-overlay xwing zugaina ardunio sunrise seden kde-sunset science vmware x-portage
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="* -@EULA sun-bcla-java-vm googleearth Oracle-BCLA-JavaSE PUEL skype-eula AdobeFlash-11.x dlj-1.1 Google-TOS google-chrome"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=core2 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/polkit-1/actions"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=core2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -march=i686 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -march=i686 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="fr_FR.UTF-8"
LC_ALL="fr_FR.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/java-overlay /var/lib/layman/xwing /var/lib/layman/zugaina /var/lib/layman/arduino /var/lib/layman/sunrise /var/lib/layman/seden /var/lib/layman/kde-sunset /var/lib/layman/science /var/lib/layman/vmware /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acl alsa asf berkdb bzip2 cli cracklib crypt css cxx dri dv dvd dvdr encode ffmpeg fortran gdbm gif hal iconv ipv6 jpeg mad mmx mmxext modules mp3 mudflap ncurses nls nptl nsplugin opengl openmp pam pcre png quicktime readline real session sse sse2 ssl ssse3 tcpd tiff unicode win32codecs x86 xvid zlib" ABI_X86="32" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="fr" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-4" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby19 ruby18" USERLAND="GNU" VIDEO_CARDS="nouveau" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON


Merci d'avance

Thoma
Back to top
View user's profile Send private message
boozo
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3136

PostPosted: Fri Aug 09, 2013 8:28 am    Post subject: Reply with quote

Thoma HAUC wrote:
Je n'ai jamais installé de Python hors portage (du moins, pas de manière volontaire).

Du coup, je vais essayer de réinstaller les différents interpréteurs Python.
Est-ce que cela peut corriger mon problème ?

Ah? très étrange... :? pourtant on dirait une install a la mano avec un --prefix=/usr/bin i.e.

Quoi qu'il en soit : tu as _déjà_ presque toutes les versions dont les plus antédiluviennes à ce que je vois.

THOMA HAUC #emerge --info wrote:

Portage 2.1.12.2 (default/linux/x86/13.0, gcc-4.6.3, glibc-2.15-r3, 3.7.10-gentoo i686)
=================================================================
System uname: Linux-3.7.10-gentoo-i686-Intel-R-_Core-TM-2_Quad_CPU_Q6600_'@'_2.40GHz-with-gentoo-2.2
KiB Mem: 6227424 total, 4670628 free
KiB Swap: 4194300 total, 4194300 free
Timestamp of tree: Mon, 05 Aug 2013 08:00:01 +0000
(...)
dev-lang/python:
2.4.6, 2.5.4-r5, 2.6.8-r1, 2.7.3-r3, 3.2.5-r1

(...)
PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2"
(...)
Unset: USE_PYTHON


Sauf raison/besoin en developpement peut-être, il serait bon de faire un peu le ménage dans tout çà non ?
Car malgré les slot/target qui gère la coexistance, il se peut que le problème vienne de là ; sinon d'une montée en version mal réalisée précédemment (un #python-updater oublié à un moment donné au hasard :wink: )
Perso, je ne tourne même qu'en 2.7 mais tu peux passer en 3.2 si tu veux ; je n'ai pas vérifier le tracker mais depuis un an environ je crois que ça doit passer partout maintenant (m'enfin, je garderai les 2 quand même histoire de pouvoir switcher facilement en cas de pb avec un prog non porté)

Bref, je ferai un --unmerge des anciennes versions et utilisation de eselect python (voire avec options d'interpreteurs en fonction) pour vérifier le tout avant de repasser un python-updater et retester libxml2.
_________________
" Un psychotique, c'est quelqu'un qui croit dur comme fer que 2 et 2 font 5, et qui en est pleinement satisfait.
Un névrosé, c'est quelqu'un qui sait pertinemment que 2 et 2 font 4, et ça le rend malade ! "
Back to top
View user's profile Send private message
XavierMiller
Moderator
Moderator


Joined: 23 Jul 2004
Posts: 5267
Location: ~Brussels - Belgique

PostPosted: Fri Aug 09, 2013 8:33 am    Post subject: Reply with quote

@boozo: tout ne passe pas encore en python 3, j'ai quelques dépendances vers python 2 actuellement, donc je reste sur 2.7 en bloquant >=3
_________________
Xavier Miller
(FR) Merci de respecter les règles du forum.
http://www.xaviermiller.be
Back to top
View user's profile Send private message
boozo
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3136

PostPosted: Sat Aug 10, 2013 8:41 am    Post subject: Reply with quote

@XavierMiller:> ah bin merci pour l'info :wink: comme je l'ai dis je suis aussi en 2.7 exclusif et n'ai pas vérifier le tracker dans b.g.o mais depuis le temps - fait au moins 2,3 ans qu'"ils" ont poussé la branche 3.x en stable dans l'arbre non ? -, je croyais que c'était réglé maintenant...
_________________
" Un psychotique, c'est quelqu'un qui croit dur comme fer que 2 et 2 font 5, et qui en est pleinement satisfait.
Un névrosé, c'est quelqu'un qui sait pertinemment que 2 et 2 font 4, et ça le rend malade ! "
Back to top
View user's profile Send private message
XavierMiller
Moderator
Moderator


Joined: 23 Jul 2004
Posts: 5267
Location: ~Brussels - Belgique

PostPosted: Sat Aug 10, 2013 5:29 pm    Post subject: Reply with quote

J'ai essayé de passer à une version unique >= 3, et ça n'a pas été : python 2 était poussé par plusieurs ebuilds (24 dans mon cas, contre 14 qui supportent python 3).
_________________
Xavier Miller
(FR) Merci de respecter les règles du forum.
http://www.xaviermiller.be
Back to top
View user's profile Send private message
Thoma HAUC
n00b
n00b


Joined: 30 May 2011
Posts: 32

PostPosted: Tue Aug 13, 2013 7:29 pm    Post subject: Reply with quote

@boozo:

J'ai désinstallé dev-lang/python-2.7.3-r3 puis réinstallé dev-lang/python:2.7, un petit coup de eselect et le problème semble résolu.

D'ailleurs, je n'ai jamais trouvé un quelconque répertoire /usr/local/Module/*.

Je fais du développement hardware et j'ai différents outils qui exploitent les versions 2.4, 2.5 et 2.6 de python.

En tout cas, merci.

Thoma
Back to top
View user's profile Send private message
boozo
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3136

PostPosted: Fri Aug 16, 2013 3:33 pm    Post subject: Reply with quote

Thoma HAUC wrote:
@boozo:

J'ai désinstallé dev-lang/python-2.7.3-r3 puis réinstallé dev-lang/python:2.7, un petit coup de eselect et le problème semble résolu.

D'ailleurs, je n'ai jamais trouvé un quelconque répertoire /usr/local/Module/*.

Je fais du développement hardware et j'ai différents outils qui exploitent les versions 2.4, 2.5 et 2.6 de python.

En tout cas, merci.

Thoma

Bien ! content que ça tourne :) après je ne saurai te dire pourquoi il y a eu un path /usr/local/ en prefix comme ça ; pour moi on dirait une mauvaise $var d'environnement fixée en manuel... étrange, m'enfin si c'est re-rentré dans l'ordre via portage c'est le principal hein ? ^^

Je t'avais évoqué le cas de contraintes spécifiques que tu as donc, et si jamais tu as besoin d'une gestion plus fine avec les interpréteurs, tu pourras au besoin jeter un oeil sur ce guide pour éventuellement paufiner la gestion slot/target pour tes packages.

n.b. Quoique pour être franc, je n'ai jamais bien compris la différence d'usage qu'il y a à passer par la solution USE_PYTHON... une vieille impémentation résiduelle sans doute...
D'ailleurs, si un dev passe dans le coin qu'il ne se prive pas pour m'expliquer l'horloge, la pendule, tout çà... :p

_________________
" Un psychotique, c'est quelqu'un qui croit dur comme fer que 2 et 2 font 5, et qui en est pleinement satisfait.
Un névrosé, c'est quelqu'un qui sait pertinemment que 2 et 2 font 4, et ça le rend malade ! "
Back to top
View user's profile Send private message
MystX
n00b
n00b


Joined: 08 Aug 2012
Posts: 9

PostPosted: Mon Aug 19, 2013 2:50 am    Post subject: Reply with quote

Y'a des fois un ptit coup de python-updater peut faire du bien aussi ... (et aussi aller voir la page python au sujet de quel python utiliser qui permet de résoudre des soucis portage avec beaucoup de slots python http://www.gentoo.org/proj/en/Python/python-r1/user-guide.xml )
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum